OpenWrt/LEDE Project

Welcome to the OpenWrt/LEDE Project bug reporting and issue tracking system

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to

OpenedIDCategoryTask TypePrioritySeveritySummaryReported InStatus
11.02.20202831Base systemBug ReportVery LowHigh2.4Ghz Wifi speed degradation on WNDR3800AllUnconfirmed Task Description

I found that on WNDR3800, ath79 build 2.4Ghz Wifi slower than ar71xx build.
ath79 build only get about 3.5MB/s (2.4Ghz 40Mhz), ar71xx build get about 10MB/s. (2.4Ghz 40Mhz)
Same network, Same wifi channel, test on speedtest.
I think this is a serious performance issue.

- Device problem occurs on
WNDR3800(ath79) latest sources at master branch.

- Steps to reproduce
install ar71xx build
test on (Samsung S6 and Sony xz1 use 2.4G wifi)
install ath79 build
test on (Samsung S6 and Sony xz1 use 2.4G wifi)
download speed only half of ar71xx build.

10.02.20202830Base systemBug ReportVery LowLowMikroTik RB951G-2HnD does not bootTrunkUnconfirmed Task Description

Supply the following if possible:
- MikroTik RB951G-2HnD
- Tried 19.07.1 and 18.06.7

Steps to reproduce
- Network boot from port 1
- Have another device connected to network port 2
- See it sometimes (so far it happened 2 times out of approx 10 tries) ask for a network address after finishing loading the initramfs image
- When it has assigned an IP, it also gives away IP’s to connected clients
- Running ping from a client gives approx 95% packet loss

Note on it mentions the gigabit switch doesn’t work properly without a patch
Note I tried compiling a patch for 19.07.1 (same result), or even loading in the kernel module built into the initram fs image (self built) (
but neither options seem to have any improvement.

Note the wiki page mentions only rev 3 needs this patch

  The new version (rev 3, requires patch) can apparently be distinguished from the old version (rev 2, works out-of-the-box) by the MAC address:
     The old one starts with D4:CA:6D
     The new one starts with 4C:5E:0C

My Mac Address starts with 74:4D:28. So either this is a newer revision (which might need a different patch?) or they ran out of mac address space, and the same HW revision has added another range...


10.02.20202829Base systemBug ReportVery LowLowMikroTik RB951Ui-2HnD has limited functionalityAllUnconfirmed Task Description

Supply the following if possible:
- RB951UI-2HnD
- Tried OpenWRT 19.07.1, 18.07.7 and lede 17.01.07
- Mac Address strts with 74:4D:28 (I include it because maybe it indicates a newer HW revisionthat needs to be supported)

Steps to reproduce
- Boot machine from network
- Flash image (tried 3 different versions, all same result)
- Wait for reboot to complete
- NOTE: LED 5 is red, I expect them to be green if network cable was connected, or off otherwise
- run `iw list` ⇒ Empty response
- Install pciutils (opkg install pciutils)
- run `lspci -nn` ⇒ Nothing is outputted
- run `cat /proc/cpuinfo` ⇒ Note the Mhz of the device is 299, while the device should be running at 600 Mhz

So to summarize
* LEDs aren’t working properly (or indicating its in a failed state, although I can’t find anything obvious in dmesg)
* WiFi isn’t working
* pci listing doesn’t work (maybe this device doesn’t have anything pci related, but I executed that command to debug the wifi issue)
* CPU is limited to 300 Mhz while it should be 600 Mhz (in dmesg I can actually see in the commandline it boots with MHZ=3000000, not sure how/if I can override or why the default would be 300


09.02.20202826PackagesBug ReportVery LowLowdnsmasq: neg-ttl, addn-hosts jail supportTrunkUnconfirmed Task Description

Is it possible to add neg-ttl config option to dnsmasq, please?
And maybe set it to a default value of 15minutes?

addn-hosts files are not added to the jail, which results in a failure to load them.


09.02.20202825Base systemBug ReportVery LowLow[kmod-sched-cake | kmod-nf-conntrack] module load order...TrunkUnconfirmed Task Description

Having observed in the logs

sch_cake: Unknown symbol nf_conntrack_find_get (err -2)
sch_cake: Unknown symbol nf_ct_get_tuplepr (err -2)

it would appear being caused by the static load order of kernel modules, particularly


being loaded after


Since dynamic interdependency of modules’ load order would seem unfeasible changing the static load order to


remedies the issue, i.e. no further errors observed.

09.02.20202824Base systemBug ReportVery LowLow[netifd] bridge STP - mcast_last_member_interval syntaxTrunkUnconfirmed Task Description

* issue as described in [1] and observed by various users on different branches | target devices
* potential cause syntax error in [2]

cfg->last_member_interval = 100;

according to [3] the expected syntax reads



08.02.20202823KernelBug ReportVery LowLowcpufreq plugin for collectd (luci statistics) missing c...TrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on x86_64 device with Intel i5-4570T cpu/4gb of ram
- Software versions of OpenWrt/LEDE release: 19.07.1

Steps to reproduce:
1. Install luci-app-statistics
2. install collectd-mod-cpufreq

See error in system log:
Sat Feb 8 14:37:31 2020 daemon.err collectd[9875]: cpufreq plugin: File /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state not exists or no access. P-State statistics will not be reported. Check if `cpufreq-stats’ kernel module is loaded.

Now the plugin does function but clearly the kernel-module would allow for more robust reporting as capable by collectd (allow to check “extra items” in the configuration of statistics.)

08.02.20202822Base systemBug ReportVery LowMediumsysupgrade does not work with coreutils sha256sumopenwrt-19.07Unconfirmed Task Description

When running sysupgrade backup, checksum generation fails as per below if having installed coreutils version of sha256sum as it doesn’t recognize the -s flag.

OpenWrt 19.07-SNAPSHOT r10906-3212290a3b

# sha256sum –version
sha256sum (GNU coreutils) 8.30

# sysupgrade -b /root/backup-${HOSTNAME}-$(date +%F).tar.gz
sha256sum: invalid option – ‘s’ Try ‘sha256sum –help’ for more information.
sha256sum: invalid option – ‘s’ Try ‘sha256sum –help’ for more information.
Saving config files...

07.02.20202820Base systemBug ReportVery LowMediumath79 19.07.x always creates an interface with 192.168....openwrt-19.07Unconfirmed Task Description


I have a TP-Link Archer-C7-V2 device. I installed via tftp the factory.bin file for 19.07.1, and changed the br-lan IP address to After installing some packages and rebooting, the lan side switch interface was given the address, despite the WAN interface getting from an upstream router via DHCP. This does not happen with ar71xx 19.07.1. I’ve remained on the ar71xx version.

I’ve attached the output from several show interface config commands for both ath79 and ar71xx. Since I rsync the entire router filesystem to my Linux system, I’ve also included a recursive diff of the ‘rom’ directories for both ath79 and ar71xx if that helps. In the diff output, for smaller size and better clarity, I removed the diff output for ‘.control’ files in opkg/info that only differed in kernel dependency and/or installed size.

07.02.20202819Base systemBug ReportVery LowMediumDefault configuration for PPPoE client (PPPd) is not pr...openwrt-19.07Unconfirmed Task Description

Default configuration for PPPoE client is not properly set.

Certain HW manufacturers (Alcatel Lucent for example) have implemented LCP flooding prevention systems for PPP clients if multiple LCP request/echos arrive in < 30s. When this occours BNG (BRAS) sends a PPP disconnect request and the PPP session gets dropped and PPP username gets remporary banned.

LCP echo interval default values for PPPoE connections should be set in the value of at least 30 (60 perferably) (seconds that is) and not 5s as set per current default value. Currently all users using PPPoE are affected.

Still present in –> OpenWrt 19.07.1 r10911-c155900f66 / LuCI openwrt-19.07 branch git-20.029.45734-adbbd5c

07.02.20202818Base systemBug ReportVery LowLowCurrent time displayed incorrectly in v.19.07 system ta...openwrt-19.07Unconfirmed Task Description

- Device problem occurs on
Aerohive HiveAP-121

- Software versions of OpenWrt/LEDE release, packages, etc.
OpenWrt 19.07.1 r10911-c155900f66 / LuCI openwrt-19.07 branch git-20.029.45734-adbbd5c

- Steps to reproduce
This is evident when you have two AP (exact same hardware) side by side running v.19.07.1 and v.18.06.5

The issue:
After upgrading firmware from 18.06.5 to 19.07.1 we noticed that the current time reported incorrectly on the ‘System’ tab in GUI.

Please note, current time IS reported correctly in the ‘Status’ tab on both versions.

Please note, GUI is accessed using a desktop version of Debian GNU/Linux 10 (buster), with Firefox ESR 68.4.1esr (64-bit).

Please note, Firefox configuration has been modified - hardened to prevent remote sites code loaded to the browser to detect local time zone.

Using the same browser with the exact same configuration shows current time been displayed correctly in firmware v.18.06.5 and displayed incorrectly only on the system tab in firmware version 19.07.1.

Please see screenshots attached.

Development team - thank you for your efforts in writing this code and making it available free of charge. You guys are awesome! :)


06.02.20202817KernelBuild FailureVery LowLowcompiler complain 'asm/types.h' file not found when com...openwrt-19.07Unconfirmed Task Description

Compile on macOS 10.15.3 (19D76)

uname -a

Darwin TioudeMBP.lan 19.3.0 Darwin Kernel Version 19.3.0: Thu Jan  9 20:58:23 PST 2020; root:xnu-6153.81.5~1/RELEASE_X86_64 x86_64 i386 MacBookPro11,5 Darwin

gcc –version

Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Apple clang version 11.0.0 (clang-1100.0.33.17)
Target: x86_64-apple-darwin19.3.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin

make target/linux/compile V=sc

make[1]: Entering directory `/Volumes/Coder/docker/openwrt/openwrt'
make[2]: Entering directory `/Volumes/Coder/docker/openwrt/openwrt/target/linux'
make[3]: Entering directory `/Volumes/Coder/docker/openwrt/openwrt/target/linux/x86'
rm -f /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/localversion
/Volumes/Coder/docker/openwrt/openwrt/scripts/  + + /Volumes/Coder/docker/openwrt/openwrt/target/linux/generic/config-4.14 /Volumes/Coder/docker/openwrt/openwrt/target/linux/x86/config-4.14 /Volumes/Coder/docker/openwrt/openwrt/target/linux/x86/64/config-4.14 > /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
awk '/^(#[[:space:]]+)?CONFIG_KERNEL/{sub("CONFIG_KERNEL_","CONFIG_");print}' /Volumes/Coder/docker/openwrt/openwrt/.config >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
echo "# CONFIG_KALLSYMS_ALL is not set" >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
echo "CONFIG_KALLSYMS_UNCOMPRESSED=y" >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
/Volumes/Coder/docker/openwrt/openwrt/scripts/ kconfig /Volumes/Coder/docker/openwrt/openwrt/tmp/.packageinfo /Volumes/Coder/docker/openwrt/openwrt/.config 4.14 > /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.override
/Volumes/Coder/docker/openwrt/openwrt/scripts/ 'm+' '+' /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/ /dev/null /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.override > /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set
mv /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.old
grep -v INITRAMFS /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.old > /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set
echo 'CONFIG_INITRAMFS_SOURCE=""' >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set
echo '# CONFIG_INITRAMFS_FORCE is not set' >> /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set
rm -rf /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/modules
cmp -s /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.prev || { cp /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config; cp /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.prev; }
export MAKEFLAGS= ; [ -d /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/user_headers ] || /Library/Developer/CommandLineTools/usr/bin/make -C /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167 HOSTCFLAGS="-O2 -I/Volumes/Coder/docker/openwrt/openwrt/staging_dir/host/include  -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="x86_64-openwrt-linux-musl-" ARCH="x86" KBUILD_HAVE_NLS=no KBUILD_BUILD_USER="" KBUILD_BUILD_HOST="" KBUILD_BUILD_TIMESTAMP="Wed Jan 29 16:05:35 2020" KBUILD_BUILD_VERSION="0" HOST_LOADLIBES="-L/Volumes/Coder/docker/openwrt/openwrt/staging_dir/host/lib" CONFIG_SHELL="bash" V=1  cmd_syscalls= KERNELRELEASE=4.14.167 CC="x86_64-openwrt-linux-musl-gcc" INSTALL_HDR_PATH=/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/user_headers headers_install
grep '=[ym]' /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.config.set | LC_ALL=C sort | mkhash md5 > /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.vermagic
touch /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.configured
rm -f /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/vmlinux /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/
/Library/Developer/CommandLineTools/usr/bin/make -C /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167 HOSTCFLAGS="-O2 -I/Volumes/Coder/docker/openwrt/openwrt/staging_dir/host/include  -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="x86_64-openwrt-linux-musl-" ARCH="x86" KBUILD_HAVE_NLS=no KBUILD_BUILD_USER="" KBUILD_BUILD_HOST="" KBUILD_BUILD_TIMESTAMP="Wed Jan 29 16:05:35 2020" KBUILD_BUILD_VERSION="0" HOST_LOADLIBES="-L/Volumes/Coder/docker/openwrt/openwrt/staging_dir/host/lib" CONFIG_SHELL="bash" V=1  cmd_syscalls= KERNELRELEASE=4.14.167 CC="x86_64-openwrt-linux-musl-gcc" modules
make[4]: Entering directory `/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167'
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/ obj=arch/x86/entry/syscalls all
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/ obj=scripts/basic
rm -f .tmp_quiet_recordmcount
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/ obj=arch/x86/tools relocs
set -e; : '  CHK     include/config/kernel.release'; mkdir -p include/config/; 	echo "4.14.167$(bash ./scripts/setlocalversion .)" < include/config/auto.conf > include/config/kernel.release.tmp; if [ -r include/config/kernel.release ] && cmp -s include/config/kernel.release include/config/kernel.release.tmp; then rm -f include/config/kernel.release.tmp; else : '  UPD     include/config/kernel.release'; mv -f include/config/kernel.release.tmp include/config/kernel.release; fi
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/Makefile.asm-generic \
	            src=uapi/asm obj=arch/x86/include/generated/uapi/asm
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/Makefile.asm-generic \
	            src=asm obj=arch/x86/include/generated/asm
set -e; : '  CHK     include/generated/uapi/linux/version.h'; mkdir -p include/generated/uapi/linux/; 	(echo \#define LINUX_VERSION_CODE 265895; echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';) < Makefile > include/generated/uapi/linux/version.h.tmp; if [ -r include/generated/uapi/linux/version.h ] && cmp -s include/generated/uapi/linux/version.h include/generated/uapi/linux/version.h.tmp; then rm -f include/generated/uapi/linux/version.h.tmp; else : '  UPD     include/generated/uapi/linux/version.h'; mv -f include/generated/uapi/linux/version.h.tmp include/generated/uapi/linux/version.h; fi
rm -f include/linux/version.h
set -e; : '  CHK     include/generated/utsrelease.h'; mkdir -p include/generated/; 	if [ `echo -n "4.14.167" | wc -c ` -gt 64 ]; then echo '"4.14.167" exceeds 64 characters' >&2; exit 1; fi; (echo \#define UTS_RELEASE \"4.14.167\";) < include/config/kernel.release > include/generated/utsrelease.h.tmp; if [ -r include/generated/utsrelease.h ] && cmp -s include/generated/utsrelease.h include/generated/utsrelease.h.tmp; then rm -f include/generated/utsrelease.h.tmp; else : '  UPD     include/generated/utsrelease.h'; mv -f include/generated/utsrelease.h.tmp include/generated/utsrelease.h; fi
mkdir -p .tmp_versions ; rm -f .tmp_versions/*
/Library/Developer/CommandLineTools/usr/bin/make -f ./scripts/ obj=.
mkdir -p kernel/
set -e; : '  CHK     include/generated/bounds.h'; mkdir -p include/generated/; 	(set -e; echo "#ifndef __LINUX_BOUNDS_H__"; echo "#define __LINUX_BOUNDS_H__"; echo "/*"; echo " * DO NOT MODIFY."; echo " *"; echo " * This file was generated by Kbuild"; echo " */"; echo ""; sed -ne 	's:^[[:space:]]*\.ascii[[:space:]]*"\(.*\)".*:\1:; /^->/{s:->#\(.*\):/* \1 */:; s:^->\([^ ]*\) [\$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; s:->::; p;}'; echo ""; echo "#endif" ) < kernel/bounds.s > include/generated/bounds.h.tmp; if [ -r include/generated/bounds.h ] && cmp -s include/generated/bounds.h include/generated/bounds.h.tmp; then rm -f include/generated/bounds.h.tmp; else : '  UPD     include/generated/bounds.h'; mv -f include/generated/bounds.h.tmp include/generated/bounds.h; fi
set -e; : '  CHK     include/generated/timeconst.h'; mkdir -p include/generated/; 	(echo 100 | bc -q kernel/time/timeconst.bc ) < kernel/time/timeconst.bc > include/generated/timeconst.h.tmp; if [ -r include/generated/timeconst.h ] && cmp -s include/generated/timeconst.h include/generated/timeconst.h.tmp; then rm -f include/generated/timeconst.h.tmp; else : '  UPD     include/generated/timeconst.h'; mv -f include/generated/timeconst.h.tmp include/generated/timeconst.h; fi
mkdir -p arch/x86/kernel/
set -e; : '  CHK     include/generated/asm-offsets.h'; mkdir -p include/generated/; 	(set -e; echo "#ifndef __ASM_OFFSETS_H__"; echo "#define __ASM_OFFSETS_H__"; echo "/*"; echo " * DO NOT MODIFY."; echo " *"; echo " * This file was generated by Kbuild"; echo " */"; echo ""; sed -ne 	's:^[[:space:]]*\.ascii[[:space:]]*"\(.*\)".*:\1:; /^->/{s:->#\(.*\):/* \1 */:; s:^->\([^ ]*\) [\$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; s:->::; p;}'; echo ""; echo "#endif" ) < arch/x86/kernel/asm-offsets.s > include/generated/asm-offsets.h.tmp; if [ -r include/generated/asm-offsets.h ] && cmp -s include/generated/asm-offsets.h include/generated/asm-offsets.h.tmp; then rm -f include/generated/asm-offsets.h.tmp; else : '  UPD     include/generated/asm-offsets.h'; mv -f include/generated/asm-offsets.h.tmp include/generated/asm-offsets.h; fi
mkdir -p ./tools
/Library/Developer/CommandLineTools/usr/bin/make LDFLAGS= MAKEFLAGS=" " O=/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167 subdir=tools -C ./tools/ objtool
mkdir -p /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool && /Library/Developer/CommandLineTools/usr/bin/make O=/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167 subdir=tools/objtool --no-print-directory -C objtool
error: unknown warning option '-Wstrict-aliasing=3'; did you mean '-Wstring-plus-int'? [-Werror,-Wunknown-warning-option]
/Library/Developer/CommandLineTools/usr/bin/make -C /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/build CFLAGS= LDFLAGS= /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/fixdep
/Library/Developer/CommandLineTools/usr/bin/make -f /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/build/ dir=. obj=fixdep
/Library/Developer/CommandLineTools/usr/bin/make -C /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/lib/subcmd/ OUTPUT=/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/
/Library/Developer/CommandLineTools/usr/bin/make -C /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/build CFLAGS= LDFLAGS= /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/fixdep
/Library/Developer/CommandLineTools/usr/bin/make -f /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/build/ dir=. obj=fixdep
  gcc -Wp,-MD,/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/.exec-cmd.o.d -Wp,-MT,/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/exec-cmd.o -Wbad-function-cast -Wdeclaration-after-statement -Wformat-security -Wformat-y2k -Winit-self -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wno-system-headers -Wold-style-definition -Wpacked -Wredundant-decls -Wshadow -Wstrict-prototypes -Wswitch-default -Wswitch-enum -Wundef -Wwrite-strings -Wformat -fno-strict-aliasing -ggdb3 -Wall -Wextra -std=gnu99 -fPIC -O3 -Werror -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -I/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/include/ -D"BUILD_STR(s)=#s" -c -o /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/exec-cmd.o exec-cmd.c
In file included from exec-cmd.c:2:
In file included from /Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/include/linux/compiler.h:89:
/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/include/linux/types.h:10:10: fatal error: 'asm/types.h' file not found
#include <asm/types.h>
1 error generated.
mv: cannot stat '/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/.exec-cmd.o.tmp': No such file or directory
make[8]: *** [/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/exec-cmd.o] Error 1
make[7]: *** [/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/libsubcmd-in.o] Error 2
make[6]: *** [/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/objtool/libsubcmd.a] Error 2
make[5]: *** [objtool] Error 2
make[4]: *** [tools/objtool] Error 2
make[4]: Leaving directory `/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167'
make[3]: *** [/Volumes/Coder/docker/openwrt/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/.modules] Error 2
make[3]: Leaving directory `/Volumes/Coder/docker/openwrt/openwrt/target/linux/x86'
make[2]: *** [compile] Error 2
make[2]: Leaving directory `/Volumes/Coder/docker/openwrt/openwrt/target/linux'
time: target/linux/compile#1.48#1.67#3.81
make[1]: *** [target/linux/compile] Error 2
make[1]: Leaving directory `/Volumes/Coder/docker/openwrt/openwrt'
make: *** [target/linux/compile] Error 2

tree build_dir/target-x86_64_musl/linux-x86_64/linux-4.14.167/tools/include/asm

├── alternative-asm.h
├── atomic.h
├── barrier.h
├── bug.h
├── export.h
└── sections.h
06.02.20202816Base systemBug ReportVery LowLowPoor upload speed with Relayd and Mediatek SoCsTrunkUnconfirmed Task Description

Raising a bug report to highlight there may be a problem with relayd performance issues with MT7621 and MT7628 SoCs

Wireless signal strength and link speeds reported by the devices are OK when displayed in LuCI, but the measured data throughput on upload link is extremely poor. Less than 1 Mbps.

Examples of affected devices include Xiaomi R3G, RT-AC57U and C50 v4.

Xiaomi R3G & RT-AC57U

Archer C50 v4

When using prebuilt owrt images, there is nothing in system log to indicate there are any problems.

05.02.20202815Base systemBug ReportVery LowLownftables in 19.07TrunkUnconfirmed Task Description


starting in 19.07 nftables don’t work properly.

This is on a MIPS xrx200 device, TPlink td w8970.

To install nftables:
- opkg update
- opkg install nftables
- opkg install kmod-nft-nat
- rm /etc/modules.d/ipt*
- rm /etc/modules.d/42-ip6tables
- reboot

Create the file /etc/nftables.conf

flush ruleset

table ip nat {
	chain prerouting {
		type nat hook prerouting priority filter; policy accept;

	chain postrouting {
		type nat hook postrouting priority srcnat; policy accept;
		meta oiftype ppp masquerade
table inet filter {
	chain input {
		type filter hook input priority filter; policy drop;
		ct state { established, related } accept
		ct state invalid drop
		meta iiftype != ppp accept
		ip protocol icmp accept
		ip6 nexthdr ipv6-icmp accept
		meta iiftype ppp drop

	chain forward {
		type filter hook forward priority filter; policy drop;
		ct state { established, related } accept
		ct state invalid drop
		meta iiftype != ppp accept
		ip protocol icmp accept
		ip6 nexthdr ipv6-icmp accept
		meta iiftype ppp drop

	chain output {
		type filter hook output priority filter; policy accept;

Then attempt to install via

nft -f /etc/nftables.conf

Gives the error that

/etc/nftables.conf:4:8-17: Error: Could not process rule: File exists
	chain prerouting {
/etc/nftables.conf:8:8-18: Error: Could not process rule: File exists
	chain postrouting {
/etc/nftables.conf:10:3-29: Error: Could not process rule: No such file or directory
		meta oiftype ppp masquerade

This is the error you would usually get if iptables nat was in the kernel, but lsmod confirms not installed. Running “nft flush ruleset” in isolatation works; and then the “nft -f /etc/nftables.conf” works as expected.

This provides WAN access for the lan, as expected; so NAT is working, and also router not scanned, so firewall is correct.

However on the router can’t do nslookups without error, eg.

opkg update
*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

Collected errors:
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download, wget returned -1.

But “ping” works.

But flushing the ruleset first (so no NAT or firewall) and the router access to the WAN works.

So this as a whole says nftables badly broken on this machine in 19.07, as can’t do an atomic replacement of the rules, and can’t get WAN access from the router.

In 18.06 this worked perfectly.

So it looks like in 19.07, there is some IPtable baggage left in the kernel, stopping nftables working correctly.

I checked the kernel configuation, and built my own openwrt 19.07, with hand crafted 4.14.167 kernel config. This boots with the same messages as 19.07.1 and has the same nftable faults.

I’ll keep digging, but time to report it here.

As long term, openwrt will probably need to move away from iptables, to nftables (as the iptables backend goes to nftables). So ideally we would get this working, so those openwrt users that use nftables, can debug their usage on openwrt, before everyone has to move.

Any ideas?


05.02.20202814KernelBug ReportVery LowHighnetns cleanup_net race conditionTrunkUnconfirmed Task Description

I’m seeing this issue on master built for x86-64, it’s been happening since I started using this x86-64 machine around December.

[   73.300163] =============================================================================                                                                                                                                                                                   
[   73.309803] BUG kmalloc-32 (Not tainted): Object already free                                                                                                                                                                                                               
[   73.316694] -----------------------------------------------------------------------------                                                                                                                                                                                   
[   73.328675] Disabling lock debugging due to kernel taint                                                                                                                                                                                                                    
[   73.335167] INFO: Allocated in ops_init+0x6d/0x100 age=147 cpu=0 pid=11053                                                                                                                                                                                                  
[   73.343242] INFO: Freed in 0xffffffffa09c94ca age=36 cpu=2 pid=50                                                                                                                                                                                                           
[   73.350557] INFO: Slab 0x00000000ed33138b objects=36 used=11 fp=0x0000000017541cc8 flags=0xf700000000101                                                                                                                                                                    
[   73.361281] INFO: Object 0x0000000041bc5c4c @offset=1576 fp=0x000000007d23c440                                                                                                                                                                                              
[   73.372490] Redzone 000000008c59cd8b: bb bb bb bb bb bb bb bb                          ........                                                                                                                                                                             
[   73.382449] Object 0000000041bc5c4c: 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b  kkkkkkkkkkkkkkkk                                                                                                                                                                      
[   73.393029] Object 0000000073cabfc7: 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b a5  kkkkkkkkkkkkkkk.                                                                                                                                                                      
[   73.403599] Redzone 000000009196639c: bb bb bb bb bb bb bb bb                          ........                                                                                                                                                                             
[   73.413574] Padding 000000009337e5e1: 5a 5a 5a 5a 5a 5a 5a 5a                          ZZZZZZZZ                                                                                                                                                                             
[   73.423549] CPU: 2 PID: 50 Comm: kworker/u16:1 Tainted: G    B             4.19.101 #0                                                                                                                                                                                      
[   73.432698] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./Z77 Pro4-M, BIOS P2.10 03/13/2018                                                                                                                                                                  
[   73.443617] Workqueue: netns cleanup_net                                                                                                                                                                                                                                    
[   73.448798] Call Trace:                                                                                                                                                                                                                                                     
[   73.452495]  dump_stack+0x57/0x7a                                                                                                                                                                                                                                           
[   73.457083]  print_trailer+0x203/0x210                                                                                                                                                                                                                                      
[   73.462068]  object_err+0x2f/0x36                                                                                                                                                                                                                                           
[   73.466613]  free_debug_processing.cold.107+0x2c/0x11f                                                                                                                                                                                                                      
[   73.472985]  ? ops_free_list.part.14+0x4d/0x60                                                                                                                                                                                                                              
[   73.478663]  __slab_free+0x1bd/0x330                                                                                                                                                                                                                                        
[   73.483482]  ? kmem_cache_free+0x1b5/0x1e0                                                                                                                                                                                                                                  
[   73.488778]  kfree+0x11c/0x140                                                                                                                                                                                                                                              
[   73.493009]  ops_free_list.part.14+0x4d/0x60                                                                                                                                                                                                                                
[   73.498460]  cleanup_net+0x1c4/0x280                                                                                                                                                                                                                                        
[   73.503215]  process_one_work+0x1a8/0x340                                                                                                                                                                                                                                   
[   73.508384]  worker_thread+0x2f/0x3a0                                                                                                                                                                                                                                       
[   73.513215]  kthread+0x10b/0x130                                                                                                                                                                                                                                            
[   73.517619]  ? process_one_work+0x340/0x340                                                                                                                                                                                                                                 
[   73.522967]  ? kthread_create_worker_on_cpu+0x60/0x60                                                                                                                                                                                                                       
[   73.529193]  ret_from_fork+0x35/0x40                                                                                                                                                                                                                                        
[   73.534067] FIX kmalloc-32: Object at 0x0000000041bc5c4c not freed                                                                                                                                                                                                          

There are old closed reports about it 2353 2354

I have tried with kernel 4.14 and with kernel 4.19 from the 19 branch and also removing the nf_conntrack_rtcache module, but the result is the same.

There are times that I see no BUG at all, others where I see it appear between 1 and several times. I use several docker containers and depending on the races, sometimes everything launches well and afterwards (if I don’t play with new docker instances) it is 100% stable whereas other times I have to reboot up to 3 or even 5 times for everything to work reliably.

dmesg with some race but working stable

partial dmesg which ends crashing, captured from another machine

05.02.20202812Base systemBug ReportVery LowCriticalXiaomi router 3g Openwrt V19 problem. Upload very low. openwrt-19.07Unconfirmed Task Description

Hello, I have xiaomi router 3g, I installed OpenWrt v18 and everything perfect, perfect speed, perfect management (although improvable) etc ...
The problem comes when upgrading to v19.07 and v19.07.1, the router’s upload speed low by half (wired 600mbs v18) v19 300mbs upload speed .... it looks like a bug and it happens to many people , is there any solution to this? Is it possible to improve the router driver and improve the upload and full management of v19? thanks.

04.02.20202811KernelBug ReportVery LowLowbrcm63xx: ssb: b43-pci-bridge: wifi broken: Speedport 3...AllUnconfirmed Task Description

Device problem occurs on: Speedport W 303V Type B

Software versions of OpenWrt/LEDE release: since kernel 4.x (OpenWrt 15.05)


PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
ssb: Found chip with id 0x4322, rev 0x01 and package 0x09
ssb: WARNING: Using fallback SPROM failed (err -2)
ssb: Failed to register PCI version of SSB with error -2
b43-pci-bridge: probe of 0000:00:01.0 failed with error -2

full bootlog

tried fixes:

  • build/enable all SSB kernel and OpenWrt modules
  • test all compatible broadcom wifi modules/versions supported by OpenWrt
04.02.20202810KernelBug ReportVery LowLowbrcm63xx: ssb: wifi broken: Speedport 303VAllUnconfirmed Task Description

Device problem occurs on: Speedport W 303V Type B

Software versions of OpenWrt/LEDE release: since kernel 4.x (OpenWrt 15.05)


PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
ssb: Found chip with id 0x4322, rev 0x01 and package 0x09
ssb: WARNING: Using fallback SPROM failed (err -2)
ssb: Failed to register PCI version of SSB with error -2
b43-pci-bridge: probe of 0000:00:01.0 failed with error -2

full bootlog

tried fixes:

  • build/enable all SSB kernel and OpenWrt modules
  • test all compatible broadcom wifi modules/versions supported by OpenWrt
04.02.20202809KernelBug ReportVery LowLowbrcm63xx: ssb: b43-pci-bridge: wifi broken: Speedport W...AllUnconfirmed Task Description

Device problem occurs on: Speedport W 303V Type B

Software versions of OpenWrt/LEDE release: since kernel 4.x (OpenWrt 15.05)


PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
ssb: Found chip with id 0x4322, rev 0x01 and package 0x09
ssb: WARNING: Using fallback SPROM failed (err -2)
ssb: Failed to register PCI version of SSB with error -2
b43-pci-bridge: probe of 0000:00:01.0 failed with error -2

full bootlog

tried fixes:

  • build/enable all SSB kernel and OpenWrt modules
  • test all compatible broadcom wifi modules/versions supported by OpenWrt
04.02.20202808KernelBug ReportVery LowMediumlantiq: xway: dwc2 - USB not working (ARV752DPW22 - Eas...TrunkUnconfirmed Task Description

Device problem occurs on: ARV752DPW22 (EasyBox803a) tested.

Software versions of OpenWrt/LEDE release: since kernel 4.19 (OpenWrt trunk)

kernel 4.14 USB reset every time working

Steps to reproduce:

openWrt_trunk first boot	> hang!
30sec power supply disconnect	> no_hang
soft reboot			> no_hang
short power supply disconnect	> hang!
15sec power supply disconnect	> hang!
30sec power supply disconnect	> hang!
30sec power plug disconnect	> hang!
soft reboot			> hang!
60sec power plug disconnect	> hang!

?seems hardware related? (reproducible), 2 of 3 EasyBoxes have hang! bug / behave like


dwc2 1e101000.usb: dwc2_core_reset: HANG! Soft Reset timeout GRSTCTL GRSTCTL_CSFTRST
dwc2: probe of 1e101000.usb failed with error -16

full bootlog

tried fixes:

lantiq: 4.19: increase usb reset timeouts → set to: 1000000

04.02.20202807Base systemBug ReportVery LowMedium(Wavlink WL-WN575A3) Signal strength LEDs don't work - ...openwrt-19.07Unconfirmed Task Description

Wavlink WL-WN575A3, Openwrt 19.07
Clean install set signal LEDs to rssi trigger but any of 3 LEDs don’t light due to missing rssileds package in default set of packages. After manual rssileds package install all 3 signal LEDs works as expected.

04.02.20202806Base systemBug ReportVery LowMediumDHCP enabled even though not present in config fileopenwrt-19.07Unconfirmed Task Description

Supply the following if possible:
- Device problem occurs on : Mikrotik RBM33G
- Software versions of OpenWrt/LEDE release, packages, etc: OpenWrt 19.07, synced this morning, fully up-to-date
- Steps to reproduce: no idea
My “Lan” /etc/config/network:
config interface ‘lan’

      option type 'bridge'
      option ifname 'eth0.1'
      option proto 'static'
      option netmask ''
      option gateway ''
      option ipaddr ''
      list dns ''
      list dns ''
      option ip6assign '60'

My “Lan in /etc/config/dhcp:
config dhcp ‘lan’

      option interface 'lan'
      option ignore '1'

My ip addr list:
25: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000

  link/ether cc:2d:e0:5a:b8:5b brd ff:ff:ff:ff:ff:ff
  inet brd scope global br-lan
     valid_lft forever preferred_lft forever
  inet brd scope global secondary br-lan
     valid_lft forever preferred_lft forever
  inet6 2a02:1802:a6:0:8a00:dfc6:fd71:a219/64 scope global dynamic
     valid_lft 2591708sec preferred_lft 604508sec
  inet6 fe80::6617:aede:f2cc:dd4/64 scope link
     valid_lft forever preferred_lft forever
  inet6 fe80::ce2d:e0ff:fe5a:b85b/64 scope link
     valid_lft forever preferred_lft forever

DHCP lease info from DHCP server:
LAN cc:2d:e0:5a:b8:5b 2020/02/04 10:23:54 2020/02/04 18:23:54 ethernet
LAN cc:2d:e0:5a:b8:5b 2020/02/04 10:23:56 2020/02/04 18:23:56 ethernet
... it does not listen to, though.

The device also sends traps to the trap server using, which is not registered in DNS (the reason why I detected it)

Maybe a bug in the config scripts somewhere?

03.02.20202803KernelBug ReportVery LowVery Lowmt76 kernel spam log with ingnoring tx power message openwrt-19.07Unconfirmed Task Description


Official build OpenWRT 19.07.1 without installed any add-ons packages.

System and kernel log all time are spammed by information about ignoring default 2.4G tx power even when in its set to default driver. This issue appears right after fresh installation and rebooting or changing wireless setting doesn’t fix it.

02.02.20202801PackagesBug ReportVery LowLowAdd s3fs packageTrunkUnconfirmed Task Description

A user recently asked how to compile s3fs on OpenWrt:

This is likely challenging to do on a router itself due to the limited RAM. I wonder if OpenWrt could include s3fs as a package? These is some precedent for this with sshfs:

01.02.20202795Base systemBug ReportVery LowLow19.07.x , TP-Link TL-WR841N v9, kernell panic openwrt-19.07Unconfirmed Task Description

Used TP-Link TL-WR841N/D v9 with mod 8M
tested with build for 8M firmware.

updated via:
scp copy to /tmp
mtd -r write /tmp/firmwaew.bin firmware

18.06 work ok on this hardware, report:

*     U-Boot 1.1.4-7a540a78-clean     *
*          Build: 2018-02-23          *

** Warning: bad env CRC, using default,
   use 'saveenv' to save it in FLASH

  BOARD: TP-Link TL-WR841N/D v9
    SOC: QCA953x ver. 1 rev. 1
    CPU: MIPS 24Kc
    RAM: 32 MB DDR1 16-bit CL3-3-3-8
  FLASH: 8 MB Winbond W25Q64
    MAC: E8:DE:27:CD:0C:C4
         550/400/200/ 25/ 25 MHz

Hit any key to stop booting:  0

Booting image from 0x9F020000...

   Vendor/image name:    OpenWrt r10911-c155900f66
   Hardware ID:          0x8410009
   Whole image size:     0 kB (0 bytes)
   Kernel size:          3.4 MB (3579760 bytes)
   Rootfs size:          0 kB (0 bytes)
   Kernel load address:  0x80060000
   Kernel entry point:   0x80060000

   Header CRC...  skipped
   Data CRC...    skipped

Stopping network... OK!
Uncompressing Kernel... OK!
Starting kernel...

[    0.000000] Linux version 4.14.167 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r10911-c155900f66)) #0 Wed Jan 29 16:05:35 2020
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] MIPS: machine is TP-Link TL-WR841N/ND v9
[    0.000000] SoC: Qualcomm Atheros QCA9533 ver 1 rev 1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] random: get_random_bytes called from 0x804776ec with crng_init=0
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 19648K/32768K available (3544K kernel code, 144K rwdata, 492K rodata, 7972K init, 203K bss, 13120K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] CPU clock: 550.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6950037990 ns
[    0.000011] sched_clock: 32 bits at 275MHz, resolution 3ns, wraps every 7809031678ns
[    0.008899] Calibrating delay loop... 366.18 BogoMIPS (lpj=1830912)
[    0.075976] pid_max: default: 32768 minimum: 301
[    0.081456] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.088993] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.102006] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.113239] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.120271] pinctrl core: initialized pinctrl subsystem
[    0.129130] NET: Registered protocol family 16
[    0.159871] clocksource: Switched to clocksource MIPS
[    0.166986] NET: Registered protocol family 2
[    0.173070] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.181077] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.188304] TCP: Hash tables configured (established 1024 bind 1024)
[    0.195734] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.202443] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.209932] NET: Registered protocol family 1
[    0.441778] Crashlog allocated RAM at address 0x1f00000
[    0.449761] workingset: timestamp_bits=30 max_order=13 bucket_order=0
[    0.463652] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.470338] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.573035] io scheduler noop registered
[    0.577495] io scheduler deadline registered (default)
[    0.586478] pinctrl-single 1804002c.pinmux: 576 pins at pa b804002c size 72
[    0.595622] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.605887] console [ttyS0] disabled
[    0.610067] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.619896] console [ttyS0] enabled
[    0.619896] console [ttyS0] enabled
[    0.627446] bootconsole [early0] disabled
[    0.627446] bootconsole [early0] disabled
[    0.655906] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[    0.660968] 3 fixed-partitions partitions found on MTD device spi0.0
[    0.667534] Creating 3 MTD partitions on "spi0.0":
[    0.672514] 0x000000000000-0x000000020000 : "u-boot"
[    0.678707] 0x000000020000-0x0000003f0000 : "firmware"
[    0.685921] 2 tplink-fw partitions found on MTD device firmware
[    0.692126] Creating 2 MTD partitions on "firmware":
[    0.697268] 0x000000000000-0x00000036a170 : "kernel"
[    0.703347] 0x000000370000-0x0000003d0000 : "rootfs"
[    0.709470] mtd: device 3 (rootfs) set to be root filesystem
[    0.715429] mtdsplit: no squashfs found in "rootfs"
[    0.720527] 0x0000003f0000-0x000000400000 : "art"
[    0.727132] libphy: Fixed MDIO Bus: probed
[    1.071005] ag71xx 19000000.eth: Could not connect to PHY device. Deferring probe.
[    1.750303] libphy: ag71xx_mdio: probed
[    1.755849] libphy: ar8xxx-mdio: probed
[    1.821951] switch0: Atheros AR8229 rev. 1 switch registered on mdio-bus.0
[    1.908098] ag71xx 1a000000.eth: connected to PHY at fixed-0:00 [uid=00000000, driver=Generic PHY]
[    1.918258] eth0: Atheros AG71xx at 0xba000000, irq 5, mode: gmii
[    1.927890] NET: Registered protocol family 10
[    1.939093] Segment Routing with IPv6
[    1.943086] NET: Registered protocol family 17
[    1.947742] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.961897] 8021q: 802.1Q VLAN Support v1.8
[    2.302222] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:1f:04 [uid=004dd042, driver=Generic PHY]
[    2.313243] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    2.370657] Freeing unused kernel memory: 7972K
[    2.375356] This architecture does not have kernel memory protection.
[    2.403375] init: Console is alive
[    2.407211] init: - watchdog -
[    2.437672] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    2.448667] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    2.466809] init: - preinit -
[    2.509932] random: fast init done
[    2.808648] random: jshn: uninitialized urandom read (4 bytes read)
[    2.917601] random: jshn: uninitialized urandom read (4 bytes read)
[    3.163179] random: jshn: uninitialized urandom read (4 bytes read)
[    3.805753] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    3.811977] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    4.821087] eth0: link up (1000Mbps/Full duplex)
[    4.825913] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    4.833060] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[    7.014588] eth0: link down
[    7.042239] procd: - early -
[    7.045358] procd: - watchdog -
[    7.636953] procd: - watchdog -
[    7.640695] procd: - ubus -
[    7.652470] urandom_read: 5 callbacks suppressed
[    7.652481] random: ubusd: uninitialized urandom read (4 bytes read)
[    7.694505] random: ubusd: uninitialized urandom read (4 bytes read)
[    7.702822] procd: - init -
Please press Enter to activate this console.
[    8.251779] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.275535] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.306112] Loading modules backported from Linux version v4.19.98-0-gd183c8e2647a
[    8.314024] Backport generated by backports.git v4.19.98-1-0-g8204eb99
[    8.342826] ip_tables: (C) 2000-2006 Netfilter Core Team
[    8.369084] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[    8.509039] xt_time: kernel timezone is -0000
[    8.643102] PPP generic driver version 2.4.2
[    8.661009] NET: Registered protocol family 24
[    8.746124] Data bus error, epc == 801f4180, ra == 8129febc
[    8.751898] Oops[#1]:
[    8.754255] CPU: 0 PID: 497 Comm: kmodloader Not tainted 4.14.167 #0
[    8.760819] task: 81878000 task.stack: 811f8000
[    8.765491] $ 0   : 00000000 00000001 deadc0de 00014000
[    8.770901] $ 4   : b81143fc 000143fc 00014000 00000004
[    8.776305] $ 8   : 00000001 7c7c3c7c 7c7c7c7c 7c7c7c7c
[    8.781707] $12   : 7c7c3c7c 81236500 ffffff80 7c7c7c3c
[    8.787120] $16   : 8115c080 00000018 00000000 00030000
[    8.792522] $20   : 00010000 00031018 00000004 000003ff
[    8.797925] $24   : 00000000 00000000
[    8.803328] $28   : 811f8000 811f9a30 811f9a84 8129febc
[    8.808740] Hi    : 00000003
[    8.811715] Lo    : 000000ff
[    8.814696] epc   : 801f4180 0x801f4180
[    8.818663] ra    : 8129febc 0x8129febc [ath9k_hw@81280000+0x51660]
[    8.825129] Status: 1000f403 KERNEL EXL IE
[    8.829458] Cause : 1080001c (ExcCode 07)
[    8.833598] PrId  : 00019374 (MIPS 24Kc)
[    8.837644] Modules linked in: ath9k(+) ath9k_common pppoe ppp_async ath9k_hw ath pppox ppp_generic nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_FLOWOFFLOAD xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 gpio_button_hotplug
[    8.901314] Process kmodloader (pid: 497, threadinfo=811f8000, task=81878000, tls=77fb3efc)
[    8.909933] Stack : ffffffff 81236500 ffffff80 ffffffff 00002710 8115c080 000003ff 812a0000
[    8.918580]         8111a800 8115c080 811f9b14 00000004 812ccda8 8115c4bc 00000001 8129ea64
[    8.927226]         811f8000 811f9a98 00000220 00000220 00008000 ffffffff 811f9b14 812a0ab0
[    8.935872]         8115a080 81283e88 00000001 80450000 812d9500 81201ff0 000186a0 8115c080
[    8.944519]         8115c080 8115c0a8 00008000 00000001 811f9b14 00000004 812ccda8 99999999
[    8.953165]         ...
[    8.955692] Call Trace:
[    8.955740] [<812a0000>] 0x812a0000 [ath9k_hw@81280000+0x51660]
[    8.964387] [<8129ea64>] 0x8129ea64 [ath9k_hw@81280000+0x51660]
[    8.970516] [<812a0ab0>] 0x812a0ab0 [ath9k_hw@81280000+0x51660]
[    8.976635] [<81283e88>] 0x81283e88 [ath9k_hw@81280000+0x51660]
[    8.982755] [<81201ff0>] 0x81201ff0 [ath9k@81200000+0x16bb0]
[    8.988619] [<812930f8>] 0x812930f8 [ath9k_hw@81280000+0x51660]
[    8.994739] [<80093348>] 0x80093348
[    8.998350] [<812864d0>] 0x812864d0 [ath9k_hw@81280000+0x51660]
[    9.004467] [<80250bd8>] 0x80250bd8
[    9.008081] [<80093348>] 0x80093348
[    9.011691] [<812026a4>] 0x812026a4 [ath9k@81200000+0x16bb0]
[    9.017543] [<800aefec>] 0x800aefec
[    9.021168] [<8120e468>] 0x8120e468 [ath9k@81200000+0x16bb0]
[    9.027023] [<80299160>] 0x80299160
[    9.030649] [<8024f43c>] 0x8024f43c
[    9.034250] [<8029367c>] 0x8029367c
[    9.037852] [<8024db98>] 0x8024db98
[    9.041454] [<8024fabc>] 0x8024fabc
[    9.045058] [<8024dce4>] 0x8024dce4
[    9.048656] [<8024bd38>] 0x8024bd38
[    9.052263] [<8024dc60>] 0x8024dc60
[    9.055870] [<8024bdf0>] 0x8024bdf0
[    9.059471] [<803bf270>] 0x803bf270
[    9.063074] [<8024bc3c>] 0x8024bc3c
[    9.066680] [<8024d124>] 0x8024d124
[    9.070291] [<8024e300>] 0x8024e300
[    9.073905] [<81217000>] 0x81217000 [ath9k@81200000+0x16bb0]
[    9.079748] [<8024e4a8>] 0x8024e4a8
[    9.083366] [<81217018>] 0x81217018 [ath9k@81200000+0x16bb0]
[    9.089214] [<80060a00>] 0x80060a00
[    9.092822] [<800e6a40>] 0x800e6a40
[    9.096423] [<800912d4>] 0x800912d4
[    9.100025] [<8010fbe0>] 0x8010fbe0
[    9.103642] [<800cbee4>] 0x800cbee4
[    9.107247] [<80111044>] 0x80111044
[    9.110854] [<800cb81c>] 0x800cb81c
[    9.114462] [<800c9680>] 0x800c9680
[    9.118071] [<80111a14>] 0x80111a14
[    9.121673] [<8011c4e0>] 0x8011c4e0
[    9.125275] [<800cbb3c>] 0x800cbb3c
[    9.128878] [<800cbc28>] 0x800cbc28
[    9.132487] [<8006ed8c>] 0x8006ed8c
[    9.136093] [<803d0c74>] 0x803d0c74
[    9.139698] [<800698a0>] 0x800698a0
[    9.143307]
[    9.144847] Code: 26310001  8c820000  0000000f <03e00008> 00000000  27bdffe8  afbf0014  0c0a76b2  00000000
[    9.154936]
[    9.156551] ---[ end trace eb9837c2a907321b ]---
[    9.163433] Kernel panic - not syncing: Fatal exception
[    9.169959] Rebooting in 1 seconds..

same crash and with public images:

01.02.20202794Base systemBug ReportVery LowLowCannot Override MAC add of wireless interfaceopenwrt-19.07Unconfirmed Task Description

- Device problem — Can’t change wireless MAC add
- Software versions of OpenWrt/LEDE release,— openwrt-19.07.0-ar71xx-generic-cpe210-220-v1-


hi..good day... i have tp-link CPE 220 v1 i used openwrt firmware openwrt-18.06.6-ar71xx-generic-cpe210-220-v1-squashfs-sysupgrade no problem. i can change the Wi-Fi BSSID or Override MAC address...

when i upgrade the firmware to openwrt-19.07.0-ar71xx-generic-cpe210-220-v1-squashfs-sysupgrade i can’t Override the MAC address...

pls help...

openwrt-18.06.0 TO openwrt-18.06.6 can Override the MAC address all interface

openwrt-19.07.0 cannot Override the MAC address of Wireless, (Wireless only)

31.01.20202792Base systemBug ReportVery LowLowlantiq DSL statuistics and diagnostics do not report G....openwrt-19.07Unconfirmed Task Description

OpenWrt 19.07.1 on BT HomeHub5A (lantiq vrx200) the dsl stats report tool (ltq-vdsl-app_4.17.18.6-2_mips_24kc.ipk) and the matching kerel module (kmod-ltq-vdsl-vr9-mei_4.14.167+ do not report ITU G.998.4 Retransmission counts (on lines using G.INP retransmissions. It turns out that adding:

  1. -enable-dsl-pm-retx-counters \
  2. -enable-dsl-pm-retx-thresholds

to openwrt/package/kernel/lantiq/ltq-vdsl/Makefile and openwrt/package/network/config/ltq-vdsl-app/Makefile and rebuilding yields a working ReTx counter report:

root@BTHH5A:~# . /lib/functions/ ; dsl_cmd rtsg 0
nReturn=0 nDirection=0 nRxCorruptedTotal=0 nRxUncorrectedProtected=0 nRxRetransmitted=0 nRxCorrected=0 nTxRetransmitted=3
root@ BTHH5A:~# . /lib/functions/ ; dsl_cmd rtsg 1
nReturn=0 nDirection=1 nRxCorruptedTotal=7114893 nRxUncorrectedProtected=6171968 nRxRetransmitted=0 nRxCorrected=942925 nTxRetransmitted=9228892

At least in Germany the incumbent uses G.998.4 Retransmission, not only do deal with impulse noise, but also as a diagnostic counters for its Dynamik Link/Spektrum Management tool that based on these and other counters will limit the maximum perissable Sync for each line to optimize lik stability. It would be really great if stock OpenWrt builds would alow to report these values and I would like to propose to change the makefiles as shown above.

31.01.20202791Base systemBug ReportVery LowHighIPv6 router advertisments lost after upgrade to 19.07openwrt-19.07Unconfirmed Task Description

I’ve just upgraded my linksys wrt-1200ac from 18.06.4 to 19.07.0

I’ve got a more-or-less out-of-the-box configuration with wired and wireless clients all connected to the ‘br-lan’ bridge. My ISP provides native IPv6. I’ve got odhcpd-ip6only installed, and a mixture of clients, some using SLAAC and some using DHCPv6.

When a wireless client that is configured for SLAAC (e.g. an android phone) connects, it sends an IPv6 router solicitation to ff02::1 and receives a router advertisement on its fe80::<something> address. That still works fine. But the client never receives any further router adverts, so the route times out after 1800 seconds and IPv6 connectivity is lost.

This is *only* going wrong with wireless clients: tcpdump on a wired client shows router adverts arriving on ff02::1 every few minutes. But tcpdump on a wireless client shows no router adverts after the initial one.

I’ve retested with 18.06.4 and the problem does not exist in that version.

31.01.20202790Base systemBug ReportVery LowLowRouter LEDs on Asus RT-N11P not work properlyAllUnconfirmed Task Description

On router Asus RT-N11P (MT7620) not work properly hardware LEDs. Zero-day problem. Affected all firmwares from 18.06.0 to 19.07.1. No additional packages used. Router LEDs “WiFi”, “WAN“, “LAN” always on even if WiFi fully disabled and all cables is unplug.

Steps to reproduce:

1: Disable WiFi (if enabled) and unplug all cables.
2: LEDs will still light even if reboot.

Changing the LEDs settings does not solve the problem at all. LEDE 18.06.XX not have problem with “WiFi” LED. 19.07.XX have problems with all LEDs.


31.01.20202789KernelBug ReportVery LowLowWAN-LAN leakage during boot on Asus RT-N11PAllUnconfirmed Task Description

On Asus RT-N11P (MT7620N) not work properly DHCP. Zero-day bug. Affected all firmwares from 18.06.0 to 19.07.1. No additional packages used.

Steps to reproduce:

1: Reboot router when any OS fully loaded.
2: After reboot router give through DHCP internal ip my ISP.
3: No internet connection.

If restart OS network, router give normal ip. But if again reboot router then the problem is repeated. Its a bug MT7620N but official router firmware have solution to bypass it and DHCP gives normal ip.
For now, to bypass the bug, I use manual entry in OS network settings:


31.01.20202788Base systemBug ReportVery LowMediumr11486 in unable to bring up/down wifi interfaces multi...TrunkUnconfirmed Task Description

Model Buffalo WZR-HP-G300NH
Issue reproducible in commit r11486
Issue absent in Commit r11483

This device has one wifi device which is configured to provide at least two wifi-ifaces, each iface is disabled at startup; each iface got a different BSSID/maccaddr/ifname;

These wifi-interfaces are enabled/disabled manually by using a script: the script set one wifi-iface “disabled” param to either “0” or “1” (these changes are NOT saved using uci commit) and then runs the commands “wifi” and “ubus call network reload && /etc/init.d/dnsmasq reload”

- Steps to reproduce
Enabling and then disabling both interfaces multiple times make wifi inoperable without a reboot.

SYSLOG detailing what happens when the issue manifests itself

Sample wireless config

30.01.20202786Base systemBug ReportVery LowLowlibubox: usock: usock_inet_timeout() does not try all s...TrunkUnconfirmed Task Description

usock_inet_timeout() does not try all possible ipv6 and ipv4 server addresses if getaddrinfo() returns multiple records on the same family.

Also, it does not allow one to easily differentiate server-not-found (or other getaddrinfo() issue) from connect timeout, from connect refused.

To try all possible servers, one can either attempt to connect() to all of them in parallel (which seems too aggressive), or try to keep one connect() in progress for each family, replacing it with the next possibility should it return ECONNREFUSED, until the timeout expires.

Defining the use of errno should not be a problem, since it was undefined before so it is backwards-compatible:

If getaddrinfo() returns an error, it would be best to return -1, errno=ENOENT.
If none of the servers connect, return ECONNREFUSED if *at least one of them* returned ECONNREFUSED, or ETIMEDOUT otherwise (i.e. all timed out).

If timeout is zero, we return a socket that is likely to be in-progress and might fail to connect. That’s fine, just try IPv6 first.

30.01.20202785Base systemBug ReportVery LowHighkernel loading during netboot fails on mikrotik devicesopenwrt-19.07Unconfirmed Task Description

Devices tested:

  • Mikrotik rb433
  • Mikrotik rb435g

Software version: Using the v19.07.1 tag.

Issue: There are a few packages, whose are leading the ramdisk “unbbotable”, more precise the device is not able to load the kernel. First this happened by kmod-scsi-core , I thought it must be some kernel-related issue. Afterthat I realised that either I enable the aforementioned kernel-module, or the libraries called libpcre and libpci, the boot procedure will stop at:

transfer started ................................... transfer ok, time=2.61s
setting up elf image... OK
jumping to kernel code OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos Decompressing kernel... done!
Starting kernel at 80060000...

Compiling these packages only as a module results a nice bootable image. Firstly I thought that maybe my ramdisk is too large, but it is about only 4,5 MB - previously using older trunk I was able to boot up images over 5 MByte.
I have pasted the config file to the ticket. If you switch libpcre and libpci to M instead of * it will boot.

This issue was not there before, using the image built from 18.06.

30.01.20202784Base systemBug ReportVery LowMediumlibubox: usock: poll_restart() broken, affects usock_in...TrunkUnconfirmed Task Description

on libubox/usock.c:

poll_restart() is trying to use the return of poll() as if it were errno.

This renders the error paths in that function ineffective, and most likely result in errors being hidden. The function will spin around until it times out, and mask the real error.

This impacts the “happy eyeballs” code on usock_inet_timeout(), plus any other users of poll_restart().

30.01.20202783Base systemBug ReportVery LowHighTP-Link Archer A7 v5 can't be flashet via tftpopenwrt-19.07Unconfirmed Task Description

Device: TP-Link Archer A7 (RU) Ver 5.0
Software: OpenWRT 19.07.0

I just bought this router. And I trying to flash it with openwrt-19.07.0-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin trough tftp.
In wireshark I clearly see that file was downloaded. But router didn’t flashed.
I tried to flash snapshot image wtih same result.
I checked sha256 sums and it matches.

When I reproduced same steps with original TP-Link update image it worked well. Seems like something prevents router from flashing OpenWRT image.

27.01.20202779Base systemBug ReportVery LowLowFeature request: Display name of file in /etc/config if...TrunkUnconfirmed Task Description

In LuCI issues #3567 on Github ( I asked about the “uci: Entry not found” message. The problem was that there was an unusual (non-standard) file present in /etc/config

I created a feature request there (, but I understand that this report/request should be filed here.

Request: It would be good if that error message could include more information, perhaps the file name of the offending file. Thank you.

26.01.20202777KernelBug ReportVery LowLowCONFIG_NETLINK_DIAG is not setTrunkUnconfirmed Task Description

The Socket statistics utility, ss, will throw Cannot open netlink socket: Protocol not supported errors due to CONFIG_NETLINK_DIAG being unset in the kernel config.

root@apu:~# ss
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Cannot open netlink socket: Protocol not supported
Netid                    State                      Recv-Q                      Send-Q                                                 Local Address:Port                                              Peer Address:Port                      
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 245                                                          * 0                         
u_str                    ESTAB                      0                           0                                                                  * 473                                                          * 0                         
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 1363                                                         * 0                         
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 1515                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 2486                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 2514                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 3197                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 3366                                                         * 0                         
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 3367                                                         * 0                         
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 3520                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 5924                                                         * 0                         
u_str                    ESTAB                      0                           0                                                                  * 5925                                                         * 0                         
u_str                    ESTAB                      0                           0                                                 /var/run/ubus.sock 600750                                                       * 0                         
u_str                    ESTAB                      0                           0                                                                  * 601742                                                       * 0                         
u_dgr                    ESTAB                      0                           0                                                           /dev/log 471                                                          * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 1576                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 1595                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 2445                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 2484                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 3188                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 5505                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 5929                                                         * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 565769                                                       * 0                         
u_dgr                    ESTAB                      0                           0                                                                  * 601735                                                       * 0                         
tcp                      ESTAB                      0                           0                                                                                                 
tcp                      ESTAB                      0                           0                                                                                                    
tcp                      ESTAB                      0                           0                                                                                                  
tcp                      ESTAB                      0                           0                                                                                                    
tcp                      ESTAB                      0                           0 

I’ve confirmed this on OpenWrt 18.06.5 (x86/64) but the issue will exist on all platforms.
@neheb helped identify the real issue when I opened a bug for the ss package on Github and @RussellSenior recently saw the thread -

The suggested fix is:

--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -3164,7 +3164,7 @@ CONFIG_NETDEVICES=y
 # CONFIG_NETPOLL is not set
 # CONFIG_NETROM is not set

24.01.20202774ToolchainBug ReportVery LowMediumimagebuilder breaks in long pwdopenwrt-19.07Unconfirmed Task Description

I have a directory where I keep imagebuilder. I can sucessfully build custom images there for d-link/dir-825, xiaomi/mini, tp-link/wr842nd_v1 and linksys/wrt1900ac. But trying to create default image for ar71xx/mikrotik gives error:

Successfully writed 13 blocks and 1757184 bytes
Each block contain 64 chanks + 0 bytes tail hole.
Each chunk(2112 bytes) consists: data part(2048 bytes) + oob part(64 bytes).
mv: cannot stat '/mydir/openwrt/imagebuilder/openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/tmp/': No such file or directory
make[3]: *** [Makefile:71: /mydir/openwrt/imagebuilder/openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/tmp/openwrt-19.07.0-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin] Error 1
make[2]: *** [Makefile:169: build_image] Error 2
make[1]: *** [Makefile:120: _call_image] Error 2
make: *** [Makefile:197: image] Error 2

It can be reproduced:

% mkdir /tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
% cd /tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
% wget
% tar xf openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64.tar.xz
% cd openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64
% make image PROFILE=nand-large
1671656 bytes (1.7 MB, 1.6 MiB) copied, 0.00693055 s, 241 MB/s
Can't get lstat from kernel file!: No such file or directory
make[3]: *** [Makefile:71: /tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa/openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/tmp/openwrt-19.07.0-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin] Error 255
make[2]: *** [Makefile:169: build_image] Error 2
make[1]: *** [Makefile:120: _call_image] Error 2
make: *** [Makefile:197: image] Error 2
zsh: exit 2     make image PROFILE=nand-large
24.01.20202773Base systemBug ReportVery LowLowimagebuilder doesn't work if pwd contains spacesTrunkUnconfirmed Task Description

- Steps to reproduce

% mkdir "/tmp/a b"
% cd /tmp/a\ b
% wget
% tar xf openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64.tar.xz
% cd openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64
% make info                    
bash: /tmp/a: No such file or directory
Makefile:72: b/openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64/include/ No such file or directory
make: *** No rule to make target 'b/openwrt-imagebuilder-19.07.0-ar71xx-mikrotik.Linux-x86_64/include/'.  Stop.
zsh: exit 2     make info
24.01.20202771Base systemBug ReportVery LowLownon-US region card doesn't start in VHT80 modeTrunkUnconfirmed Task Description

Supply the following if possible:
- Archer C7 v1
- r11895-fba8083
- set country to US or world, enable 5ghz wifi with 80mhz bw


card is falling back to VHT20 mode, and no channel/country config change from interface helps to get it started at VHT80.
confirmed using QCA9880 v1 card that comes with CR regdomain burned in by default, and is likely present with cards coming with several other regdomains in eeprom.
hardcoding null value for regdomain in ath10k driver allows it to get detected as US region card in which case VHT80 starts as expected

log output:

Wed Jan 15 10:05:22 2020 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Wed Jan 15 10:05:23 2020 daemon.err hostapd: HT40 secondary channel 40 not allowed
Wed Jan 15 10:05:23 2020 daemon.notice hostapd: Fallback to 20 MHz
Wed Jan 15 10:05:23 2020 daemon.err hostapd: Using interface wlan0 with hwaddr 10:fe:ed:eb:f0:5f and ssid "OpenWrt55"

it is expected that once different country is set from config, its limits will take effect without old/default country values interference

24.01.20202770Base systemBug ReportVery LowLowSome WiFi interfaces are not coming up after a rebootTrunkUnconfirmed Task Description

ipq806x / R7800


I started having issues in master when some of wifi (either 5GHz or 2GHz) interfaces would not come up and it now takes several router reboots to get them all going. I have compared the output of “wifi status” in both cases and noticed that when the interfaces did not come up, the output was missing the “ifname” line for the affected interfaces. Restarting wifi triggers a similar issue: some wifi’s would show up dis-associated in LuCI.

These are some messages related to one of the interfaces. In this case the router came up with wifi radios disabled (on purpose) and once a PPPoE link got established and the connectivity verified, a hot plug script enabled wifi and then restarted it.

daemon.notice hostapd: nl80211: Failed to remove interface ap2 from bridge br-lan: No such device
user.notice root: ip link set dev ap2 up
daemon.notice hostapd: ap2: CTRL-EVENT-TERMINATING
daemon.err hostapd: hostapd_free_hapd_data: Interface ap2 wasn’t started

This all used to work until a month or so ago. I am now back to 19.07 where is all working fine.

24.01.20202769Base systemBug ReportVery LowLowct-htt firmware is missing from ipq40xx target in 19.07openwrt-19.07Unconfirmed Task Description


I am trying to put together an image for gl-b1300 (ipq40xx) using the image builder and it is failing with the error below. I looked at the base packages for 19.07 and the htt variants are missing for all ath10k-firrmware-qca supported targets. I also checked ipq806x for 19.07 and the htt firmware is present there.
Looking at master: the ipq40xx target does include htt packages.

Are the htt firmware files excluded from ipq40xx in 19.07 for a reason?

Collected errors:
* opkg_install_cmd: Cannot install package ath10k-firmware-qca4019-ct-htt.
Makefile:153: recipe for target ‘package_install’ failed
make[2]: * [package_install] Error 255
Makefile:112: recipe for target ‘_call_image’ failed
* [_call_image] Error 2
Makefile:196: recipe for target ‘image’ failed
make: *** [image] Error 2

24.01.20202768ToolchainBug ReportVery LowHighmake_ext4fs: Name-Based UUID leads to collisionTrunkUnconfirmed Task Description

make_ext4fs uses name-based uuid generation (see

Therefore, as the uuid generation does only depend on the Filesystem Label and an hardcoded namespace, the UUID is exactly identical for multiple different filesystems with the same label (see;a=blob;f=ext4_utils.c;h=1a886d7e86262d35e30d894f821ca91d32384e96;hb=HEAD#l224).

This can lead to problems like the inability to mount an filesystem by UUID.
In my constellation, I have an MMC Storage and an external SD-Card, both flashed with filesystems generated by make_ext4fs. They both have the same UUID, therefore it’s impossible to distinguish/mount them by UUID.

My suggestion would be to replace “info.label” as parameter for “generate_uuid” trough another, better suited value, e.g. an hash of the make_ext4fs directory content. Maybe it should be considered to switch to an Random Number-based UUID (

Affected Devices/Targets: All toolchains that use make_ext4fs
Revision: make-ext4fs-2020-01-05-5c201be7

23.01.20202765Base systemBug ReportVery LowMediumLong working use of spidev in Device Tree fails in rece...TrunkUnconfirmed Task Description

Here’s I original ticket posting from several years ago.

The driver for the Linux-4.4.6 kernel supplied with the ‘trunk’ source code, gives the following message when the eSPI driver is initialized.

Kernel boot printk’s...

spidev spi32766.0: buggy DT: spidev listed directly in DT

Upon looking into this apparently this diagnostic was added for some reason which seems to be impossible to find.

In any case, the ‘solution’ that was proposed in one of the messages I found discussing the problem was to ‘modify the driver’ to accept the spi device in question... which in my opinion corrupts the whole business of the Device Tree, and no other description was give on how to correct the Device Tree to match someone’s expectation of what it should be.

The irony is that when I ignore the error message, the devices are entered in to the /dev/spidevX.Y correctly

When I remove the offending ‘spidev’ compatibility tag, the instances fail to appear.

22.01.20202764Base systemBug ReportVery LowHighucert: ucert -A output is invalidTrunkUnconfirmed Task Description

ucert -A generates something that ucert cannot read back.

This happens because ucert -A appears to be appending several libubox “blobs” together, but cert_load() uses libubox’ blob_parse_untrusted() which expects to get a buffer with a single blob inside, and no padding.

Thus a valid ucert file with certificate and signature will be *bigger* than the first blob inside it, and blob_parse_untrusted() in libubox won’t even try to process it.

Since this renders ucert useless, severity is set to high.

This is related to FS#2762 and FS#2763

22.01.20202763Base systemBug ReportVery LowLowucert: missing tests for certificate chains and ucert -...TrunkUnconfirmed Task Description

ucert is missing test cases for:

ucert -A
ucert -D on the output of ucert -A.

This is very important because it would have flagged the fact that currently ucert -A generates something that ucert will not read back, in fact rendering signed sysupgrade images unusable without sysupgrade -F.

22.01.20202762Base systemBug ReportVery LowMediumlibubox: blob_parse_untrusted() / blob_parse() incompat...TrunkRequires testing Task Description

blob_parse_untrusted(), as written, requires that the buffer length be exactly the same of the first blob inside it, the buffer being the memory area of size attr_len, pointed to by attr.

This can work if that input buffer contains exactly a single blob (which recursively contains other blobs, maybe). But it certainly does not work if there is any padding at the end of the buffer (thus attr_len > blob_raw_len(attr)), or if the buffer contains a series of blobs “back-to-back” (like an ucert chain seems to be defined to be).

Just removing the code block below (or adjusting it to use len > attr_len):

len = blob_raw_len(attr); 
if (len != attr_len) 
      return 0; 

Won’t fix it, because blob_for_each_attr_len() does not actually walk a series of back-to-back blobs anyway (it never updates attr and attr_len).

So, what is actually the intended usage for this stuff? This really wants to be documented, there is no high-level “what this is supposed to be used for” documentation anywhere in blob.h or blob.c, let alone a proper documentation of every exported function in blob.h/blob.c :-(

Anyway, what ucert -A is doing is incompatible with blob_parse() and also blob_parse_untrusted(), since it wants to deal with a series of blobs back-to-back, and not a single blob that contains other blobs.

22.01.20202761PackagesBug ReportVery LowLowlibopenssl-devcryptoAllUnconfirmed Task Description

Hi All,

I think there is a problem with the package:

As reported in the guide Hardware Accelerators:

when trying to install the package libopenssl-devcrypto, that depends on kmod-cryptodev, but it doesn’t exist.

Obviously, the problem is reproducible in LUCI

21.01.20202759PackagesBug ReportVery LowMediumodhcpd IPv6 NDP + macOS don't play togetheropenwrt-19.07Unconfirmed Task Description

My device: TP-Link Archer C7 v2.0 (JP)
My software stack: OpenWrt 19.07

My router uses odhcpd’s relay mode to relay IPv6 neighbor discovery protocol and router advertisements from the uplink router.

My linux-based system connected to the router is able to get IPv6 connectivity through the router without problems.

However, my macOS-based system doesn’t get IPv6 connectivity. It gets a global IPv6 prefix, which suggests that it’s able to receive RA packets, but my router is also unable to ping6 the macOS system by it’s globally unique address, and doing ip -6 neigh on the router makes it clear that the router doesn’t know the MAC address of the macOS system, and all of it’s probes to find it, end up failing.

Inspecting the ICMPv6 traffic in the LAN shows that my macOS system doesn’t respond to the neighbor solicitation packets send by the router. Here’s an example of such a packet:

02:28:50.006540 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fd26:e9f1:e833::1 > ff02::1:ff65:88f8: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2404:7a80:9621:7100:404:978a:5765:88f8

  source link-address option (1), length 8 (1): 18:a6:f7:8d:c0:d3

Here, fd26:e9f1:e833::1 is the ULA of the LAN interface of the router.

According to Apple discussion board ( ) macOS seems to have a behaviour such that it ignores neighbor solicitation packets unless the source address of the packet is a link-local address.

Indeed, commenting out option ula_prefix in /etc/config/network makes odhcpd to use link-local addresses, and that makes macOS to respond to neighbor solicitation queries, and in my system, demonstrably restores IPv6 connectivity.

Since macOS is a very common operating system, it would be benefical if odhcpd’s default behaviour were to use LLA in NDP packets. The current situation of not being able to set ULA prefix without losing connectivity is unfortunate. (And I think that ULA prefix is set by default in OpenWRT, which makes macOS not play together with it by default.)

For reference, here’s a forum thread I documented my forays into inspecting this problem:

Could the default source address of odhcpd’s NDP/RA packets be changed to LLA?

21.01.20202758Base systemBug ReportVery LowLowlibubox: lua: cmake forces install prefix TrunkUnconfirmed Task Description

the CMakeLists.txt in libubox/lua is installs to LUAPATH, which is detected via the (badly versioned) raw lua call, which results in an absolute path, so the library destination call ignores the prefix

cmake -DCMAKE_INSTALL_PREFIX:PATH=/home/karlp/.local

– Installing: /home/karlp/.local/share/libubox/
– Installing: /usr/lib64/lua/5.3/ «< neither 5.1, nor within /home/karlp/.local

This is just awkward when building local versions of things

git version: 43a103ff17 (side note, tags in this repo wouldn’t hurt)

Showing tasks 201 - 250 of 1138 Page 5 of 23<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts


Task Details

Task Editing