OpenWrt/LEDE Project

Welcome to the OpenWrt/LEDE Project bug reporting and issue tracking system

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to lede-bugs@infradead.org.

OpenedIDCategoryTask TypePrioritySeveritySummaryReported InStatus
18.01.2017401PackagesFeature RequestVery LowLowodhcpd: lease trigger script receives no argumentsTrunkUnconfirmed Task Description

when odhcpd calls the “lease trigger” script it does not pass any arguments to the script. The reason for the trigger and the host involved in the trigger are not shared. There is no discretion for RENEW, REBIND, CONFIRM, or RELEASE. Scripts which wish to load DNS with limited data, need to store their own copy of DHCP lease file and do differences. Otherwise a raw translate and dump of a large DHCP network could cause a lot of congestion as DHCP clients come on line. Reseting a network can cause an “in rush” flow like air conditioning loads on a power grid during a summer power outage.
This is exacerbated if the DNS is served on a separate device over the network, such as nsd and nsd-control (bind or unbound also). It would be good to at least pass the command and parameters common to a odhcpd lease file line.

18.01.2017400PackagesBug ReportVery LowLowodhcpd: lease file persistence per RFC2131 S-2.1 and S-...TrunkUnconfirmed Task Description

RFC2131 DHCPv4 expects that the DHCP leases and other configuration results are in persistent storage. For small embedded routers during a machine reboot, it has been accepted that read-write memory is RAM (not flash) and persistence may not be entirely upheld. That being said, odhcpd has no means to maintain the lease information even through an application only restart (example ifup event). The lease file odhcpd writes is not used to seed odhcpd, if it is restarted. (1) an interface reconnect that causes odhcpd to restart destroys the lease record, even if the network resumes as previously configured. (2) even if odhcpd lease file is directed to persistent storage (USB drive) it is not used to resume leases.

17.01.2017398PackagesFeature RequestVery LowLowodhcpd: add UCI option to insert DHCP fill for missing ...TrunkUnconfirmed Task Description

This is a request for a common DHCP function found in other software. It would be nice for an odhcpd general option to enable it to fill in unnamed leases. DHCPv4 use the MAC as in unknown-010203040506 and DHCPv6 use the last 64 bits of the DUID as in unknown-0102030405060708. This can be used to figure out which device has failed to send its host name. This is a common problem with DHCPv6. This is a common problem for smart TV or cameras. Consider logs from a device other than the DHCP serving router. Consider where IT may not want to static assign 100’s of host names for display devices over a large work site or campus. Security logs and DHCP logs on a distributed network can then be reconciled a-synchronously, off line, or only when an investigation is required.

17.01.2017394Base systemBug ReportVery LowLowPPPoE/802.1Q issues on Linksys WRT1900ACSTrunkUnconfirmed Task Description

Device: Linksys WRT1900ACS
LEDE commit: b9a408c2b49ccfa0e906bda00ef77f4002e401fd

diffconfig:
CONFIG_TARGET_mvebu=y
CONFIG_TARGET_mvebu_DEVICE_linksys-wrt1900acs=y
CONFIG_TARGET_BOARD=”mvebu” CONFIG_LIBSODIUM_MINIMAL=y
CONFIG_PACKAGE_dnscrypt-proxy=y
CONFIG_PACKAGE_dnscrypt-proxy-resolvers=y
CONFIG_PACKAGE_libsodium=y

I have an ISP that requires PPPoE on vlan 201 with 802.1Q tags (CenturyLink fiber). On OpenWRT 15.05.1 and on earlier versions of LEDE (not sure about an exact revision, but maybe October/November timeframe) I could simply define my wan interface in /etc/config/network like this and it just worked:

```
config interface ‘wan’

  option ifname 'eth0.201'
  option proto 'pppoe'
  option username 'user@provider'
  option password 'password'

```

I can’t find any way to make this work on recent versions of LEDE. I’ve tried new builds at least every few weeks, but none have worked for the past few months. I’ve tried configuring the switch_vlan section by adding a ‘t’ after the appropriate switch port to enable tagging, I’ve tried defining a new interface and then using that as the wan ifname, and I’ve tried the command line `ip link` and `ppp` invocations that work on every other linux system I’ve tried, but I can’t find anything that works on recent versions of LEDE.

On other linux systems I can do roughly the following and it works:

```
ip link add link eth0 name eth0.201 type vlan id 201
ip link set eth0.201 up
pppd call centurylink
```

where /etc/ppp/peers/centurylink and /etc/ppp/chap-secrets looks like this:
```
> cat /etc/ppp/peers/centurylink
plugin rp-pppoe.so

eth0.201
name “user@provider” usepeerdns
persist
defaultroute
hide-password
noauth

cat /etc/ppp/chap-secrets
#USERNAME PROVIDER PASSWORD IPADDRESS
user@provider * password
```

I’ve tried using tcpdump to capture what’s happening and on other systems (Ubuntu 16.10, Debian Jessie, pfsense) I see an 802.1Q tag, but I don’t see that on LEDE. That might be expected though because it seems totally possible that the switch itself is doing the 802.1Q stuff and tcpdump doesn’t see the actual packets sent over the wire. I have no idea if that’s the case, though. I guess I could also try this on OpenWRT as well, but I haven’t taken the time to do that yet.

The only other difference I’ve seen is that by default LEDE doesn’t send a Host-Uniq tag, but even if I set the host_uniq uci config it doesn’t fix things. Regardless of what I do I see logs that look like this:

```
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is now down
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is disabled
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ has link connectivity loss
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.581135] mvneta f1034000.ethernet eth0: configuring for fixed link mode
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.588150] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.594095] mvneta f1034000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is enabled
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Network device ‘eth0’ link is up
Tue Jan 17 01:55:26 2017 daemon.notice netifd: VLAN ‘eth0.201’ link is up
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ has link connectivity
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is setting up now
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.602431] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Tue Jan 17 01:55:26 2017 daemon.info pppd[2263]: Plugin rp-pppoe.so loaded.
Tue Jan 17 01:55:26 2017 daemon.info pppd[2263]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Jan 17 01:55:26 2017 daemon.notice pppd[2263]: pppd 2.4.7 started by root, uid 0
...
Tue Jan 17 01:55:41 2017 daemon.warn pppd[2263]: Timeout waiting for PADO packets
Tue Jan 17 01:55:41 2017 daemon.err pppd[2263]: Unable to complete PPPoE Discovery
Tue Jan 17 01:55:41 2017 daemon.info pppd[2263]: Exit.
```

A sample /etc/config/network looks like this:
```
config interface ‘loopback’

      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

config globals ‘globals’

      option ula_prefix 'fd25:2a59:2a7b::/48'

config interface ‘lan’

      option type 'bridge'
      option ifname 'eth1'
      option proto 'static'
      option ipaddr '192.168.2.1'
      option netmask '255.255.255.0'
      option ip6assign '60'

config interface ‘wan’

  option ifname 'eth0.201'
  option proto 'pppoe'
  option username 'user@provider'
  option password 'password'

config switch

      option name 'switch0'
      option reset '1'
      option enable_vlan '1'

config switch_vlan

      option device 'switch0'
      option vlan '1'
      option ports '0 1 2 3 6'

config switch_vlan

      option device 'switch0'
      option vlan '2'
      option ports '4 5'

config interface ‘guest’

      option _orig_ifname 'wlan1'
      option _orig_bridge 'false'
      option proto 'static'
      option ipaddr '192.168.3.1'
      option netmask '255.255.255.0'

```

Interestingly, OpenWRT has exactly the same version of ppp and rp-pppoe (2.4.7 and 3.8p, respectively) so it seems like there’s something else in play and my guess is it’s related to vlan tagging, but I don’t seem to have the same issue as FS#227 which mentions both PPPoE and vlan config, but it is quite difficult to follow the discussion there so maybe I’m missing something.

15.01.2017389Base systemBug ReportVery LowLowodhcpd relay mode is blocked by firewall by defaultTrunkUnconfirmed Task Description

odhcpd currently won’t work when put in relay mode if followed the manual naively. Turns out this is because firewall blocks incoming traffic to DHCPv6 server (port 547) from external DHCPv6 servers (port 547) from WAN zone by default. It may be a good idea to allow this out of the box, though I’m unsure if there are any security complications from this – I’m a newcomer to IPv6. Replies come with the source global IPv6 address of DHCPv6 server to the global IPv6 address of the router, so it’s difficult to make a more constrained rule without hardcoding them or at least the prefix.

Example rule which fixes relay mode:

config rule
	option enabled '1'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option dest_port '547'
	option name 'Allow DHCPv6 Relay'
	option family 'ipv6'
	option src_port '547'

LEDE revision: 3e7b894ac08b56343e6e449a38fdb2be7b02a127

13.01.2017386Base systemBug ReportVery LowLowConfig option "list channels" doesn't workTrunkUnconfirmed Task Description

Hi,

the option “list channels” is not working.

Patch which implements the function: https://patchwork.ozlabs.org/patch/536533/

LEDE version: SNAPSHOT r2790-08d73bf

Device: Archer C5

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option country 'DE'
	option htmode 'VHT80'
	option txpower '12'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'yyy'
	option encryption 'psk2+ccmp'
	option key 'xxx'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option channel 'auto'
	option country 'DE'
	option txpower '20'
	option htmode 'HT40'
	list channels 13
        list channels 12

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'xxx'
	option ssid 'yyy'


Ends with a 2.4GHz wlan which is not
visible and iwinfo shows the following information:

Mode: Master Channel: unknown (2.407 GHz)

root@lede:~# iwinfo wlan1 freqlist
  2.412 GHz (Channel 1)
  2.417 GHz (Channel 2)
  2.422 GHz (Channel 3)
  2.427 GHz (Channel 4)
  2.432 GHz (Channel 5)
  2.437 GHz (Channel 6)
  2.442 GHz (Channel 7)
  2.447 GHz (Channel 8)
  2.452 GHz (Channel 9)
  2.457 GHz (Channel 10)
  2.462 GHz (Channel 11)
  2.467 GHz (Channel 12)
  2.472 GHz (Channel 13)

A part of the syslog with a bunch of error messages is attached.

Fell free to ask, if something is missing.

13.01.2017385Base systemBug ReportVery LowLowrampis / JFFS2-problem / Xiaomi Miwifi mini / r2919 / w...TrunkUnconfirmed Task Description

after flashing r2919 i can see strange message with dmesg:

root@lede:~  dmesg | grep -i jffs
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.638380] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    9.908794] jffs2: Node at 0x00000044 with length 0x00001044 would run over the end of the erase block
[    9.918337] jffs2: Perhaps the file system was created with the wrong erase size?
[    9.926009] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000048: 0x1044 instead
[    9.935697] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000004c: 0x586d instead
[    9.945403] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000050: 0x0002 instead
[    9.955094] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000054: 0x0002 instead
[    9.964797] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000058: 0x81a4 instead
[    9.974488] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000060: 0xd8a2 instead
[    9.984190] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000064: 0x9ad1 instead
[    9.993881] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000068: 0x9ad2 instead
[   10.003587] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000006c: 0x9ad2 instead
[   10.013278] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000074: 0x1000 instead
[   10.022959] jffs2: Further such events for this erase block will not be printed
[   11.479386] jffs2: notice: (377) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   11.496420] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   11.525523] jffs2: Node at 0x00000044 with length 0x00001044 would run over the end of the erase block
[   11.535100] jffs2: Perhaps the file system was created with the wrong erase size?
[   11.542896] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000048: 0x1044 instead
[   11.552600] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000004c: 0x586d instead
[   11.562304] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000050: 0x0002 instead
[   11.571994] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000054: 0x0002 instead
[   11.581696] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000058: 0x81a4 instead
[   11.591387] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000060: 0xd8a2 instead
[   11.601089] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000064: 0x9ad1 instead
[   11.610780] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000068: 0x9ad2 instead
[   11.620481] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000006c: 0x9ad2 instead
[   11.630173] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000074: 0x1000 instead
[   11.639854] jffs2: Further such events for this erase block will not be printed
[   13.095966] jffs2: notice: (374) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   14.064922] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   14.086950] mount_root: switching to jffs2 overlay
root@lede:~  

beside that, it seems that the device is working:

root@lede:~  df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.5M      3.5M         0 100% /rom
tmpfs                    61.5M      1.1M     60.4M   2% /tmp
/dev/mtdblock6           10.8M    796.0K     10.0M   7% /overlay
overlayfs:/overlay       10.8M    796.0K     10.0M   7% /
tmpfs                   512.0K         0    512.0K   0% /dev
tmpfs                     2.0M         0      2.0M   0% /coredumps
08.01.2017375ToolchainBuild FailureVery LowMediumBulidbots should have multilib support installed to pre...TrunkUnconfirmed Task Description

I’ve run into this earlier myself and now we are seeing at least one package failing because of it.
https://github.com/openwrt/packages/pull/2823

People seem to have run into this issue before since it’s listed as a requirement for Ubuntu 64-bit as an example.
https://wiki.openwrt.org/doc/howto/buildroot.exigence#examples_of_package_installations

12.12.2016331Base systemBug ReportVery LowLowmac80211 / warning / ieee80211_ibss_leave / r2449TrunkUnconfirmed Task Description

spotted on TP-Link 4900 v1 with LEDE r2449 (selfcompiled):

[ 2860.974569] ------------[ cut here ]------------
[ 2860.979191] WARNING: at compat-wireless-2016-10-08/net/mac80211/ibss.c:1082
[ 2860.986142] Modules linked in: ath9k ath9k_common iptable_nat ath9k_hw ath snd_usb_audio nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda snd_usbmidi_lib nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack macvlan iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables compat em_nbyte sch_dsmark sch_pie sch_codel sch_gred sch_htb em_cmp cls_basic act_ipt sch_red sch_prio em_meta act_police em_text sch_tbf sch_sfq sch_fq act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ipip tunnel4 ip_tunnel tun snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore nls_utf8 zram lz4_decompress lz4_compress lzo_compress lzo_decompress zsmalloc usb_storage gpio_keys leds_gpio ehci_fsl ehci_platform ehci_hcd scsi_mod fsl_mph_dr_of mbcache button_hotplug input_core usbcore nls_base usb_common crc16 crc32c_generic crypto_hash [last unloaded: sd_mod]
[ 2861.124825] CPU: 0 PID: 8624 Comm: kworker/u2:0 Not tainted 4.4.36 #0
[ 2861.131337] Workqueue: phy1 ieee80211_ibss_leave [mac80211]
[ 2861.136903] task: c783b840 ti: c68a4000 task.ti: c68a4000
[ 2861.142292] NIP: c99ab128 LR: c99ab354 CTR: 00000000
[ 2861.147247] REGS: c68a5b10 TRAP: 0700   Not tainted  (4.4.36)
[ 2861.152982] MSR: 00029000 <CE,EE,ME>  CR: 28072422  XER: 20000000
[ 2861.159082]
[ 2861.159082] GPR00: c99ab004 c68a5bc0 c783b840 00000000 c68a5bf4 00000000 00000001 00000000
[ 2861.159082] GPR08: c724b114 00000001 c99f97f6 00000000 000000ff 00000000 c003c474 c790bfe0
[ 2861.159082] GPR16: c6f0f070 00000fff 00000fff c70b2138 c6ae5800 c6e30b40 00000000 00000087
[ 2861.159082] GPR24: 00000000 c68a5c68 c724b114 00000000 c6e30b40 c6e7a3d8 c6f25420 c6f0f070
[ 2861.188805] NIP [c99ab128] ieee80211_get_vht_mask_from_cap+0x1964/0x1c64 [mac80211]
[ 2861.196468] LR [c99ab354] ieee80211_get_vht_mask_from_cap+0x1b90/0x1c64 [mac80211]
[ 2861.204025] Call Trace:
[ 2861.206481] [c68a5bc0] [c99ab004] ieee80211_get_vht_mask_from_cap+0x1840/0x1c64 [mac80211] (unreliable)
[ 2861.215884] [c68a5c60] [c99ab414] ieee80211_get_vht_mask_from_cap+0x1c50/0x1c64 [mac80211]
[ 2861.224156] [c68a5d30] [c99ab9d0] ieee80211_ibss_rx_queued_mgmt+0x264/0x370 [mac80211]
[ 2861.232081] [c68a5e20] [c99acc44] ieee80211_ibss_leave+0x768/0x1770 [mac80211]
[ 2861.239307] [c68a5e80] [c00379f8] process_one_work+0x208/0x380
[ 2861.245135] [c68a5ea0] [c0037de0] worker_thread+0x270/0x48c
[ 2861.250704] [c68a5ef0] [c003c53c] kthread+0xc8/0xcc
[ 2861.255580] [c68a5f40] [c000cb3c] ret_from_kernel_thread+0x5c/0x64
[ 2861.261752] --- interrupt: 0 at   (null)
[ 2861.261752]     LR =   (null)
[ 2861.268618] Instruction dump:
[ 2861.271578] 38810034 387e0510 7f984800 419e024c 4bf410ed 2f830000 40be0030 3d40c9a0
[ 2861.279336] 394a97f6 3b600001 892a0003 69290001 <0f090000> 2f890000 41be01d0 39200001
[ 2861.287267] ---[ end trace a37b58c3292c2cbf ]---

09.12.2016329Base systemBug ReportVery LowLowAR9341 needs analog switch resetTrunkUnconfirmed Task Description

This is a bug report for the AR9341 SOC on LEDE trunk reboot-2445-gee5a6c1.

I have builded a custom firmware for a unsupported device based on the Atheros DB120 reference board.

The analog port of the ethernet switch needs to be resetted before it can operate.

Part of bootlog without analog reset:

[    2.179262] ag71xx-mdio.1: unknown phy id 'ffff:ffff'

Br-lan is not intialized due no analog switch reset.

Part of bootlog with analog reset:

[    2.059037] ag71xx-mdio.1: Found an AR934X built-in switch

And br-lan is initialized and networking is working fine.

A reset is performed by the function ath79_register_eth (defined in dev-eth.c):

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH);

However, no analog reset is performed, for example:

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH);

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH_ANALOG);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH_ANALOG);

Omitting the analog reset does not break the DB120 builds because the analog reset is already performed by ar934x_nfc_hw_reset in dev-nfc.c.

An easy fix is to do a analog reset in the device’s mach file. However, for the sake of consistency and autism, the reset should be performed by ath79_register_eth in dev_eth.c and not by ar934x_nfc_hw_reset in dev_nfc.c. My AR9341 device doesn’t even use a NAND flash.

03.12.2016320Base systemFeature RequestVery LowLowrelayd feature requestTrunkUnconfirmed Task Description

I found a couple of bugs with relayd based bridge configuration and I would like to suggest a feature request. Will fill one entry per issue:

On today’s trunk

3- in a configuration where the network attached to the wireless radio is configured via DHCP, the listening interface is not set up automatically. DD-WRT and Gargoyle do this automatically ( they overwrite the config/network file with the gateway parameter and reload relayd.

 


29.11.2016315Base systemFeature RequestVery LowMediumImprove sysupgrade (CLI) on dual-partition routersTrunkUnconfirmed Task Description

Some of the recent Linksys (maybe other) routers have two partitions: WRT1900, EA8500, etc.

Would be great if when running sysupgrade on those routers it did NOT kill all active processes and kept the router working while writing an image to the inactive partition.

Would also be great if there was an option to prevent automatic reboot after writing an image.

Ultimate goal is to have an upgrade process where current working state is uninterrupted and only when you reboot – you boot into new image.

21.11.2016296Base systemBug ReportVery LowHighUbiquiti Bullet M 10/100 ethernet interface comes up as...TrunkUnconfirmed Task Description

For the last month or so, and persisting in r2248, when a Ubiquiti Bullet M is booted through typical Ubiquiti 10/100 passive PoE injector, the interface appears to come up in gigabit mode (see timestamp 18.990274 below), despite being only a 10/100 Mbps interface. Restarting /etc/init.d/network fixes it. I am running batman-adv over the ethernet interface, which may be involved. I will check if it happens when batman-adv is not used on the interface and report in a followup comment.

The dmesg look like this:

[    0.000000] Linux version 4.4.32 (openwrt@hawg) (gcc version 5.4.0 (LEDE GCC 5.4.0 r1439) ) #0 Mon Nov 21 07:14:51 2016
[    0.000000] MyLoader: sysp=00030800, boardp=088201a0, parts=fdeffeff
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7240 rev 2
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] No valid device tree found, continuing without
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 80412320, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=UBNT-BM mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 27616K/32768K available (2990K kernel code, 174K rwdata, 756K rodata, 296K init, 198K bss, 5152K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:390.000MHz, DDR:390.000MHz, AHB:195.000MHz, Ref:40.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9801335621 ns
[    0.000013] sched_clock: 32 bits at 195MHz, resolution 5ns, wraps every 11012737021ns
[    0.007858] Calibrating delay loop... 259.27 BogoMIPS (lpj=1296384)
[    0.080537] pid_max: default: 32768 minimum: 301
[    0.085319] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.091915] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.102739] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.113516] NET: Registered protocol family 16
[    0.120053] MIPS: machine is Ubiquiti Bullet M
[    0.126714] registering PCI controller with io_map_base unset
[    0.357171] PCI host bridge to bus 0000:00
[    0.361273] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.368174] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.373719] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.380486] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.388422] pci 0000:00:00.0: [168c:002a] type 00 class 0x028000
[    0.388466] pci 0000:00:00.0: fixup device configuration
[    0.395018] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x0000ffff 64bit]
[    0.395154] pci 0000:00:00.0: supports D1
[    0.395179] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.395521] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.395573] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bit]
[    0.402864] pci 0000:00:00.0: using irq 40 for pin 1
[    0.408959] clocksource: Switched to clocksource MIPS
[    0.415845] NET: Registered protocol family 2
[    0.421435] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.428393] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.434796] TCP: Hash tables configured (established 1024 bind 1024)
[    0.441291] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.447126] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.453786] NET: Registered protocol family 1
[    0.458221] PCI: CLS 0 bytes, default 32
[    0.464223] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.470512] Crashlog allocated RAM at address 0x1f00000
[    0.495166] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.501050] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.514332] io scheduler noop registered
[    0.518252] io scheduler deadline registered (default)
[    0.523724] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.530709] console [ttyS0] disabled
[    0.554342] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 12187500) is a 16550A
[    0.563020] console [ttyS0] enabled
[    0.570030] bootconsole [early0] disabled
[    0.582486] m25p80 spi0.0: found mx25l6405d, expected m25p80
[    0.588201] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
[    0.593207] 5 cmdlinepart partitions found on MTD device spi0.0
[    0.599160] Creating 5 MTD partitions on "spi0.0":
[    0.603978] 0x000000000000-0x000000040000 : "u-boot"
[    0.611975] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.619659] 0x000000050000-0x0000007b0000 : "firmware"
[    0.638850] 2 uimage-fw partitions found on MTD device firmware
[    0.644866] 0x000000050000-0x0000001a0000 : "kernel"
[    0.651748] 0x0000001a0000-0x0000007b0000 : "rootfs"
[    0.658927] mtd: device 4 (rootfs) set to be root filesystem
[    0.664753] 1 squashfs-split partitions found on MTD device rootfs
[    0.671002] 0x000000550000-0x0000007b0000 : "rootfs_data"
[    0.678725] 0x0000007b0000-0x0000007f0000 : "cfg"
[    0.685799] 0x0000007f0000-0x000000800000 : "EEPROM"
[    0.713743] libphy: ag71xx_mdio: probed
[    1.302694] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:04 [uid=004dd041, driver=Generic PHY]
[    1.312905] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    1.322158] NET: Registered protocol family 10
[    1.332118] NET: Registered protocol family 17
[    1.336691] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.349583] 8021q: 802.1Q VLAN Support v1.8
[    1.362372] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.372025] Freeing unused kernel memory: 296K (80436000 - 80480000)
[    2.887723] init: Console is alive
[    2.891524] init: - watchdog -
[    4.278153] usbcore: registered new interface driver usbfs
[    4.283867] usbcore: registered new interface driver hub
[    4.289377] usbcore: registered new device driver usb
[    4.301662] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.310384] ehci-platform: EHCI generic platform driver
[    4.319460] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.327414] ohci-platform: OHCI generic platform driver
[    4.336259] init: - preinit -
[    5.148878] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    5.181862] random: procd: uninitialized urandom read (4 bytes read, 8 bits of entropy available)
[    7.440590] eth0: link up (100Mbps/Full duplex)
[    7.445184] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    8.484066] jffs2: notice: (361) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[    8.501955] mount_root: switching to jffs2 overlay
[    8.517794] urandom-seed: Seeding with /etc/urandom.seed
[    8.794632] eth0: link down
[    8.814035] procd: - early -
[    8.817063] procd: - watchdog -
[    9.492101] procd: - ubus -
[    9.545805] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.555498] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.564637] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.574254] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.583375] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.593373] random: ubusd: uninitialized urandom read (4 bytes read, 16 bits of entropy available)
[    9.602738] random: ubusd: uninitialized urandom read (4 bytes read, 16 bits of entropy available)
[    9.612394] procd: - init -
[   10.066368] Loading modules backported from Linux version wt-2016-10-03-1-g6fcb1a6
[   10.074041] Backport generated by backports.git backports-20160324-9-g0e38f5c
[   10.125220] batman_adv: B.A.T.M.A.N. advanced 2016.4 (compatibility version 15) loaded
[   10.213939] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   10.224958] ath: phy0: Ignoring endianness difference in EEPROM magic bytes.
[   10.233630] ath: EEPROM regdomain: 0x0
[   10.233647] ath: EEPROM indicates default country code should be used
[   10.233661] ath: doing EEPROM country->regdmn map search
[   10.233689] ath: country maps to regdmn code: 0x3a
[   10.233705] ath: Country alpha2 being used: US
[   10.233718] ath: Regpair used: 0x3a
[   10.248634] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.257391] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=40
[   11.870351] random: jshn: uninitialized urandom read (4 bytes read, 19 bits of entropy available)
[   12.001559] random: ubusd: uninitialized urandom read (4 bytes read, 19 bits of entropy available)
[   18.855427] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   18.875510] IPv6: ADDRCONF(NETDEV_UP): br-pub: link is not ready
[   18.990274] eth0: link up (1000Mbps/Full duplex)
[   18.994964] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   19.330349] batman_adv: bat0: Adding interface: eth0
[   19.335365] batman_adv: bat0: The MTU of interface eth0 is too small (1500) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the
 performance. Setting the MTU to 1532 would solve the problem.
[   19.359419] batman_adv: bat0: Interface activated: eth0
[   19.367077] 8021q: adding VLAN 0 to HW filter on device bat0
[   19.406417] device bat0 entered promiscuous mode
[   19.411309] br-pub: port 1(bat0) entered forwarding state
[   19.416772] br-pub: port 1(bat0) entered forwarding state
[   19.422579] IPv6: ADDRCONF(NETDEV_CHANGE): br-pub: link becomes ready
[   19.870508] batman_adv: bat0: bridge_loop_avoidance: Changing from: enabled to: disabled
[   20.359133] batman_adv: bat0: No IGMP Querier present - multicast optimizations disabled
[   20.367269] batman_adv: bat0: No MLD Querier present - multicast optimizations disabled
[   21.412169] br-pub: port 1(bat0) entered forwarding state
[   21.549966] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   21.563679] device wlan0 entered promiscuous mode
[   21.591315] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   21.597879] br-pub: port 2(wlan0) entered forwarding state
[   21.603541] br-pub: port 2(wlan0) entered forwarding state
[   21.784924] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
[   21.912131] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
[   22.268273] batman_adv: bat0: Adding interface: mesh0
[   22.273432] batman_adv: bat0: Interface activated: mesh0
[   23.599046] br-pub: port 2(wlan0) entered forwarding state
[   29.369162] batman_adv: bat0: IGMP Querier appeared
[   29.374093] batman_adv: bat0: MLD Querier appeared
[   34.068975] ------------[ cut here ]------------
[   34.073700] WARNING: CPU: 0 PID: 0 at net/sched/sch_generic.c:306 dev_watchdog+0x1dc/0x260()
[   34.082197] NETDEV WATCHDOG: eth0 (ag71xx): transmit queue 0 timed out
[   34.088754] Modules linked in: ath9k ath9k_common mac80211 ath9k_hw ath batman_adv libcrc32c cfg80211 compat ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common crc16
 cryptomgr aead crypto_null crc32c_generic crypto_hash
[   34.112252] CPU: 0 PID: 0 Comm: swapper Not tainted 4.4.32 #0
[   34.118013] Stack : 803c8fc4 00000000 00000001 80420000 80413038 80412cc3 803aa67c 00000000
[   34.118013] 	  8048379c 8041135c 00000200 00100000 0000000a 800a71a8 803afce8 80410000
[   34.118013] 	  00000003 8041135c 803ae0f4 8040dc2c 0000000a 800a5124 00000006 00000000
[   34.118013] 	  00000000 801f3100 00000000 00000000 00000000 00000000 00000000 00000000
[   34.118013] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[   34.118013] 	  ...
[   34.153969] Call Trace:
[   34.156440] [<80071af0>] show_stack+0x50/0x84
[   34.160843] [<80081870>] warn_slowpath_common+0xa0/0xd0
[   34.166096] [<800818cc>] warn_slowpath_fmt+0x2c/0x38
[   34.171111] [<80290970>] dev_watchdog+0x1dc/0x260
[   34.175854] [<800b0460>] call_timer_fn.isra.5+0x24/0x80
[   34.181125] [<800b06e4>] run_timer_softirq+0x1b4/0x1fc
[   34.186296] [<80083dec>] __do_softirq+0x250/0x298
[   34.191059] [<8006a5d0>] plat_irq_dispatch+0xd4/0x10c
[   34.196134] [<80060830>] ret_from_irq+0x0/0x4
[   34.200526] [<80060a80>] __r4k_wait+0x20/0x40
[   34.204906] [<800a2304>] cpu_startup_entry+0x9c/0xe8
[   34.209934] [<80436bd4>] start_kernel+0x470/0x490
[   34.214656] 
[   34.216159] ---[ end trace ef06a4b3ec78272a ]---
[   34.220810] eth0: tx timeout
[   37.565193] random: nonblocking pool is initialized
[   44.068999] eth0: tx timeout
[   54.069064] eth0: tx timeout
[   64.068993] eth0: tx timeout
[   74.069871] eth0: tx timeout
[   82.660973] batman_adv: bat0: MLD Querier disappeared - multicast optimizations disabled
[   84.070901] eth0: tx timeout
[   92.701961] batman_adv: bat0: MLD Querier appeared
[   94.071717] eth0: tx timeout
[  104.072355] eth0: tx timeout
[  114.072669] eth0: tx timeout
[...]

When I do an /etc/init.d/network restart, the interface recovers to normal function, and I get this in dmesg:

[ 1296.763793] br-pub: port 2(wlan0) entered disabled state
[ 1296.769232] br-pub: port 1(bat0) entered disabled state
[ 1296.808305] device bat0 left promiscuous mode
[ 1296.812986] br-pub: port 1(bat0) entered disabled state
[ 1296.862085] IPv6: ADDRCONF(NETDEV_UP): bat0: link is not ready
[ 1296.879239] device wlan0 left promiscuous mode
[ 1296.883945] br-pub: port 2(wlan0) entered disabled state
[ 1296.904196] batman_adv: bat0: Interface deactivated: mesh0
[ 1296.909752] batman_adv: bat0: Removing interface: mesh0
[ 1296.963462] batman_adv: bat0: Interface deactivated: eth0
[ 1296.993492] eth0: link down
[ 1296.998705] batman_adv: bat0: Removing interface: eth0
[ 1301.629484] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1301.649941] IPv6: ADDRCONF(NETDEV_UP): br-pub: link is not ready
[ 1301.985100] eth0: link up (100Mbps/Full duplex)
[ 1301.989698] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1302.191373] batman_adv: bat0: Adding interface: eth0
[ 1302.196453] batman_adv: bat0: The MTU of interface eth0 is too small (1500) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the
 performance. Setting the MTU to 1532 would solve the problem.
[ 1302.220488] batman_adv: bat0: Interface activated: eth0
[ 1302.228092] 8021q: adding VLAN 0 to HW filter on device bat0
[ 1302.275944] device bat0 entered promiscuous mode
[ 1302.280747] br-pub: port 1(bat0) entered forwarding state
[ 1302.286292] br-pub: port 1(bat0) entered forwarding state
[ 1302.292106] IPv6: ADDRCONF(NETDEV_CHANGE): br-pub: link becomes ready
[ 1302.590333] batman_adv: bat0: bridge_loop_avoidance: Changing from: enabled to: disabled
[ 1303.213417] batman_adv: bat0: No IGMP Querier present - multicast optimizations disabled
[ 1303.221556] batman_adv: bat0: No MLD Querier present - multicast optimizations disabled
[ 1304.283452] br-pub: port 1(bat0) entered forwarding state
[ 1304.672382] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1304.782643] device wlan0 entered promiscuous mode
[ 1304.827845] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1304.834479] br-pub: port 2(wlan0) entered forwarding state
[ 1304.840053] br-pub: port 2(wlan0) entered forwarding state
[ 1305.112607] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
[ 1305.190600] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
[ 1305.692918] batman_adv: bat0: Adding interface: mesh0
[ 1305.698080] batman_adv: bat0: Interface activated: mesh0
[ 1306.833410] br-pub: port 2(wlan0) entered forwarding state
[ 1312.303688] batman_adv: bat0: IGMP Querier appeared
[ 1312.308629] batman_adv: bat0: MLD Querier appeared

If I disconnect the other end of the ethernet cable so that there is no link peer, I do not see the problem (see below):

[    0.000000] Linux version 4.4.32 (openwrt@hawg) (gcc version 5.4.0 (LEDE GCC 5.4.0 r1439) ) #0 Mon Nov 21 07:14:51 2016
[    0.000000] MyLoader: sysp=00000000, boardp=00000000, parts=ffffffff
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7240 rev 2
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] No valid device tree found, continuing without
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000001ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 80412320, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=UBNT-BM mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 27616K/32768K available (2990K kernel code, 174K rwdata, 756K rodata, 296K init, 198K bss, 5152K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:390.000MHz, DDR:390.000MHz, AHB:195.000MHz, Ref:40.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9801335621 ns
[    0.000013] sched_clock: 32 bits at 195MHz, resolution 5ns, wraps every 11012737021ns
[    0.007859] Calibrating delay loop... 259.27 BogoMIPS (lpj=1296384)
[    0.080537] pid_max: default: 32768 minimum: 301
[    0.085319] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.091915] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.102743] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.113517] NET: Registered protocol family 16
[    0.120061] MIPS: machine is Ubiquiti Bullet M
[    0.126721] registering PCI controller with io_map_base unset
[    0.357179] PCI host bridge to bus 0000:00
[    0.361281] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.368182] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.373728] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.380495] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.388431] pci 0000:00:00.0: [168c:002a] type 00 class 0x028000
[    0.388474] pci 0000:00:00.0: fixup device configuration
[    0.395026] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x0000ffff 64bit]
[    0.395163] pci 0000:00:00.0: supports D1
[    0.395187] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.395530] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.395581] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bit]
[    0.402872] pci 0000:00:00.0: using irq 40 for pin 1
[    0.408968] clocksource: Switched to clocksource MIPS
[    0.415854] NET: Registered protocol family 2
[    0.421444] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.428402] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.434805] TCP: Hash tables configured (established 1024 bind 1024)
[    0.441299] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.447134] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.453795] NET: Registered protocol family 1
[    0.458229] PCI: CLS 0 bytes, default 32
[    0.464231] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.470521] Crashlog allocated RAM at address 0x1f00000
[    0.495175] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.501058] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.514341] io scheduler noop registered
[    0.518261] io scheduler deadline registered (default)
[    0.523733] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.530718] console [ttyS0] disabled
[    0.554351] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 12187500) is a 16550A
[    0.563030] console [ttyS0] enabled
[    0.570040] bootconsole [early0] disabled
[    0.582496] m25p80 spi0.0: found mx25l6405d, expected m25p80
[    0.588212] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
[    0.593216] 5 cmdlinepart partitions found on MTD device spi0.0
[    0.599171] Creating 5 MTD partitions on "spi0.0":
[    0.603989] 0x000000000000-0x000000040000 : "u-boot"
[    0.611984] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.619662] 0x000000050000-0x0000007b0000 : "firmware"
[    0.638852] 2 uimage-fw partitions found on MTD device firmware
[    0.644868] 0x000000050000-0x0000001a0000 : "kernel"
[    0.651750] 0x0000001a0000-0x0000007b0000 : "rootfs"
[    0.658926] mtd: device 4 (rootfs) set to be root filesystem
[    0.664753] 1 squashfs-split partitions found on MTD device rootfs
[    0.671004] 0x000000550000-0x0000007b0000 : "rootfs_data"
[    0.678725] 0x0000007b0000-0x0000007f0000 : "cfg"
[    0.685800] 0x0000007f0000-0x000000800000 : "EEPROM"
[    0.713752] libphy: ag71xx_mdio: probed
[    1.302703] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:04 [uid=004dd041, driver=Generic PHY]
[    1.312917] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    1.322177] NET: Registered protocol family 10
[    1.332146] NET: Registered protocol family 17
[    1.336720] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.349611] 8021q: 802.1Q VLAN Support v1.8
[    1.362390] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.372040] Freeing unused kernel memory: 296K (80436000 - 80480000)
[    2.887726] init: Console is alive
[    2.891520] init: - watchdog -
[    4.278086] usbcore: registered new interface driver usbfs
[    4.283799] usbcore: registered new interface driver hub
[    4.289318] usbcore: registered new device driver usb
[    4.301475] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.310215] ehci-platform: EHCI generic platform driver
[    4.319363] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.327317] ohci-platform: OHCI generic platform driver
[    4.336163] init: - preinit -
[    5.148612] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    5.181619] random: procd: uninitialized urandom read (4 bytes read, 8 bits of entropy available)
[    8.484735] jffs2: notice: (361) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[    8.502585] mount_root: switching to jffs2 overlay
[    8.518273] urandom-seed: Seeding with /etc/urandom.seed
[    8.810840] procd: - early -
[    8.813863] procd: - watchdog -
[    9.487850] procd: - ubus -
[    9.541721] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.551409] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.560553] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.570163] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.579297] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.589333] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.598611] random: ubusd: uninitialized urandom read (4 bytes read, 15 bits of entropy available)
[    9.608223] procd: - init -
[   10.064115] Loading modules backported from Linux version wt-2016-10-03-1-g6fcb1a6
[   10.071796] Backport generated by backports.git backports-20160324-9-g0e38f5c
[   10.122372] batman_adv: B.A.T.M.A.N. advanced 2016.4 (compatibility version 15) loaded
[   10.205329] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   10.216362] ath: phy0: Ignoring endianness difference in EEPROM magic bytes.
[   10.225034] ath: EEPROM regdomain: 0x0
[   10.225051] ath: EEPROM indicates default country code should be used
[   10.225065] ath: doing EEPROM country->regdmn map search
[   10.225093] ath: country maps to regdmn code: 0x3a
[   10.225109] ath: Country alpha2 being used: US
[   10.225122] ath: Regpair used: 0x3a
[   10.240049] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.248689] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=40
[   11.861887] random: jshn: uninitialized urandom read (4 bytes read, 19 bits of entropy available)
[   11.993063] random: ubusd: uninitialized urandom read (4 bytes read, 19 bits of entropy available)
[   18.833441] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   18.855566] IPv6: ADDRCONF(NETDEV_UP): br-pub: link is not ready
[   21.215610] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   21.255512] device wlan0 entered promiscuous mode
[   21.286637] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   21.293301] br-pub: port 1(wlan0) entered forwarding state
[   21.298864] br-pub: port 1(wlan0) entered forwarding state
[   21.335689] IPv6: ADDRCONF(NETDEV_CHANGE): br-pub: link becomes ready
[   21.541225] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
[   21.594616] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
[   22.284927] batman_adv: bat0: Adding interface: mesh0
[   22.290148] batman_adv: bat0: Interface activated: mesh0
[   22.297750] 8021q: adding VLAN 0 to HW filter on device bat0
[   22.362868] device bat0 entered promiscuous mode
[   22.367627] br-pub: port 2(bat0) entered forwarding state
[   22.373200] br-pub: port 2(bat0) entered forwarding state
[   22.718089] batman_adv: bat0: bridge_loop_avoidance: Changing from: enabled to: disabled
[   23.289035] br-pub: port 1(wlan0) entered forwarding state
[   23.309325] batman_adv: bat0: No IGMP Querier present - multicast optimizations disabled
[   23.317459] batman_adv: bat0: No MLD Querier present - multicast optimizations disabled
[   24.369054] br-pub: port 2(bat0) entered forwarding state
[   29.389161] batman_adv: bat0: IGMP Querier appeared
[   38.069058] random: nonblocking pool is initialized
[   44.920666] eth0: link up (100Mbps/Full duplex)
[   44.925732] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   45.001214] batman_adv: bat0: Adding interface: eth0
[   45.006233] batman_adv: bat0: The MTU of interface eth0 is too small (1500) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the
 performance. Setting the MTU to 1532 would solve the problem.
[   45.030291] batman_adv: bat0: Interface activated: eth0
[   50.459193] batman_adv: bat0: MLD Querier appeared
[   67.509156] batman_adv: bat0: MLD Querier disappeared - multicast optimizations disabled
[   77.549128] batman_adv: bat0: MLD Querier appeared

My LEDE diffconfig looks like this:

CONFIG_TARGET_ar71xx=y
CONFIG_TARGET_ar71xx_generic=y
CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-bullet-m=y
CONFIG_DEVEL=y
CONFIG_BUSYBOX_CUSTOM=y
CONFIG_ALFRED_NEEDS_lua=y
CONFIG_BUILD_LOG=y
CONFIG_BUSYBOX_CONFIG_MESG=y
CONFIG_BUSYBOX_CONFIG_PKILL=y
CONFIG_BUSYBOX_CONFIG_RDATE=y
# CONFIG_BUSYBOX_CONFIG_SHA256SUM is not set
CONFIG_KMOD_BATMAN_ADV_BATMAN_V=y
CONFIG_KMOD_BATMAN_ADV_BLA=y
CONFIG_KMOD_BATMAN_ADV_DAT=y
CONFIG_KMOD_BATMAN_ADV_DEBUGFS=y
CONFIG_KMOD_BATMAN_ADV_MCAST=y
CONFIG_LIBCURL_COOKIES=y
CONFIG_LIBCURL_FILE=y
CONFIG_LIBCURL_FTP=y
CONFIG_LIBCURL_HTTP=y
CONFIG_LIBCURL_NO_SMB="!"
CONFIG_LIBCURL_POLARSSL=y
CONFIG_LIBCURL_PROXY=y
CONFIG_OPENSSL_ENGINE_CRYPTO=y
CONFIG_OPENSSL_WITH_DEPRECATED=y
CONFIG_OPENSSL_WITH_EC=y
CONFIG_OPENSSL_WITH_NPN=y
CONFIG_OPENSSL_WITH_PSK=y
CONFIG_OPENSSL_WITH_SRP=y
CONFIG_PACKAGE_ALFRED_BATHOSTS=y
CONFIG_PACKAGE_ALFRED_VIS=y
CONFIG_PACKAGE_alfred=y
CONFIG_PACKAGE_batctl=y
CONFIG_PACKAGE_bridge=y
CONFIG_PACKAGE_curl=y
CONFIG_PACKAGE_diffutils=y
# CONFIG_PACKAGE_dnsmasq is not set
# CONFIG_PACKAGE_firewall is not set
CONFIG_PACKAGE_horst=y
CONFIG_PACKAGE_iftop=y
# CONFIG_PACKAGE_ip6tables is not set
CONFIG_PACKAGE_iperf3=y
# CONFIG_PACKAGE_iptables is not set
CONFIG_PACKAGE_kmod-batman-adv=y
CONFIG_PACKAGE_kmod-bridge=y
CONFIG_PACKAGE_kmod-crypto-aead=y
CONFIG_PACKAGE_kmod-crypto-crc32c=y
CONFIG_PACKAGE_kmod-crypto-hash=y
CONFIG_PACKAGE_kmod-crypto-manager=y
CONFIG_PACKAGE_kmod-crypto-null=y
CONFIG_PACKAGE_kmod-crypto-pcompress=y
# CONFIG_PACKAGE_kmod-ip6tables is not set
# CONFIG_PACKAGE_kmod-ipt-conntrack is not set
# CONFIG_PACKAGE_kmod-ipt-core is not set
# CONFIG_PACKAGE_kmod-ipt-nat is not set
# CONFIG_PACKAGE_kmod-lib-crc-ccitt is not set
CONFIG_PACKAGE_kmod-lib-crc16=y
CONFIG_PACKAGE_kmod-lib-crc32c=y
CONFIG_PACKAGE_kmod-llc=y
# CONFIG_PACKAGE_kmod-nf-conntrack is not set
# CONFIG_PACKAGE_kmod-nf-conntrack6 is not set
# CONFIG_PACKAGE_kmod-nf-ipt is not set
# CONFIG_PACKAGE_kmod-nf-ipt6 is not set
# CONFIG_PACKAGE_kmod-nf-nat is not set
# CONFIG_PACKAGE_kmod-ppp is not set
CONFIG_PACKAGE_kmod-stp=y
CONFIG_PACKAGE_libcurl=y
# CONFIG_PACKAGE_libip4tc is not set
# CONFIG_PACKAGE_libip6tc is not set
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_libncursesw=y
CONFIG_PACKAGE_libnetsnmp=y
CONFIG_PACKAGE_libopenssl=y
CONFIG_PACKAGE_libpcap=y
CONFIG_PACKAGE_libpcre=y
CONFIG_PACKAGE_libpolarssl=y
CONFIG_PACKAGE_libpopt=y
CONFIG_PACKAGE_libpthread=y
CONFIG_PACKAGE_librt=y
# CONFIG_PACKAGE_libxtables is not set
CONFIG_PACKAGE_lua=y
# CONFIG_PACKAGE_odhcp6c is not set
# CONFIG_PACKAGE_odhcpd is not set
# CONFIG_PACKAGE_ppp is not set
CONFIG_PACKAGE_procps-ng=y
CONFIG_PACKAGE_procps-ng-free=y
CONFIG_PACKAGE_procps-ng-kill=y
CONFIG_PACKAGE_procps-ng-pgrep=y
CONFIG_PACKAGE_procps-ng-pkill=y
CONFIG_PACKAGE_procps-ng-pmap=y
CONFIG_PACKAGE_procps-ng-ps=y
CONFIG_PACKAGE_procps-ng-pwdx=y
CONFIG_PACKAGE_procps-ng-skill=y
CONFIG_PACKAGE_procps-ng-slabtop=y
CONFIG_PACKAGE_procps-ng-snice=y
CONFIG_PACKAGE_procps-ng-tload=y
CONFIG_PACKAGE_procps-ng-top=y
CONFIG_PACKAGE_procps-ng-uptime=y
CONFIG_PACKAGE_procps-ng-vmstat=y
CONFIG_PACKAGE_procps-ng-w=y
CONFIG_PACKAGE_procps-ng-watch=y
CONFIG_PACKAGE_ptp-utils=y
CONFIG_PACKAGE_rsync=y
CONFIG_PACKAGE_snmpd=y
CONFIG_PACKAGE_tcpdump=y
CONFIG_PACKAGE_terminfo=y
CONFIG_PACKAGE_wget=y
CONFIG_PACKAGE_wireless-tools=y
CONFIG_PACKAGE_zlib=y
CONFIG_RSYNC_zlib=y

My uci show looks like this (system and wireless elided):

alfred.alfred=alfred
alfred.alfred.mode='master'
alfred.alfred.batmanif='bat0'
alfred.alfred.start_vis='1'
alfred.alfred.run_facters='1'
alfred.alfred.interface='br-pub'
alfred.alfred.disabled='0'
batman-adv.bat0=mesh
batman-adv.bat0.bridge_loop_avoidance='0'
dropbear.@dropbear[0]=dropbear
dropbear.@dropbear[0].PasswordAuth='on'
dropbear.@dropbear[0].RootPasswordAuth='on'
dropbear.@dropbear[0].Port='22'
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.pub=interface
network.pub.type='bridge'
network.pub.proto='static'
network.pub.ip6assign='60'
network.pub.ifname='bat0'
network.pub.ipaddr='10.11.x.y'
network.pub.netmask='255.255.252.0'
network.pub.gateway='10.11.x.1'
network.pub.dns='10.11.x.1'
network.mesh=interface
network.mesh.mtu='1532'
network.mesh.proto='batadv'
network.mesh.mesh='bat0'
network.meshwire=interface
network.meshwire.proto='batadv'
network.meshwire.mesh='bat0'
network.meshwire.ifname='eth0'
21.11.2016295KernelBug ReportVery LowHighath10k_pci 0001:01:00.0: SWBA overrun on vdevTrunkUnconfirmed Task Description

Supply the following if possible:

- TP-LINK c2600 v1.1
- LEDE Reboot r2244
- after some hours, the network device produce the below stacktrace.

[61789.980553] ————[ cut here ]———— [61789.980600] WARNING: CPU: 0 PID: 3 at net/core/dev.c:4837 net_rx_action+0×154/0x2e4()
[61789.984240] Modules linked in: pppoe ppp_async iptable_nat pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY ts_kmp ts_fsm ts_bm slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_netlink nf_conntrack iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt br_netfilter em_cmp sch_teql em_nbyte sch_htb sch_pie sch_gred sch_dsmark cls_basic act_ipt sch_prio em_text
[61790.061568] sch_codel sch_tbf sch_sfq em_meta act_police sch_fq sch_red act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ath10k_pci ath10k_core ath mac80211 cfg80211 compat ledtrig_usbport xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ifb ip6_tunnel tunnel6 tun snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd input_core soundcore
[61790.130320] usb_storage uhci_hcd f2fs ext4 jbd2 mbcache crc32c_generic crypto_hash leds_gpio xhci_plat_hcd xhci_pci xhci_hcd dwc3 dwc3_qcom dwc3_of_simple ohci_platform ohci_hcd phy_qcom_dwc3 ahci ehci_platform ehci_hcd sd_mod ahci_platform libahci_platform libahci libata scsi_mod gpio_button_hotplug usbcore nls_base usb_common
[61790.158798] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 4.4.30 #0
[61790.159062] Hardware name: Qualcomm (Flattened Device Tree)
[61790.165160] [<c02207f4>] (unwind_backtrace) from [<c021d2e4>] (show_stack+0×14/0×20)
[61790.170534] [<c021d2e4>] (show_stack) from [<c03b82a4>] (dump_stack+0x8c/0xa0)
[61790.178521] [<c03b82a4>] (dump_stack) from [<c0228aec>] (warn_slowpath_common+0xa4/0xd0)
[61790.185550] [<c0228aec>] (warn_slowpath_common) from [<c0228bcc>] (warn_slowpath_null+0x1c/0×24)
[61790.193798] [<c0228bcc>] (warn_slowpath_null) from [<c050bcd0>] (net_rx_action+0×154/0x2e4)
[61790.202568] [<c050bcd0>] (net_rx_action) from [<c022bc90>] (do_softirq+0xdc/0×230)
[61790.210636] [<c022bc90>] (
do_softirq) from [<c022be18>] (run_ksoftirqd+0×34/0×64)
[61790.218626] [<c022be18>] (run_ksoftirqd) from [<c0246784>] (smpboot_thread_fn+0×190/0x1b8)
[61790.226006] [<c0246784>] (smpboot_thread_fn) from [<c02438e4>] (kthread+0xf8/0×100)
[61790.234335] [<c02438e4>] (kthread) from [<c0209cb8>] (ret_from_fork+0×14/0x3c)
[61790.241951] —[ end trace bbf62e8dea16c714 ]— [61790.250226] ath10k_pci 0001:01:00.0: SWBA overrun on vdev 1, skipped old beacon

27.10.2016253Base systemBug ReportVery LowHighMulticast over wireless ceases to work properly after a...AllNew Task Description

I am having a problem on a UBNT UAP-LR where, if many clients stay connected the router for a long time, multicast packets will stop being reliably sent to the wireless clients. I can reproduce this with LEDE r1953, but it goes back at least as far as OpenWRT 15.05.1 with kernel 3.18. I can not, however, reproduce it on another network with the same WAP but with only one or two wireless clients.

This originally manifested as IPv6 ceasing to work since the (multicasted) RA packets were not reaching the wireless clients. I used tcpdump on the WAP and determined that the RAs were arriving through the wired interface and leaving through the wireless interface as they should, but tcpdump on the client indicates that a vast majority of the RAs are never received. (Please note that the IPv6 issue is not reproducible with the router running OpenWRT/LEDE and odhcpd, since odhcpd unicasts RAs sent as a response to an RS instead of multicasting them, while it is reproducible when the router is running radvd, for example as pfSense does.)

13.10.2016224Base systemBug ReportVery LowLowwrong source IP when logging to remote IPv6 syslog serv...TrunkAssigned Task Description

Hello,

I’m trying to send log to remote IPv6 syslog server (x:y:z:12::1), but packets received by syslog server are invalid. Instead of public IPv6 address, syslog udp packets are sent with ::1 source IP and therefore ignored by destination server. Logging over IPv4 works ok.

tcpdump log from destination syslog server:
23:34:16.988433 IP6 ::1.38044 > x:y:z:12::1.514: SYSLOG daemon.notice, length: 65

Configuration:

/etc/config/system:

 option log_ip 'x:y:z:12::1'

Device is in the same range as syslog server (x:y:z:12::119/64) and has native IPv6 connectivity. Other services (dropbear, ntp client, snmpd, luci) are running fine over IPv6.

Device is TP-Link WDR3600, running lede reboot-1818-gb81fc29.

12.10.2016222Base systemFeature RequestVery LowLowproviding pre-built images for extroot for devices with...TrunkUnconfirmed Task Description

Currently, the only way to be able to make extroot (use an external drive as overlay) for 4MiB devices is to build an image with the Image Builder as they can’t fit the packages needed in the jffs.

For most linux users this isn’t a major issue as the Image Builder runs on Linux and with a couple commands you build all, but it’s still time-consuming.

For everyone else this is an issue, as they need to get a linux system, learn how to use the Image Builder, and so on.

I’m asking if it is possible to make pre-built images with the right packages to allow extroot on 4 MiB devices.

The packages I thing we need in these pre-built images are all is needed by the device to be able to format and check its own drive, because again most users don’t have access to a linux system to format a drive with ext4 or whatever.

It seems e2fsprogs is too big to fit with the other packages required, currently only f2fs filesystem tools are split and can be used in 4MiB devices for extroot.

These are the packages that currently should allow building an extrootable image that fits on 4MiB storage:

blkid block-mount kmod-fs-f2fs kmod-usb-storage kmod-usb-uhci kmod-usb-ohci mkf2fs f2fsck

(of course no luci is included).

17.09.2016181Base systemBug ReportVery LowMediumChanging TX power doesn't nothing (MediaTek MT7628AN ve...TrunkUnconfirmed Task Description

Hello,

As I said, if I change the TX power from 0 dBm to 20 dBm doesn’t nothing. There isn’t any visible change in tx power. I tested other powers too (5, 8, 15,..).

It is a Xiaomi Nano (lite).

SoC Type: MediaTek MT7628AN ver:1 eco:2
MIPS: machine is MiWiFi Nano
Linux version 4.4.19 (-) (gcc version 5.4.0 (LEDE GCC 5.4.0 r1444) ) #0 Fri Aug 26 15:03:40 2016.

07.09.2016162Base systemBug ReportVery LowLowTwo issues with libuclient-openssl in luci-sslTrunkUnconfirmed Task Description

1: RC4 and 3DES are used when both have security issues. Actually the latter also is true of mbedtls/polarssl.

2: Only TLS 1.2 is supported. This makes multiple clients unable to connect.

BTW, I got this working after modifying the Makefile to luci-ssl to depend on libustream-openssl instead. No idea what the situation is but so far it works without a problem.

05.09.2016160Base systemBug ReportVery LowLowusb-serial (pl2303) failures on mt7621 dlink dir860l-b1TrunkUnconfirmed Task Description
git describe
reboot-1497-ga810e77

with diffconfig:

CONFIG_TARGET_ramips=y
CONFIG_TARGET_ramips_mt7621=y
CONFIG_TARGET_ramips_mt7621_DEVICE_dir-860l-b1=y
CONFIG_DEVEL=y
CONFIG_BUILD_LOG=y
CONFIG_PACKAGE_ip=y
CONFIG_PACKAGE_kmod-usb-core=y
CONFIG_PACKAGE_kmod-usb-ohci=y
CONFIG_PACKAGE_kmod-usb-ohci-pci=y
CONFIG_PACKAGE_kmod-usb-serial=y
CONFIG_PACKAGE_kmod-usb-serial-ftdi=y
CONFIG_PACKAGE_kmod-usb-serial-pl2303=y
CONFIG_PACKAGE_kmod-usb2=y
CONFIG_PACKAGE_kmod-usb2-pci=y
CONFIG_PACKAGE_kmod-usb3=y
CONFIG_PACKAGE_screen=y

screen starts, but doesn’t work. The usb-relevant dmesg’s are:

[    4.550000] usbcore: registered new interface driver usbfs
[    4.560000] usbcore: registered new interface driver hub
[    4.570000] usbcore: registered new device driver usb
[    4.580000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.620000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.670000] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    4.720000] hub 1-0:1.0: USB hub found
[    4.740000] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    4.760000] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    4.770000] hub 2-0:1.0: USB hub found
[    5.260000] usb 1-1: new full-speed USB device number 2 using xhci-mtk
[    5.410000] usb 1-1: no of_node; not parsing pinctrl DT
[   10.150000] usbcore: registered new interface driver usbserial
[   10.160000] usbcore: registered new interface driver usbserial_generic
[   10.180000] usbserial: USB Serial support registered for generic
[   10.220000] usbcore: registered new interface driver ftdi_sio
[   10.240000] usbserial: USB Serial support registered for FTDI USB Serial Device
[   10.260000] usbcore: registered new interface driver pl2303
[   10.270000] usbserial: USB Serial support registered for pl2303
[   10.290000] pl2303 ttyUSB0: no of_node; not parsing pinctrl DT
[   10.290000] usb 1-1: pl2303 converter now attached to ttyUSB0
[  871.510000] pl2303 ttyUSB0: pl2303_get_line_request - failed: -145
[  871.620000] pl2303 ttyUSB0: pl2303_set_line_request - failed: -145
[  871.840000] pl2303 ttyUSB0: pl2303_set_control_lines - failed: -145

Screen also throws an error (which gets blanked out, but is captured by the serial console):

# screen /dev/ttyUSB0 115200
/dev/null/utmp: Not a directory
02.09.2016133Base systemBug ReportVery LowLowNetgear r8000 cannot use 802.1x encryptionTrunkUnconfirmed Task Description

Github issue #305 reported by https://github.com/Halry

My android phone can’t connect to it.(tested on nexus 6p and samsung s7 edge)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 IEEE 802.1X: Sending EAP Packet (identifier 247)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: sending 1/4 msg of 4-Way Handshake
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: received EAPOL-Key frame (2/4 Pairwise)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: sending 3/4 msg of 4-Way Handshake
Sun Aug 28 16:28:46 2016 daemon.info hostapd: wlan2: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: event 2 notification
Sun Aug 28 16:29:00 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: associated
Sun Aug 28 16:29:00 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated
Sun Aug 28 16:29:11 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: associated
Sun Aug 28 16:29:11 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated

However,Windows can connect to it.

Here are some my nexus 6p’s dmesg:
CFG80211-ERROR wl_cfg80211_disconnect:Reason 17

30.08.2016126KernelBug ReportVery LowMediumkernel panic on brcm47xx (netgear wgt634u) when routing...TrunkUnconfirmed Task Description

With LEDE version reboot-1444-g1bb914d, when pulling data through the WAN interface to the LAN interface at a sufficiently high speed, e.g. on a Raspberry Pi connected by ethernet to a LAN port, and the WAN interface connected to a gigabit internet service and issuing a command like:

curl https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.7.2.tar.xz > /dev/null

From the pi, I see something like:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  9 86.2M    9 7977k    0     0  1834k      0  0:00:48  0:00:04  0:00:44 1835k[  352.295252] smsc95xx 1-1.1:1.0 eth0: link down
  9 86.2M    9 7977k    0     0  1255k      0  0:01:10  0:00:06  0:01:04 1155k[  353.959380] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
  9 86.2M    9 7977k    0     0  43292      0  0:34:48  0:03:08  0:31:40     0

or

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  8 86.2M    8 7440k    0     0  1478k      0  0:00:59  0:00:05  0:00:54 1478k[ 1100.164849] smsc95xx 1-1.1:1.0 eth0: link down
  8 86.2M    8 7440k    0     0  1232k      0  0:01:11  0:00:06  0:01:05 1300k[ 1101.836954] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
  8 86.2M    8 7440k    0     0   740k      0  0:01:59  0:00:10  0:01:49     0

Where the “link down” is the WGT634U panic’ing and rebooting. The panic on the WGT634U looks like this:

[  171.966841] CPU 0 Unable to handle kernel paging request at virtual address 008224d8, epc == 80077ecc, ra == 801d8100
[  171.977700] Oops[#1]:
[  171.980093] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 4.1.20 #0
[  171.986265] task: 8181e008 ti: 8182a000 task.ti: 8182a000
[  171.991711] $ 0   : 00000000 1000b800 008224d8 b41c479b
[  171.997140] $ 4   : 008224d8 00010000 80361ef8 00000000
[  172.002557] $ 8   : 81018b14 8101da14 00100100 dceb27b8
[  172.007983] $12   : ffffffff 00000001 ffffff80 000042c6
[  172.013400] $16   : b41c479b 00000001 81b450a8 81b7d260
[  172.018817] $20   : 803b5dcc 00000002 00000008 0000000a
[  172.024235] $24   : 00000000 80072b24                  
[  172.029653] $28   : 8182a000 8182bdb8 00000100 801d8100
[  172.035083] Hi    : 00000000
[  172.038026] Lo    : 0000006c
[  172.041036] epc   : 80077ecc put_compound_page+0x78/0x240
[  172.046547] ra    : 801d8100 skb_release_data+0xa8/0x10c
[  172.051920] Status: 1000b803 KERNEL EXL IE 
[  172.056254] Cause : 00800008
[  172.059194] BadVA : 008224d8
[  172.062144] PrId  : 00029007 (Broadcom BMIPS3300)
[  172.066891] Modules linked in: pppoe ppp_async iptable_nat ath5k ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables leds_gpio ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common ssb_hcd
[  172.132913] Process ksoftirqd/0 (pid: 3, threadinfo=8182a000, task=8181e008, tls=00000000)
[  172.141213] Stack : 1000b803 00000000 0000006c b41c479b 81b45080 801d8100 00000000 0000012c
          00000001 801e7d60 81becb60 81b7d260 81b7d260 80335b3c 81bece60 801d818c
          80360000 803623e0 81becb60 80335b3c 803623e0 801e63d8 8182be10 8182be10
          00000001 00000002 803b5dd0 00000001 803b5dd4 00000003 803b0000 80024fec
          81841048 80361100 819bb770 80007664 80364510 8181e008 80362898 04208040
          ...
[  172.178058] Call Trace:
[  172.180640] [<80077ecc>] put_compound_page+0x78/0x240
[  172.185822] [<801d8100>] skb_release_data+0xa8/0x10c
[  172.190895] [<801d818c>] __kfree_skb+0x28/0xb4
[  172.195466] [<801e63d8>] net_tx_action+0xd8/0x140
[  172.200329] [<80024fec>] __do_softirq+0x184/0x2b0
[  172.205184] [<80025140>] run_ksoftirqd+0x28/0x80
[  172.209953] [<8003bae0>] smpboot_thread_fn+0x148/0x178
[  172.215246] [<80039390>] kthread+0xdc/0xe8
[  172.219459] [<800010a8>] ret_from_kernel_thread+0x14/0x1c
[  172.224921] 
[  172.226470] 
Code: 30840001  0204100a  00402021 <8c420000> 000211c2  30420001  10400018  00000000  8e020000 
[  172.237022] ---[ end trace 89a3318b662df6d8 ]---
[  172.250536] Kernel panic - not syncing: Fatal exception in interrupt
[  172.262338] Rebooting in 3 seconds..

or

[ 1317.958261] Unhandled kernel unaligned access[#1]:
[ 1317.963173] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 4.1.20 #0
[ 1317.969349] task: 8181e008 ti: 8182a000 task.ti: 8182a000
[ 1317.974795] $ 0   : 00000000 1000b801 00000001 00200000
[ 1317.980232] $ 4   : 647b394a 00010000 00018da4 00000000
[ 1317.985658] $ 8   : 8181e040 b1e1b104 00000017 40000000
[ 1317.991085] $12   : 500018dd 00000000 00000000 010102f2
[ 1317.996510] $16   : 80e4d1e0 00000001 80e4d208 81acb0e0
[ 1318.001936] $20   : 803b5dcc 00000002 00000008 0000000a
[ 1318.007362] $24   : 00000010 8001ead0                  
[ 1318.012789] $28   : 8182a000 8182bdd0 00000100 801d8100
[ 1318.018220] Hi    : 00000001
[ 1318.021160] Lo    : 00000001
[ 1318.024169] epc   : 80078474 put_page+0x0/0x4c
[ 1318.028732] ra    : 801d8100 skb_release_data+0xa8/0x10c
[ 1318.034104] Status: 1000b803 KERNEL EXL IE 
[ 1318.038439] Cause : 00800010
[ 1318.041380] BadVA : 647b394a
[ 1318.044330] PrId  : 00029007 (Broadcom BMIPS3300)
[ 1318.049076] Modules linked in: pppoe ppp_async iptable_nat ath5k ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables leds_gpio ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common ssb_hcd
[ 1318.115124] Process ksoftirqd/0 (pid: 3, threadinfo=8182a000, task=8181e008, tls=00000000)
[ 1318.123424] Stack : 00000000 80c60c94 00db35c0 626a006e ff330000 81acb0e0 81acb0e0 80335b3c
          80c28260 801d818c 80360000 8004f368 00000018 0000000a 803623e0 801e63d8
          8182be10 8182be10 80361100 00000002 803b5dd0 00000001 803b5dd4 00000013
          803b0000 80024fec 80364510 80361100 80360000 8000736c 80364510 8181e008
          80362898 04208040 00018da4 80360000 80310000 803b5dcc 803615a0 803114f4
          ...
[ 1318.160295] Call Trace:
[ 1318.162885] [<80078474>] put_page+0x0/0x4c
[ 1318.167108] [<801d8100>] skb_release_data+0xa8/0x10c
[ 1318.172182] [<801d818c>] __kfree_skb+0x28/0xb4
[ 1318.176752] [<801e63d8>] net_tx_action+0xd8/0x140
[ 1318.181614] [<80024fec>] __do_softirq+0x184/0x2b0
[ 1318.186471] [<80025140>] run_ksoftirqd+0x28/0x80
[ 1318.191238] [<8003bae0>] smpboot_thread_fn+0x148/0x178
[ 1318.196530] [<80039390>] kthread+0xdc/0xe8
[ 1318.200744] [<800010a8>] ret_from_kernel_thread+0x14/0x1c
[ 1318.206200] 
[ 1318.207747] 
Code: 00003021  0801e0ce  24a57888 <8c820000> 3042c000  10400003  00801821  0801df95  00000000 
[ 1318.218397] ---[ end trace 2502a626803fb4b9 ]---
[ 1318.231740] Kernel panic - not syncing: Fatal exception in interrupt
[ 1318.243362] Rebooting in 3 seconds..

This looks similar to: https://dev.openwrt.org/ticket/11091

24.08.2016115Base systemBug ReportVery LowMediumWWAN-connections using 3g with HUAWEI ME909u-521 unstab...TrunkUnconfirmed Task Description

Actually, I am trying to stabilize wwan (3g actually; LTE later on) using pppd with my HUAWEI ME909u-521,
because either my MT7620-based router locks up during boot already; or after short period of real usage.
During night, when router is almost idle, just some watchdog date sent via wwan, no problem.

First trace of a possible problem was this msg in logread:
daemon.notice netifd: wwan (1676): Error setting WWAN mode!

Wich is expected, as in /lib/netifd/proto/3g.sh:

...

                      elif echo "$cardinfo" | grep -qi huawei; then
                              case "$service" in
                                      umts_only) CODE="14,2";;
                                      gprs_only) CODE="13,1";;
                                      *) CODE="2,2";;
                              esac
                              export MODE="AT^SYSCFG=${CODE},3FFFFFFF,2,4"    #####Will not work !!!!! Switching USB-Stick to 3g-preferred ?

...
...

                      [ -n "$MODE" ] && gcom -d "$device" -s /etc/gcom/setmode.gcom

Will not work, because the ME909u-521 rejects AT^SYSCFG . However, AT^SYSCFGEX will work, but having different syntax.
MODE=”AT^SYSCFG=${CODE},3FFFFFFF,2,4” will be effective for simpler modems.

/etc/gcom/setmode.gcom returns exit 1; but this error is not checked in 3g.sh

Not shure, whether this is the reason for my problems; however, reason of concern, as high speed modems
are more and more common.
Willing to participate in testing/debugging.

For details regarding my modem, consult
HUAWEI ME909u-521 LTE LGA Module AT Command Interface Specification
http://www.paoli.cz/out/media/HUAWEI_ME909u-521_LTE_LGA_Module_AT_Command_Interface_Specification-V100R001_02.pdf

16.08.201694Base systemBug ReportVery LowMediumnetifd: PPPoE MTU problemTrunkNew Task Description

When you set the MTU of a ppp interface with proto=pppoe and ifname=nas0 via the mtu option,
the configured mtu will not be set on the ppp interface (what you want), but on the
underlying interface named by ifname (what you normally don’t want to change).

This leeds to log messages like this:


pppd[5641]: Interface nas0 has MTU of 1448 – should be at least 1500.


and MTUs other than what you really want.

example:


desired PPPoE MTU: 1448
actual nas0 MTU: 1448
actual PPPoE MTU: 1440

This issue seems to be related to the commit 7ac29b75319fd69a8a7c0aeea7804d381ec07d3d of netifd.

Regards,
Martin

22.06.201626FlysprayFeature RequestVery LowLowComment formatting syntax should be documentedTrunkResearching Task Description

Currently the formatting options are not documented anywhere, and I failed to find any documentation with google. There are a few buttons to use, but they seem to be rather limited (e.g. nothing for quotations).

Showing tasks 1101 - 1125 of 1125 Page 23 of 23<<First - 19 - 20 - 21 - 22 - 23

Available keyboard shortcuts

Tasklist

Task Details

Task Editing