OpenWrt/LEDE Project

Welcome to the OpenWrt/LEDE Project bug reporting and issue tracking system

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to lede-bugs@infradead.org.

OpenedIDCategoryTask TypePrioritySeverity  ascSummaryReported InStatus
15.02.2017517Base systemBug ReportVery LowVery LowPCEngines Alix Ethernet right hand led lit on boot for ...lede-17.01Unconfirmed Task Description

PCEngines Alix, Ethernet right hand led is on once booted, on all ports, with no cable connected.
LEDE Reboot 17.01.0-rc2
Image used: lede-17.01.0-rc2-r3131-42f3c1f-x86-geode-combined-squashfs.img

On booting the right hand LED is on for all ethernet ports with no cable connected. On connecting a cable the left hand light comes on as expected and the right hand stays on. Both leds then flash with traffic as expected.

Operation is not effected.

28.02.2017568Base systemBug ReportVery LowVery LowFirst boot messages are not logged to filelede-17.01Unconfirmed Task Description

I’m saving logs to a file on an external partition that is mounted at boot. After rebooting with an empty log file, an inconsistency can be noticed between the output of logread and the content of the log file. The first message printed by logread is, as expected,

Mon Feb 27 20:33:15 2017 kern.info kernel: [    0.000000] Booting Linux on physical CPU 0x0

while the first message in the log file reads

Mon Feb 27 20:33:16 2017 user.notice : Added device handler type: tunnel

The first boot messages are missing from the log file. From this point on, logread and the log file are identical.
Of course this is a minor issue, but still one would expect logs to be 100% complete, regardless whether they are stored in memory or to file.

root@lede:~# cat /etc/config/system 
config system
        option hostname 'lede'
	option zonename 'Europe/Rome'
	option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'
        option ttylogin '0'
        option urandom_seed '0'
        option log_remote '0'
        option log_type 'file'
        option log_file '/mnt/sda1/var/log/messages'
        option log_buffer_size '64'
        option log_size '1024'
        option conloglevel '8'
        option cronloglevel '0'
...

Start order of init scripts log and fstab has been changed to start logging as early as possible.

root@lede:~# ls -1 /etc/rc.d/S*
/etc/rc.d/S00sysfixtime
/etc/rc.d/S10boot
/etc/rc.d/S10fstab
/etc/rc.d/S10system
/etc/rc.d/S11log
/etc/rc.d/S11sysctl
...

Device: WRT1200AC
Software version: Reboot (17.01.0, r3205-59508e3)

24.04.2017732Base systemBug ReportVery LowVery LowD-Link DIR-615 D2 (ramips rt305x) Wireless LED Not Flas...AllUnconfirmed Task Description

I have a D-Link DIR-615 D2 (dir-615-d-squashfs-factory.bin), Its all working fine however the LED for the wireless light dosnt flash nor show activity to show is been used as it shows a solid green WiFi light. LANs from 1-4 all flash perfectly so no issue here.

02.05.2017751Base systemFeature RequestVery LowVery LowAdd customisable SIGINT behaviour to procdlede-17.01Unconfirmed Task Description

I am running LEDE 17.01.1 on a Linksys NSLU2.

The device has a power button on the front panel, which will boot the device when pressed when power is present. If the button is pressed when the device is running the device will reboot. I would like to be able to configure the device to power off when the button is pressed instead.

I have tried editing some of the stock scripts in /etc/rc.button to no effect. I ran across this page on the OpenWrt wiki, which suggests that pressing the button causes SIGINT to be delivered to PID 1.

I took a look at the procd git repository, and procd reboots the system when it catches SIGINT. If this were configurable then procd could take specific action, such as powering the device down, when it receives a hardware interrupt.

09.05.2017772PackagesFeature RequestVery LowVery LowAllowing Snort to also block possibly using SnortSamTrunkUnconfirmed Task Description

I noticed that Snort is available from the packages. I wanted to inquire if it would be possible to intergrate dynamic blocking through software such as SnortSam (http://www.snortsam.net/).

pfSence implements a blocking feature with Snort, I’m curious if others may be likewise be interested in this feature being added in to a future release of LEDE.

Thanks

18.06.2017854Base systemBug ReportVery LowVery LowUnstable Internet caused by frequent PPPoE reconnect, n...lede-17.01Unconfirmed Task Description
daemon.info pppd[7738]: No response to 5 echo-requests
daemon.notice pppd[7738]: Serial link appears to be disconnected.
daemon.info pppd[7738]: Connect time 1.0 minutes.
daemon.info pppd[7738]: Sent 28006 bytes, received 46170 bytes.
daemon.notice pppd[7738]: Connection terminated.
daemon.info pppd[7738]: Connect time 1.0 minutes.
daemon.info pppd[7738]: Sent 28006 bytes, received 46170 bytes.
daemon.info pppd[7738]: Sent PADT
daemon.info pppd[7738]: Exit.

network.wan.keepalive is not set, and on luci “LCP echo failure threshold” shows a grey 0 and the description below it says “Presume peer to be dead after given amount of LCP echo failures, use 0 to ignore failures”, but this description is not consistent with the behaviour.

After running the commands below, the grey 0 becomes darker, but the problem persists.

root@LEDE:~# uci set network.wan.keepalive=0
root@LEDE:~# /etc/init.d/network restart

The value of network.wan.keepalive when set using luci has two numbers separated by a space (which appears to be in the format of ‘[threshold] [interval]’), but it should be a number according to the wiki https://lede-project.org/docs/user-guide/wan_interface_protocols?s[]=pppoe#protocol_pppoe_ppp_over_ethernet

I then tried the following commands, and there’re no reconnects after one hour.

root@LEDE:~# uci set network.wan.keepalive='0 1'
root@LEDE:~# /etc/init.d/network restart

Is it better to have a default of 0 (default=undefined network.wan.keepalive) instead of seemingly 5 which would also be consistent with luci?

28.08.2017989Base systemBug ReportVery LowVery LowAttempting to just build iptables failsTrunkUnconfirmed Task Description

Using LEDE HEAD (currently 4b3ffecf2bbbfb8df618314e5bec52659b648fac), running “make defconfig; make -j1 V=s package/iptables/compiles” in a fresh checkout yields

make[1]: Entering directory '/tank/openwrt/scratch/test'                                                                                                                             
make[2]: Entering directory '/tank/openwrt/scratch/test/package/libs/toolchain'                                                                                
touch /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.prepared_9c30076b46b1812fb254b6ec31ccf85e_6664517399ebbbc92a37c5bb081b5c53_check
mkdir -p /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain
touch /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.prepared_9c30076b46b1812fb254b6ec31ccf85e_6664517399ebbbc92a37c5bb081b5c53
rm -f /tank/openwrt/scratch/test/staging_dir/target-mips_24kc_musl/stamp/.toolchain_installed
(cd /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/./; if [ -x ./configure ]; then find /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/ -name config.guess | xargs -r chmod u+w; find /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/ -name config.guess | xargs -r -n1 cp --remove-destination /tank/openwrt/scratch/test/scripts/config.guess; find /tank/openwrt/s
cratch/test/build_dir/target-mips_24kc_musl/toolchain/ -name config.sub | xargs -r chmod u+w; find /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/ -name config.sub | xargs -r -n1 cp --remove-destination /tank/openwrt/scratch/test/scripts/config.sub; AR="mips-openwrt-linux-musl-gcc-ar" AS="mips-openwrt-linux-musl-gcc -c -Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -f
honour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -iremap/tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain:toolchain -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro" LD=mips-openwrt-linux-musl-ld NM="mips-openwrt-linux-musl-gcc-nm" CC="mips-openwrt-linux-musl-gcc" GCC="mips-openwrt-linux-musl-gcc" CPP="mips-openwrt-linu
x-musl-cpp" CXX="mips-openwrt-linux-musl-g++" RANLIB="mips-openwrt-linux-musl-gcc-ranlib" STRIP=mips-openwrt-linux-musl-strip OBJCOPY=mips-openwrt-linux-musl-objcopy OBJDUMP=mips-openwrt-linux-musl-objdump SIZE=mips-openwrt-linux-musl-size CFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -mips16 -
minterlink-mips16 -iremap/tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain:toolchain -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro " CXXFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -mips16 -minterlink-mips16 -iremap/tank/openwr
t/scratch/test/build_dir/target-mips_24kc_musl/toolchain:toolchain -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro " CPPFLAGS="-I/tank/openwrt/scratch/test/staging_dir/target-mips_24kc_musl/usr/include -I/tank/openwrt/scratch/test/staging_dir/target-mips_24kc_musl/include -I/tank/openwrt/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/usr/include -I/tank/openwrt
/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/include/fortify -I/tank/openwrt/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/include " LDFLAGS="-L/tank/openwrt/scratch/test/staging_dir/target-mips_24kc_musl/usr/lib -L/tank/openwrt/scratch/test/staging_dir/target-mips_24kc_musl/lib -L/tank/openwrt/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/usr/lib -L/tank/openwrt/scratch/test/
staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/lib -znow -zrelro "   ./configure --target=mips-openwrt-linux --host=mips-openwrt-linux --build=x86_64-pc-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls  ; fi; )
rm -f /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.configured_*
touch /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.configured_68b329da9893e34099c7d8ad5cb9c940
rm -f /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.built
touch /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.built_check
touch /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.built
rm -rf /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc.installed /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc
mkdir -p /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc
install -d -m0755 /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc/lib /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc/usr/bin
cp -fpR /tank/openwrt/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/lib/ld-musl-*.so* /tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc/lib/
cp: cannot stat '/tank/openwrt/scratch/test/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl/lib/ld-musl-*.so*': No such file or directory
Makefile:618: recipe for target '/tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc.installed' failed
make[2]: *** [/tank/openwrt/scratch/test/build_dir/target-mips_24kc_musl/toolchain/.pkgdir/libc.installed] Error 1
make[2]: Leaving directory '/tank/openwrt/scratch/test/package/libs/toolchain'
package/Makefile:109: recipe for target 'package/libs/toolchain/compile' failed
make[1]: *** [package/libs/toolchain/compile] Error 2
make[1]: Leaving directory '/tank/openwrt/scratch/test'
/tank/openwrt/scratch/test/include/toplevel.mk:207: recipe for target 'package/iptables/compile' failed
make: *** [package/iptables/compile] Error 2

If I just run “make” the system builds successfully, so I am not exactly sure what’s wrong. Perhaps it’s as simple as a missing dependency? This came about because I was attempting to build iptables without having built the kernel and was getting yet different build failures, but I have not reliably reproduced them from a blank slate yet. Will advise.

10.02.20181339PackagesBug ReportVery LowVery LowIt seems that ‘–dport’ option is not recognized by ipta...lede-17.01Unconfirmed Task Description

Mys router:

System: CHAOS CALMER (15.05.1, r48532)
Router: Asus RT-N56U

I also reproduced this bug with lede 17.01.1 r3316-7eb58cf109 in VirtualBox (according to the guide on https://wiki.openwrt.org/doc/howto/virtualbox).

What happens:

It seems that ‘–dport’ option is not recognized by iptables for sctp. Command execution fails.

Expected result:

Command runs successfully and we can create rules with iptables to match by sctp and destination port.

Steps to reproduce:

First install these:
sctp
kmod-sctp
libsctp
sctp-tools

Try to run this:

iptables -A INPUT -p sctp --dport 1234 -j ACCEPT

Shows error:

iptables v1.4.21: unknown option "--dport"
Try `iptables -h' or 'iptables --help' for more information.

Try to run this:

iptables -A INPUT -p sctp -j ACCEPT

Works!

06.03.20181414ToolchainBuild FailureVery LowVery Lowmbedtls: building with ccache: /staging_dir/host/bin/cc...TrunkUnconfirmed Task Description

I am currently trying to compile OpenWRT for

CONFIG_TARGET_LANTIQ=Y
CONFIG_TARGET_LANTIQ_XWAY=Y
CONFIG_TARGET_lantiq_xway_DEVICE_arcadyan_arv752dpw22=y

I am using

CONFIG_DEVEL=y
CONFIG_CCACHE=y

I am building in the following way:

The build was carried out on a git clone git://github.com/openwrt/openwrt.git, later brought up to date with a git pull, with latest commit from 2018-03-05T10:44:20+01:00, commit hash 5cbd22bb0f.

Into this git clone a previously generated .config seed, made previously by make menuconfig and ./scripts/diffconfig.sh, was copied over to ./.config.

From there on, the following commands were issued:

./scripts/feeds update -a
./scripts/feeds install -a
make -j1 V=s defconfig
make -j1 V=s download
make -j1 V=s IGNORE_ERRORS=m | tee make.log

When it comed to building mbedtls, there are the following lines of output which indicate something is wrong:

[...]
make[3]: [Makefile:75: /home/felics/download/router/OS/OpenWRT/source_build/source/batch_builds/2018-02-26_12-04-45_-_custom-wo-pie_feeds-rooter-custom/build_dir/target-mips_24kc_musl/mbedtls-2.7.0/.configured_68b329da9893e34099c7d8ad5cb9c940] Error 123 (ignored)
[...]
/home/felics/download/router/OS/OpenWRT/source_build/source/batch_builds/2018-02-26_12-04-45_-_custom-wo-pie_feeds-rooter-custom/staging_dir/host/bin/ccache: invalid option -- 'd'
Usage:
    ccache [options]
[...]

Build continues, (seemingliy) successfully: Indicated by the further output of make, and issuing later a make -j1 V=s (i.e. without IGNORE_ERRORS=m), does not bring this up again.

The toolchain (./staging_dir/toolchain-*) is mips_24kc_gcc-5.5.0_musl.

Build is carried out on an x86_64 Arch Linux machine.

Attached are the following files:

  • .config-diffconfig-seed: The .config-seed used for make defconfig,
  • .config: The .config created by the make defconfig and used for the build,
  • mbedtls.log: The pa[.config-diffconfig-seed.txt](https://github.com/openwrt/packages/files/1782373/default.config-diffconfig-rt of the output of make -j1 V=s IGNORE_ERRORS=m regarding building mbedtls,
  • make.log.stdout.xz: For your interest, the full output of make -j1 V=s IGNORE_ERRORS=m (.xz compressed; decompresses to about 29 MB) (Note that at the end another build error occurs, which seems not to be related to embedtls),
  • feeds.conf: The feeds.conf used.

(Note that I just forgot to capture stderr too, but the error messages seem to be present in stdout. Since a full rebuild takes a day on my machine, I won’t do that if not necessary.)

07.03.20181415Base systemFeature RequestVery LowVery Low[Enhancement] Consider shorter interface-name prefixesTrunkUnconfirmed Task Description

Given that `IFNAMSIZ` is typically 16, there are 15 characters available for an interface name.

OpenWRT prepends a prefix that can be at least 6 characters `gre4t-` as an example.

If one then creates pseudo/virtual-interfaces using VLAN notation, there are only 4 characters available for configuration

`gre4t-ABCD.1234`

As long as this limitation is known, there is no loss of functionality, only utility in the naming. I would have ideally been able to name my tunnels with a more readable indication of where the other endpoint was, for example `portal1` rather than `gt99`.

At some time in the future, shortening these generated prefixes would be welcome. I acknowledge that this likely impacts only a small fraction of advanced users and a change may impact scripts that rely on the generated name.

 


28.04.20181523Base systemBug ReportVery LowVery Lowblock-mount: unnecessary remounts after extroot switchlede-17.01Unconfirmed Task Description

Environment: arm_cortex-a9_vfpv3, Linksys WRT1200AC, LEDE Reboot 17.01.4 r3560-79f57e422d

Description:
A USB flash drive has been configured with an ext4 partition to be used as external overlay, following the steps at https://openwrt.org/docs/guide-user/additional-software/extroot_configuration precisely. After the extroot switch, block tries to remount partitions that have already been mounted, generating the following errors in the logs:

Sat Apr 28 12:25:00 2018 daemon.err block: /dev/ubiblock0_0 is already mounted on /rom
Sat Apr 28 12:25:00 2018 daemon.err block: /dev/sdb1 is already mounted on /overlay
14.08.20181777Base systemBug ReportVery LowVery Lowrelease 18.06 on RouterBoards (ar71xx/mikrotik): superf...openwrt-18.06Unconfirmed Task Description

The sysupgrade-procedure of release 18.06 for RouterBoards (ar71xx/mikrotik)
(as contained in openwrt-18.06.0-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf) creates
a superfluous UBI volume named “none”.

Details:

The function platform_nand_pre_upgrade() intarget/linux/ar71xx/base-files/lib/upgrade/platform.sh sets
“CI_KERNPART=none” to bypass the normal kernel-install-procedure.
This works, but causes nand_upgrade_prepare_ubi() in package/base-files/files/lib/upgrade/nand.sh
to creat an UBI volume named “none”, containing a (supposedly defective) kernel-yaffs2-image.

Used command :

sysupgrade -n -v http://192.168.88.1:8080/openwrt-18.06.0-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin

25.01.20192083Base systemBug ReportVery LowVery LowRemove last references to the lede-project.org URLTrunkUnconfirmed Task Description

git grep -i “lede-project\.org” | grep -vi Copyright
There are still some references to the old project.

Thanks.

06.05.20192269PackagesBug ReportVery LowVery Lowiwinfo_lib.c does not correlate it's list with kernelTrunkUnconfirmed Task Description

The following issue occurs on all devices across all OpenWRT versions as it is partly a problem derived from the Linux Kernel.

It is explained in detail here: https://forum.openwrt.org/t/wifi-regulatory-country-database/35775

Prerequisites:

1) You need to have set up a working Wireless access point.
2) The set country has to not be one of the ones patched out here: https://pastebin.com/M2qTQFT5

Steps to reproduce:

1) Type ‘iw reg get’ in the terminal. This will give you a list of all available channels in the regulatory zone (country).
2) Change country to one of the patched out ones: https://pastebin.com/M2qTQFT5 (Eg. Angola, Antarctica)
3) [opt - Disregard this step if you used the WebUI] Type ‘/etc/init.d/network restart’ 4) Type ‘iw reg get’ in the terminal. You will notice that it has not changed.

Problem:

You can, unknown to you, set up a channel which is prohibited in your country. This is very hard to *check* because there is no way to pre-query whether you can set such a country or not.

More detailed explanation and argumentation can be found here: https://forum.openwrt.org/t/wifi-regulatory-country-database/35775


11.05.20192278Base systemFeature RequestVery LowVery LowRFE: Replace iptables(legacy) with iptables(nf_tables)TrunkUnconfirmed Task Description

Supported since iptables 1.8: https://marc.info/?l=netfilter-devel&m=153086953903487

22.06.201626FlysprayFeature RequestVery LowLowComment formatting syntax should be documentedTrunkResearching Task Description

Currently the formatting options are not documented anywhere, and I failed to find any documentation with google. There are a few buttons to use, but they seem to be rather limited (e.g. nothing for quotations).

13.07.201650Base systemBug ReportVery LowLowNo image or non-verbose output created if image is too ...TrunkUnconfirmed Task Description

The target/install target does not produce the *squashfs-factory.bin and *squashfs-sysupgrade.bin binaries if the images are too big to fit the selected flash size.
However, make doesn't say a word to the user but simply does not produce the files. The user has to either check the mtime of the files if they were created earlier or use

make target/install V=s

to derive what's wrong.
According to jow on IRC this is just an artifact of no way to bypass silent mode. That might be the common explanation but it is still a bug from my POV.

07.08.201681Base systemFeature RequestVery LowLowAdd ability to limit wifi channels for "auto" channel s...TrunkUnconfirmed Task Description

A nice feature for LEDE would be ability to limit what channels are used for when setting an interface up for “auto” channel selection.

For example, on 2.4 GHz, while channels 1-11 are often available, it’s better to just use 1, 6, and 11. But for “auto” mode, the router will still sometimes pick one of the in between channels. If there was some sort of checklist where you could pick only those channels you want the algorithm to use, it would allow finer grained control over the process.

It would be trickier for the GHz band though, since there are often different power limits associated with the different bands.

17.08.201697Base systemBug ReportMediumLowdnsmasq doesn't receive updated dns servers when runnin...TrunkNew Task Description

Bind-mounting /tmp/resolv.conf.auto apparently doesn’t forward inotify events arriving from the kernel when resolv.conf.auto was changed (e.g. upstream DNS servers were received by a DHCP client or pppd). Restarting dnsmasq or running it without ujail solves the issue.

02.09.2016133Base systemBug ReportVery LowLowNetgear r8000 cannot use 802.1x encryptionTrunkUnconfirmed Task Description

Github issue #305 reported by https://github.com/Halry

My android phone can’t connect to it.(tested on nexus 6p and samsung s7 edge)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 IEEE 802.1X: Sending EAP Packet (identifier 247)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: sending 1/4 msg of 4-Way Handshake
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: received EAPOL-Key frame (2/4 Pairwise)
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: sending 3/4 msg of 4-Way Handshake
Sun Aug 28 16:28:46 2016 daemon.info hostapd: wlan2: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated
Sun Aug 28 16:28:46 2016 daemon.debug hostapd: wlan2: STA 94:fe:22:11:22:33 WPA: event 2 notification
Sun Aug 28 16:29:00 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: associated
Sun Aug 28 16:29:00 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated
Sun Aug 28 16:29:11 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: associated
Sun Aug 28 16:29:11 2016 daemon.info hostapd: wlan1: STA 94:fe:22:11:22:33 IEEE 802.11: disassociated

However,Windows can connect to it.

Here are some my nexus 6p’s dmesg:
CFG80211-ERROR wl_cfg80211_disconnect:Reason 17

05.09.2016160Base systemBug ReportVery LowLowusb-serial (pl2303) failures on mt7621 dlink dir860l-b1TrunkUnconfirmed Task Description
git describe
reboot-1497-ga810e77

with diffconfig:

CONFIG_TARGET_ramips=y
CONFIG_TARGET_ramips_mt7621=y
CONFIG_TARGET_ramips_mt7621_DEVICE_dir-860l-b1=y
CONFIG_DEVEL=y
CONFIG_BUILD_LOG=y
CONFIG_PACKAGE_ip=y
CONFIG_PACKAGE_kmod-usb-core=y
CONFIG_PACKAGE_kmod-usb-ohci=y
CONFIG_PACKAGE_kmod-usb-ohci-pci=y
CONFIG_PACKAGE_kmod-usb-serial=y
CONFIG_PACKAGE_kmod-usb-serial-ftdi=y
CONFIG_PACKAGE_kmod-usb-serial-pl2303=y
CONFIG_PACKAGE_kmod-usb2=y
CONFIG_PACKAGE_kmod-usb2-pci=y
CONFIG_PACKAGE_kmod-usb3=y
CONFIG_PACKAGE_screen=y

screen starts, but doesn’t work. The usb-relevant dmesg’s are:

[    4.550000] usbcore: registered new interface driver usbfs
[    4.560000] usbcore: registered new interface driver hub
[    4.570000] usbcore: registered new device driver usb
[    4.580000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.620000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.670000] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    4.720000] hub 1-0:1.0: USB hub found
[    4.740000] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    4.760000] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    4.770000] hub 2-0:1.0: USB hub found
[    5.260000] usb 1-1: new full-speed USB device number 2 using xhci-mtk
[    5.410000] usb 1-1: no of_node; not parsing pinctrl DT
[   10.150000] usbcore: registered new interface driver usbserial
[   10.160000] usbcore: registered new interface driver usbserial_generic
[   10.180000] usbserial: USB Serial support registered for generic
[   10.220000] usbcore: registered new interface driver ftdi_sio
[   10.240000] usbserial: USB Serial support registered for FTDI USB Serial Device
[   10.260000] usbcore: registered new interface driver pl2303
[   10.270000] usbserial: USB Serial support registered for pl2303
[   10.290000] pl2303 ttyUSB0: no of_node; not parsing pinctrl DT
[   10.290000] usb 1-1: pl2303 converter now attached to ttyUSB0
[  871.510000] pl2303 ttyUSB0: pl2303_get_line_request - failed: -145
[  871.620000] pl2303 ttyUSB0: pl2303_set_line_request - failed: -145
[  871.840000] pl2303 ttyUSB0: pl2303_set_control_lines - failed: -145

Screen also throws an error (which gets blanked out, but is captured by the serial console):

# screen /dev/ttyUSB0 115200
/dev/null/utmp: Not a directory
07.09.2016162Base systemBug ReportVery LowLowTwo issues with libuclient-openssl in luci-sslTrunkUnconfirmed Task Description

1: RC4 and 3DES are used when both have security issues. Actually the latter also is true of mbedtls/polarssl.

2: Only TLS 1.2 is supported. This makes multiple clients unable to connect.

BTW, I got this working after modifying the Makefile to luci-ssl to depend on libustream-openssl instead. No idea what the situation is but so far it works without a problem.

12.10.2016222Base systemFeature RequestVery LowLowproviding pre-built images for extroot for devices with...TrunkUnconfirmed Task Description

Currently, the only way to be able to make extroot (use an external drive as overlay) for 4MiB devices is to build an image with the Image Builder as they can’t fit the packages needed in the jffs.

For most linux users this isn’t a major issue as the Image Builder runs on Linux and with a couple commands you build all, but it’s still time-consuming.

For everyone else this is an issue, as they need to get a linux system, learn how to use the Image Builder, and so on.

I’m asking if it is possible to make pre-built images with the right packages to allow extroot on 4 MiB devices.

The packages I thing we need in these pre-built images are all is needed by the device to be able to format and check its own drive, because again most users don’t have access to a linux system to format a drive with ext4 or whatever.

It seems e2fsprogs is too big to fit with the other packages required, currently only f2fs filesystem tools are split and can be used in 4MiB devices for extroot.

These are the packages that currently should allow building an extrootable image that fits on 4MiB storage:

blkid block-mount kmod-fs-f2fs kmod-usb-storage kmod-usb-uhci kmod-usb-ohci mkf2fs f2fsck

(of course no luci is included).

13.10.2016224Base systemBug ReportVery LowLowwrong source IP when logging to remote IPv6 syslog serv...TrunkAssigned Task Description

Hello,

I’m trying to send log to remote IPv6 syslog server (x:y:z:12::1), but packets received by syslog server are invalid. Instead of public IPv6 address, syslog udp packets are sent with ::1 source IP and therefore ignored by destination server. Logging over IPv4 works ok.

tcpdump log from destination syslog server:
23:34:16.988433 IP6 ::1.38044 > x:y:z:12::1.514: SYSLOG daemon.notice, length: 65

Configuration:

/etc/config/system:

 option log_ip 'x:y:z:12::1'

Device is in the same range as syslog server (x:y:z:12::119/64) and has native IPv6 connectivity. Other services (dropbear, ntp client, snmpd, luci) are running fine over IPv6.

Device is TP-Link WDR3600, running lede reboot-1818-gb81fc29.

02.11.2016262Base systemBug ReportVery LowLowipq806x: wlan LEDs not working on TP-Link Archer C2600AllNew Task Description

The LEDs on the Archer C2600 don’t work properly. The WLAN lights don’t work at all (I believe that they are controlled PCIE chips and not GPIO) and the LAN and WAN lights are always on regardless of a cable being connected.

JW


03.12.2016320Base systemFeature RequestVery LowLowrelayd feature requestTrunkUnconfirmed Task Description

I found a couple of bugs with relayd based bridge configuration and I would like to suggest a feature request. Will fill one entry per issue:

On today’s trunk

3- in a configuration where the network attached to the wireless radio is configured via DHCP, the listening interface is not set up automatically. DD-WRT and Gargoyle do this automatically ( they overwrite the config/network file with the gateway parameter and reload relayd.

 


09.12.2016329Base systemBug ReportVery LowLowAR9341 needs analog switch resetTrunkUnconfirmed Task Description

This is a bug report for the AR9341 SOC on LEDE trunk reboot-2445-gee5a6c1.

I have builded a custom firmware for a unsupported device based on the Atheros DB120 reference board.

The analog port of the ethernet switch needs to be resetted before it can operate.

Part of bootlog without analog reset:

[    2.179262] ag71xx-mdio.1: unknown phy id 'ffff:ffff'

Br-lan is not intialized due no analog switch reset.

Part of bootlog with analog reset:

[    2.059037] ag71xx-mdio.1: Found an AR934X built-in switch

And br-lan is initialized and networking is working fine.

A reset is performed by the function ath79_register_eth (defined in dev-eth.c):

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH);

However, no analog reset is performed, for example:

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH);

ath79_device_reset_set(AR934X_RESET_ETH_SWITCH_ANALOG);
ath79_device_reset_clear(AR934X_RESET_ETH_SWITCH_ANALOG);

Omitting the analog reset does not break the DB120 builds because the analog reset is already performed by ar934x_nfc_hw_reset in dev-nfc.c.

An easy fix is to do a analog reset in the device’s mach file. However, for the sake of consistency and autism, the reset should be performed by ath79_register_eth in dev_eth.c and not by ar934x_nfc_hw_reset in dev_nfc.c. My AR9341 device doesn’t even use a NAND flash.

12.12.2016331Base systemBug ReportVery LowLowmac80211 / warning / ieee80211_ibss_leave / r2449TrunkUnconfirmed Task Description

spotted on TP-Link 4900 v1 with LEDE r2449 (selfcompiled):

[ 2860.974569] ------------[ cut here ]------------
[ 2860.979191] WARNING: at compat-wireless-2016-10-08/net/mac80211/ibss.c:1082
[ 2860.986142] Modules linked in: ath9k ath9k_common iptable_nat ath9k_hw ath snd_usb_audio nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda snd_usbmidi_lib nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack macvlan iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables compat em_nbyte sch_dsmark sch_pie sch_codel sch_gred sch_htb em_cmp cls_basic act_ipt sch_red sch_prio em_meta act_police em_text sch_tbf sch_sfq sch_fq act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ipip tunnel4 ip_tunnel tun snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore nls_utf8 zram lz4_decompress lz4_compress lzo_compress lzo_decompress zsmalloc usb_storage gpio_keys leds_gpio ehci_fsl ehci_platform ehci_hcd scsi_mod fsl_mph_dr_of mbcache button_hotplug input_core usbcore nls_base usb_common crc16 crc32c_generic crypto_hash [last unloaded: sd_mod]
[ 2861.124825] CPU: 0 PID: 8624 Comm: kworker/u2:0 Not tainted 4.4.36 #0
[ 2861.131337] Workqueue: phy1 ieee80211_ibss_leave [mac80211]
[ 2861.136903] task: c783b840 ti: c68a4000 task.ti: c68a4000
[ 2861.142292] NIP: c99ab128 LR: c99ab354 CTR: 00000000
[ 2861.147247] REGS: c68a5b10 TRAP: 0700   Not tainted  (4.4.36)
[ 2861.152982] MSR: 00029000 <CE,EE,ME>  CR: 28072422  XER: 20000000
[ 2861.159082]
[ 2861.159082] GPR00: c99ab004 c68a5bc0 c783b840 00000000 c68a5bf4 00000000 00000001 00000000
[ 2861.159082] GPR08: c724b114 00000001 c99f97f6 00000000 000000ff 00000000 c003c474 c790bfe0
[ 2861.159082] GPR16: c6f0f070 00000fff 00000fff c70b2138 c6ae5800 c6e30b40 00000000 00000087
[ 2861.159082] GPR24: 00000000 c68a5c68 c724b114 00000000 c6e30b40 c6e7a3d8 c6f25420 c6f0f070
[ 2861.188805] NIP [c99ab128] ieee80211_get_vht_mask_from_cap+0x1964/0x1c64 [mac80211]
[ 2861.196468] LR [c99ab354] ieee80211_get_vht_mask_from_cap+0x1b90/0x1c64 [mac80211]
[ 2861.204025] Call Trace:
[ 2861.206481] [c68a5bc0] [c99ab004] ieee80211_get_vht_mask_from_cap+0x1840/0x1c64 [mac80211] (unreliable)
[ 2861.215884] [c68a5c60] [c99ab414] ieee80211_get_vht_mask_from_cap+0x1c50/0x1c64 [mac80211]
[ 2861.224156] [c68a5d30] [c99ab9d0] ieee80211_ibss_rx_queued_mgmt+0x264/0x370 [mac80211]
[ 2861.232081] [c68a5e20] [c99acc44] ieee80211_ibss_leave+0x768/0x1770 [mac80211]
[ 2861.239307] [c68a5e80] [c00379f8] process_one_work+0x208/0x380
[ 2861.245135] [c68a5ea0] [c0037de0] worker_thread+0x270/0x48c
[ 2861.250704] [c68a5ef0] [c003c53c] kthread+0xc8/0xcc
[ 2861.255580] [c68a5f40] [c000cb3c] ret_from_kernel_thread+0x5c/0x64
[ 2861.261752] --- interrupt: 0 at   (null)
[ 2861.261752]     LR =   (null)
[ 2861.268618] Instruction dump:
[ 2861.271578] 38810034 387e0510 7f984800 419e024c 4bf410ed 2f830000 40be0030 3d40c9a0
[ 2861.279336] 394a97f6 3b600001 892a0003 69290001 <0f090000> 2f890000 41be01d0 39200001
[ 2861.287267] ---[ end trace a37b58c3292c2cbf ]---

13.01.2017385Base systemBug ReportVery LowLowrampis / JFFS2-problem / Xiaomi Miwifi mini / r2919 / w...TrunkUnconfirmed Task Description

after flashing r2919 i can see strange message with dmesg:

root@lede:~  dmesg | grep -i jffs
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.638380] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    9.908794] jffs2: Node at 0x00000044 with length 0x00001044 would run over the end of the erase block
[    9.918337] jffs2: Perhaps the file system was created with the wrong erase size?
[    9.926009] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000048: 0x1044 instead
[    9.935697] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000004c: 0x586d instead
[    9.945403] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000050: 0x0002 instead
[    9.955094] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000054: 0x0002 instead
[    9.964797] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000058: 0x81a4 instead
[    9.974488] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000060: 0xd8a2 instead
[    9.984190] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000064: 0x9ad1 instead
[    9.993881] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000068: 0x9ad2 instead
[   10.003587] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000006c: 0x9ad2 instead
[   10.013278] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000074: 0x1000 instead
[   10.022959] jffs2: Further such events for this erase block will not be printed
[   11.479386] jffs2: notice: (377) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   11.496420] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   11.525523] jffs2: Node at 0x00000044 with length 0x00001044 would run over the end of the erase block
[   11.535100] jffs2: Perhaps the file system was created with the wrong erase size?
[   11.542896] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000048: 0x1044 instead
[   11.552600] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000004c: 0x586d instead
[   11.562304] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000050: 0x0002 instead
[   11.571994] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000054: 0x0002 instead
[   11.581696] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000058: 0x81a4 instead
[   11.591387] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000060: 0xd8a2 instead
[   11.601089] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000064: 0x9ad1 instead
[   11.610780] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000068: 0x9ad2 instead
[   11.620481] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000006c: 0x9ad2 instead
[   11.630173] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000074: 0x1000 instead
[   11.639854] jffs2: Further such events for this erase block will not be printed
[   13.095966] jffs2: notice: (374) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   14.064922] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   14.086950] mount_root: switching to jffs2 overlay
root@lede:~  

beside that, it seems that the device is working:

root@lede:~  df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.5M      3.5M         0 100% /rom
tmpfs                    61.5M      1.1M     60.4M   2% /tmp
/dev/mtdblock6           10.8M    796.0K     10.0M   7% /overlay
overlayfs:/overlay       10.8M    796.0K     10.0M   7% /
tmpfs                   512.0K         0    512.0K   0% /dev
tmpfs                     2.0M         0      2.0M   0% /coredumps
13.01.2017386Base systemBug ReportVery LowLowConfig option "list channels" doesn't workTrunkUnconfirmed Task Description

Hi,

the option “list channels” is not working.

Patch which implements the function: https://patchwork.ozlabs.org/patch/536533/

LEDE version: SNAPSHOT r2790-08d73bf

Device: Archer C5

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option country 'DE'
	option htmode 'VHT80'
	option txpower '12'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'yyy'
	option encryption 'psk2+ccmp'
	option key 'xxx'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option channel 'auto'
	option country 'DE'
	option txpower '20'
	option htmode 'HT40'
	list channels 13
        list channels 12

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'xxx'
	option ssid 'yyy'


Ends with a 2.4GHz wlan which is not
visible and iwinfo shows the following information:

Mode: Master Channel: unknown (2.407 GHz)

root@lede:~# iwinfo wlan1 freqlist
  2.412 GHz (Channel 1)
  2.417 GHz (Channel 2)
  2.422 GHz (Channel 3)
  2.427 GHz (Channel 4)
  2.432 GHz (Channel 5)
  2.437 GHz (Channel 6)
  2.442 GHz (Channel 7)
  2.447 GHz (Channel 8)
  2.452 GHz (Channel 9)
  2.457 GHz (Channel 10)
  2.462 GHz (Channel 11)
  2.467 GHz (Channel 12)
  2.472 GHz (Channel 13)

A part of the syslog with a bunch of error messages is attached.

Fell free to ask, if something is missing.

15.01.2017389Base systemBug ReportVery LowLowodhcpd relay mode is blocked by firewall by defaultTrunkUnconfirmed Task Description

odhcpd currently won’t work when put in relay mode if followed the manual naively. Turns out this is because firewall blocks incoming traffic to DHCPv6 server (port 547) from external DHCPv6 servers (port 547) from WAN zone by default. It may be a good idea to allow this out of the box, though I’m unsure if there are any security complications from this – I’m a newcomer to IPv6. Replies come with the source global IPv6 address of DHCPv6 server to the global IPv6 address of the router, so it’s difficult to make a more constrained rule without hardcoding them or at least the prefix.

Example rule which fixes relay mode:

config rule
	option enabled '1'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option dest_port '547'
	option name 'Allow DHCPv6 Relay'
	option family 'ipv6'
	option src_port '547'

LEDE revision: 3e7b894ac08b56343e6e449a38fdb2be7b02a127

17.01.2017394Base systemBug ReportVery LowLowPPPoE/802.1Q issues on Linksys WRT1900ACSTrunkUnconfirmed Task Description

Device: Linksys WRT1900ACS
LEDE commit: b9a408c2b49ccfa0e906bda00ef77f4002e401fd

diffconfig:
CONFIG_TARGET_mvebu=y
CONFIG_TARGET_mvebu_DEVICE_linksys-wrt1900acs=y
CONFIG_TARGET_BOARD=”mvebu” CONFIG_LIBSODIUM_MINIMAL=y
CONFIG_PACKAGE_dnscrypt-proxy=y
CONFIG_PACKAGE_dnscrypt-proxy-resolvers=y
CONFIG_PACKAGE_libsodium=y

I have an ISP that requires PPPoE on vlan 201 with 802.1Q tags (CenturyLink fiber). On OpenWRT 15.05.1 and on earlier versions of LEDE (not sure about an exact revision, but maybe October/November timeframe) I could simply define my wan interface in /etc/config/network like this and it just worked:

```
config interface ‘wan’

  option ifname 'eth0.201'
  option proto 'pppoe'
  option username 'user@provider'
  option password 'password'

```

I can’t find any way to make this work on recent versions of LEDE. I’ve tried new builds at least every few weeks, but none have worked for the past few months. I’ve tried configuring the switch_vlan section by adding a ‘t’ after the appropriate switch port to enable tagging, I’ve tried defining a new interface and then using that as the wan ifname, and I’ve tried the command line `ip link` and `ppp` invocations that work on every other linux system I’ve tried, but I can’t find anything that works on recent versions of LEDE.

On other linux systems I can do roughly the following and it works:

```
ip link add link eth0 name eth0.201 type vlan id 201
ip link set eth0.201 up
pppd call centurylink
```

where /etc/ppp/peers/centurylink and /etc/ppp/chap-secrets looks like this:
```
> cat /etc/ppp/peers/centurylink
plugin rp-pppoe.so

eth0.201
name “user@provider” usepeerdns
persist
defaultroute
hide-password
noauth

cat /etc/ppp/chap-secrets
#USERNAME PROVIDER PASSWORD IPADDRESS
user@provider * password
```

I’ve tried using tcpdump to capture what’s happening and on other systems (Ubuntu 16.10, Debian Jessie, pfsense) I see an 802.1Q tag, but I don’t see that on LEDE. That might be expected though because it seems totally possible that the switch itself is doing the 802.1Q stuff and tcpdump doesn’t see the actual packets sent over the wire. I have no idea if that’s the case, though. I guess I could also try this on OpenWRT as well, but I haven’t taken the time to do that yet.

The only other difference I’ve seen is that by default LEDE doesn’t send a Host-Uniq tag, but even if I set the host_uniq uci config it doesn’t fix things. Regardless of what I do I see logs that look like this:

```
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is now down
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is disabled
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ has link connectivity loss
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.581135] mvneta f1034000.ethernet eth0: configuring for fixed link mode
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.588150] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.594095] mvneta f1034000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is enabled
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Network device ‘eth0’ link is up
Tue Jan 17 01:55:26 2017 daemon.notice netifd: VLAN ‘eth0.201’ link is up
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ has link connectivity
Tue Jan 17 01:55:26 2017 daemon.notice netifd: Interface ‘wan’ is setting up now
Tue Jan 17 01:55:26 2017 kern.info kernel: [23415.602431] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Tue Jan 17 01:55:26 2017 daemon.info pppd[2263]: Plugin rp-pppoe.so loaded.
Tue Jan 17 01:55:26 2017 daemon.info pppd[2263]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Jan 17 01:55:26 2017 daemon.notice pppd[2263]: pppd 2.4.7 started by root, uid 0
...
Tue Jan 17 01:55:41 2017 daemon.warn pppd[2263]: Timeout waiting for PADO packets
Tue Jan 17 01:55:41 2017 daemon.err pppd[2263]: Unable to complete PPPoE Discovery
Tue Jan 17 01:55:41 2017 daemon.info pppd[2263]: Exit.
```

A sample /etc/config/network looks like this:
```
config interface ‘loopback’

      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

config globals ‘globals’

      option ula_prefix 'fd25:2a59:2a7b::/48'

config interface ‘lan’

      option type 'bridge'
      option ifname 'eth1'
      option proto 'static'
      option ipaddr '192.168.2.1'
      option netmask '255.255.255.0'
      option ip6assign '60'

config interface ‘wan’

  option ifname 'eth0.201'
  option proto 'pppoe'
  option username 'user@provider'
  option password 'password'

config switch

      option name 'switch0'
      option reset '1'
      option enable_vlan '1'

config switch_vlan

      option device 'switch0'
      option vlan '1'
      option ports '0 1 2 3 6'

config switch_vlan

      option device 'switch0'
      option vlan '2'
      option ports '4 5'

config interface ‘guest’

      option _orig_ifname 'wlan1'
      option _orig_bridge 'false'
      option proto 'static'
      option ipaddr '192.168.3.1'
      option netmask '255.255.255.0'

```

Interestingly, OpenWRT has exactly the same version of ppp and rp-pppoe (2.4.7 and 3.8p, respectively) so it seems like there’s something else in play and my guess is it’s related to vlan tagging, but I don’t seem to have the same issue as FS#227 which mentions both PPPoE and vlan config, but it is quite difficult to follow the discussion there so maybe I’m missing something.

17.01.2017395Base systemBug ReportMediumLowmac80211.sh: detect_mac80211 should check available cha...TrunkNew Task Description

This problem was reported by few Netgear R8000 users and I managed to reproduce it. It’s related to the following code:

		vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
		cap_5ghz=$(iw phy "$dev" info | grep -c "Band 2")
		[ "$vht_cap" -gt 0 -a "$cap_5ghz" -gt 0 ] && {
			mode_band="a";
			channel="36"
			htmode="VHT80"
		}

Default htmode

The first problem is that even if hardware supports VHT80 it may be not available for every/any current channel. If channel 36 doesn’t support VHT80, for better user experience, it shouldn’t be set in /etc/config/wireless by default. Example:

root@lede:/# iw phy phy2 info
Wiphy phy2
        max # scan SSIDs: 10
        max scan IEs length: 2048 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports roaming.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 2:
                Capabilities: 0x1062
                        HT20/HT40
                        Static SM Power Save
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT TX/RX MCS rate indexes supported: 0-23
                VHT Capabilities (0x0c025820):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        short GI (80 MHz)
                        SU Beamformer
                        SU Beamformee
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5170 MHz [34] (disabled)
                        * 5180 MHz [36] (20.0 dBm)
                        * 5190 MHz [38] (disabled)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5210 MHz [42] (disabled)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5230 MHz [46] (disabled)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
                        * 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
                        * 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
                        * 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
                        * 5500 MHz [100] (20.0 dBm) (no IR, radar detection)
                        * 5520 MHz [104] (20.0 dBm) (no IR, radar detection)
                        * 5540 MHz [108] (20.0 dBm) (no IR, radar detection)
                        * 5560 MHz [112] (20.0 dBm) (no IR, radar detection)
                        * 5580 MHz [116] (20.0 dBm) (no IR, radar detection)
                        * 5600 MHz [120] (20.0 dBm) (no IR, radar detection)
                        * 5620 MHz [124] (20.0 dBm) (no IR, radar detection)
                        * 5640 MHz [128] (20.0 dBm) (no IR, radar detection)
                        * 5660 MHz [132] (20.0 dBm) (no IR, radar detection)
                        * 5680 MHz [136] (20.0 dBm) (no IR, radar detection)
                        * 5700 MHz [140] (20.0 dBm) (no IR, radar detection)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (disabled)
                        * 5765 MHz [153] (disabled)
                        * 5785 MHz [157] (disabled)
                        * 5805 MHz [161] (disabled)
                        * 5825 MHz [165] (disabled)
        valid interface combinations:
                 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 3, #channels <= 1
                 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
                   total <= 4, #channels <= 1
                 * #{ AP } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
root@lede:/# iw phy phy2 channels
Band 2:
        * 5170 MHz [34] (disabled)
        * 5180 MHz [36] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 5190 MHz [38] (disabled)
        * 5200 MHz [40] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 5210 MHz [42] (disabled)
        * 5220 MHz [44] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+
        * 5230 MHz [46] (disabled)
        * 5240 MHz [48] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40-
        * 5260 MHz [52] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5280 MHz [56] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5300 MHz [60] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5320 MHz [64] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5500 MHz [100] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5520 MHz [104] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5540 MHz [108] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5560 MHz [112] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5580 MHz [116] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5600 MHz [120] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5620 MHz [124] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5640 MHz [128] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5660 MHz [132] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40+
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5680 MHz [136] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz HT40-
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5700 MHz [140] 
          Maximum TX power: 20.0 dBm
          No IR
          Radar detection
          Channel widths: 20MHz
          DFS state: usable (for 163 sec)
          DFS CAC time: 0 ms
        * 5720 MHz [144] (disabled)
        * 5745 MHz [149] (disabled)
        * 5765 MHz [153] (disabled)
        * 5785 MHz [157] (disabled)
        * 5805 MHz [161] (disabled)
        * 5825 MHz [165] (disabled)

as you can see, VHT80 isn’t support on any currently available channel due to regulatory limits.

Default channel

Picking channel 36 blindly is a bad idea as it may not be available. In case of phy0/radio0 on Netgear R8000 only available channels are 149+ due to hardware/board design (see ARM: BCM5301X: Set 5 GHz wireless frequency limits on Netgear R8000).

root@lede:/# iw phy phy0 info
Wiphy phy0
        max # scan SSIDs: 10
        max scan IEs length: 2048 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports roaming.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 2:
                Capabilities: 0x1062
                        HT20/HT40
                        Static SM Power Save
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT TX/RX MCS rate indexes supported: 0-23
                VHT Capabilities (0x0c025820):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        short GI (80 MHz)
                        SU Beamformer
                        SU Beamformee
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5170 MHz [34] (disabled)
                        * 5180 MHz [36] (disabled)
                        * 5190 MHz [38] (disabled)
                        * 5200 MHz [40] (disabled)
                        * 5210 MHz [42] (disabled)
                        * 5220 MHz [44] (disabled)
                        * 5230 MHz [46] (disabled)
                        * 5240 MHz [48] (disabled)
                        * 5260 MHz [52] (disabled)
                        * 5280 MHz [56] (disabled)
                        * 5300 MHz [60] (disabled)
                        * 5320 MHz [64] (disabled)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (20.0 dBm)
                        * 5765 MHz [153] (20.0 dBm)
                        * 5785 MHz [157] (20.0 dBm)
                        * 5805 MHz [161] (20.0 dBm)
                        * 5825 MHz [165] (20.0 dBm)
        valid interface combinations:
                 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 3, #channels <= 1
                 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
                   total <= 4, #channels <= 1
                 * #{ AP } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
root@lede:/# iw phy phy0 channels
Band 2:
        * 5170 MHz [34] (disabled)
        * 5180 MHz [36] (disabled)
        * 5190 MHz [38] (disabled)
        * 5200 MHz [40] (disabled)
        * 5210 MHz [42] (disabled)
        * 5220 MHz [44] (disabled)
        * 5230 MHz [46] (disabled)
        * 5240 MHz [48] (disabled)
        * 5260 MHz [52] (disabled)
        * 5280 MHz [56] (disabled)
        * 5300 MHz [60] (disabled)
        * 5320 MHz [64] (disabled)
        * 5500 MHz [100] (disabled)
        * 5520 MHz [104] (disabled)
        * 5540 MHz [108] (disabled)
        * 5560 MHz [112] (disabled)
        * 5580 MHz [116] (disabled)
        * 5600 MHz [120] (disabled)
        * 5620 MHz [124] (disabled)
        * 5640 MHz [128] (disabled)
        * 5660 MHz [132] (disabled)
        * 5680 MHz [136] (disabled)
        * 5700 MHz [140] (disabled)
        * 5720 MHz [144] (disabled)
        * 5745 MHz [149] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+ VHT80
        * 5765 MHz [153] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- VHT80
        * 5785 MHz [157] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40+ VHT80
        * 5805 MHz [161] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz HT40- VHT80
        * 5825 MHz [165] 
          Maximum TX power: 20.0 dBm
          Channel widths: 20MHz
17.01.2017398PackagesFeature RequestVery LowLowodhcpd: add UCI option to insert DHCP fill for missing ...TrunkUnconfirmed Task Description

This is a request for a common DHCP function found in other software. It would be nice for an odhcpd general option to enable it to fill in unnamed leases. DHCPv4 use the MAC as in unknown-010203040506 and DHCPv6 use the last 64 bits of the DUID as in unknown-0102030405060708. This can be used to figure out which device has failed to send its host name. This is a common problem with DHCPv6. This is a common problem for smart TV or cameras. Consider logs from a device other than the DHCP serving router. Consider where IT may not want to static assign 100’s of host names for display devices over a large work site or campus. Security logs and DHCP logs on a distributed network can then be reconciled a-synchronously, off line, or only when an investigation is required.

18.01.2017400PackagesBug ReportVery LowLowodhcpd: lease file persistence per RFC2131 S-2.1 and S-...TrunkUnconfirmed Task Description

RFC2131 DHCPv4 expects that the DHCP leases and other configuration results are in persistent storage. For small embedded routers during a machine reboot, it has been accepted that read-write memory is RAM (not flash) and persistence may not be entirely upheld. That being said, odhcpd has no means to maintain the lease information even through an application only restart (example ifup event). The lease file odhcpd writes is not used to seed odhcpd, if it is restarted. (1) an interface reconnect that causes odhcpd to restart destroys the lease record, even if the network resumes as previously configured. (2) even if odhcpd lease file is directed to persistent storage (USB drive) it is not used to resume leases.

18.01.2017401PackagesFeature RequestVery LowLowodhcpd: lease trigger script receives no argumentsTrunkUnconfirmed Task Description

when odhcpd calls the “lease trigger” script it does not pass any arguments to the script. The reason for the trigger and the host involved in the trigger are not shared. There is no discretion for RENEW, REBIND, CONFIRM, or RELEASE. Scripts which wish to load DNS with limited data, need to store their own copy of DHCP lease file and do differences. Otherwise a raw translate and dump of a large DHCP network could cause a lot of congestion as DHCP clients come on line. Reseting a network can cause an “in rush” flow like air conditioning loads on a power grid during a summer power outage.
This is exacerbated if the DNS is served on a separate device over the network, such as nsd and nsd-control (bind or unbound also). It would be good to at least pass the command and parameters common to a odhcpd lease file line.

18.01.2017403PackagesFeature RequestVery LowLowodhcpd: expand the capability of DHCPv6 HOSTID assignem...TrunkUnconfirmed Task Description

It would be nice to assign the HOSTID range or bit width as an option. odhcpd just assigns ::0100~::0FFF without any options. It would be nice to be able to use all 64 bits. With this, also it would be nice to add a random seed and seed time as options. This way the DUID hash-to-HOSTID could be rotated. In this way, SLAAC privacy addresses could be replicated with STATEFUL DHCP control and well known hostnames. This would support high-accountability networks like Universities and other large organizations.

It would be a counter to Google’s lack of “interest” in supporting DHCPv6. This would provide DHCPv6 privacy addresses.
Android Bug: https://code.google.com/p/android/issues/detail?id=32621

18.01.2017406Base systemFeature RequestVery LowLowodhcpd: enable IPv6 unicast relayTrunkUnconfirmed Task Description

We want to use Prefix Delegation in a large layer3 mesh network. Currently odhcpd only supports DHCPv6-Relay by forwarding the incoming request to the master interface with multicast all-routers-destination address.

In a mesh network we do not have master/uplink interfaces. But we have the IP of the DHCP server which is X hops away and the routing protocol knows which way to send the packet.

Is it possible to add dhcp relay via unicast? An additional config parameter for the IP of the DHCP server is then also needed.

18.01.2017408Base systemBug ReportVery LowLowArcher C7 has incorrect default bssid addresses for wif...TrunkUnconfirmed Task Description

Using LEDE Reboot SNAPSHOT r3022-7fb11c8.

This is at least for Archer C7 v2. The default bssids for the networks in my particular device are:

:::::*D for the 2,4 GHz radio and
:::::*C for the 5 GHz radio

In LEDE they result in

:::::*C for the 2,4 GHz radio and
:::::*B for the 5 GHz radio

The problem in LEDE is that the bssid set up for the 2,4 GHz is the one for 5 GHz and then the 5 GHz gets minus one. Don’t know if it could be because the ethernet lan gets also :::::*D and wlan1 can’t have the same mac address as eth1. In the original firmware this seems to be possible, both ethernet lan and 2,4 GHz radio have the same mac/bssid. Also, at least with the 2,4 GHz radio, when you set up another connection with the device as client, the bssid of the master one change *(+2)::::**:*C the second hex digit gets plus 2, the bssid that should get a second connection as ap, but in this case there is one ap one client connections. This one could be right and I have to test with another router to see if it happens because I didn’t notice this before.

19.01.2017409Base systemBug ReportVery LowLowArcher C7 all leds are greenTrunkUnconfirmed Task Description

In Archer C7 all leds are green but in lede only the usb leds are labeled as green, all the rest ones are labeled as blue.

28.01.2017441Base systemBug ReportVery LowLowKernel crash: eth0 (ag71xx): transmit queue 0 timed outTrunkUnconfirmed Task Description

Device: TL-WR1043ND v1
LEDE: snapshot r3189-12db207

During a simultaneous bidirectional iperf load test, after about 20 minutes, the kernel crashes. I reproduced this several times:

Server 1 ←–> 1043ND ←–> Laptop via wireless N

LEDE is using a default setup. Only changes:
* Setting wireless encryption to psk with password
* Setting a DNAT rule for server 1 to be able reach the iperf server on the Laptop

This bug was actually discovered while testing fixes for  FS#13  - Ath9k AP stays up for connected clients but doesn’t show in scan on new ones

Serial console ouput:

[ 1294.022551] ------------[ cut here ]------------
[ 1294.027247] WARNING: CPU: 0 PID: 0 at net/sched/sch_generic.c:306 dev_watchdog+0x1dc/0x260()
[ 1294.035754] NETDEV WATCHDOG: eth0 (ag71xx): transmit queue 0 timed out
[ 1294.042319] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath pppox ppp_generic nf_conntrack_ipv6 mac80211 iptable_nn
[ 1294.106287] CPU: 0 PID: 0 Comm: swapper Not tainted 4.4.45 #0
[ 1294.112066] Stack : 803e4844 00000000 00000001 80440000 8042f1dc 8042ee63 803c5e64 00000000
          804a378c 8042d4fc 00000200 00100000 0000000a 800a7618 803cb554 80430000
          00000003 8042d4fc 803c9960 81809e34 0000000a 800a5594 00000006 00000000
          00000000 801f5400 00000000 00000000 00000000 00000000 00000000 00000000
          00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
          ...
[ 1294.148122] Call Trace:
[ 1294.150617] [<800a7618>] vprintk_default+0x24/0x30
[ 1294.155474] [<800a5594>] printk+0x2c/0x38
[ 1294.159515] [<801f5400>] wait_for_xmitr+0x84/0xcc
[ 1294.164289] [<80081c3c>] warn_slowpath_common+0xa0/0xd0
[ 1294.169564] [<801a72dc>] dump_stack+0x14/0x28
[ 1294.173975] [<80071eb0>] show_stack+0x50/0x84
[ 1294.178376] [<80081c3c>] warn_slowpath_common+0xa0/0xd0
[ 1294.183661] [<8028ef3c>] dev_watchdog+0x1dc/0x260
[ 1294.188408] [<80081c98>] warn_slowpath_fmt+0x2c/0x38
[ 1294.193450] [<8028ef3c>] dev_watchdog+0x1dc/0x260
[ 1294.198191] [<8028ed60>] dev_watchdog+0x0/0x260
[ 1294.202782] [<800b08d0>] call_timer_fn.isra.5+0x24/0x80
[ 1294.208051] [<800b0b54>] run_timer_softirq+0x1b4/0x1fc
[ 1294.213248] [<800a89f0>] handle_irq_event_percpu+0x154/0x188
[ 1294.218960] [<800841b8>] __do_softirq+0x250/0x298
[ 1294.223721] [<800abdac>] handle_percpu_irq+0x50/0x80
[ 1294.228746] [<8006a9e0>] plat_irq_dispatch+0xd4/0x10c
[ 1294.233848] [<80060bf4>] handle_int+0x134/0x140
[ 1294.238400] 
[ 1294.239904] ---[ end trace 17bad011a41ccba7 ]---
[ 1294.244567] eth0: tx timeout
[ 1299.022570] eth0: tx timeout
[ 1304.022581] eth0: tx timeout
[ 1309.022588] eth0: tx timeout

The eth0: tx timeout line is repeated every 5 seconds.


31.01.2017446Base systemBug ReportVery LowLowusbport trigger: The default configuration for all fami...TrunkUnconfirmed Task Description

Recently LuCI has get ability to configure LED’s with the usbport trigger https://github.com/openwrt/luci/issues/971. There are issues when reading the old usbdev trigger. There is no need to stay with usbdev at all so if it’s possible it should be converted to use usbport.

01.02.2017449Base systemBug ReportVery LowLowrelayd can cause dropped packets if client has /proc/sy...TrunkUnconfirmed Task Description

DEVICE: N/A (can be reproduced on any system running relayd)
LEDE version: N/A (can be reproduced on a VM running debian with relayd installed)

Steps to reproduce:

* Run relayd on a system (aka router)with two interfaces.
* Run a stock Ubuntu-16.04 system (aka client) connected to the managed interface.
* Run another system (aka server) on the other interface of relayd system.
* Have server ping client and watch connectivity drop out periodically.
* Have client ping server and watch connectivity drop out periodically.

Our fix for the problem need two changes:

* Add arptables rules to system to handle kernel level arp requests properly via mangling the source address in the arp requests
* Modify relayd to send the correct src addr in the arp requests that it generates.

Our changes to relayd are here:

* https://github.com/troth/relayd/commit/c8d895ee71be59262f01c3fdf50f307ebf1593e7

From commit message for my fix:

    Add option to set arp src addr for managed interfaces.
    
    Relayd will send arp requests out a managed interface like this:
    
        Who has 192.168.1.40, tell 192.168.2.1
    
    In most cases, this works, but some clients will not send a reply (on
    linux, client will not reply if /proc/sys/net/ipv4/conf/*/rp_filter is
    set to 1, which happens to be the default on ubuntu-16.04).
    
    Add '-s' option to tell relayd to use the specified addr as the arp src
    addr for managed interfaces. The arp requests would then look like:
    
        Who has 192.168.1.40, tell 192.168.1.100
    
    for which the client properly sends a reply.
    
    The symptoms of the problem manifest as dropped packets due to the
    kernel marking the arp entry for the client as FAILED due to lack of
    responses to the arp requests. Eventually (10-30 seconds later), the arp
    table is updated and connectivity is restored.
04.02.2017463Base systemBug ReportVery LowLowup/down on a usbnet interfaces fails to reassign ULA ad...TrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on: anything running usbnet
- Software versions of LEDE release, packages, etc: head
- Steps to reproduce:

Install the usbnet package, enable a usb0 device in /etc/config/network

(in my case this is a c.h.i.p, but most hackerboards except the pi do usbnet)

config interface ‘usb0’

      option ifname 'usb0'            
      option proto 'static'                 
      option ipaddr '172.26.97.200'
      option netmask '255.255.255.255'
      option ip6assign '64'           
      option ip6class 'local' 

So long as the chip beats the router to booting, this gives it an ipv4 and ipv6 ULA out of the pool.

Reboot the device on the other side. The kernel deregisters and registers the usbnet driver, and netifd assigns the ipv4 address again.

However the ip6 subnet that was assigned from the ula does not come back. Haven’t tried it with a public address.

ifup/ifdown does not work and the ifstatus usb0 does not show any ipv6 addresses assigned.

05.02.2017468Base systemBug ReportVery LowLowFirstboot does not work on ZyXEL P-2812HNU-F1 (17.01.0-...lede-17.01Unconfirmed Task Description

After installing lede-17.01.0-rc1-r3042-ec095b5-lantiq-xrx200-P2812HNUF1-squashfs-sysupgrade.bin on top of Chaos-Calmer on my P-2812HNU-F1, it kept it’s old config, although I didn’t specify that

sysupgrade /tmp/lede.bin

After activating fail-safe I tried to use firstboot to drop the config, but it failed:

root@(none):~# firstboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/ubi0_1 is not mounted
/dev/ubi0_1 will be erased on next mount
writing /dev/ubi0_1 failed: Operation not permitted

After rebooting it had kept it’s config.

Worked around it with

root@(none):~# mount_root 
switching to ubifs overlay
root@(none):/rom/root# firstboot 
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/ubi0_1 is mounted as /overlay, only erasing files
05.02.2017469Base systemBug ReportVery LowLowWifi firmware file is not available on ZyXEL P-2812HNU-...lede-17.01Unconfirmed Task Description

Kernel log:

[   11.336056] PCI: Enabling device 0000:00:0e.0 (0000 -> 0002)
[   11.340485] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'RT3062.eeprom'.
[   11.350276] rt2800pci 0000:00:0e.0: Direct firmware load for RT3062.eeprom failed with error -2
[   11.358782] rt2800pci 0000:00:0e.0: Falling back to user helper
[   11.479331] firmware RT3062.eeprom: firmware_loading_store: map pages failed
[   11.485217] ieee80211 phy0: rt2x00lib_request_eeprom_file: Error - Failed to request EEPROM.
[   11.493519] rt2800pci: probe of 0000:00:0e.0 failed with error -11

Firmware files:

root@lede:/lib/firmware# ls /lib/firmware/
lantiq-vrx200-a-to-b.bspatch                 rt2860.bin                                   xcpe_581816_580B11.LICENSE                   xcpe_581816_580B11_to_579906_574402.bspatch
lantiq-vrx200-a.bin                          rt3290.bin                                   xcpe_581816_580B11.bin

After adding a RT3062.eeprom the wifi port is available.

 


07.02.2017479Base systemBug ReportVery LowLowSoftethervpn results in ReAlloc error after vpnbridge i...TrunkUnconfirmed Task Description

On a mostly vanilla Atmel at91sam9g20-ek with 32MB of RAM, we are seeing a couple of errors using the current package software version + patches.

Overall, it may be the cross compilation process, overlay or something else entirely.

1. If the vpnbridge is already started, a NAND-WAIT stacktrace results if the binary is executed to instantiate a second instance.

root@lede:/usr/libexec/softethervpn# /usr/bin/env LANG=en_US.UTF-8 vpncmd
[  241.880000] 
[  241.880000] =================================
[  241.880000] [ INFO: inconsistent lock state ]
[  241.880000] 4.4.36 #0 Not tainted
[  241.880000] ---------------------------------
[  241.880000] inconsistent {RECLAIM_FS-ON-W} -> {IN-RECLAIM_FS-W} usage.
[  241.880000] kswapd0/155 [HC0[0]:SC0[0]:HE1:SE1] takes:
[  241.880000]  (&f->sem){+.+.?.}, at: [<c012949c>] jffs2_do_clear_inode+0x28/0x114
[  241.880000] {RECLAIM_FS-ON-W} state was registered at:
[  241.880000]   [<c005047c>] lockdep_trace_alloc+0xf8/0x118
[  241.880000]   [<c00b5610>] kmem_cache_alloc+0x28/0x144
[  241.880000]   [<c01261d8>] jffs2_alloc_inode_cache+0x1c/0x28
[  241.880000]   [<c01293a4>] jffs2_do_read_inode+0x13c/0x20c
[  241.880000]   [<c012fe58>] jffs2_iget+0x74/0x324
[  241.880000]   [<c0130830>] jffs2_do_fill_super+0x190/0x274
[  241.880000]   [<c0130e98>] jffs2_fill_super+0xf4/0x144
[  241.880000]   [<c01d1528>] mount_mtd_aux+0x80/0x10c
[  241.880000]   [<c01d1630>] mount_mtd_nr+0x7c/0x94
[  241.880000]   [<c01d17f8>] mount_mtd+0x1b0/0x210
[  241.880000]   [<c01309d4>] jffs2_mount+0x1c/0x28
[  241.880000]   [<c00bbbe4>] mount_fs+0x1c/0xac
[  241.880000]   [<c00d6418>] vfs_kern_mount+0x5c/0x12c
[  241.880000]   [<c00d9e68>] do_mount+0xa04/0xbc8
[  241.880000]   [<c00da270>] SyS_mount+0x7c/0xa8
[  241.880000]   [<c0009660>] ret_fast_syscall+0x0/0x1c
[  241.880000] irq event stamp: 45867
[  241.880000] hardirqs last  enabled at (45867): [<c001508c>] _raw_spin_unlock_irq+0x2c/0x6c
[  241.880000] hardirqs last disabled at (45866): [<c0014e88>] _raw_spin_lock_irq+0x28/0x70
[  241.880000] softirqs last  enabled at (45450): [<c0024088>] __do_softirq+0x208/0x2a4
[  241.880000] softirqs last disabled at (45431): [<c0024488>] irq_exit+0xa4/0xec
[  241.880000] 
[  241.880000] other info that might help us debug this:
[  241.880000]  Possible unsafe locking scenario:
[  241.880000] 
[  241.880000]        CPU0
[  241.880000]        ----
[  241.880000]   lock(&f->sem);
[  241.880000]   <Interrupt>
[  241.880000]     lock(&f->sem);
[  241.880000] 
[  241.880000]  *** DEADLOCK ***
[  241.880000] 
[  241.880000] 2 locks held by kswapd0/155:
[  241.880000]  #0:  (shrinker_rwsem){++++..}, at: [<c0090034>] shrink_slab.part.1.constprop.7+0x30/0x230
[  241.880000]  #1:  (&type->s_umount_key#32){.+.+..}, at: [<c00bb3ec>] trylock_super+0x1c/0x60
[  241.880000] 
[  241.880000] stack backtrace:
[  241.880000] CPU: 0 PID: 155 Comm: kswapd0 Not tainted 4.4.36 #0
[  241.880000] Hardware name: Atmel AT91SAM9
[  241.880000] Backtrace: 
[  241.880000] [<c0019798>] (dump_backtrace) from [<c0019994>] (show_stack+0x18/0x1c)
[  241.880000]  r7:0000000a r6:c38af4c0 r5:c38af0c0 r4:c068f314
[  241.880000] [<c001997c>] (show_stack) from [<c016fdd8>] (dump_stack+0x20/0x28)
[  241.880000] [<c016fdb8>] (dump_stack) from [<c004d144>] (print_usage_bug.part.11+0x228/0x290)
[  241.880000] [<c004cf1c>] (print_usage_bug.part.11) from [<c004d5b0>] (mark_lock+0x404/0x63c)
[  241.880000]  r8:c004c558 r7:c38af0c0 r6:c38af4c0 r5:00000008 r4:0000000a
[  241.880000] [<c004d1ac>] (mark_lock) from [<c004e638>] (__lock_acquire+0x97c/0x198c)
[  241.880000]  r10:c38af0c0 r9:c0667044 r8:c38af4c0 r7:00000001 r6:00000002 r5:c3675704
[  241.880000]  r4:0000025d r3:00000004
[  241.880000] [<c004dcbc>] (__lock_acquire) from [<c004fdcc>] (lock_acquire+0x7c/0x9c)
[  241.880000]  r10:00000042 r9:c334c4c4 r8:c38af0c0 r7:c0ccdd8c r6:00000001 r5:60000013
[  241.880000]  r4:00000000
[  241.880000] [<c004fd50>] (lock_acquire) from [<c0011580>] (mutex_lock_nested+0x50/0x39c)
[  241.880000]  r6:c334d000 r5:c334d000 r4:c36756d0
[  241.880000] [<c0011530>] (mutex_lock_nested) from [<c012949c>] (jffs2_do_clear_inode+0x28/0x114)
[  241.880000]  r10:00000042 r9:c334c4c4 r8:c334c000 r7:00000058 r6:c334d000 r5:c334d000
[  241.880000]  r4:c36756d0
[  241.880000] [<c0129474>] (jffs2_do_clear_inode) from [<c012fde0>] (jffs2_evict_inode+0x34/0x38)
[  241.880000]  r7:00000058 r6:c044ba88 r5:c334d000 r4:c3675730
[  241.880000] [<c012fdac>] (jffs2_evict_inode) from [<c00d1a7c>] (evict+0xac/0x164)
[  241.880000]  r5:c367580c r4:c3675730
[  241.880000] [<c00d19d0>] (evict) from [<c00d1b6c>] (dispose_list+0x38/0x44)
[  241.880000]  r7:00000058 r6:00000063 r5:00000006 r4:c392dd58
[  241.880000] [<c00d1b34>] (dispose_list) from [<c00d2e1c>] (prune_icache_sb+0x4c/0x5c)
[  241.880000]  r5:00000006 r4:c392dd58
[  241.880000] [<c00d2dd0>] (prune_icache_sb) from [<c00bb570>] (super_cache_scan+0x140/0x184)
[  241.880000]  r5:00000000 r4:c392ddd8
[  241.880000] [<c00bb430>] (super_cache_scan) from [<c00901b0>] (shrink_slab.part.1.constprop.7+0x1ac/0x230)
[  241.880000]  r10:00000601 r9:00000000 r8:00000000 r7:00000400 r6:00000062 r5:c334c4c4
[  241.880000]  r4:000000a5
[  241.880000] [<c0090004>] (shrink_slab.part.1.constprop.7) from [<c0092318>] (shrink_zone+0x5f0/0x640)
[  241.880000]  r10:00000004 r9:00000117 r8:c04da918 r7:00000000 r6:00000000 r5:c392ded4
[  241.880000]  r4:c04da6fc
[  241.880000] [<c0091d28>] (shrink_zone) from [<c0092c8c>] (kswapd+0x4ac/0x668)
[  241.880000]  r10:00000000 r9:00000000 r8:00000000 r7:00000000 r6:00000000 r5:c04da6fc
[  241.880000]  r4:c04da6fc
[  241.880000] [<c00927e0>] (kswapd) from [<c003d1b4>] (kthread+0xe4/0xfc)
[  241.880000]  r10:00000000 r9:00000000 r8:00000000 r7:c00927e0 r6:c04da6fc r5:00000000
[  241.880000]  r4:c3950780
[  241.880000] [<c003d0d0>] (kthread) from [<c00096ec>] (ret_from_fork+0x14/0x28)
[  241.880000]  r7:00000000 r6:00000000 r5:c003d0d0 r4:c3950780

2. If the vpnbridge is instantiated only once, and the vpn client is to be executed, a realloc error occurs:

 /usr/bin/env LANG=en_US.UTF-8 ./vpnclient 
Fatal Error: InternalReAlloc: error: realloc() failed.


Aborted

This is on 4.4.36 LEDE trunk with a FS that looks like:

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 7.4M      7.4M         0 100% /rom
tmpfs                    25.3M      2.7M     22.6M  11% /tmp
tmpfs                    25.3M     44.0K     25.2M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock2           50.0M      2.2M     47.8M   4% /overlay
overlayfs:/overlay       50.0M      2.2M     47.8M   4% /

Any assistance would be helpful.


11.02.2017499Base systemBug ReportVery LowLowWiFi client mode leaves router inaccessible if upstream...TrunkUnconfirmed Task Description

This bug was originally reported to the OpenWrt team and there is a discussion of it in their mailing list. Luiz Angelo Daros de Luca suggested reporting here (and switching to LEDE, which I will do).

I have a TP-Link TL-MR3020 v1.9 with Chaos Calmer 15.05.01. I’m using it to provide a WiFi access point to my phone/tablet while I travel, and it’s acting as a WiFi client for the various hostels I visit.

If you configure it as a wifi client with a wwan interface using the LuCI scan/join wizard, and then you configure a wifi access point on the same radio, the router works as expected and when you connect to the router’s AP, you get Internet via the client connection.

However, if you move out of range of the network the router is a client of, or if it goes down, when you power off the OpenWrt router and power back on, the access point won’t come up.

The AP will only come up if the client network you configured is also working; so you have no way to connect to the router over wifi, and no way to reconfigure the router, if that client network is down or out of range.

This is a particular problem for a travel router because it will often move it out of range of the original upstream network, and you may only have a wifi-capable device with which to reconfigure it.

The Ethernet port on the router does remain active, so I can tell it does actually boot. It’s just the radio that doesn’t come up. I managed to get back in range of a network once, and the router worked as expected.

It doesn’t matter whether the AP or client connection are configured first or second on the radio interface, and, unticking “bring up on boot” for the wwan interface has no effect on the behaviour.

Steps to reproduce: Connect the router to a wifi network as a client using the Join wizard. Add a wifi master-mode access point on the same radio interface. Verify you can access the Internet by joining the router’s new master AP. Reboot the router with the original network it was a client of turned off. Notice the router’s AP you configured never comes up.

Expected behaviour: The master access point of the router should always come up, regardless of the availability of the client network.

The OpenWRT team will not fix it, but had some explanation as to why it is happening. IMO, it’s still a very frustrating bug and most users would expect the behaviour I did.

12.02.2017500Base systemBug ReportVery LowLowfirewall3: missing targets with IPv6 NATlede-17.01Unconfirmed Task Description

When the kmod-ipt-nat6 package is installed, running /etc/init.d/firewall reload or /etc/init.d/firewall restart produces warnings that targets are missing:

 * Populating IPv6 nat table
   * Zone 'lan'
Warning: fw3_ipt_rule_append(): Can't find target 'prerouting_lan_rule'
Warning: fw3_ipt_rule_append(): Can't find target 'postrouting_lan_rule'
   * Zone 'wan'
Warning: fw3_ipt_rule_append(): Can't find target 'prerouting_wan_rule'
Warning: fw3_ipt_rule_append(): Can't find target 'postrouting_wan_rule'
Warning: fw3_ipt_rule_append(): Can't find target 'prerouting_rule'
Warning: fw3_ipt_rule_append(): Can't find target 'postrouting_rule'

I tested this on an Archer C7 v2 running LEDE 17.01.0rc2.

13.02.2017505Base systemBug ReportVery LowLowCan't install LEDE on Linksys EA3500AllUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on Linksys EA3500
- Software versions of LEDE release, packages, etc. Base Stable 17.01rc2 and Development build kirkwood/audi
- Steps to reproduce

 

LEDE kirkwood/audi...factory.bin will not flash on the ea3500, it just boots back into stock firmware. I was able to flash OpenWrt from factory and then flash LEDE from OpenWrt, so i tested both 17.01rc2 and development build, rc2 seems fine but there are no radios present in development build.

Showing tasks 1 - 50 of 825 Page 1 of 171 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing