OpenWrt/LEDE Project

Welcome to the OpenWrt Project bug reporting and issue tracking system

Problems to be reported here are for the current OpenWrt and legacy LEDE Project’s targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to openwrt-bugs@infradead.org.

Opened  descIDCategoryTask TypePrioritySeveritySummaryReported InStatus
23.01.20224238Base systemBug ReportVery LowHighTL-WR841N v13 (SoC MT7628AN) wifi disappears after some...openwrt-21.02Unconfirmed Task Description

TP-LINK TL-WR841N v13 (SoC is MediaTek MT7628AN)
with OpenWrt 21.02.1 r16325-88151b8303

Steps:
Connect computer A via Ethernet to the router (TL-WR841N)
Connect computer B via wifi (802.11n, WPA3) to the router
At B side connect to a shared folder in A
At B side copy a very large file (in my case >200GB) from A
wait for a while, and the copy would fail (less than 5% is copied in my case)
check the wifi in B, and found that there is no wifi - even the original SSID is gone, and other computers/devices also could not find that SSID either.

I tested 3 times, and reproduced 3 times.
Pity I didn’t try this out in the original firmware (before I overwrote it with OpenWRT).

This might be the same problem reported in FS#3325.

 


23.01.20224237Base systemBug ReportVery LowLowbeagle bone black boot failedopenwrt-21.02Unconfirmed Task Description

device:beagle bone black
kernel boot failed:

Starting kernel ...

[ 0.000000] Booting Linux on physical CPU 0×0 [ 0.000000] Linux version 5.4.154 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16325-88151b8303)) #0 SMP Sun Oct 24 09:01:35 2021
[ 0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ 0.000000] OF: fdt: Machine model: TI AM335x BeagleBone Black
[ 0.000000] Memory policy: Data cache writeback
[ 0.000000] cma: Reserved 16 MiB at 0x9ec00000
[ 0.000000] CPU: All CPU(s) started in SVC mode.
[ 0.000000] AM335X ES2.1 (sgx neon)
[ 0.000000] percpu: Embedded 15 pages/cpu s31116 r8192 d22132 u61440
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 129412
[ 0.000000] Kernel command line: console=ttyO0,115200n8 root=/dev/mmcblk0p2 rootwait
[ 0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes, linear)
[ 0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[ 0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[ 0.000000] Memory: 488620K/522240K available (8290K kernel code, 333K rwdata, 1528K rodata, 1024K init, 302K bss, 17236K reserved, 16384K cma-reserved, 0K highmem)
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] rcu: Hierarchical RCU implementation.
[ 0.000000] rcu: RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=1.
[ 0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[ 0.000000] rcu: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=1
[ 0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
[ 0.000000] IRQ: Found an INTC at 0x(ptrval) (revision 5.0) with 128 interrupts
[ 0.000000] random: get_random_bytes called from 0xc0b00bbc with crng_init=0
[ 0.000000] OMAP clockevent source: timer2 at 24000000 Hz
[ 0.000016] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 89478484971ns
[ 0.000039] clocksource: timer1: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 79635851949 ns
[ 0.000049] OMAP clocksource: timer1 at 24000000 Hz
[ 0.000550] timer_probe: no matching timers found
[ 0.000681] Console: colour dummy device 80×30 [ 0.000744] Calibrating delay loop... 996.14 BogoMIPS (lpj=4980736)
[ 0.089202] pid_max: default: 32768 minimum: 301
[ 0.089391] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[ 0.089406] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[ 0.090350] CPU: Testing write buffer coherency: ok
[ 0.090424] CPU0: Spectre v2: using BPIALL workaround
[ 0.090832] CPU0: thread -1, cpu 0, socket -1, mpidr 0
[ 0.091525] Setting up static identity map for 0×80100000 - 0×80100060 [ 0.091691] rcu: Hierarchical SRCU implementation.
[ 0.092003] smp: Bringing up secondary CPUs ...
[ 0.092014] smp: Brought up 1 node, 1 CPU
[ 0.092023] SMP: Total of 1 processors activated (996.14 BogoMIPS).
[ 0.092030] CPU: All CPU(s) started in SVC mode.
[ 0.103066] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
[ 0.103293] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.103318] futex hash table entries: 256 (order: 2, 16384 bytes, linear)
[ 0.104436] pinctrl core: initialized pinctrl subsystem
[ 0.105843] NET: Registered protocol family 16
[ 0.107780] DMA: preallocated 256 KiB pool for atomic coherent allocations
[ 0.133304] l3-aon-clkctrl:0000:0: failed to disable
[ 0.135292] cpuidle: using governor ladder
[ 0.135307] cpuidle: using governor menu
[ 0.203217] edma 49000000.edma: TI EDMA DMA engine driver
[ 0.207828] SCSI subsystem initialized
[ 0.221787] usbcore: registered new interface driver usbfs
[ 0.221866] usbcore: registered new interface driver hub
[ 0.221932] usbcore: registered new device driver usb
[ 0.222648] pps_core: LinuxPPS API ver. 1 registered
[ 0.222661] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti giometti@linux.it [ 0.222688] PTP clock support registered
[ 0.222918] Advanced Linux Sound Architecture Driver Initialized.
[ 0.223024] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[ 0.227741] clocksource: Switched to clocksource timer1
[ 0.228025] VFS: Disk quotas dquot_6.6.0
[ 0.228103] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.232596] thermal_sys: Registered thermal governor ‘fair_share’ [ 0.232605] thermal_sys: Registered thermal governor ‘step_wise’ [ 0.232622] thermal_sys: Registered thermal governor ‘user_space’ [ 0.233173] NET: Registered protocol family 2
[ 0.233387] IP idents hash table entries: 8192 (order: 4, 65536 bytes, linear)
[ 0.234015] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[ 0.234047] TCP established hash table entries: 4096 (order: 2, 16384 bytes, linear)
[ 0.234090] TCP bind hash table entries: 4096 (order: 3, 32768 bytes, linear)
[ 0.234149] TCP: Hash tables configured (established 4096 bind 4096)
[ 0.234249] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[ 0.234273] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[ 0.234465] NET: Registered protocol family 1
[ 0.243484] RPC: Registered named UNIX socket transport module.
[ 0.243506] RPC: Registered udp transport module.
[ 0.243512] RPC: Registered tcp transport module.
[ 0.243518] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.245642] workingset: timestamp_bits=14 max_order=17 bucket_order=3
[ 0.256299] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.257846] NFS: Registering the id_resolver key type
[ 0.257899] Key type id_resolver registered
[ 0.257906] Key type id_legacy registered
[ 0.257960] jffs2: version 2.2 (NAND) (SUMMARY) (LZO) (LZMA) (RTIME) (RUBIN) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 0.299463] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 248)
[ 0.303740] OMAP GPIO hardware version 0.1
[ 0.339587] pinctrl-single 44e10800.pinmux: 142 pins, size 568
[ 0.342721] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.345685] omap_uart 44e09000.serial: no wakeirq for uart0
[ 0.345766] 44e09000.serial: ttyO0 at MMIO 0x44e09000 (irq = 29, base_baud = 3000000) is a OMAP UART0
[ 0.964952] printk: console [ttyO0] enabled
[ 0.984598] brd: module loaded
[ 0.991748] loop: module loaded
[ 0.996221] Loading iSCSI transport class v2.0-870.
[ 1.009284] mtdoops: mtd device (mtddev=name/number) must be supplied
[ 1.017998] libphy: Fixed MDIO Bus: probed
[ 1.077692] davinci_mdio 4a101000.mdio: davinci mdio revision 1.6, bus freq 1000000
[ 1.085743] libphy: 4a101000.mdio: probed
[ 1.091425] davinci_mdio 4a101000.mdio: phy[0]: device 4a101000.mdio:00, driver SMSC LAN8710/LAN8720
[ 1.101179] cpsw 4a100000.ethernet: initialized cpsw ale version 1.4
[ 1.107865] cpsw 4a100000.ethernet: ALE Table size 1024
[ 1.113840] cpsw 4a100000.ethernet: cpts: overflow check period 500 (jiffies)
[ 1.121444] cpsw 4a100000.ethernet: Detected MACID = d0:39:72:18:7e:df
[ 1.130700] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 1.137548] ehci-omap: OMAP-EHCI Host Controller driver
[ 1.145901] am335x-phy-driver 47401300.usb-phy: 47401300.usb-phy supply vcc not found, using dummy regulator
[ 1.164143] am335x-phy-driver 47401b00.usb-phy: 47401b00.usb-phy supply vcc not found, using dummy regulator
[ 1.185272] omap_rtc 44e3e000.rtc: registered as rtc0
[ 1.191456] i2c /dev entries driver
[ 1.196624] omap_wdt: OMAP Watchdog Timer Rev 0×01: initial timeout 60 sec
[ 1.206725] omap_gpio 44e07000.gpio: Could not set line 6 debounce to 200000 microseconds (-22)
[ 1.215938] omap_hsmmc 48060000.mmc: Got CD GPIO
[ 1.272647] omap_hsmmc 47810000.mmc: RX DMA channel request failed
[ 1.283060] ledtrig-cpu: registered to indicate activity on CPUs
[ 1.290000] omap-aes 53500000.aes: OMAP AES hw accel rev: 3.2
[ 1.296388] omap-aes 53500000.aes: will run requests pump with realtime priority
[ 1.306328] omap-sham 53100000.sham: hw accel on OMAP rev 4.3
[ 1.319478] davinci-mcasp 48038000.mcasp: IRQ common not found
[ 1.332861] NET: Registered protocol family 10
[ 1.341140] Segment Routing with IPv6
[ 1.345162] NET: Registered protocol family 17
[ 1.349962] NET: Registered protocol family 15
[ 1.354678] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 1.368332] 8021q: 802.1Q VLAN Support v1.8
[ 1.372756] Key type dns_resolver registered
[ 1.377329] ThumbEE CPU extension supported.
[ 1.381840] Registering SWP/SWPB emulation handler
[ 1.386859] omap_voltage_late_init: Voltage driver support not added
[ 1.393539] sr_dev_init: Unknown instance smartreflex0
[ 1.399263] SmartReflex Class3 initialized
[ 1.421174] mmc0: host does not support reading read-only switch, assuming write-enable
[ 1.433890] mmc0: new high speed SDHC card at address aaaa
[ 1.440872] mmcblk0: mmc0:aaaa SU08G 7.40 GiB
[ 1.447431] mmcblk0: p1 p2
[ 1.460191] random: fast init done
[ 1.473464] mmc1: new high speed MMC card at address 0001
[ 1.481731] mmcblk1: mmc1:0001 MMC04G 3.60 GiB
[ 1.486778] mmcblk1boot0: mmc1:0001 MMC04G partition 1 2.00 MiB
[ 1.493389] mmcblk1boot1: mmc1:0001 MMC04G partition 2 2.00 MiB
[ 1.499783] mmcblk1rpmb: mmc1:0001 MMC04G partition 3 128 KiB, chardev (246:0)
[ 1.508096] tps65217 0-0024: TPS65217 ID 0xe version 1.2
[ 1.514222] omap_i2c 44e0b000.i2c: bus 0 rev0.11 at 400 kHz
[ 1.522631] omap_i2c 4819c000.i2c: bus 2 rev0.11 at 100 kHz
[ 1.529179] 8←– cut here — [ 1.532387] Unable to handle kernel NULL pointer dereference at virtual address 00000008
[ 1.540913] pgd = (ptrval)
[ 1.543746] [00000008] *pgd=00000000
[ 1.547496] Internal error: Oops: 5 [#1] SMP ARM
[ 1.552325] Modules linked in:
[ 1.555527] CPU: 0 PID: 1108 Comm: kworker/0:3 Not tainted 5.4.154 #0
[ 1.562268] Hardware name: Generic AM33XX (Flattened Device Tree)
[ 1.568652] Workqueue: events 0xc05aba90
[ 1.572757] PC is at 0xc06b4294
[ 1.576040] LR is at 0xc06a4968
[ 1.579325] pc : [<c06b4294>] lr : [<c06a4968>] psr: a0000013
[ 1.585884] sp : dd96dd88 ip : 00000002 fp : ffffe000
[ 1.591351] r10: c0c96ec4 r9 : c0c04f08 r8 : ddad2400
[ 1.596819] r7 : 00000000 r6 : de035040 r5 : ddad2410 r4 : de034040
[ 1.603652] r3 : ddad2210 r2 : c09ed4a0 r1 : 00000200 r0 : ddad2200
[ 1.610486] Flags: NzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment none
[ 1.617955] Control: 10c5387d Table: 80004019 DAC: 00000051
[ 1.623967] Process kworker/0:3 (pid: 1108, stack limit = 0x(ptrval))
[ 1.630708] Stack: (0xdd96dd88 to 0xdd96e000)
[ 1.635269] dd80: c0c04f08 c06831fc de034040 c0c96ec0 de035040 c0c96ebc
[ 1.643833] dda0: ddad2400 c06a4968 00000a20 00000000 c0c971f4 dfdeea38 a0000013 ddad2410
[ 1.652395] ddc0: de27ba00 00000038 c0c96ec0 c0c96eb8 00000000 c04fb214 00000000 dfdee528
[ 1.660957] dde0: 00000000 00000001 00000001 c071214c dd488b40 dd488b40 c0c271f8 c02d48d0
[ 1.669522] de00: dd488b40 00000000 00000000 c0a35c48 00000001 c02d4a7c c0c3fbc0 00000006
[ 1.678087] de20: dda98300 c02d46fc 00000000 dd488b40 ddad05a0 ddad05a0 dd488b40 0ebe159f
[ 1.686651] de40: c0a35c48 ddad2410 00000000 c0c3fbc0 00000000 00000000 c0c3fbc0 00000006
[ 1.695216] de60: ffffe000 c05adf3c c0c9482c ddad2410 c0c94824 00000000 00000000 c05ac51c
[ 1.703780] de80: ddad2410 c0c3fbc0 c05ac9b0 00000001 00000000 00000000 00000000 c05ac800
[ 1.712344] dea0: c0c3fbc0 dd96dee8 ddad2410 00000000 dd96dee8 c05ac9b0 00000001 00000000
[ 1.720908] dec0: 00000000 00000000 ffffe000 c05aaa54 de008b6c de2e16b8 ddad2410 ddad2454
[ 1.729472] dee0: c0c37cd0 c05ac2b4 ddad2410 00000001 c0c37a54 ddad2410 ddad2410 c0c37cd0
[ 1.738035] df00: dfdc5c00 c05ab668 ddad2410 c0c37a4c c0c37a54 c05abaf8 c0c37aa0 dd8ea500
[ 1.746598] df20: dfdc29c0 c0145dd0 00000008 c0c03d00 dd8ea500 dd8ea514 dfdc29c0 00000008
[ 1.755163] df40: c0c03d00 dfdc29d8 dfdc29c0 c01462d4 c0c1de30 c092f0fc ffffe000 dd8ea500
[ 1.763727] df60: c014602c dd8e6b80 dd8e6c80 00000000 dd96c000 dd8ea500 c014602c de071eac
[ 1.772291] df80: dd8e6b9c c014b7c0 00000015 dd8e6c80 c014b674 00000000 00000000 00000000
[ 1.780854] dfa0: 00000000 00000000 00000000 c01010e8 00000000 00000000 00000000 00000000
[ 1.789417] dfc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[ 1.797979] dfe0: 00000000 00000000 00000000 00000000 00000013 00000000 00000000 00000000
[ 1.806549] Function entered at [<c06b4294>] from [<c06a4968>]
[ 1.812654] Function entered at [<c06a4968>] from [<c05adf3c>]
[ 1.818759] Function entered at [<c05adf3c>] from [<c05ac51c>]
[ 1.824861] Function entered at [<c05ac51c>] from [<c05ac800>]
[ 1.830964] Function entered at [<c05ac800>] from [<c05aaa54>]
[ 1.837065] Function entered at [<c05aaa54>] from [<c05ac2b4>]
[ 1.843167] Function entered at [<c05ac2b4>] from [<c05ab668>]
[ 1.849270] Function entered at [<c05ab668>] from [<c05abaf8>]
[ 1.855372] Function entered at [<c05abaf8>] from [<c0145dd0>]
[ 1.861477] Function entered at [<c0145dd0>] from [<c01462d4>]
[ 1.867579] Function entered at [<c01462d4>] from [<c014b7c0>]
[ 1.873683] Function entered at [<c014b7c0>] from [<c01010e8>]
[ 1.879785] Exception stack(0xdd96dfb0 to 0xdd96dff8)
[ 1.885071] dfa0: 00000000 00000000 00000000 00000000
[ 1.893632] dfc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[ 1.902193] dfe0: 00000000 00000000 00000000 00000000 00000013 00000000
[ 1.909122] Code: e34c209e e5953024 e2430010 e5937040 (e5978008)
[ 1.915543] —[ end trace b9a3348b3cd5e5c5 ]— [ 1.920392] Kernel panic - not syncing: Fatal exception
[ 1.925869] Rebooting in 1 seconds..


23.01.20224236Base systemBug ReportVery LowLowbeagle bone black boot failedopenwrt-21.02Unconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 


22.01.20224235Base systemBug ReportVery LowHighlantiq FB7362SL missing "urlader" partition .wifi unusa...TrunkUnconfirmed Task Description

FritzBox 7262SL
OpenWrt SNAPSHOT, r18621-af8a059bb4
Tested custom build and default trunk image

root@OpenWrt:~# cat /proc/mtd
dev: size erasesize name
mtd0: 00400000 00020000 “kernel” mtd1: 07c00000 00020000 “ubi” mtd2: 00060000 00010000 “tffs (1)” mtd3: 00060000 00010000 “tffs (2)”

root@OpenWrt:~# ls -l /lib/firmware/ath9k-eeprom-pci-0000:01:00.0.bin
-rw-r–r– 1 root root 0 Jan 22 00:19 /lib/firmware/ath9k-eeprom-pci-0000:01:00.0.bin

After restoring eeprom bin from previous build radio was back

20.01.20224233Base systemBug ReportVery LowCriticalawk from busybox-v1.35.0 doesn't work.TrunkUnconfirmed Task Description

Form data handler ‘<form action=”/examples/awk-scripts.cgi” method=”post“>’ is not executed.
awk problem with busybox-v1.35.0-1.

Reverting awk itself to busybox-v1.33.1 and rebuilding.
And the awk scripting engine works.

The patch is needed in: /openwrt-master/package/utils/busybox/patches/521-revert_awk_busybox-1.33.1.patch

20.01.20224232PackagesBug ReportVery LowMediumdnsmasq-full fails to resolve randomly domains if DNSSE...TrunkUnconfirmed Task Description

dnsmasq-full fails to resolve randomly domains if DNSSEC is enabled and DNS forwarders are Cloudfare servers e.g. 1.1.1.1, 1.0.0.1
Device problem occurs on TP-Link Archer C2 and Archer C7.
OpenWRT 19.07.8, dnsmasq-full 2.80-16.3.

 


20.01.20224231Base systemBug ReportVery LowHighIssue with the autotool macroTrunkUnconfirmed Task Description

Hi,

I’m trying to add a kernel package that needs it’s modules loaded at boot, but in a certain order. Yet, when I make the following:

JOOL_AUTOLOAD:= \
jool_common \
jool_nat64 \
jool_siit

AUTOLOAD:=$(call AutoLoad,48,$(JOOL_AUTOLOAD))

The output of the file is always:

jool
jool_common
jool_siit

After some research it seems that the macro sorts the items alphabetically breaking the makefile configuration. Is it possible to fix this behaviour? Is there any alternative that should be used?

Thanks!

20.01.20224230PackagesBug ReportVery LowLowI didn't find a wifidog or wifidog app package in toolc...TrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 


19.01.20224229Base systemBug ReportVery LowHighMT7621 Wireless default erroropenwrt-21.02Unconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 
  1. Device problem occurs on Phicomm K2P
  2. Software versions of OpenWrt/LEDE release OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d
  3. Steps to reproduce just flash openwrt-21.02.1-ramips-mt7621-phicomm_k2p-squashfs-sysupgrade.bin

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

It’s two 802.11nac,no have 802.11bg.

in luci if you enable two wifi ,they all cheange to 802.11nac.

18.01.20224228ToolchainBug ReportVery LowMediumtools: update libtoolTrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
No specific device
- Software versions of OpenWrt/LEDE release, packages, etc.
Trunk

I am trying to add a package which requires libtool 2.4.6 and I was wondering if it is possible for it to be updated, since the most recent version was released 7 years ago I believe we should already be there.

Thanks!

16.01.20224227Base systemBug ReportVery LowMediummr8300: no WAN port in switchopenwrt-21.02Unconfirmed Task Description

Device problem occurs on: Linksys MR8300

Software version: OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d

Steps to reproduce:
- navigate to Network → Switch
- the WAN port does not appear

Workaround:
- create a VLAN without the WAN port
- connect via SSH and edit /etc/config/network
- add port number 5 in the VLAN
- reboot

16.01.20224226Base systemBug ReportVery LowHighPackage kmod-phy-ath79-usb missing kernel modules.TrunkUnconfirmed Task Description

Hi!

I upgraded my DIR-505 to 21.02.1 using openwrt-21.02.1-ath79-generic-dlink_dir-505-squashfs-sysupgrade.bin and found that the USB port wasn’t working.

I then reset the device(long pressed the reset button) and the USB port still doesn’t work.

Upon investigation I found that the `kmod-phy-ath79-usb` package doesn’t contain any kernel modules.(Only 2 text files.)

Supply the following if possible:
- Device problem occurs on

D-Link DIR-505

- Software versions of OpenWrt/LEDE release, packages, etc.

BUILD_ID=”r16325-88151b8303” OPENWRT_BOARD=”ath79/generic” OPENWRT_ARCH=”mips_24kc” OPENWRT_TAINTS=”” OPENWRT_DEVICE_MANUFACTURER=”OpenWrt” OPENWRT_DEVICE_MANUFACTURER_URL=”https://openwrt.org/” OPENWRT_DEVICE_PRODUCT=”Generic” OPENWRT_DEVICE_REVISION=”v0” OPENWRT_RELEASE=”OpenWrt 21.02.1 r16325-88151b8303”

root@OpenWrt:~# opkg info kmod-phy-ath79-usb
Package: kmod-phy-ath79-usb
Version: 5.4.154-1
Depends: kernel (= 5.4.154-1-79c5dc6db69102eb2943a96b9bec8b63), kmod-usb-core
Status: install ok installed
Architecture: mips_24kc
Installed-Time: 1635066095

- Steps to reproduce

 root@OpenWrt:~# opkg files kmod-phy-ath79-usb

Package kmod-phy-ath79-usb (5.4.154-1) is installed on root and has the following files:
/etc/modules.d/21-phy-ath79-usb
/etc/modules-boot.d/21-phy-ath79-usb
root@OpenWrt:~#


13.01.20224225Base systemBug ReportVery LowLowlogread starts before interface is upTrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

openwrt 21.02.1 on x86_64 (virtualbox)
interfaces are all Intel Pro/1000 T Server 82543GC
logread is configured to forward messages to a syslog server

It seems as if logread forwarding starts before it is able to actually send messages to the syslog server, resulting in lost messages. This is important as the syslog server generates monitoring information, including status of all interfaces on the router. The loss of early interface messages means that the monitoring does not get a full picture of the status of these devices.

I have attached a log of the console output from the router bootup.
I have also attached a log of the messages received by the syslog server.

Interestingly, other routers forward their messages to the same syslog server and yet none of those routers’ messages are dropped. These routers have nearly identical configuations too.

Incidentally, a google search reveals that this was previously logged on the old openwrt bug tracker at External Link.
Additionally, a similar bug was logged against logread at External Link.


13.01.20224224Base systemBug ReportVery LowHighR4s refresh the latest firmware, the uplink speed is on...AllUnconfirmed Task Description

Device name: r4s
Firmware download: https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/openwrt-rockchip-armv8-friendlyarm_nanopi-r4s-ext4-sysupgrade.img.gz

Problem description: Using iperf3 test the uplink speed is only 1-3Mbps, but using https://github.com/DHDAXCW/NanoPi-R4S/releases 2 can run the full bandwidth.


12.01.20224223Base systemBug ReportVery LowLowUpgrade from ar71xx to ath79 fails on NETGEAR WNDR4300 ...openwrt-21.02Unconfirmed Task Description

Reporting according to
https://openwrt.org/docs/guide-user/installation/ar71xx.to.ath79

because from what I gather, that is probably the cause for the upgrade failure.

Model NETGEAR WNDR4300
Architecture Atheros AR9344 rev 2
Firmware Version OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-21.357.58233-6f349c9

sysupgrade -n openwrt-21.02.1-ath79-nand-netgear_wndr4300-squashfs-sysupgrade.bin

fails with

Device wndr4300 not supported by this image
Supported devices: netgear,wndr4300
Invalid sysupgrade file.
Image check failed.

Image downloaded from
https://downloads.openwrt.org/releases/21.02.1/targets/ath79/nand/openwrt-21.02.1-ath79-nand-netgear_wndr4300-squashfs-sysupgrade.bin

Checked
https://openwrt.org/docs/techref/targets/ar71xx-ath79

Also tried the SNAPSHOT from
https://downloads.openwrt.org/snapshots/targets/ath79/nand/openwrt-ath79-nand-netgear_wndr4300-squashfs-sysupgrade.bin

sysupgrade -T openwrt-ath79-nand-netgear_wndr4300-squashfs-sysupgrade.bin
Device wndr4300 not supported by this image
Supported devices: netgear,wndr4300
Invalid sysupgrade file.
Image check failed.

dmesg output attached.

And last, but not least, thanks for this excellent project.
/Yan

09.01.20224222Base systemBug ReportVery LowLowvalgrind: does not detect memory leaks depite unstrippe...TrunkUnconfirmed Task Description

I am using valgrind 3.18.1-1 on x86_64 r18400-f9782f5bcd. This build uses musl 1.2.2-3. My libraries, to include libc, are not stripped.

According to the upstream bug at https://bugs.kde.org/show_bug.cgi?id=435441, changes to musl left valgrind unable to detect memory leaks. The workaround proposed in that bug report, namely passing “–soname-synonyms=somalloc=NONE” to valgrind, seems to fix the problem on OpenWrt.

Here is an example program:

#include <stdio.h>
#include <stdlib.h>
                   
int f(void) {
        char *buf = malloc(BUFSIZ);
        if (buf == NULL) {         
                return -1;
        }                 
        return 0;
}                           
                            
int main(void)   
{             
        f();  
}

I compiled this with “gcc -O0 -o test test.c”, and I ran the following to demonstrate the problem and workaround:

$ valgrind --leak-check=full ./test
==31728== Memcheck, a memory error detector
==31728== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==31728== Using Valgrind-3.18.1 and LibVEX; rerun with -h for copyright info
==31728== Command: ./test
==31728== 
==31728== 
==31728== HEAP SUMMARY:
==31728==     in use at exit: 0 bytes in 0 blocks
==31728==   total heap usage: 0 allocs, 0 frees, 0 bytes allocated
==31728== 
==31728== All heap blocks were freed -- no leaks are possible
==31728== 
==31728== For lists of detected and suppressed errors, rerun with: -s
==31728== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)
$ valgrind --leak-check=full  --soname-synonyms=somalloc=NONE ./test
==31732== Memcheck, a memory error detector
==31732== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==31732== Using Valgrind-3.18.1 and LibVEX; rerun with -h for copyright info
==31732== Command: ./test
==31732== 
==31732== 
==31732== HEAP SUMMARY:
==31732==     in use at exit: 1,024 bytes in 1 blocks
==31732==   total heap usage: 1 allocs, 0 frees, 1,024 bytes allocated
==31732== 
==31732== 1,024 bytes in 1 blocks are definitely lost in loss record 1 of 1
==31732==    at 0x48806B6: malloc (vg_replace_malloc.c:381)
==31732==    by 0x40111B: f (in /home/mike@flyn.org/valgrindC/test)
==31732==    by 0x40113D: main (in /home/mike@flyn.org/valgrindC/test)
==31732== 
==31732== LEAK SUMMARY:
==31732==    definitely lost: 1,024 bytes in 1 blocks
==31732==    indirectly lost: 0 bytes in 0 blocks
==31732==      possibly lost: 0 bytes in 0 blocks
==31732==    still reachable: 0 bytes in 0 blocks
==31732==         suppressed: 0 bytes in 0 blocks
==31732== 
==31732== For lists of detected and suppressed errors, rerun with: -s
==31732== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 0 from 0)
09.01.20224221Base systemBug ReportVery LowLowR7800 poor download rate when client connects with 100F...TrunkUnconfirmed Task Description

Netgear Nighthawk X4S R7800 with OpenWrt 21.02.1 freshly installed

ISP line is 250/25. Wan port is 1G (auto).

Steps to reproduce:
Laptop connected on LAN-side with 1G (auto): Ookla speedtest is 250/25.
Laptop connected on LAN-side with 100FD: Ookla speedtest is only 30/25.

This performance degration only occurs, when the R7800 is routing and natting the traffic.
“Switched only” traffic inside the LAN is not affected.

With stock ROM the download rate is as expected:
Laptop connected on LAN-side with 100FD: Ookla speedtest is 80/25.


07.01.20224220Base systemBug ReportVery LowLowMTU > 1500 settings are missing for WAN and LANx mt7621TrunkUnconfirmed Task Description

Dir878 /882 /882-r1 (mt7530)
OpenWrt SNAPSHOT, r18502-53b87a7a28 but seems linux 5.10 builds are afected as 5.4 kernel it’s fine.

There is issue with setting MTU to 1508 for DSA driver to be rfc4638 compatibile

root@OpenWrt:~# ifconfig br-lan mtu 1508
root@OpenWrt:~# ifconfig eth0 mtu 1508
root@OpenWrt:~# ifconfig LAN2 mtu 1508
ifconfig: SIOCSIFMTU: Invalid argument

But even then MTU > 1500 seem to work for lan side.

root@OpenWrt:~# fping -s -M -b 1473 192.168.1.3
192.168.1.3 is alive

But to be able to use rfc4638 pppoe WAN must be set to 1508
root@OpenWrt:~# ifconfig wan mtu 1508
ifconfig: SIOCSIFMTU: Invalid argument

PPPoE session is always connecting with MTU 1492

06.01.20224219Base systemBug ReportVery LowLowConsider enabling crontab special time extensionTrunkUnconfirmed Task Description

Please consider enabling cron special time extensions by default. Having them enabled improves crontab UX.
Grepping openwrt/openwrt suggest that enabling BUSYBOX_DEFAULT_FEATURE_CROND_SPECIAL_TIMES under openwrt/package/utils/busybox/Config-defaults.in should do the trick.

- Software versions of OpenWrt/LEDE release, packages, etc.
Busybox 1.34.1-1, OpenWrt SNAPSHOT r18125-b764cb9e5b
- Steps to reproduce
1. Add a scheduled task via LuCI or crontab -e
Example:

@weekly foo.sh

2. Log:

cron.err crond[25439]: user root: parse error at @weekly
04.01.20224218Base systemBug ReportVery LowLowon bcm63xx/HW553 i can chage wired MAC address but not ...openwrt-21.02Unconfirmed Task Description

I Own a set of router as subject, that had to be ‘jailbreaked’ installing a custom CFE via JTAG. Clearly, in this way all router have the same MAC addresses.

I can change wired mac address in LUCI, or appending:

 option macaddr '00:24:89:41:4e:22'

and work as expected. But i cannot do that for wireless one, simply does not work.

Strange things, if i do:

 ifconfig wlan0 down
 ifconfig wlan hw ether 00:24:89:41:4e:22
 ifconfig wlan0 up

MAC address change, but wireless does not work, i need to do a ‘wifi restart’, and after that MAC address get back to ‘wrong’ one.

I’ve tried to look for that in OpenWRT wiki, also in b43 driver page, but nothing useful popoup.

Thanks.

02.01.20224217Base systemBug ReportVery LowLowImage check failes for ar71xx to ath79 on WNDR3700v4openwrt-19.07Unconfirmed Task Description

Image check fails if trying to upgrade from OpenWrt 19.07.8 r11364-ef56c85848 / LuCI openwrt-19.07 branch git-21.189.23240-7b931da to the new ath79 based builds.

Model: NETGEAR WNDR3700v4
Architecture: Atheros AR9344 rev 2

 

Reproducible with sysupgrade from either:

https://firmware-selector.openwrt.org/?version=21.02.0&target=ath79%2Fnand&id=netgear_wndr3700-v4 https://firmware-selector.openwrt.org/?version=21.02.1&target=ath79%2Fnand&id=netgear_wndr3700-v4

Error says:

Device wndr3700v4 not supported by this image Supported devices: netgear,wndr3700-v4 Invalid sysupgrade file. Image check failed.

01.01.20224216Base systemBug ReportVery LowLowds-lite: Command failed: Invalid argumentopenwrt-21.02Unconfirmed Task Description

System info

- Device problem occurs on

  • x86-64 based router

- Software versions of OpenWrt/LEDE release, packages, etc.

  • OpenWrt 21.02.1

ISP connectivity options

My ISP (Orange Polska) provides two options for network connectivity:

  • IPv4
  • IPv6 with DS-Lite

My WAN interface is called “Orange”.

IPv4

IPv4 setup works fine. My router uses PPPoE to authenticate, setup all routes etc and things “just works”.

IPv6

IPv6 is more problematic. I can setup IPv6 only network (including LAN clients). But to get IPv4 connectivity I need to setup DS-Lite.

Installed ‘ds-lite’ package. Used tcpdump to get AFTR address from DHCPv6 packets. Reconfigured “Orange_6” and “Orange_DS_lite”:

config interface 'Orange'
        option proto 'pppoe'
        option device 'eth0.35'
        option username 'bez_ochrony-REDACTED@neostrada.pl/ipv6'
        option password 'REDACTED'
        option ipv6 'auto'
        option ip6assign '64'

config interface 'Orange_6'
        option proto 'dhcpv6'
        option device '@Orange'
        option iface_dslite 'Orange_DS_lite'
        option reqaddress 'try'
        option reqprefix 'auto'
        option reqopts '64'

config interface 'Orange_DS_lite'
        option proto 'dslite'
        option peeraddr 'szcz01f.cgn.tpnet.pl'
        option ip6addr '2a01:ZZZZ:YYYY:XXXX::1'
        option encaplimit 'ignore'

I can see (from debug output added in /lib/netifd/proto/dslite.sh and /lib/netifd/netifd-proto.sh scripts) that it tries to configure DS-Lite link:

Sat Jan  1 13:11:14 2022 daemon.notice netifd: Orange_DS_lite (13810): dslite.sh: ip6addr: 2a01:ZZZZ:YYYY:XXXX::1
Sat Jan  1 13:11:14 2022 daemon.notice netifd: Orange_DS_lite (13810): dslite.sh: peeraddr: 2a01:1000:0:1::9114
Sat Jan  1 13:11:14 2022 daemon.notice netifd: Orange_DS_lite (13810): _proto_notify(): iface=Orange_DS_lite opts=
Sat Jan  1 13:11:14 2022 daemon.notice netifd: Orange_DS_lite (13810): _proto_notify(): json_dump={ "action": 0, "ifname": "ds-Orange_DS_lite", "link-up": true, "tunnel": { "mode": "ipip6", "mtu": 1280, "ttl": 64, "local": "2a01:ZZZZ:YYYY:XXXX::1", "remote": "2a01:1000:0:1::9114", "data": { "encaplimit": "ignore" } }, "data": { "firewall": [ { "type": "nat", "target": "ACCEPT" } ] }, "keep": false, "ipaddr": [ { "ipaddr": "192.0.0.2", "ptp": "192.0.0.1" } ], "routes": [ { "target": "0.0.0.0", "netmask": "0" } ], "interface": "Orange_DS_lite" }
Sat Jan  1 13:11:14 2022 daemon.notice netifd: Orange_DS_lite (13810): Command failed: Invalid argument

And then it loops and floods log with repeated failures.

What is wrong?

31.12.20214215Base systemBug ReportVery LowMediumTP-Link Archer C6 loses internet connectivity after a w...TrunkUnconfirmed Task Description

Problem device: Tp-Link Archer C6 v2 EU version
Software:
- LuCI openwrt-21.02 branch (git-21.231.26241-422c175)
- OpenWrt 21.02.0 r16279-5cc0535800

I installed the open wrt binary using this guide: https://radix007.github.io/OpenWrt-Tp-Link-C6/#installing-openwrt-using-tftpd-method-b-

No custom setup was done, I only turned 5Ghz radio on. Both wifi and ethernet worked out of the box, WAN connected without issues however in the morning internet connection was down. It fixed after restarting WAN interface from GUI. According to my script that was pinging google connection lasted for about 7 hours before going down. There were no logs from around the time connection was lost.

30.12.20214214Base systemBug ReportVery LowMediumNetgear r6220 randomly disconnecting from ISPopenwrt-21.02Unconfirmed Task Description

Device: Netgear R6220
Firmware: 20.02 snapshot r18400-f9782f5bcd

After the router has been up a while it will start to lose wan connectivity to my ISP (Frontier FiOS). I’m unable to ping the default gateway. Using my cellular data, I ssh to a remote server and ping the same gateway and it pings fine.

It’s only down for a a few to 30 seconds and comes backup usually with the following message

 

Dec 30 01:07:02 gateway dnsmasq[304]: possible DNS-rebind attack detected: dns.msftncsi.com

There is no indication that the wan connection is down, and the lights don’t change.

The ISP sent me a new router which I have now connected up and it’s been stable.

I’ve tried two different R6220 routers, since I have a spare, and that gave the same issues.

28.12.20214213Base systemBug ReportVery LowLowInternet Doesn't Work At All. Needs Investigation. TrunkUnconfirmed Task Description

I have been experimenting with OpenWRT using a Raspberry Pi, however the PI cannot connect to the internet. After wasting many hours google-ing and trying every suggestion I can find I have reached the conclusion that something is critically wrong with OpenWRT. I have seen that a lot of people are having this problem, so I would like to start a discussion on how to resolve these internet connectivity issues once and for all.

Set-Up
I am in my office, I just have a single ethernet port for my suite. So the office ethernet port is connected to a TP-Link (TL-GS1016S). My MacBook is connected to one port and the Pi running OpenWRT is connected using another port.

My MacBook pro is connected to the same switch as the Pi and the internet is working fine. I have Wi-fi disabled on my Mac. I can ping the Raspberry pi from my MacBook (ping 192.168.1.200) with no issues and vice-versa. Although I cannot access Luci via the IP address.

Process
Download OpenWRT for Pi 4 from here: https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi Image: https://downloads.openwrt.org/releases/21.02.1/targets/bcm27xx/bcm2711/openwrt-21.02.1-bcm27xx-bcm2711-rpi-4-squashfs-factory.img.gz

Flash to SD Card using etcher

Add IP Address using the following commands. Source: https://openwrt.org/docs/guide-quick-start/ssh_connect_to_the_internet_and_install_luci uci set network.lan.ipaddr=”192.168.1.200” uci set network.lan.gateway=”192.168.1.1” uci set network.lan.dns=”192.168.1.1” uci commit
/etc/init.d/network restart

However i still can not run
ping google.com
ping: bad address ‘google.com’ ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
does nothing

WHY?!?!?!?!

Solutions I have tried.
Add default gateway as there was no default when I ran $> route. Source: https://superuser.com/questions/854166/openwrt-software-update-wget-returns-network-is-unreachable

route add default gw 192.168.1.1 br-lan

Also tried:

route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.1.1

I tried adding 2 dns items to /etc/config/network

list dns ‘192.168.1.2’ list dns ‘8.8.8.8’

27.12.20214211Base systemBug ReportVery LowMediumDIR-867: udhcpc fails to get a lease on the WAN portopenwrt-21.02Unconfirmed Task Description

Device: D-Link DIR-867 HW:A1
Software: openwrt-21.02.1-ramips-mt7621-dlink_dir-867-a1-squashfs-factory.bin

Reproducer:

  1. Install OpenWRT on the DIR-867.
  2. Set the system configuration to defaults.
  3. Reboot.
  4. Wait for a DHCP lease on the WAN port.

I only ever got this message with a timeout and zero bytes inbound:

udhcpc: sending discover

I tried these things:

  • Running udhcpc at the console with various options like -T, -C and -B.
  • Doing ifconfig up/down on the WAN interface.
  • Toggling every DHCP option in LuCI.
  • Disabling the firewall.

The ISP is Teksavvy through a Technicolor DOCSIS modem. Any other DHCP client works as expected when directly connected to the modem. Reverting to stock D-Link firmware version 1.30 resolves the glitch.

27.12.20214210Base systemBug ReportVery LowLowMerge Archer C6 v3.2 to Stable from SnapshotAllUnconfirmed Task Description

- Device: Archer C6 v3.2
The device has not been pushed to stable
I am more than happy to make the docs if your willing to merge
I have tested the latest snapshot and it works fine

https://github.com/openwrt/openwrt/pull/4222

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=d22fb7f4fd833c420bc2ab34384862da0a6688b5


26.12.20214209Base systemBug ReportVery LowLowopkg invalid SSL certificate issue on FriendlyARM NanoP...TrunkUnconfirmed Task Description

opkg will not update or install packages after installing FriendlyARM NanoPi R4S 4GB EXT4 snapshot r18404-236c3ea730. The included SSL certificate is invalid. See output below:

root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/kmods/5.10.87-1-78061f7b1147755d248e0158e056315e/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/kmods/5.10.87-1-78061f7b1147755d248e0158e056315e/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/luci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_generic/luci/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_generic/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/routing/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_generic/routing/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/telephony/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_generic/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/packages/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/kmods/5.10.87-1-78061f7b1147755d248e0158e056315e/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/luci/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/packages/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/routing/Packages.gz, wget returned 5.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/telephony/Packages.gz, wget returned 5.
root@OpenWrt:~# wget https://downloads.openwrt.org/snapshots/packages/aarch64_generic/routing/Packages.gz
Downloading 'https://downloads.openwrt.org/snapshots/packages/aarch64_generic/routing/Packages.gz'
Connecting to 168.119.138.211:443
Connection error: Invalid SSL certificate
26.12.20214208KernelBug ReportVery LowMediumCpufreq Espressobin V7 doesn't work since Release of 21...openwrt-21.02Unconfirmed Task Description

Hello Guys,

Thanx for your great software. I love using it.

Until 21.02 RC3 cpufreq on my espressobin worked. Since Release of 21.02 frequency scaling it is not available any more. This heats up my espressobin too much. Unfortunately my espressobin is exposed to natural warmth on the place where it is installed.

I think that is related to commit f407b2f43c27a7b35c4f96d3efcee2cc440f8efe (”mvebu: armada-37xx: add patch to forbid cpufreq for 1.2 GHz“)

This commit was a quick shot, to not block the release, but the bug should be fixed.

25.12.20214207Base systemBug ReportVery LowMediumsysupgrade is not aborted by an error but causes a cycl...openwrt-21.02Unconfirmed Task Description

Device: Beeline SmartBox flash (RAMIPS MT7621, 128mb NAND)
Version: OpenWrt 5.10.87
Commit: https://github.com/legale/openwrt/commit/99dd68bcedd0796c240511d2383cbd1232e9cd89

Start system normally then try to upgrade firmware with sysupgrade.

Upgrade and next boot log:
root@OpenWrt:/tmp# sysupgrade -v openwrt-ramips-mt7621-beeline_smartbox-flash-squashfs-sysupgrade.bin
Fri Dec 24 20:32:54 UTC 2021 upgrade: Saving config files...
etc/config/dhcp
etc/config/dropbear
etc/config/firewall
etc/config/luci
etc/config/network
etc/config/rpcd
etc/config/system
etc/config/ubootenv
etc/config/ucitrack
etc/config/uhttpd
etc/config/wireless
etc/dropbear/dropbear_ed25519_host_key
etc/dropbear/dropbear_rsa_host_key
etc/fw_env.config
etc/group
etc/hosts
etc/inittab
etc/luci-uploads/.placeholder
etc/opkg/keys/456559476c33fb8f
etc/opkg/keys/b5043e70f9a75cde
etc/passwd
etc/profile
etc/rc.local
etc/shadow
etc/shells
etc/shinit
etc/sysctl.conf
etc/uhttpd.crt
etc/uhttpd.key
etc/uhttpd.key
etc/uhttpd.crt
Fri Dec 24 20:32:55 UTC 2021 upgrade: Commencing upgrade. Closing all shell sessions.
[ 166.384122] device wlan0 left promiscuous mode
[ 166.393301] br-lan: port 3(wlan0) entered disabled state
Watchdog handover: fd=3
- watchdog -
Watchdog does not have CARDRESET support
[ 166.491730] device wlan1 left promiscuous mode
[ 166.500880] br-lan: port 4(wlan1) entered disabled state
Fri Dec 24 20:32:56 UTC 2021 upgrade: Sending TERM to remaining processes ...
Fri Dec 24 20:32:56 UTC 2021 upgrade: Sending signal TERM to ntpd (2321)
Fri Dec 24 20:32:56 UTC 2021 upgrade: Sending signal TERM to ntpd (2372)
Fri Dec 24 20:33:00 UTC 2021 upgrade: Sending KILL to remaining processes ...
[ 177.140419] sh (3318): drop_caches: 3
Fri Dec 24 20:33:06 UTC 2021 upgrade: Switching to ramdisk...
[ 180.241606] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” stops
[ 180.269397] UBIFS (ubi0:1): un-mount UBI device 0
Fri Dec 24 20:33:09 UTC 2021 upgrade: Performing system upgrade...
Unlocking kernel ...

Writing from <stdin> to kernel ... [ ][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w][e][w]
removing ubiblock0_0
[ 190.263812] block ubiblock0_0: released
Volume ID 0, size 32 LEBs (4063232 bytes, 3.8 MiB), LEB size 126976 bytes (124.0 KiB), dynamic, name “rootfs”, alignment 1
Set volume size to 77455360
Volume ID 1, size 610 LEBs (77455360 bytes, 73.8 MiB), LEB size 126976 bytes (124.0 KiB), dynamic, name “rootfs_data”, alignment 1
[ 192.395021] UBIFS (ubi0:1): default file-system created
[ 192.406795] UBIFS (ubi0:1): Mounting in unauthenticated mode
[ 192.418401] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” started, PID 4026
[ 192.543243] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name “rootfs_data” [ 192.558916] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[ 192.578665] UBIFS (ubi0:1): FS size: 76185600 bytes (72 MiB, 600 LEBs), journal size 3809280 bytes (3 MiB, 30 LEBs)
[ 192.599447] UBIFS (ubi0:1): reserved for root: 3598434 bytes (3514 KiB)
[ 192.612638] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID A34CF210-54A6-40D8-AD48-EC8928E6FB68, small LPT model
[ 192.660816] UBIFS (ubi0:1): un-mount UBI device 0
[ 192.670249] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” stops
sysupgrade successful
umount: can’t unmount /dev: Resource busy
umoun[ 192.704192] reboot: Restarting system
t: can’t unmount /tmp: Resource busy

NEXT BOOT

HHLX{+rprintk: console [ttyS0] enabled
[ 0.614144] printk: console [ttyS0] enabled
[ 0.630629] printk: bootconsole [early0] disabled
[ 0.630629] printk: bootconsole [early0] disabled
[ 0.651459] mt7621-nand 1e003000.nand: Using programmed access timing: 31c07388
[ 0.666330] nand: device found, Manufacturer ID: 0xef, Chip ID: 0xf1
[ 0.678982] nand: Winbond W29N01HV
[ 0.685755] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[ 0.700826] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[ 0.713863] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[ 0.728415] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[ 0.742962] Scanning device for bad blocks
[ 1.394912] 15 fixed-partitions partitions found on MTD device mt7621-nand
[ 1.408599] Creating 15 MTD partitions on “mt7621-nand”:
[ 1.419180] 0×000000000000-0x000007f80000 : “all” [ 1.429887] 0×000000000000-0×000000100000 : “bootloader” [ 1.441504] 0×000000100000-0×000000200000 : “config” [ 1.452314] 0×000000200000-0×000000300000 : “factory” [ 1.463398] 0×000000300000-0×000002300000 : “kernel_stock” [ 1.475511] 0×000000720000-0×000002300000 : “rootfs_stock” [ 1.487464] 0×000002300000-0×000004300000 : “kernel” [ 1.498443] 0×000002720000-0×000004300000 : “rootfs2” [ 1.509518] 0×000004300000-0×000004500000 : “glbcfg” [ 1.520383] 0×000004500000-0×000004600000 : “board_data” [ 1.531888] 0×000004600000-0×000004800000 : “glbcfg2” [ 1.542849] 0×000004800000-0×000004900000 : “board_data2” [ 1.554540] 0×000004900000-0x000007f80000 : “data” [ 1.565220] 0×000002720000-0×000004300000 : “ubipart0” [ 1.576539] 0×000004600000-0x000007f80000 : “ubipart1” [ 1.596752] Concatenating MTD devices:
[ 1.604282] (0): “ubipart0” [ 1.609836] (1): “ubipart1” [ 1.615405] into device “ubi-concat” [ 1.622556] 1 fixed-partitions partitions found on MTD device ubi-concat
[ 1.635911] Creating 1 MTD partitions on “ubi-concat”:
[ 1.646157] 0×000000000000-0×000005280000 : “ubi” [ 1.659457] libphy: Fixed MDIO Bus: probed
[ 1.704050] libphy: mdio: probed
[ 1.710796] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[ 1.725444] mtk_soc_eth 1e100000.ethernet: generated random MAC address c6:47:a5:c0:79:e2
[ 1.742529] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 21
[ 1.762221] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[ 1.775637] mt7621-pci 1e140000.pcie: No bus range found for /pcie@1e140000, using [bus 00-ff]
[ 1.793205] mt7621-pci 1e140000.pcie: MEM 0×0060000000..0x006fffffff → 0×0000000000 [ 1.809503] mt7621-pci 1e140000.pcie: IO 0x001e160000..0x001e16ffff → 0×0000000000 [ 1.825901] mt7621-pci 1e140000.pcie: Parsing DT failed
[ 1.838529] NET: Registered protocol family 10
[ 1.848854] Segment Routing with IPv6
[ 1.856296] NET: Registered protocol family 17
[ 1.865498] 8021q: 802.1Q VLAN Support v1.8
[ 1.877127] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[ 1.901570] libphy: dsa slave smi: probed
[ 1.911030] mt7530 mdio-bus:1f lan2 (uninitialized): PHY [dsa-0.0:02] driver [Generic PHY] (irq=POLL)
[ 1.931035] mt7530 mdio-bus:1f lan1 (uninitialized): PHY [dsa-0.0:03] driver [Generic PHY] (irq=POLL)
[ 1.951019] mt7530 mdio-bus:1f wan (uninitialized): PHY [dsa-0.0:04] driver [Generic PHY] (irq=POLL)
[ 1.971739] mt7530 mdio-bus:1f: configuring for fixed/rgmii link mode
[ 1.988679] DSA: tree 0 setup
[ 1.994935] rt2880-pinmux pinctrl: pcie is already enabled
[ 2.005971] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[ 2.019339] mt7621-pci 1e140000.pcie: No bus range found for /pcie@1e140000, using [bus 00-ff]
[ 2.036878] mt7621-pci 1e140000.pcie: MEM 0×0060000000..0x006fffffff → 0×0000000000 [ 2.053187] mt7621-pci 1e140000.pcie: IO 0x001e160000..0x001e16ffff → 0×0000000000 [ 2.069569] mt7621-pci-phy 1e149000.pcie-phy: PHY for 0xbe149000 (dual port = 1)
[ 2.084676] mt7621-pci-phy 1e14a000.pcie-phy: PHY for 0xbe14a000 (dual port = 0)
[ 2.099669] mt7621-pci 1e140000.pcie: failed to parse bus ranges property: -22
[ 2.214265] mt7621-pci-phy 1e149000.pcie-phy: Xtal is 40MHz
[ 2.225382] mt7621-pci-phy 1e14a000.pcie-phy: Xtal is 40MHz
[ 2.336639] mt7621-pci 1e140000.pcie: pcie0 no card, disable it (RST & CLK)
[ 2.350502] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[ 2.364377] mt7621-pci 1e140000.pcie: PCIE1 enabled
[ 2.374097] mt7621-pci 1e140000.pcie: PCI coherence region base: 0×60000000, mask/settings: 0xf0000002
[ 2.392794] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[ 2.405490] pci_bus 0000:00: root bus resource [io 0x1e160000-0x1e16ffff]
[ 2.419193] pci_bus 0000:00: root bus resource [mem 0×60000000-0x6fffffff]
[ 2.432890] pci_bus 0000:00: root bus resource [bus 00-ff]
[ 2.443826] pci_bus 0000:00: root bus resource [mem 0×60000000-0x6fffffff] (bus address [0×00000000-0x0fffffff])
[ 2.464146] pci 0000:00:00.0: [0e8d:0801] type 01 class 0×060400 [ 2.476130] pci 0000:00:00.0: reg 0×10: [mem 0×00000000-0x7fffffff]
[ 2.488623] pci 0000:00:00.0: reg 0×14: [mem 0×60200000-0x6020ffff]
[ 2.501171] pci 0000:00:00.0: supports D1
[ 2.509160] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[ 2.522258] pci 0000:01:00.0: [14c3:7615] type 00 class 0×000280 [ 2.534319] pci 0000:01:00.0: reg 0×10: initial BAR value 0×00000000 invalid
[ 2.548367] pci 0000:01:00.0: reg 0×10: [mem size 0×00100000 64bit]
[ 2.561019] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[ 2.591952] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[ 2.602410] pci 0000:00:00.0: bridge window [io 0×0000-0x0fff]
[ 2.614562] pci 0000:00:00.0: bridge window [mem 0×60000000-0x600fffff]
[ 2.628085] pci 0000:00:00.0: bridge window [mem 0×60100000-0x601fffff pref]
[ 2.642476] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[ 2.655705] pci 0000:00:00.0: BAR 0: no space for [mem size 0×80000000]
[ 2.668882] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0×80000000]
[ 2.682753] pci 0000:00:00.0: BAR 8: assigned [mem 0×60000000-0x600fffff]
[ 2.696282] pci 0000:00:00.0: BAR 9: assigned [mem 0×60100000-0x601fffff pref]
[ 2.710669] pci 0000:00:00.0: BAR 1: assigned [mem 0×60200000-0x6020ffff]
[ 2.724208] pci 0000:00:00.0: BAR 7: assigned [io 0x1e160000-0x1e160fff]
[ 2.737743] pci 0000:01:00.0: BAR 0: assigned [mem 0×60000000-0x600fffff 64bit]
[ 2.752314] pci 0000:00:00.0: PCI bridge to [bus 01]
[ 2.762206] pci 0000:00:00.0: bridge window [io 0x1e160000-0x1e160fff]
[ 2.775732] pci 0000:00:00.0: bridge window [mem 0×60000000-0x600fffff]
[ 2.789260] pci 0000:00:00.0: bridge window [mem 0×60100000-0x601fffff pref]
[ 2.805717] UBI error: no valid UBI magic found inside mtd15
[ 2.817722] mt7530 mdio-bus:1f: Link is Up - 1Gbps/Full - flow control off
[ 2.831896] /dev/root: Can’t open blockdev
[ 2.840115] VFS: Cannot open root device “(null)” or unknown-block(0,0): error -6
[ 2.855062] Please append a correct “root=” boot option; here are the available partitions:
[ 2.871702] 1f00 130560 mtdblock0
[ 2.871707] (driver?)
[ 2.884729] 1f01 1024 mtdblock1
[ 2.884734] (driver?)
[ 2.897736] 1f02 1024 mtdblock2
[ 2.897740] (driver?)
[ 2.910744] 1f03 1024 mtdblock3
[ 2.910749] (driver?)
[ 2.923764] 1f04 32768 mtdblock4
[ 2.923769] (driver?)
[ 2.936770] 1f05 28544 mtdblock5
[ 2.936775] (driver?)
[ 2.949777] 1f06 32768 mtdblock6
[ 2.949782] (driver?)
[ 2.962785] 1f07 28544 mtdblock7
[ 2.962789] (driver?)
[ 2.975804] 1f08 2048 mtdblock8
[ 2.975809] (driver?)
[ 2.988812] 1f09 1024 mtdblock9
[ 2.988817] (driver?)
[ 3.001819] 1f0a 2048 mtdblock10
[ 3.001824] (driver?)
[ 3.015012] 1f0b 1024 mtdblock11
[ 3.015017] (driver?)
[ 3.028194] 1f0c 55808 mtdblock12
[ 3.028199] (driver?)
[ 3.041373] 1f0d 28544 mtdblock13
[ 3.041378] (driver?)
[ 3.054567] 1f0e 58880 mtdblock14
[ 3.054572] (driver?)
[ 3.067745] 1f0f 84480 mtdblock15
[ 3.067750] (driver?)
[ 3.080926] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 3.097389] Rebooting in 1 seconds..

25.12.20214206Base systemBug ReportVery LowHighflash can not be correctly identified & USB does not wo...openwrt-21.02Unconfirmed Task Description

I have a mercury mw151, the CPU is ar9331, 16M/64M a port 100 megabit network port, a USB/microUSB(Power), configuration as attached.

https://bugs.openwrt.org/index.php?getfile=1294

Since there is no corresponding firmware, I have been using the firmware of ts-d084, from BB until 19.07.8 version, and used quite well.

Recently I used the latest version 21.02.1 firmware and saw that FLASH is only recognized to 8M.

Also the device does not recognize the USB drive correctly after installing the corresponding USB driver.


opkg install block-mount
opkg install kmod-usb-core
opkg install kmod-usb-storage
opkg install kmod-usb-uhci
opkg install kmod-fs-vfat
opkg install kmod-usb2

https://bugs.openwrt.org/index.php?getfile=1295

25.12.20214205Base systemBug ReportVery LowLowflash不能正确识别 & USB不能正常工作TrunkUnconfirmed Task Description

我手上有一台mw151,CPU为ar9331,16M/64M 一端口百兆网口,一个USB,配置如附件:

由于没有相应用固件,一直使用ts-d084的固件,用得也相当好,从BB一直用到19.08版本。

最近刷到21.02版本,看到FLASH只识别到8M;
另安装好USB驱动,如:
opkg install block-mount
opkg install kmod-usb-core
opkg install kmod-usb-storage
opkg install kmod-usb-uhci
opkg install kmod-fs-vfat
opkg install kmod-usb2

但在21.02版本不能识别USB,如附件。


25.12.20214204PackagesBug ReportVery LowMediumthe Device hardware version Info in bin file is Incorre...openwrt-21.02Unconfirmed Task Description

When I try to update the firmware to openwrt-21.02.1 in the TP-Link pharos UI, occurred the error “The hardware version is not supported.”

I checked the Device hardware version and bin file.
They are match.

Device hardware version: tplink cpe210 v1
ImageFile: openwrt-21.02.1-ath79-generic-tplink_cpe210-v1-squashfs-factory.bin

But when I open the bin file with Editor to check the hardware version of the bin file, I found the string:
“CPE510(TP-LINK|UN|N300-5):1.0\r\n” in the header of the file
but not “CPE210(TP-LINK|UN|N300-5):1.0\r\n”

So I think that the Device hardware version Info in bin file is not match for tplink_cpe210-v1.
Could you please check it?
Thank you very much!

Firmware OpenWrt Install URL: https://downloads.openwrt.org/releases/21.02.1/targets/ath79/generic/openwrt-21.02.1-ath79-generic-tplink_cpe210-v1-squashfs-factory.bin Firmware OpenWrt snapshot Install URL: https://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_cpe210-v1-squashfs-factory.bin

25.12.20214202Base systemBug ReportVery LowLowReboot on NanoPi R4S brokenTrunkUnconfirmed Task Description

Hello there,

I’m testing the latest snapshot build on the NanoPi R4S (4gb) and have noticed that the reboot command is broken. The system doesn’t come back up after issuing the command via SSH. Just as a sanity check, I’ve flashed a fresh card and attempted the reboot as the first command with the same result.

Image version:
OpenWrt SNAPSHOT, r18400-f9782f5bcd
from: (root) / snapshots / targets / rockchip / armv8 / friendlyarm_nanopi-r4s-ext4-sysupgrade.img.gz

Please let me know if there’s any additional info that might be helpful.

24.12.20214201KernelBug ReportVery LowLowBroken 802.11r roaming if 802.11w is enabled (WPA3 or W...openwrt-21.02Unconfirmed Task Description

Tested on TP-LINK CPE510 (ath9k) and TP-LINK WDR3600 (ath9k). Other users reported the same error: https://github.com/openwrt/mt76/issues/278

Steps to reproduce:

  1. Put two WiFi routers at the desk and enable the same SSID on both. The SSIDs should belong to a unique network (using the two routers as APs, or one as a router and another as a AP)
  2. Enable WPA2-PSK in CCMP mode, and 802.11w with “Generate PMK locally” (ft_psk_generate_local) enabled and FT protocol “FT Over the Air”. I have not filled in the “NAS ID” and “Mobility Domain” options, but checking the /var/run/hostapd-phy0.conf file, I see that they have been autoconfigured correctly.
  3. Test with a bunch of Android phones (in my case, Huawei, Xiaomi & Motorola, all w/Android 10). I’ve used Termux (ping 192.168.1.1 and/or iperf3)
  4. Roam with the phones. All works seamless, the ping and iperf3 does not break.
  5. Enable 802.11w (optional) and reboot the routers.
  6. Roam doesn’t work.
  7. Disable 802.11w and reboot
  8. Roam works
  9. Enable WPA3/WPA2 Mixed Mode and reboot
  10. Roam doesn’t work. All the devices insist on mantain a connection with the original AP. They only connect to the nearest new router if they are previously disassociated with the previous router (breaking the ping and iperf3 tests).
24.12.20214200Base systemBug ReportVery LowMediumlost 5g wifi, WNDR3700v4 openwrt-21.02Unconfirmed Task Description

Supply the following if possible:
- Device problem occurs on

  WNDR3700v4

- Software versions of OpenWrt/LEDE release, packages, etc.

  openwrt-21.02

- Steps to reproduce

  yesterday, I upgrade my router form ar71xx to ath79(19.07 to 21.02), default /etc/config/wireless as p1. // lost 5g options//.
  when I search /sys/devices/ , I can't find any folders contains 'phy1'. As 19.07, It's in folder named 'pci0000:00'. but as 21.02, 

/pci0000:00/ almost nothing.


23.12.20214198Base systemBug ReportVery LowMediumUbnt Bullet M2 XW broken with 21.02+openwrt-21.02Unconfirmed Task Description

OpenWRT 19.07 works (https://downloads.openwrt.org/releases/19.07.8/targets/ath79/generic/openwrt-19.07.8-ath79-generic-ubnt_bullet-m-xw-squashfs-factory.bin)
OpenWrt 21.02 or master doesn’t (tftp flash or sysupgrade)

(need to find my serial cable now)

20.12.20214197Base systemBug ReportVery LowLowdnsmasq fails to start when using IPv6 address for bogu...openwrt-21.02Unconfirmed Task Description
OpenWrt version: 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d
dnsmasq version: 2.85-8

When setting an IPv6 address for the bogusnxdomain option in dnsmasq, the server fails to start. IPv6 addresses should be supported. From the dnsmasq manpage:

-B, --bogus-nxdomain=<ipaddr>[/prefix]
Transform replies which contain the specified address or subnet into "No such domain" replies.
IPv4 and IPv6 are supported.

When setting an IPv6 address like this:

config dnsmasq
	...
	list bogusnxdomain '2606:4700:4700::1111'
	...

The server will fail to start:

Mon Dec 20 11:33:39 2021 daemon.crit dnsmasq[17019]: error at line 25 of /var/etc/dnsmasq.conf.cfg01411c
Mon Dec 20 11:33:39 2021 daemon.crit dnsmasq[17019]: FAILED to start up
Mon Dec 20 11:33:39 2021 daemon.info procd: Instance dnsmasq::cfg01411c s in a crash loop 7 crashes, 0 seconds since last crash

Line 25 of /var/etc/dnsmasq.conf.cfg01411c:

bogus-nxdomain=2606:4700:4700::1111

IPv4 addresses work fine.

20.12.20214196Base systemBuild FailureVery LowMediumcan not build help plzzopenwrt-21.02Unconfirmed Task Description

hcat@ubuntu:~/Desktop/openwrt$ ./scripts/feeds update -a
Updating feed ‘packages’ from ‘https://git.openwrt.org/feed/packages.git’ ...
已经是最新的。
Updating feed ‘luci’ from ‘https://git.openwrt.org/project/luci.git’ ...
已经是最新的。
Updating feed ‘routing’ from ‘https://git.openwrt.org/feed/routing.git’ ...
已经是最新的。
Updating feed ‘telephony’ from ‘https://git.openwrt.org/feed/telephony.git’ ...
已经是最新的。
Create index file ‘./feeds/packages.index’
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make: * [/home/hcat/Desktop/openwrt/include/toplevel.mk:180:staging_dir/host/.prereq-build] 错误 1
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
Create index file ‘./feeds/luci.index’
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make:
* [/home/hcat/Desktop/openwrt/include/toplevel.mk:180:staging_dir/host/.prereq-build] 错误 1
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
Create index file ‘./feeds/routing.index’
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make: * [/home/hcat/Desktop/openwrt/include/toplevel.mk:180:staging_dir/host/.prereq-build] 错误 1
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
Create index file ‘./feeds/telephony.index’
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make:
* [/home/hcat/Desktop/openwrt/include/toplevel.mk:180:staging_dir/host/.prereq-build] error 1
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录
bash: 行 2: /home/hcat/Desktop/openwrt/staging_dir/host/bin/mkhash: 没有那个文件或目录

hcat@ubuntu:~/Desktop/openwrt$ ./scripts/feeds install -a
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make[1]: * [/home/hcat/Desktop/openwrt/include/toplevel.mk:180: staging_dir/host/.prereq-build] Error 1
make:
* [/home/hcat/Desktop/openwrt/include/toplevel.mk:77:prepare-tmpinfo] 错误 2
Cannot open ‘./tmp/.packageinfo’: No such file or directory
Can’t open file ‘./tmp/.targetinfo’: No such file or directory
Installing all packages from feed packages.
Installing package ‘acl’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘attr’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘acme’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘wget’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpcre’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpcre’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘openssl-util’ found
Installing package ‘socat’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘acpica-unix’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘acpid’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘kmod-input-evdev’ found
Installing package ‘acsccid’ from packages
WARNING: No feed for source package ‘libtool’ found
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for package ‘libusb-1.0’ found
Installing package ‘pcsc-lite’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libusb-1.0’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘adblock’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘jshn’ found
WARNING: No feed for package ‘jsonfilter’ found
Installing package ‘coreutils’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libcap’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libgmp’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libgmp’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libcap’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libcap’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘opkg’ found
Installing package ‘addrwatch’ from packages
WARNING: No feed for source package ‘argp-standalone’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpcap’ found
WARNING: No feed for package ‘libevent2’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘libmariadb’ from packages
Installing package ‘curl’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libwolfssl’ found
WARNING: No feed for package ‘libopenssl’ found
Installing package ‘gnutls’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libnettle’ found
WARNING: No feed for package ‘libgmp’ found
Installing package ‘libtasn1’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘p11-kit’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘kmod-cryptodev’ found
WARNING: No feed for package ‘libatomic’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘unbound’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
Installing package ‘libsodium’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libmnl’ found
WARNING: No feed for package ‘libevent2’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘nghttp2’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘python3’ from packages
Installing package ‘bluez’ from packages
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘kmod-bluetooth’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘librt’ found
Installing package ‘glib2’ from packages
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for source package ‘libiconv’ found
Installing package ‘libffi’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for source package ‘pcre’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for package ‘libintl-full’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpcre’ found
WARNING: No feed for package ‘libncurses’ found
WARNING: No feed for package ‘libreadline’ found
WARNING: No feed for package ‘libintl-full’ found
WARNING: No feed for package ‘libiconv-full’ found
Installing package ‘dbus’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘expat’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libncurses’ found
WARNING: No feed for package ‘libreadline’ found
Installing package ‘libical’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libintl-full’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for source package ‘bzip2’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libncursesw’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘python-pip-conf’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libreadline’ found
WARNING: No feed for package ‘libncursesw’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘sqlite3’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘libedit’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libncurses’ found
WARNING: No feed for package ‘libreadline’ found
WARNING: No feed for package ‘libncursesw’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘ca-certs’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘gdbm’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘xz’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libuuid’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libbz2’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘protobuf-c’ from packages
Installing package ‘protobuf’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libatomic’ found
WARNING: No feed for package ‘libstdcpp’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libatomic’ found
WARNING: No feed for package ‘libstdcpp’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘openssl-util’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libmbedtls’ found
WARNING: No feed for package ‘zlib’ found
Installing package ‘zstd’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘openldap’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libopenssl’ found
Installing package ‘cyrus-sasl’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘db47’ from packages
Installing package ‘libxml2’ from packages
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libstdcpp’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libuuid’ found
Installing package ‘icu’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libstdcpp’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libuuid’ found
Installing package ‘libidn2’ from packages
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘libunistring’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for package ‘libintl-full’ found
Installing package ‘libssh2’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libmbedtls’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘ca-bundle’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for source package ‘libiconv’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libiconv-full’ found
WARNING: No feed for package ‘libopenssl’ found
WARNING: No feed for package ‘zlib’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘krb5’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libncurses’ found
WARNING: No feed for package ‘libss’ found
WARNING: No feed for package ‘libcomerr’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘adguardhome’ from packages
Installing package ‘golang’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
Installing package ‘node’ from packages
WARNING: No feed for package ‘libc’ found
WARNING: No feed for package ‘librt’ found
WARNING: No feed for package ‘libpthread’ found
WARNING: No feed for package ‘libstdcpp’ found
WARNING: No feed for package ‘libopenssl’ found

hcat@ubuntu:~/Desktop/openwrt$ make menuconfig
Checking ‘working-make’... ok.
Checking ‘case-sensitive-fs’... ok.
Checking ‘proper-umask’... ok.
Checking ‘gcc’... ok.
Checking ‘working-gcc’... ok.
Checking ‘g++’... ok.
Checking ‘working-g++’... ok.
Checking ‘ncurses’... ok.
Checking ‘perl-data-dumper’... ok.
Checking ‘perl-findbin’... ok.
Checking ‘perl-file-copy’... ok.
Checking ‘perl-file-compare’... ok.
Checking ‘perl-thread-queue’... ok.
Checking ‘tar’... ok.
Checking ‘find’... ok.
Checking ‘bash’... ok.
Checking ‘xargs’... ok.
Checking ‘patch’... ok.
Checking ‘diff’... ok.
Checking ‘cp’... ok.
Checking ‘seq’... ok.
Checking ‘awk’... ok.
Checking ‘grep’... ok.
Checking ‘egrep’... ok.
Checking ‘getopt’... ok.
Checking ‘stat’... ok.
Checking ‘unzip’... ok.
Checking ‘bzip2’... ok.
Checking ‘wget’... ok.
Checking ‘install’... ok.
Checking ‘perl’... ok.
Checking ‘python2-cleanup’... ok.
Checking ‘python’... ok.
Checking ‘python3’... ok.
Checking ‘python3-distutils’... ok.
Checking ‘git’... ok.
Checking ‘file’... ok.
Checking ‘rsync’... ok.
Checking ‘which’... ok.
Prerequisite check failed. Use FORCE=1 to override.
make: *** [/home/hcat/Desktop/openwrt/include/toplevel.mk:180:staging_dir/host/.prereq-build] error 1

19.12.20214195Base systemBug ReportVery LowLowprocd does not generate parse syscall list on ARM/GLIBCTrunkUnconfirmed Task Description

Compiling master with GLIBC on arm fails in procd trying to compile the list of syscall names (see below) when SECCOMP is enabled. The list of syscall names is generated in procd by the make_syscall_h.sh script using the following sed expression:

sed -r -n -e ‘s/^\#define[ \t]+NR_([a-z0-9_]+)[ \t]+([ ()+0-9a-zNR_Linux]+)(.*)/ [\2] = “\1”,/p’ However, the list of syscalls generated in the arm kernel takes the following form: user_headers/include/asm/unistd-common.h:#define NR_exit (NR_SYSCALL_BASE + 1) which does not match the sed expression, as it does not accept all capital letters. The resulting lines become: [(NR_] = “waitid”,

I am not very familiar with the context, but SECCOMP is a new option which is enabled by default, as per https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=b118efa0d25f5b60226a9d316eb838dd6be22f78. Previously, in my builds at least, procd was not compiled with seccomp and no syscall list was generated. I could not find any suspicious recent changes and can’t see a way how the sed script could work, unless I’m missing something obvious. I am also not sure what “NR_Linux” is supposed to do in the sed pattern.

Please note that this is a glibc build.

My configuration is almost the default one, with the following added:

CONFIG_TARGET_sunxi=y
CONFIG_TARGET_sunxi_cortexa7=y
CONFIG_TARGET_sunxi_cortexa7_Default=y
CONFIG_LIBC_USE_GLIBC=y

The compilation errors look like this:

/home/openwrt/staging_dir/toolchain-arm_cortex-a7+neon-vfpv4_gcc-8.4.0_glibc_eabi/bin/arm-openwrt-linux-gnueabi-gcc -DEARLY_PATH=\”/usr/sbin:/usr/bin:/sbin:/bin\” -DSECCOMP_SUPPORT -Dpreload_seccomp_EXPORTS -Os -pipe -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -mfloat-abi=hard -fmacro-prefix-map=/home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45=procd-2021-11-23-01ac2c45 -Wformat -Werror=format-security -DPIC -fpic -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro -flto -DNDEBUG -fPIC -Os -ggdb -Wall -Werror –std=gnu99 -Wmissing-declarations -MD -MT CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o -MF CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o.d -o CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o -c /home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/seccomp-oci.c
In file included from /home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/seccomp-oci.c:36:
/home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/../syscall-names.h:3:4: error: ‘NR_’ undeclared here (not in a function)
[(
NR_] = “waitid”,

  ^~~~~

/m/vm/a-dev/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/../syscall-names.h:3:9: error: expected ‘)’ before ‘]’ token

[(__NR_] = "waitid",
 ~     ^
       )
 


19.12.20214194Base systemBug ReportVery LowLowprocd fails to compile with SECCOMP on armTrunkUnconfirmed Task Description

Compiling master with GLIBC on arm fails in procd trying to compile the list of syscall names (see below) when SECCOMP is enabled. The list of syscall names is generated in procd by the make_syscall_h.sh script using the following sed expression:

sed -r -n -e 's/^\#define[ \t]+NR_([a-z0-9_]+)[ \t]+([ ()+0-9a-zNR_Linux]+)(.*)/ [\2] = "\1",/p' However, the list of syscalls generated in the arm kernel takes the following form: user_headers/include/asm/unistd-common.h:#define NR_exit (NR_SYSCALL_BASE + 1) which does not match the sed expression, as it does not accept all capital letters. The resulting lines become: [(NR_] = "waitid",

I am not very familiar with the context, but SECCOMP is a new option which is enabled by default, as per https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=b118efa0d25f5b60226a9d316eb838dd6be22f78. Previously, in my builds at least, procd was not compiled with seccomp and no syscall list was generated. I could not find any suspicious recent changes and can't see a way how the sed script could work, unless I'm missing something obvious. I am also not sure what "NR_Linux" is supposed to do in the sed pattern.

Please note that this is a glibc build.

My configuration is almost the default one, with the following added:

CONFIG_TARGET_sunxi=y
CONFIG_TARGET_sunxi_cortexa7=y
CONFIG_TARGET_sunxi_cortexa7_Default=y
CONFIG_LIBC_USE_GLIBC=y

The compilation errors look like this:

/home/openwrt/staging_dir/toolchain-arm_cortex-a7+neon-vfpv4_gcc-8.4.0_glibc_eabi/bin/arm-openwrt-linux-gnueabi-gcc -DEARLY_PATH=\"/usr/sbin:/usr/bin:/sbin:/bin\" -DSECCOMP_SUPPORT -Dpreload_seccomp_EXPORTS -Os -pipe -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -mfloat-abi=hard -fmacro-prefix-map=/home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45=procd-2021-11-23-01ac2c45 -Wformat -Werror=format-security -DPIC -fpic -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro -flto -DNDEBUG -fPIC -Os -ggdb -Wall -Werror –std=gnu99 -Wmissing-declarations -MD -MT CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o -MF CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o.d -o CMakeFiles/preload-seccomp.dir/jail/seccomp-oci.c.o -c /home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/seccomp-oci.c
In file included from /home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/seccomp-oci.c:36:
/home/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/../syscall-names.h:3:4: error: 'NR_' undeclared here (not in a function)
[(
NR_] = "waitid",

  ^~~~~

/m/vm/a-dev/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_glibc_eabi/procd-default/procd-2021-11-23-01ac2c45/jail/../syscall-names.h:3:9: error: expected ')' before ']' token

[(__NR_] = "waitid",
 ~     ^
       )
 


19.12.20214193KernelBug ReportVery LowMediumsunxi-h5 kernel defconfigs missing CONFIG_RTC_DRV_SUN6I...TrunkUnconfirmed Task Description

The dtb that ships with openwrt contains for orangepi-pc2 contains the rtc device, i2c devices like the sy8106a voltage regulator, but they cannot be used in the kernel because this CONFIG_RTC_DRV_SUN6I=n so the i2c clock cannot be initialized.
I assume this is an oversight because it was not known that the RTC driver is required for i2c to work ? If i2c was not supposed to work, then drivers for sy8106a and also CPU_FREQ should also be =n to not waste space as they cannot be used.
Setting CONFIG_RTC_DRV_SUN6I=y in kernel_menuconfig allows i2c to be used, so cat /sys/kernel/debug/regulator/regulator_summary shows all the voltage regulators in the dtb, and with a small dtb patch (just adding the operational settings include to all h5 device dtbs that use sy8016a, like here https://github.com/armbian/build/blob/master/patch/kernel/archive/sunxi-5.10/sun50i-h5-add-cpu-opp-refs.patch), full DVFS can be enabled via cpufreq governors (which are already baked in) and it works perfectly.

19.12.20214192KernelBug ReportVery LowMediumsunxi-h5 kernel defconfigs missing CONFIG_RTC_DRV_SUN6I...TrunkUnconfirmed Task Description

The dtb that ships with openwrt contains for orangepi-pc2 contains the rtc device, i2c devices like the sy8106a voltage regulator, but they cannot be used in the kernel because this CONFIG_RTC_DRV_SUN6I=n so the i2c clock cannot be initialized.
I assume this is an oversight because it was not known that the RTC driver is required for i2c to work ? If i2c was not supposed to work, then drivers for sy8106a and also CPU_FREQ should also be =n to not waste space as they cannot be used.
Setting CONFIG_RTC_DRV_SUN6I=y in kernel_menuconfig allows i2c to be used, so cat /sys/kernel/debug/regulator/regulator_summary shows all the voltage regulators in the dtb, and with a small dtb patch (just adding the operational settings include to all h5 device dtbs that use sy8016a, like here https://github.com/armbian/build/blob/master/patch/kernel/archive/sunxi-5.10/sun50i-h5-add-cpu-opp-refs.patch), full DVFS can be enabled via cpufreq governors (which are already baked in) and it works perfectly.

19.12.20214191KernelBug ReportVery LowMediumsunxi-h5 kernel defconfigs missing CONFIG_RTC_DRV_SUN6I...TrunkUnconfirmed Task Description

The dtb that ships with openwrt contains for orangepi-pc2 contains the rtc device, i2c devices like the sy8106a voltage regulator, but they cannot be used in the kernel because this CONFIG_RTC_DRV_SUN6I=n so the i2c clock cannot be initialized.
I assume this is an oversight because it was not known that the RTC driver is required for i2c to work ? If i2c was not supposed to work, then drivers for sy8106a and also CPU_FREQ should also be =n to not waste space as they cannot be used.
Setting CONFIG_RTC_DRV_SUN6I=y in kernel_menuconfig allows i2c to be used, so cat /sys/kernel/debug/regulator/regulator_summary shows all the voltage regulators in the dtb, and with a small dtb patch (just adding the operational settings include to all h5 device dtbs that use sy8016a, like here https://github.com/armbian/build/blob/master/patch/kernel/archive/sunxi-5.10/sun50i-h5-add-cpu-opp-refs.patch), full DVFS can be enabled via cpufreq governors (which are already baked in) and it works perfectly.

19.12.20214190KernelBug ReportVery LowMediumsunxi-h5 kernel defconfigs missing CONFIG_RTC_DRV_SUN6I...TrunkUnconfirmed Task Description

The dtb that ships with openwrt contains for orangepi-pc2 contains the rtc device, i2c devices like the sy8106a voltage regulator, but they cannot be used in the kernel because this CONFIG_RTC_DRV_SUN6I=n so the i2c clock cannot be initialized.
I assume this is an oversight because it was not known that the RTC driver is required for i2c to work ? If i2c was not supposed to work, then drivers for sy8106a and also CPU_FREQ should also be =n to not waste space as they cannot be used.
Setting CONFIG_RTC_DRV_SUN6I=y in kernel_menuconfig allows i2c to be used, so cat /sys/kernel/debug/regulator/regulator_summary shows all the voltage regulators in the dtb, and with a small dtb patch (just adding the operational settings include to all h5 device dtbs that use sy8016a, like here https://github.com/armbian/build/blob/master/patch/kernel/archive/sunxi-5.10/sun50i-h5-add-cpu-opp-refs.patch), full DVFS can be enabled via cpufreq governors (which are already baked in) and it works perfectly.

17.12.20214189Base systemBug ReportVery LowMediumDHCP server detection in dnsmasq init script is unrelia...AllUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on: various
- Software versions of OpenWrt/LEDE release, packages, etc.: various

============ Context

dnsmasq.init, as shipped in OpenWrt (any version I can find including master), tries to detect active DHCP servers on the network before configuring dnsmasq as a DHCP server.

============ Short

The 3 second udhcpc timeout in dnsmasq.init is too short and is likely to not notice another dnsmasq running on the same LAN.

============ Long
This happens with the following line in dnsmasq.init:

      udhcpc -n -q -s /bin/true -t 1 -i "$ifname" >&- && rv=1 || rv=0

with these options, udhcpc gives up after 3 seconds if no response is received.

However, dnsmasq, with default settings (*not* passing –5/–no-ping), will ICMP ping probe an address before it hands it out. The timeout for that is “two to three seconds” - see “Q: Does the dnsmasq DHCP server probe addresses before allocating them, as recommended in RFC2131?” at https://thekelleys.org.uk/dnsmasq/docs/FAQ . This text also mentions that dnsmasq can only probe one address at a time, and thus only handle one DHCP request at a time. This means that it is very easy for the udhcpc call to falsely timeout because dnsmasq was not responding, or not responding quickly enough.

I noticed this in practice on a network with two dnsmasqs already running. The third one would randomly end up with DHCP enabled or disabled, depending on whether udhcpc timed out, or got a lease in just under 3 seconds.

============ What to do

Increase the udhcpc timeout?

Remove the whole check, as it is unreliable, and thus might surprise a user two weeks from now?

16.12.20214188PackagesBug ReportVery LowLowlibwolfssl can't authenticate ip address ssl certificat...openwrt-21.02Unconfirmed Task Description

Recently I found that the libwolfssl could not authenticate some ip address ssl certificates.A strange thing is that some URLs(like https://1.1.1.1/) can be authenticated successfully, but others cannot(like https://223.5.5.5/),and it just happen on my mt7621 router Xiaomi Redmi AC2100 but cannot be reproduced on ipq4019 router MobiPromo CM520-79F.

And then i dig deeper into the source code and found the bug.

https://raw.githubusercontent.com/wolfSSL/wolfssl/v4.8.1-stable/src/internal.c

In line 10097,macro XSNPRINTF would expand to snprintf,and altName→name[i] has a char type.
on different platforms,char is not alway unsigned,if altName→name[i] is signed char and is larger than 127,it will then be convert into unsigned int incorrectly and print the wrong string.

The problem seems be sloved in wolfssl v5.0 because i saw some changes of relevant code,but the wolfssl in openwrt 21.02 is still v4.8.1-stable.I think maybe we can either upgrade the package or add a path to exist code?

15.12.20214187KernelBug ReportVery LowHighmediatek,mt7621-gpio driver register conflict irq numbe...openwrt-21.02Unconfirmed Task Description

This bug was test on a custom MT7621 board, but I think ubnt,edgerouter-x-sfp also affected.

when we have a node in DT with interrupt-parent = <&gpio> will trigger the bug.
My board:

	expender0: pcf8574a@38 {
		compatible = "nxp,pcf8574a";
		reg = <0x38>;
		interrupt-parent = <&gpio>;
		interrupts = <15 IRQ_TYPE_EDGE_FALLING>;
		gpio-controller;
		#gpio-cells = <2>;
		interrupt-controller;
		#interrupt-cells = <2>;
	};

ubnt,edgerouter-x-sfp:

	expander0: pca9555@25 {
		compatible = "nxp,pca9555";
		interrupt-parent = <&gpio>;
		interrupts = <8 IRQ_TYPE_EDGE_FALLING>;
		gpio-controller;
		#gpio-cells = <2>;
		reg = <0x25>;
	};

This bug will cause the sfp driver can’t detect module insert.

In gpio-mt7621.c:245 every bank’s parent is the driver itself, and direct call devm_gpiochip_add_data in :279.

This lead to an unexpected behavior: all three banks register IRQ 0~31 to kernel.
And the DT will always fetch the latest bank (bank2) as IRQ sink.
This can confirm by:

 1. setting interrupt = <32 0>; kernel will report too large IRQ.
 2. some additional printk in kernel
 3. an ugly workaround
14.12.20214186Base systemBug ReportVery LowLowInstalling kmod package kills ipvsadmopenwrt-21.02Unconfirmed Task Description

Tested in Openwrt 21.02.0 and 21.02.1 x86_64 general.

Running in ESXI and Virtualbox.

Uninstalling the kmod package instantly fixes the problem without reboot.

The following error is presented:

modprobe: FATAL: Module ip_vs not found in directory /lib/modules/5.4.143
Can’t initialize ipvs: Protocol not available
Are you sure that IP Virtual Server is built in the kernel or as module?

The file is in place, the kernel cannot find the file for what ever reason.

13.12.20214185Base systemBug ReportVery LowLowDeauthentication of clients due to inactivity TrunkUnconfirmed Task Description

I have followed the instructions here, however, this still does not fix my issue. I have updated all packages to the latest version in hopes that would fix the problem somehow but to no avail. I have also taken a look at this bug report and removed the country option, that still didnt fix the issue.

DEVICE INFO

Device: Linksys WRT1900ACS
OpenWRT Version: 21.02.1 r16325-88151b8303
Architecture: arm_cortex-a9_vfpv3-d16

SYSTEM LOGS

Mon Dec 13 14:04:52 2021 kern.debug kernel: [163686.092909] ieee80211 phy0: Mac80211 start BA [REDACTED MAC ADDRESS]
Mon Dec 13 14:12:15 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [REDACTED MAC ADDRESS]
Mon Dec 13 14:12:15 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: disassociated
Mon Dec 13 14:12:16 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Mon Dec 13 14:12:20 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: authenticated
Mon Dec 13 14:12:20 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: associated (aid 6)
Mon Dec 13 14:12:20 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [REDACTED MAC ADDRESS]
Mon Dec 13 14:12:20 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Dec 13 14:12:22 2021 kern.debug kernel: [164136.819439] ieee80211 phy0: Mac80211 start BA [REDACTED MAC ADDRESS]
Mon Dec 13 14:14:29 2021 kern.debug kernel: [164263.124592] ieee80211 phy0: Mac80211 start BA d2:a8:7e:c1:97:0b
Mon Dec 13 14:15:04 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [REDACTED MAC ADDRESS]
Mon Dec 13 14:15:04 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: disassociated
Mon Dec 13 14:15:05 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Mon Dec 13 14:15:08 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: authenticated
Mon Dec 13 14:15:08 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] IEEE 802.11: associated (aid 6)
Mon Dec 13 14:15:08 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [REDACTED MAC ADDRESS]
Mon Dec 13 14:15:08 2021 daemon.info hostapd: wlan0: STA [REDACTED MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Dec 13 14:15:09 2021 kern.debug kernel: [164303.439120] ieee80211 phy0: Mac80211 start BA 
[REDACTED MAC ADDRESS]
 
Showing tasks 1 - 50 of 1427 Page 1 of 291 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing