OpenWrt/LEDE Project

Welcome to the OpenWrt/LEDE Project bug reporting and issue tracking system

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to lede-bugs@infradead.org.

OpenedIDCategoryTask TypePrioritySeveritySummaryReported InStatus
18.06.20192328Base systemBug ReportHighMediumAllocate resources to sort out odhcpd/dnsmasq interacti...TrunkNew Task Description

As IPv6 is being adopted, increasingly people are seeing dnsmasq log ‘spam’. See https://bugs.openwrt.org/index.php?do=details&task_id=1492&string=1492&search_name=&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

By default under openwrt, dhcpv4 leases are handled by dnsmasq whilst dhcpv6/RA is handled by openwrt’s odhcpd.

odhcpd could handle both v4 & v6 but does not yet have the same configuration flexibility for dhcp options as dnsmasq. I guess this is why no one has been brave enough to switch to odhcpd for ipv4 operations as well as ipv6.

dnsmasq can also handle dhcpv6/RA but not quite as flexibly as odhcpd. dnsmasq will automatically find IP6 prefixes on interfaces and start handling them, whilst openwrt’s strategy with odhcpd is to only handle stuff we tell you to handle, don’t do it automagically.

As dnsmasq is the default resolver for openwrt and the wider LAN, it needs to know about DHCP/hostname allocations. For DHCPv4 this is easy, dnsmasq is controlling them. For DHCPv6 a hosts file (called a statefile in the odhcpd code) is handed to dnsmasq.

By default this host file is not read dynamically, so odhcpd has to signal dnsmasq to re-read the host file (and clear caches etc etc) upon every ipv6 lease change.

This generates a lot of log spam and process startup overhead. There are also questions about service operability during this time.

Effort needs to be put into sorting this out.

Temporary workarounds:

Use ‘hostsdir’ dnsmasq option instead of ‘addn-hosts’ - dnsmasq will dynamically scan changes/additions to hosts in hostsdir whereas addn-hosts needs a SIGHUP. Host deletions cannot be handled by this method, so odhcpd would still need to SIGHUP on lease expiry. It might reduce some of the spam.

Longer term:

Teach dnsmasq to accept hostname updates over an IPC mechanism. ubus? and carry on using odhcpd for ipv6.

Teach dnsmasq to handle ipv6 prefix additions/deletions/handling via an IPC mechanism in the same way as odhcpd. Drop odhcpd and use dnsmasq for everything.

Use odhcpd for everything and use another dns resolver that interfaces nicely with odhcpd.

Why don’t I see this problem: I use dnsmasq to handle ipv6 but I’m lucky enough that this works for me.

This needs fixing/funding to sort it out though.

18.06.20192327Base systemBug ReportMediumLow/boot mounted multiple timesTrunkNew Task Description

Supply the following if possible:
- Device problem occurs on- seen on x86 APU2 - may be others.
- Software versions of OpenWrt master
- Steps to reproduce - boot system

root@Router:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 14080 14080 0 100% /rom
tmpfs 2011892 156 2011736 0% /tmp
/dev/loop0 246016 15140 161244 9% /overlay
overlayfs:/overlay 246016 15140 161244 9% /
/dev/sda1 16112 4172 11616 26% /boot
/dev/sda1 16112 4172 11616 26% /boot
tmpfs 512 0 512 0% /dev
root@Router:/etc/config# block info
/dev/loop0: UUID=”cbbd153a-60b0-40e0-800e-b79833957b9f” VERSION=”1.12” MOUNT=”/overlay” TYPE=”f2fs” /dev/sda1: UUID=”57f8f4bc-abf4-655f-bf67-946fc0f9f25b” VERSION=”1.0” MOUNT=”/boot” TYPE=”ext4” /dev/sda2: UUID=”b9caa0dd-b7eb255f-2c2775da-3aa40e49” VERSION=”4.0” MOUNT=”/rom” TYPE=”squashfs” /dev/sda3: UUID=”e92b8416-fe49-409b-a4cf-c71476027159” VERSION=”1.12” MOUNT=”/mnt/sda3” TYPE=”f2fs” root@Router:/etc/config# cat /etc/config/fstab

config global

option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '5'
option check_fs '1'

config mount

option target '/mnt/loop0'
option uuid 'dd87006a-ba8e-44f4-a40b-f2cb6181dc4e'
option enabled '0'

config mount

option target '/mnt/sda1'
option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b'
option enabled '0'

config mount

option target '/mnt/sda2'
option uuid '8a1c0748-3d6b7bd1-0192e5c4-7fe0165c'
option enabled '0'

config mount

option target '/mnt/sda3'
option uuid 'e92b8416-fe49-409b-a4cf-c71476027159'
option enabled '1'

root@Router:/etc/config# uname -a
Linux Router 4.14.126 #0 SMP Tue Jun 18 09:45:23 2019 x86_64 GNU/Linux


19.06.20192331Base systemFeature RequestVery LowLowPackage request: libbpf packageTrunkUnconfirmed Task Description

Needed for many types of eBPF usage: https://github.com/libbpf/libbpf

19.06.20192330PackagesBug ReportVery LowHighSamba - smb.conf templating allows arbitrary injections...AllUnconfirmed Task Description

First, I have to say I’m not 100% sure it is something to be addressed within samba package itself, so forgive me if this is something you have already evaluated as not being an issue.

In short, something like that works:

 […]
    option workgroup 'WORKGROUP\
    security = share\
    guest account = root\
    interfaces = lo br-lan\
\
[ohnonotagain]'

I’m not sure this works in plain openwrt images, but there exists a widely deployed commercial fork of openwrt which is definitely vulnerable to some exploit chain involving this one in the middle.
You could argue that the right of modifying uci config already gives an equivalent authorization level, or this should have been sanitized at user interface. So, is this something you consider safe?

19.06.20192329Base systemBug ReportVery LowMediumopenvpn: Options error: You must define TUN/TAP device ...openwrt-18.06Unconfirmed Task Description

Hi!

Installation of OpenWrt 18.06.2 On Linksys E900 router.
Nothing extraordinary in relation to flashing and initial configuration.

Configure first lan port as a connection towards the internal network. Everything working as expected.
Installed openvpn-openssl. Tried to configure it and ran into the error “Options error: You must define TUN/TAP device (–dev)”.

Nothing I tried resulted in disappearance of that error message.

Below are relevant configuration snippets.

/etc/config/network
config interface ‘loopback’ option ifname ‘lo’ option proto ‘static’ option ipaddr ‘127.0.0.1’ option netmask ‘255.0.0.0’

config globals ‘globals’ option ula_prefix ‘fdd3:5676:7153::/48’

config interface ‘lan’ option type ‘bridge’ option ifname ‘eth0.1’ option proto ‘static’ option netmask ‘255.255.255.0’ option ipaddr ‘192.168.100.2’ option dns ‘192.168.100.1’ option gateway ‘192.168.100.1’ option delegate ‘0’

config interface ‘wan’ option ifname ‘eth0.2’ option proto ‘dhcp’ option auto ‘0’

config interface ‘wan6’ option ifname ‘eth0.2’ option proto ‘dhcpv6’ option auto ‘0’

config switch
option name ‘switch0’ option reset ‘1’ option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’ option vlan ‘1’ option ports ‘0 1 2 3 5t’

config switch_vlan
option device ‘switch0’ option vlan ‘2’ option ports ‘4 5t’

config interface ‘vpn’ option proto ‘none’ option ifname ‘tun0’ option auto ‘1’

/etc/config/openvpn
config openvpn ‘udp1194’ option keepalive ‘10 60’ option server ‘192.168.168.0 255.255.255.0’ option persist_tun ‘1’ option persist_key ‘1’ option tls_auth ‘/etc/openvpn/ta.key’ option ca ‘/etc/openvpn/ca.crt’ option cert ‘/etc/openvpn/server.crt’ option key ‘/etc/openvpn/server.key’ option dh ‘/etc/openvpn/dh.pem’ option key_direction ‘0’ list push ‘redirect-gateway def1’ list push ‘dhcp-option DNS 8.8.4.4’ list push ‘dhcp-option DNS 8.8.8.8’ list push ‘block-outside-dns’ option cipher ‘AES-256-CBC’ option auth ‘SHA256’ option proto ‘udp’ option port ‘1194’ option enabled ‘1’ option verb ‘9’ option log_append ‘/tmp/openvpn-udp1194.log’ option dev ‘tun’

Thank you very much in advance.

 


18.06.20192326KernelBug ReportVery LowMediumpage_owner=on doesn't work on Firefly FireWRTopenwrt-18.06Unconfirmed Task Description
  1. use ‘make kernel_menuconfig’ to configure page_owner function and add page_owner=on to kernel boot cmdline
  1. compile, and update the Firefly FireWRT board
  1. login into the system, cat ‘/sys/kernel/debug/page_owner’, no output
17.06.20192324PackagesBuild FailureVery LowMediumPackages corrupt or emptyAllUnconfirmed Task Description

Supply the following if possible:
- TL-WR841N v13
- latest snapshot from ‘http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/’ - Trying to install ‘luci’ via opkg, getting:

Unknown package ‘luci’.
Collected errors:
* opkg_install_cmd: Cannot install package luci.

Checked the ‘mipsel_24kc’ folder and it has empty/corrupt files which would account for the issue: http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/

16.06.20192322KernelBug ReportVery LowCriticalLinksys 1900V2 compile kernel 4.14.125 brokenTrunkUnconfirmed Task Description

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 


15.06.20192321Base systemBug ReportVery LowMediumKernel Panic after enabling hardware offloading - EdgeR...TrunkUnconfirmed Task Description
  • Device: Ubiquiti EdgeRouter X (ramips mt7621)
  • Software: LuCI Master (f138fc93) / OpenWrt SNAPSHOT r10210-09c6885
  • Steps to reproduce: enable hardware flow offloading

Brief description:
Enabling hardware flow offloading causes kernel oops/panic, resulting in device rebooting. The device remains in a bootloop.
Hard powercycle does not resolve the kernel panic.

Steps taken to resolve the issue:
Powering the device off, disconnecting all rj45 ports then reconnecting a single rj45 cable allows to disable the hardware offload. As the hardware offload is no longer active, the issue stops from happening.

Crash logs:
https://bugs.openwrt.org/index.php?do=details&task_id=1837

Additional information:
The issue was not present prior to this snapshot. Packet capture on a device connected to eth1 port did not reveal anything strange. There was a broadcast message sent from the router to UPD port 4919 stating

Please press button now to enter failsafe

. Presumably this is a normal part of the boot-up process.


14.06.20192320OtherBug ReportVery LowLowu-Boot OpenWrt 18.06.2 on sama5d31 Unimplemented compre...TrunkUnconfirmed Task Description

Hi,
after building 18.06.2 OpenWrt version and his nand flash u-boot (U-Boot 2017.03-linux4sam_5.8 (Jan 30 2019 - 12:21:02 +0000)) when u-boot try to uncompress lzma kernel image the following error is reached

 

Uncompressing Kernel Image ... Unimplemented compression type 3

the log:

AT91Bootstrap 3.8.10 (Tue Jun 11 17:58:40 UTC 2019)

NAND: ONFI flash detected
NAND: Manufacturer ID: 0x2c Chip ID: 0xda
NAND: Page Bytes: 2048, Spare Bytes: 64
NAND: ECC Correctability Bits: 4, ECC Sector Bytes: 512
NAND: Disable On-Die ECC
NAND: Initialize PMECC params, cap: 4, sector: 512
NAND: Image: Copy 0xa0000 bytes from 0×40000 to 0x26f00000
NAND: Done to load image
<debug_uart>

U-Boot 2017.03-linux4sam_5.8 (Jan 30 2019 - 12:21:02 +0000)

CPU: SAMA5D31
Crystal frequency: 12 MHz CPU clock : 528 MHz Master clock : 132 MHz DRAM: 256 MiB
NAND: 256 MiB
MMC: Atmel mci: 0, Atmel mci: 1
In: serial@ffffee00
Out: serial@ffffee00
Err: serial@ffffee00
Net:
Error: ethernet@f0028000 address not set.
No ethernet found.
Hit any key to stop autoboot: 0

NAND read: device 0 offset 0×180000, size 0×80000 524288 bytes read: OK

NAND read: device 0 offset 0×200000, size 0×600000 6291456 bytes read: OK
## Booting kernel from Legacy Image at 22000000 ...

 Image Name:   ARM OpenWrt Linux-4.9.152
 Image Type:   ARM Linux Kernel Image (lzma compressed)
 Data Size:    3016433 Bytes = 2.9 MiB
 Load Address: 20008000
 Entry Point:  20008000
 Verifying Checksum ... OK

## Flattened Device Tree blob at 21000000

 Booting using the fdt blob at 0x21000000
 Uncompressing Kernel Image ... Unimplemented compression type 3

Checking into u-boot (make menuconfig) seems that lzma cannot be set , only LZ4 is provided.

Also the option to change compression type of the kernel do not work. I try to switch from default (gzip) to LZ4 but kernel uimage is always lzma compressed.

Could you provide some hint to unlock the situation ?

Another strange things is :

Error: ethernet@f0028000 address not set.
No ethernet found.

f0028000 is memory address of GMAC that is not provided in sama5d31 SoC but the curious is the next No ethernet found.

Does it mean that nor EMAC was found ?

Thanks in advance
Best
Fabio


14.06.20192319PackagesBug ReportVery LowHighusbmode bug which is fixed in usb-modeswitch...openwrt-18.06Unconfirmed Task Description

I wrote a bug report but then the bug report said wrong token and I lost the report... :(

Now again but shorter version. The usb-modeswitch (which seems to be an openwrt project, a rewrite of original usb_modeswitch https://git.openwrt.org/project/usbmode.git ) needs to set some devices to config 0 before switching to config 3.

BTW this is fixed in usb-modeswitch... Here is the link to discussion about this:
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=2710&start=22

Some devices need to be set to config 0 first to be able to switch to config 3. Otherwise they hang...

Here a working example:

root@OpenWrt:~# echo 0 > /sys/bus/usb/devices/1-2/bConfigurationValue
root@OpenWrt:~# echo 3 > /sys/bus/usb/devices/1-2/bConfigurationValue
root@OpenWrt:~# umbim -d /dev/cdc-wdm0 caps

devicetype: 0001 - embedded
cellularclass: 0001
voiceclass: 0001 - no-voice
simclass: 0002
dataclass: 8000003F
smscaps: 0003
controlcaps: 0001
maxsessions: 0003
deviceid: 867377023108313
firmwareinfo: 11.617.06.00.00
hardwareinfo: RM1ME909ASM

root@OpenWrt:~#

A non-working example (after reboot):

root@OpenWrt:~# echo 3 > /sys/bus/usb/devices/1-2/bConfigurationValue
root@OpenWrt:~# umbim -d /dev/cdc-wdm0 caps
ERROR: mbim message timeout
root@OpenWrt:~#

At least one other person in OpenWRT bug tracker confirms this:
https://bugs.openwrt.org/index.php?do=details&task_id=1424

Although he has another problem with looping messages (probably unrelated to this bug)
https://forum.openwrt.org/t/usbmode-sits-in-loop-after-install/12624

14.06.20192318PackagesBug ReportVery LowMedium[busybox sysntpd] server not suitable for synchronizati...openwrt-18.06Unconfirmed Task Description

- Software versions of OpenWrt/LEDE release
18.06

- packages, etc.
* bysubox 1.28.4-3.13
* ntpdate 4.2.8p11-1.13
* ntp-utils 4.2.8p11-1.13

- setting
* etc/config/system

config timeserver 'ntp'
	option enabled '1'
	option enable_server '1'

- Steps to reproduce
install ntpdate and ntp-utils


ntpq -p

localhost: timed out, nothing received
***Request timed out

ntpdate localhost

ntpdate no server suitable for synchronization found

whilst in comparison

ntpdate 0.openwrt.pool.ntp.org

ntpdate: adjust time server 5.103.139.163 offset 0.000341 sec

 
ntpdate -q localhost

server ::1, stratum 2, offset 0.000013, delay 0.02769
server 127.0.0.1, stratum 2, offset 0.000006, delay 0.02766
14 Jun 10:40:12 ntpdate[2460]: adjust time server 127.0.0.1 offset 0.000006 sec

Showing tasks 1 - 12 of 12 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing