OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by alik trumkin - 29.08.2017
Last edited by Jo-Philipp Wich - 14.02.2018

FS#991 - untagged vlan do not work on mt7620

Supply the following if possible:
- Device Asus RT-N14U
- Software LEDE Reboot 17.01.2 r3435-65eec8bd5f
- Steps to reproduce:
when I add an untagged port with an id different from 2 or 1 it does not work, does not ping the interface
but the router pings if the port is a tagged, but does not ping the device that is connected to the untagged port
Everything works if the VLAN ID 2, but does not work with any other value

 


Closed by  Jo-Philipp Wich
14.02.2018 15:46
Reason for closing:  Fixed
Alex Maclean commented on 29.08.2017 20:06

I can confirm there's an issue here - PVID is not correctly set. In your case, you've configured VLAN 5, but PVID will get set to 3 (the VLAN group ID). VLAN 3 should work for you.

This seems to be a uci and/or luci issue, depending on how you look at it. Some drivers fix it up.

Routing Route commented on 10.02.2018 16:53

Maybe see if it is like  FS#1341  - vlan configuration fails, trying the workaround.

Admin
Jo-Philipp Wich commented on 14.02.2018 15:46

Fixed with https://git.openwrt.org/341b1427fc (ramips: properly map pvid for vlans with remapped vid on mt7530/762x switches)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing