OpenWrt/LEDE Project

  • Status Researching
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Baptiste Jonglez - 15.07.2017

FS#908 - x86: Xen support broken in 17.01.2 and later

Testing the x86/generic image with Xen 4.5:

  • 17.01.0: works
  • 17.01.1: works
  • 17.01.2: fails to boot
  • latest lede-17.01 r3466-f6907dcc79: fails to boot
  • latest trunk r4553-a89c36b: works

When the kernel fails to boot, xl prints this:

xc: error: elf_xen_note_check: ERROR: Will only load images built for the generic loader or Linux images (Not '' and ''): Invalid kernel
libxl: error: libxl_dom.c:414:libxl__build_pv: xc_dom_parse_image failed: No such file or directory
libxl: error: libxl_create.c:1024:domcreate_rebuild_done: cannot (re-)build domain: -3

It means that the kernel image has no Xen support (or there is an issue with the support).

Given the changes between 17.01.1 and 17.01.2, I think the patch adding PAE support may be responsible.

This was first reported in FS#787.

Baptiste Jonglez commented on 15.07.2017 19:18

As expected, I bisected it back to af1d1ebdda59602cbb61c84a103a1149a054a1b4 (""x86: enable 4G high memory support for generic (32bit) subtarget)

Baptiste Jonglez commented on 15.07.2017 21:01

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing