OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Grunt Gruntrucksson - 27.06.2017
Last edited by Petr Štetiar - 16.05.2019

FS#872 - Release image will brick Archer C7 v1.1

- Device problem occurs on: TP-Link Archer C7 v1.1
- Software versions of LEDE release, packages, etc: - Steps to reproduce: trying to re-flash router with lede-17.01.2-ar71xx-generic-archer-c7-v1-squashfs-factory.bin image will result in bricked router stuck in reboot loop. I tried flashing from both factory image (from factory firmware) and sysupgrade image (from OpenWRT using both SSH and web interface). Both images result in bricked router.

Unbricking was done by forcing router into failsafe mode, SSH:in into it and uploading/flashing old firmware via NC from a PC.

I suggest pulling this image from a list of supported images for Archer C7 v1.1, until issues have been solved. Otherwise, it might result in bricked equipment.

Closed by  Petr ┼átetiar
16.05.2019 07:55
Reason for closing:  Fixed
Additional comments about closing:  

https://git.o;a=comm it;h=34113999ef430ce74a627ab6e6a5370aa41 c9d20

f00b4r0 commented on 27.10.2017 20:27

This image appears to have a broken layout:

Kernel data offset     : 0x00000200 /      512 bytes
Kernel data length     : 0x00132de4 /  1256932 bytes
Rootfs data offset     : 0x00100000 /  1048576 bytes
Rootfs data length     : 0x0027c30a /  2605834 bytes

The rootfs overlaps the kernel. PR#1467 has been opened with a possible fix

zless commented on 06.08.2018 09:19

I opened a new ticket for the OpenWRT 18.06 and the same Archer C7 v1.1:

psyborg commented on 23.04.2019 15:42


Available keyboard shortcuts


Task Details

Task Editing