OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Christophe - 10.08.2016
Last edited by Baptiste Jonglez - 14.05.2021

FS#84 - sysntp does not resolves IPv6 when IPv6 only stack

sysntp (busybox ntp) does not resolve IPv6 addresses when the machine is IPv6 stack based only.

proposed solution exist:

https://dev.openwrt.org/attachment/ticket/12167/0001-busybox-make-ntpd-prefer-IPv6-addresses.patch

http://lists.busybox.net/pipermail/busybox/2016-August/084529.html

Already reported in

https://github.com/lede-project/source/issues/249

Closed by  Baptiste Jonglez
14.05.2021 14:07
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in https:/ /git.openwrt.org/7fea9d9f5dd282a7049d77c c6b75e0a703ead26c

Christophe commented on 16.08.2016 06:33

OK so after the answer of Busybox people :

http://lists.busybox.net/pipermail/busybox/2016-August/084536.html

and a discussion with blogic it seems the best solution would be to have some kind of way to tell caching DNS dnsmasq to return the IPv6 record first

Christophe commented on 17.08.2016 08:12

Ok so this can be closed the problem is not with sysntp it is with openwrt default NTP servers.

using :

config timeserver ntp
        list server     ntp.ap.sixxs.net 
        list server     ntp.us.sixxs.net 
        list server     ntp.eu.sixxs.net 
        list server     ntp.sixxs.net 
        option enabled 1
        option enable_server 0

works fine

SimonIremonger commented on 28.12.2020 20:02

The NTP servers now certainly contain ipv6 addresses, but ntpd/OpenWRT isn't trying them, from what I can tell, even if explicitly call ntpd manually on 2.openwrt.pool.ntp.org ...

SimonIremonger commented on 11.01.2021 08:27

This is a real issue, expreinceding this even in OpenWRT master 2020-12-28 version.
2.openwrt.pool.ntp.org has AAAA pointers but busybox ntpd just isn’t attempting ipv6 at all, even if system doesn’t have IPv4-route at all.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing