OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by 李鹏 - 23.05.2017
Last edited by Mathias Kresin - 27.02.2018

FS#800 - ath9k sta and ap mode change. system hang

mips device with ar9580 wireless card sta and ap mode change by use
while [ 1 ]
mv /etc/config/wireless /etc/config/wirelessbak
mv /etc/config/wireless1 /etc/config/wireless
mv /etc/config/wirelessbak /etc/config/wireless1
/etc/init.d/network restart
sleep 50

I found the system will hang , It like a deadlock but I can’t verify

Use the same shell I change the ath9k code

just delete the full sleep timer

modify ath9k_ps_wakeup ath9k_ps_restore
delete mod_timer(&sc→sc_pm_lock,flags);
detete del_timer_sync(&sc→sc_pm_lock);
The system run ok


Closed by  Mathias Kresin
27.02.2018 16:13
Reason for closing:  No response
李鹏 commented on 05.06.2017 02:16

i have test OpenWRT 15.05.1, LEDE 17.01.0 . I get the same result may this is a ath9k bug , My board is Dual Core Processor, I guess the reason may is the timer del in dual core processor ,Somebody can analysis why? thanks

李鹏 commented on 14.06.2017 02:52

Does someboby konw why? Beacuase the system hang ,I get any hint about this problem. I just try . The I found it was the timer , Even In the timer function , do nothing , I got the same result.
the system hang. So I get the result I just delete the timer . The system is ok . But I can.t understand why . So can anyone explain the reason , I timer can cause the systme hang

Project Manager
Felix Fietkau commented on 10.07.2017 08:04

Pleaes try a newer version, either 17.01.2 or a current snapshot.

李鹏 commented on 24.07.2017 09:32

Felix Fietkau My project update from OpenWRT 15.05.1 to LEDE 17.01.0 , I get the same result. We can not update again. As I metion ,I delete some timer .It worked good . but I do not know why ,So
I want somebody can expain it

Project Manager
Felix Fietkau commented on 24.07.2017 09:37

I think this issue should be fixed in a newer version. If you can't test this, I will have to close this ticket.


Available keyboard shortcuts


Task Details

Task Editing