OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Sven Roederer - 15.05.2017

FS#787 - no console in Xen-DomU guests

after upgrading my Xen-domU-guest to v17.01.1 I found the console is not working anymore. I can only get the kernellog-output.

My old working system was based on git-c71e13a. I checked V17.01-rc1 which is also broken. Further bisecting gave git-b36e24f39e63 (x86: remove the xen_domu subtarget) causing this.

So it looks like some kernel-options are missing, after this merge of sub-targets. I did not find in the kernel-config the relevant.

my domU-config is as follows:

memory = 64
name = “lede-test” on_crash = “destroy” vif = [ “mac=02:00:0a:ff:00:01, bridge=br-lan” ]

bootloader = ‘/usr/lib/xen-4.4/bin/pygrub’ disk = [”/mnt/xen-images/openwrt/lede-x86-generic-combined-ext4.img,raw,xvda,w”]

Any Ideas?

Ian MacDonald commented on 12.07.2017 19:20

I also experienced this. Looking to migrate some great NFV functions from OpenWRT to LEDE.

On 17.01.0 (59508e3) and current snapshot (a89c36b) we see this with no console:
[ 5.479550] genirq: Flags mismatch irq 15. 00000000 (hvc_console) vs. 00000000 (pata_legacy.1)
[ 5.479656] hvc_open: request_irq failed with rc -16.

Unfortunately 17.01.2 does not have domu extensions resulting in
xc: error: elf_xen_note_check: ERROR: Will only load images built for the generic loader or Linux images (Not and ): Invalid kernel

The best I can come up with will be to manually mount the images and pre-config to get them online. Trying to avoid any more older CC15.05 builds.

Ian MacDonald commented on 12.07.2017 19:37

Also, for anyone looking to mount the 17.01.0 or 17.01.1 images to pre-config, you can use similar. They have the same offset for the second (root) partition.

mount -o loop,rw,offset=17301504 lede-17.01.0-r3205-59508e3-x86-generic-combined-ext4.img /tmp/ian

Baptiste Jonglez commented on 15.07.2017 17:51

I have just submitted a patch to fix the serial console: http://patchwork.ozlabs.org/patch/788954/

The second issue (broken Xen support in 17.01.2) is unrelated, let's move to FS#908.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing