OpenWrt/LEDE Project

  • Status Assigned
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Álvaro Fernández Rojas
    David Xie
  • Operating System All
  • Severity Medium
  • Priority Medium
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Thomas Ganter - 08.04.2017
Last edited by Álvaro Fernández Rojas - 23.04.2017

FS#692 - WLAN AP not working on RasPi (bcm2710 target)

When flashing the brcm2708 / bcm2710 target the WiFi interface gets stuck in “client mode” and the AP will not be able to be brought up.

Some screenshots and a load of discussion here:

Two more days of tinkering, wifi-up’ing and -down’ing did not bring me further.
I flashed another Pi3 (to exclude a hardware defect) with the same result.

I tried latest snapshot and stable images.
I am happy to help debug – tell me what you need me to do.


Huan LI commented on 13.04.2017 07:16

I was experiencing the same issue in the past two days.

I feel this is a old bug of OpenWrt because I had met it before. But the latest version of OpenWrt seems resolved this problem.

Bastian Bittorf commented on 13.04.2017 09:13
Arun commented on 16.04.2017 23:53

I hit the same issue today, when I make the 64 bit image for RPI3 from master.

I don't see this issue when I use stock LEDE image version (lede-17.01.0-r3205-59508e3-brcm2708-bcm2710-rpi-3-ext4-sdcard.img.gz)

Build from Master:
(SNAPSHOT, r3969-8322dba)
Linux LEDE 4.9.20 #0 SMP Thu Apr 13 17:22:23 2017 aarch64 GNU/Linux

elfive commented on 22.04.2017 03:29

same to me,

I build LEDE form two way:
1) master(source code)
2) image builder

both SNAPSHOT, r3986-e1d433b

Project Manager
Álvaro Fernández Rojas commented on 23.04.2017 14:47

I could narrow it down to commit 8301e613655c2d95fa5430a1a57d92d966fdc70b:;a=commit;h=8301e613655c2d95fa5430a1a57d92d966fdc70b

If I revert this commit it works.

ucwhatic commented on 02.10.2017 02:24

Is this still incomplete? Does 50% mean that it works in 64 bit LEDE?

The latest LEDE img that came out for brcm 2710 (rpi3) a few hours ago says its 64 bit so, since this is one of 2 total raspi 3 operating systems released in 64 bit (The only other is Gentoo 64 for rpi 3 that came out ~1 month ago i think) I would love to give it a try.

The only thing holding me back is i currently use my pi3 as an wireless AP with Librelec. They have a really cool setting where you can share the pi eth0 port with the devices wlan0 to create a wifi ap.

I think they use the debian package "connman" as the backend for this functionality

David Xie commented on 07.08.2018 15:47

I've noticed a bug about the country code setting in OpenWRT does not work in RPi, please see these 2 links.


Available keyboard shortcuts


Task Details

Task Editing