OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Eugene - 01.03.2017
Last edited by Felix Fietkau - 03.04.2017

FS#577 - Poweroff command hand Geode system instead of switch off.

System boot fine. After ‘poweroff’ command system hang.
VGA monitor stay show “reboot: System halted” User need to press power button to switch device off.
WoL to this system can not do anything.

Playing with grub’s cmdline arguments acpi=off, acpi=ht, pci=noacpi, acpi=noirq, pnpacpi=off, noapic, nolapic - do nothing. Same results.
Playing with BIOS PM options APCI, APM, Legacy, Disabled - do nothing. Same results.

Same results on Openwrt 15.05.1 x86-geode.

But works perfect on Openwrt 14.07 x86-generic.

- Device problem occurs on:
Rebranded Centerm Thin Client F2950.
Marks on board: CP8B 94V-0 F2950 v1.10.
Geode LX 800 board with 1 LAN, 1 VGA, 1 PS/2, 1 COM, 3 USB, Audio Out & Mic ports. 128Mb DDR RAM & IDE 44Pin Flash Disk 256Mb. Award BIOS.
Geode CPU under heatsink, Geode CS5536AD, MK1491-09FLN clock source, RTL 8139D, ALC203, MAX3243C, Winbond W83627HG-AN IO chip.

- Software versions of LEDE release, packages, etc.
OOTB LEDE 17.01.0-x86-geode, OOTB LEDE x86-geode snapshot from 26-Feb-2017. Both -combined-ext4.img.gz

- Steps to reproduce
Boot. Type ‘poweroff’ and press Enter.

Closed by  Felix Fietkau
03.04.2017 17:33
Reason for closing:  Fixed
Project Manager
Felix Fietkau commented on 06.03.2017 09:23

Please test the latest version from my staging tree at https://git.lede-project.org/?p=lede/nbd/staging.git;a=summary

Eugene commented on 08.03.2017 16:00

Oh. It will need a week or two to test it. I'm out of compiling power atm, big hardware problems.

Eugene commented on 22.03.2017 17:22

Compiled today, tested - it work.
What is difference in your tree and "main" tree?

Project Manager
Felix Fietkau commented on 03.04.2017 17:33

My tree contains changes that need more testing before they can be merged. I rebase it frequently. I've pushed the change as r3837-9b940fe80d, thanks for testing.

Eugene commented on 12.07.2017 05:36

Do I understand right that it change was added to main tree?
I see https://github.com/lede-project/source/commit/9b940fe80ddb5017dc0fbaebc500ae2ffbc26866 and it's looks like it for me.
But 17.01.1 and 17.01.2 x86-geode releases poweroff command still hang Geode system instead of switch off.
And version compiled from nbd lede tree - work fine with it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing