OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Rod Egan - 26.02.2017
Last edited by Adrian Schmutzler - 19.06.2020

FS#557 - Nexx wt3020 wifi rx sensitivity low with LEDE 17.01

The rx sensitivity reported by a Nexx wt3020 is ~ 20dB lower than a comparable tp-link device located sided by side with the Nexx wt3020.
There have been reports of a similar problem with OpenWRT versions.

There is a ticket open with openwrt with a similar reported issue https://dev.openwrt.org/ticket/20369 as well as on the openwrt forum https://forum.openwrt.org/viewtopic.php?id=69042

lede trunk (and openwrt trunk) as of 24/2/17 also display similar poor rx sensitivity.

 


Closed by  Adrian Schmutzler
19.06.2020 11:27
Reason for closing:  Won't fix
Additional comments about closing:  

LEDE-17.01 has reached EOL (end of life). This bug has been closed automatically. If the problem persists with a newer version, please file an appropriate new bug report for that version.

Fabianhu commented on 13.03.2017 09:54

I tried hard by setting my repo to the commit mentioned by @psyborg55.
Unfortunately the same result like HEAD (080c6fa476d1320f83ad56e6aeaa292960f63dc1):

with LEDE (luci): I see only my own AP with 75% signal strength at < 1m distance
At 5m distance I have no stable connection.

With the original FW I see ~10 more from my neighbors.

does anyone have any directions for me?

Roger commented on 13.03.2017 11:56

The patch mentioned above was commited to the master branch, so the snapshot builds already have it.

You may want to give the snapshot compilation a try (if you are familiar with the command line, as they don't include the web GUI). You can find them at https://downloads.lede-project.org/snapshots/targets/ramips/mt7620/.

Try flashing both 17.01.0 and the snapshot and check if there are any differences.

Rod Egan commented on 14.03.2017 04:15

See my comment in the original bug report. No difference between 17.01.0 and snapshot as of 24/2/17. The patch indicates it was committed 20/1/17 so it should have been in the 24//17 snapshot that I tested with.

Project Manager
Felix Fietkau commented on 18.04.2017 08:10

Please try the latest snapshot

Rod Egan commented on 18.04.2017 12:22

Tried with LEDE Reboot SNAPSHOT r3975-97d1c49
RX signal still poor
Also noted that with country code set to AU, TX power can supposedly be set to 36dBm!

root@LEDE:~# iw list
Wiphy phy0

      max # scan SSIDs: 4
      max scan IEs length: 2257 bytes
      max # sched scan SSIDs: 0
      max # match sets: 0
      max # scan plans: 1
      max scan plan interval: -1
      max scan plan iterations: 0
      Retry short long limit: 2
      Coverage class: 0 (up to 0m)
      Available Antennas: TX 0 RX 0
      Supported interface modes:
               * IBSS
               * managed
               * AP
               * AP/VLAN
               * monitor
               * mesh point
      Band 1:
              Capabilities: 0x2fe
                      HT20/HT40
                      SM Power Save disabled
                      RX Greenfield
                      RX HT20 SGI
                      RX HT40 SGI
                      TX STBC
                      RX STBC 2-streams
                      Max AMSDU length: 3839 bytes
                      No DSSS/CCK HT40
              Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
              Minimum RX AMPDU time spacing: 2 usec (0x04)
              HT TX/RX MCS rate indexes supported: 0-15, 32
              Frequencies:
                      * 2412 MHz [1] (36.0 dBm)
                      * 2417 MHz [2] (36.0 dBm)
                      * 2422 MHz [3] (36.0 dBm)
                      * 2427 MHz [4] (36.0 dBm)
                      * 2432 MHz [5] (36.0 dBm)
                      * 2437 MHz [6] (36.0 dBm)
                      * 2442 MHz [7] (36.0 dBm)
                      * 2447 MHz [8] (36.0 dBm)
                      * 2452 MHz [9] (36.0 dBm)
                      * 2457 MHz [10] (36.0 dBm)
                      * 2462 MHz [11] (36.0 dBm)
                      * 2467 MHz [12] (36.0 dBm)
                      * 2472 MHz [13] (36.0 dBm)
                      * 2484 MHz [14] (disabled)
      valid interface combinations:
               * #{ managed, AP, mesh point } <= 8,
                 total <= 8, #channels <= 1
      HT Capability overrides:
               * MCS: ff ff ff ff ff ff ff ff ff ff
               * maximum A-MSDU length
               * supported channel width
               * short GI for 40 MHz
               * max A-MPDU length exponent
               * min MPDU start spacing
psyborg55 commented on 29.07.2017 11:05

next time indicate in your issue report your device use MT7620N

Rod Egan commented on 29.07.2017 11:17

Yes Sir

psyborg55 commented on 24.08.2017 13:11

can you post RF calibration data from your device?

Rod Egan commented on 24.08.2017 13:21

Can point me to info about how to get the rf cal data? I've done a quick search on the lede forum but haven't found anything so far.

psyborg55 commented on 24.08.2017 13:55

run from ssh console: dd if=/dev/mtd2 of=/tmp/mtd2
scp mtd2 file to your PC and post here

Rod Egan commented on 24.08.2017 14:16

result of mtd2 download uploaded

   mtd2 (64 KiB)
psyborg55 commented on 24.08.2017 14:46

add chanregs 14, 17 and 18 to your rt2800lib.c file like this and rebuild image:

	if (rt2x00_has_cap_external_lna_bg(rt2x00dev)) {
		rt2800_bbp_write(rt2x00dev, 75, 0x68);
		rt2800_bbp_write(rt2x00dev, 76, 0x4C);
		rt2800_bbp_write(rt2x00dev, 79, 0x1C);
		rt2800_bbp_write(rt2x00dev, 80, 0x0C);
		rt2800_bbp_write(rt2x00dev, 82, 0xB6);
	} else {
		rt2800_rfcsr_write_chanreg(rt2x00dev, 14, 0x66);
		rt2800_rfcsr_write_chanreg(rt2x00dev, 17, 0x20);
		rt2800_rfcsr_write_chanreg(rt2x00dev, 18, 0x42);
	}

try checking again if the RSSI got any better

Rod Egan commented on 25.08.2017 06:31

Built a dev system and made the suggested changes in ~/source/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/compat-wireless-2017-01-31/drivers/net/wireless/ralink/rt2x00/rt2800lib.c around line 5287

flashed the wt3020 device and rx signal strength reported as -64/68 compared to -64/66 with 17.01.2 and snapshot r4741-7a8909411c near enough to no change.

As a check a physically adjacent device (a5v11) reports rx signal strength ~-44.

Both wt3020 and a5v11 have rx signal on wr842 (ap) as ~-40.

psyborg55 commented on 25.08.2017 12:44

this is the report i got about mt7620n devices. probably unrelated at all to these registers

Rod Egan commented on 25.08.2017 14:03

I won't be able to get back to this for a couple of weeks. I read a suggestion that the code by padavan doesn't have this issue. I'll see if I can get a copy and do some comparisons to see if there is anything obvious and/or try the code.

Rod Egan commented on 20.08.2018 07:41

Issue still present in 18.06.1
It isn't an issue with a specific device as I have a new device and the reported low rx sensitivity is still present.
Unfortunately I neglected to check with the oem firmware before loading 18.06.1 so it is unknown if oem firmware is any diferent.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing