OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Jo-Philipp Wich
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by howl - 22.02.2017
Last edited by Yousong Zhou - 21.06.2017

FS#548 - firewall3: Timezone problems, UTC used always despite UTC Time not checked

I know there is a place for bug about packages but I’m not sure if firewall3 is consider a core package or not.

Making a new or editing a existing traffic rule there is a checkbox to make firewall take the time in UTC. Actually it’s not working as the time is in UTC always, doesn’t matter if the checkbox is ticked or not. Actually the way to define UTC or local time is by using appending additional parameters.

To define local time you just need to add –kerneltz to extra parameters textbox, and if you want to define the time in UTC just don’t add –kerneltz parameter.

Closed by  Yousong Zhou
21.06.2017 02:25
Reason for closing:  Fixed
howl commented on 22.02.2017 09:28

If fw3 is not consider as a core package let me know and I open this bug report in the place it should be.

Admin
Jo-Philipp Wich commented on 22.02.2017 09:49

Fix to firewall3.git pushed with https://git.lede-project.org/82ccd9e

howl commented on 10.06.2017 23:49

It seems the commint has entered into 17.01.2. I have tested it and now it works. Even –kerneltz must be removed from extra args because otherwise the rule fails as –kerneltz is setup twice.

I have tested also checking time in UTC and works as expected.

Thanks jow.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing