OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by rfr - 19.02.2017
Last edited by Adrian Schmutzler - 10.12.2020

FS#535 - 5GHz radios not working properly on Netgear R8000

After upgrading my R8000 from Chaos Calmer (15.05.1) to LEDE Reboot (17.01.0-rc2, r3131-42f3c1f), I found that I could no longer get the 5GHz radios to work as before. The 2.4GHz radio is fine.

In CC I was using the following configuration:
- radio0 on channel 149, country code ‘00’, VHT80
- radio2 on channel 48, country code ‘00’, VHT80

The firmware apparently only accepts 00 and US as country codes, which is why I was using 00. This discussed at length in: (and previous pages)

In 17.01.0-rc2, I can’t get radio0 to come up at all. radio2 can be configured, still on channel 48 and country 00, but in VHT40 mode. If I use VHT80, it stays disabled.

This was discussed previously in this forum post: and I get the same error messages and channel selection as the OP, so I will not repeat them here.

I’m not sure if this issue is really related to the country code setting, but I will note that the factory system apparently sets the country code to “EU”:

root@x6:~# nvram show | grep country_code

I see that LEDE carries a patch on brcmfmac which translates the configured country code to an internal code for the firmware on this specific model (;a=blob_plain;f=package/kernel/mac80211/patches/863-brcmfmac-add-in-driver-tables-with-country-codes.patch;hb=refs/heads/lede-17.01). I’m willing to test patches if anyone knows the right internal country code for Europe.

Closed by  Adrian Schmutzler
10.12.2020 11:20
Reason for closing:  Won't fix
Additional comments about closing:  

OpenWrt 18.06 has reached EOL (end of life). This bug has been closed automatically. If the problem persists with a newer version, please file an appropriate new bug report for that version.

Project Manager
Rafał Miłecki commented on 24.02.2017 13:58

Firmware/driver doesn't support 00. US is indeed supported in LEDE. Leaving 00 is a good idea as it shouldn't change firmware "mode".

I'll need some more info. First of all where did you but this unit (which country)?

Secondly please provide me output of following commands when running LEDE:

nvram show | egrep "ccode|regrev"
iw phy phy0 channels
iw phy phy2 channels
rfr commented on 24.02.2017 18:15

Thanks for investigating this issue, Rafał!

The unit was bought in France, and I ran the stock firmware for only a few minutes, only the time required to update to OpenWrt CC.

Please find attached a text file with the commands you asked for.

rfr commented on 25.02.2017 15:44

Also, if I set the country to US for all three radios, my previous configuration works again.

Carsten commented on 20.02.2019 19:06

I can confirm this still exists on latest release 18.06.2. The 5 GHz WiFi even broke on the upgrade from 18.06.1 to 18.06.2, I had to reset it manually to the values specified here to get it working again. I had somehow gotten it to accept "DE" as region value, but that does not seem to work anymore.

@rmilecki seems weird that this is still an issue, the R8000 is a popular device I think. Do you need any more logs or info to reproduce this?


Available keyboard shortcuts


Task Details

Task Editing