OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by phoenix.xie - 18.02.2017
Last edited by Jo-Philipp Wich - 07.03.2017

FS#530 - The switch and vlan are wrrong port with linksys RE6500

Supply the following if possible:
- Device problem occurs on
Linksys RE6500
- Software versions of LEDE release, packages, etc.
The last commit with github,SNAPSHOT r3522-157b787
- Steps to reproduce
In the luci→network→switch. The port is not correct .
When I put in the LAN2(on the back hole), the LAN1 show up, and the syslog said Sat:
Feb 18 20:32:05 2017 http://kern.info kernel: [35432.590000] mtk_soc_eth 1e100000.ethernet eth0: port 1 link up

And when I put in the LAN1, there is no one show up in the luci.. But in the syslog, it is said :
Sat Feb 18 20:36:27 2017 http://kern.info kernel: [35432.590000] mtk_soc_eth 1e100000.ethernet eth0: port 0 link up

So I think there is some bug in the file /target/linux/ramips/base-files/etc/board.d/02_network
I see that the file has:
re6500|\
rp-n53)
ucidef_add_switch “switch0” \
“1:lan” “2:lan” “3:lan” “4:lan” “6t@eth0” ;;
And then I modify it.:
rp-n53)
ucidef_add_switch “switch0” \
“1:lan” “2:lan” “3:lan” “4:lan” “6t@eth0” ;;
re6500)
ucidef_add_switch “switch0” \
“0:lan:1” “1:lan:2” “2:lan:3” “3:lan:4” “6t@eth0” ;;

And rebuild the img,, then I works... When I put in the LAN1, the LAN1 show up in the luci→network→switch...


Closed by  Jo-Philipp Wich
07.03.2017 16:40
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with https://git.lede-project.org/2543e9 8 and https://git.lede-project.org/f8e08f f

Admin
Jo-Philipp Wich commented on 20.02.2017 08:27

Did you test all four lan ports? Sometimes the internal ports are not numerically ordered.

Project Manager
Mathias Kresin commented on 21.02.2017 08:52

Jow, it seams to me the reported is right. Port 0 isn't mentioned for 02_network.

Phoenix.xie would you please send a fix according to https://lede-project.org/docs/guide-developer/the-source-code#submitting_patches if you already know how to fix this.

phoenix.xie commented on 25.02.2017 03:50

I don't know how to add patch, But I have already know how to fix it.
/target/linux/ramips/base-files/etc/board.d/02_network
before:
re6500|\
rp-n53)
ucidef_add_switch “switch0” \
“1:lan” “2:lan” “3:lan” “4:lan” “6t@eth0” ;;
after fix :
rp-n53)
ucidef_add_switch “switch0” \
“1:lan” “2:lan” “3:lan” “4:lan” “6t@eth0” ;;
re6500)
ucidef_add_switch “switch0” \
“0:lan:1” “1:lan:2” “2:lan:3” “3:lan:4” “6t@eth0” ;;

It is that just let the RE6500 have a different config, Because the re6500 port 0 is the LAN1, and there is no port 4, just port 3 for Lan4..

zjufrankzhang commented on 07.03.2017 16:25

I have also encounter the same problem on my re6500. When I plugged in port 2, the switch page said LAN1 is up. I have tried other ports, port3 → LAN2, port4 → LAN3, port1 → nothing. The reason Phoenix.xie pointed out and his fix also seems right, is anyone make the fix?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing