OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by mike - 13.02.2017
Last edited by Petr Štetiar - 23.10.2019

FS#505 - Can't install LEDE on Linksys EA3500

Supply the following if possible:
- Device problem occurs on Linksys EA3500
- Software versions of LEDE release, packages, etc. Base Stable 17.01rc2 and Development build kirkwood/audi
- Steps to reproduce

 

LEDE kirkwood/audi...factory.bin will not flash on the ea3500, it just boots back into stock firmware. I was able to flash OpenWrt from factory and then flash LEDE from OpenWrt, so i tested both 17.01rc2 and development build, rc2 seems fine but there are no radios present in development build.

Closed by  Petr Štetiar
23.10.2019 09:26
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in https:/ /git.openwrt.org/e11fc8439c9f7230441408c 4d257efc46f372312

Ian MacDonald commented on 17.05.2017 18:23

I have successfully upgraded EA3500 to 17.01.1 from Chaos Calmer

Robby commented on 24.11.2017 02:35

This is still an issue in LEDE version 17.01.4, as I have the same issue. I just got a second hand Linksys EA3500 which is currently running the stock Linksys firmware version 1.1.39.145204. I wanted to flash lede-17.01.4-kirkwood-linksys-audi-squashfs-factory.bin on it, but when it rebooted, it rebooted I think 3 times, and on the 4th reboot the stock firmware was back.

Apparently there are known workarounds for this issue in the forum, although its making things more complicated than it needs to be, if only flashing directly from the LEDE factory.bin file would work correctly instead of having to use other firmware at first.

Robby commented on 25.11.2017 04:29

In the meantime I also tried flashing today's snapshot, but that also did not succeed.

Georg commented on 21.12.2017 16:51

I can also confirm. When flashing LEDE factory.bin from stock firmware (I tried all LEDE stable releases and few snapshots) the end result was always the same. After LEDE gets flashed it tries to boot 3 times and then it alaways reverts back to the recovery partion which contains stock smart wifi firmware or basic (depending which was installed before).
I tried 5h yesterday to find a soloution to directly flash LEDE, but couldn't make it happen.

Only way to currently flash LEDE on EA3500 is to first flash Openwrt an then flash LEDE sysupgrade.tar

zz0rk commented on 26.01.2018 00:34

Still broken. Going the OpenWRT route worked.

Robby commented on 12.12.2018 19:19

I have yet another EA3500 now, and this is still broken for OpenWrt 18.06 when coming from stock firmware. This one was running 1.0.30.126544 and I upgraded it to 1.1.40.162464 first for good measure, before proceeding to put OpenWrt on it.

But now its even worse: the current OpenWrt snapshots also don't work anymore, so the earlier workaround doesn't work with it anymore (although I haven't tried using Chaos Calmer).

However, I was lucky to find an old OpenWrt archive that still had snapshots from december 2017 that doesn't have this issue and finally got the EA3500 to boot into OpenWrt and then I sysupgraded to the currently last working stable version on this router: 18.06.0, because 18.06.1 is broken for this router, see link below ( FS#1810 ).

builker commented on 30.03.2019 06:07

I can confirm Robby's comment. Couldn't flash any of the following images to 5~6 EA3500s from Linksys Web UI Firmware Update (Current Version: 1.1.40.162464), Manual.

  • snapshots/r9355-94993a7/targets/kirkwood/generic/openwrt-kirkwood-linksys_audi-squashfs-factory.bin
  • releases/18.06.2/targets/kirkwood/generic/openwrt-18.06.2-kirkwood-linksys_audi-squashfs-factory.bin
  • releases/18.06.1/targets/kirkwood/generic/openwrt-18.06.1-kirkwood-linksys_audi-squashfs-factory.bin
  • releases/18.06.0/targets/kirkwood/generic/openwrt-18.06.0-kirkwood-linksys_audi-squashfs-factory.bin
  • releases/17.01.6/targets/kirkwood/generic/lede-17.01.6-kirkwood-linksys-audi-squashfs-factory.bin
  • releases/17.01.5/targets/kirkwood/generic/lede-17.01.5-kirkwood-linksys-audi-squashfs-factory.bin
  • releases/17.01.4/targets/kirkwood/generic/lede-17.01.4-kirkwood-linksys-audi-squashfs-factory.bin
Admin
Petr Štetiar commented on 02.04.2019 07:33

Well, Robby has confirmed, that 18.06.2 works for him https://bugs.openwrt.org/index.php?do=details&task_id=1810

Robby commented on 02.04.2019 14:43

Hello Petr Štetiar, no, you misunderstood. The comment I made in  FS#1810  was specific to that particular issue. There was an issue with OpenWrt 18.06.1 for the EA3500 that prevented it from being installed, that was fixed with the release of 18.06.2.

However, this issue ( FS#505 ), is still an unresolved issue: When the device has stock Linksys firmware, flashing to OpenWrt using factory image does not work.

builker commented on 16.09.2019 02:37

Flashing snapshot r9886-399aa0b in the Linksys stock firmware's web UI. OpenWRT failed to boot with "ubi0 error: validate_ec_hdr: bad VID header offset 512, expected 256". It used to work with the pre-merged OpenWRT snapshot r50107. Not sure where the different code resides.

[    1.459990] UBI: auto-attach mtd4
[    1.463377] ubi0: attaching mtd4
[    1.467004] ubi0 error: validate_ec_hdr: bad VID header offset 512, expected 256
[    1.474473] ubi0 error: validate_ec_hdr: bad EC header
[    1.479633] Erase counter header dump:
[    1.483421]  magic          0x55424923
[    1.487185]  version        1
[    1.490184]  ec             0
[    1.493167]  vid_hdr_offset 512
[    1.496323]  data_offset    2048
[    1.499568]  image_seq      423893825
[    1.503271]  hdr_crc        0x7678fd1d
[    1.507032] erase counter header hexdump:
[    1.511107] CPU: 0 PID: 1 Comm: swapper Not tainted 4.14.111 #0
[    1.517052] Hardware name: Marvell Kirkwood (Flattened Device Tree)
[    1.523364] Backtrace: 
[    1.525842] [<c010530c>] (dump_backtrace) from [<c01055f4>] (show_stack+0x18/0x1c)
[    1.533472]  r7:00000000 r6:00000000 r5:c3078000 r4:c31f3600
[    1.539175] [<c01055dc>] (show_stack) from [<c058c320>] (dump_stack+0x20/0x28)

Please find the complete console log in the attachment: First successful boot was by the stock firmware and the last two failed boots were by OpenWRT snapshot r9886-399aa0b.

mike commented on 20.10.2019 04:46

Builder over at the OpenWrt Forum is reporting that this has been fixed in master as of r11203-e11fc8439c, so i'm going to go ahead and request closure -

       

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing