OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Stephan Quernheim - 26.10.2021

FS#4112 - bcm53xx: vlan break with kernel 5.10.xxx

Target: bcm53xx
Device: Asus RT-AC88u
Version: OpenWrt SNAPSHOT, r17818

When trying to use a Vlan configuration with Kernel 5.10.xxx, I cannot use the tagged guest Vlan. Neither a connection nor a ping to the gateway of the guest network is possible. The same configuration under OpenWrt 21.02.0, r16279 (Kernel 5.4.143), the configuration works as expected. Please read the contents of / etc / config / network.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3f:f501:9a6f::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option igmp_snooping '1'

config bridge-vlan                                                                                   
        option device 'br-lan'                                                                       
        option vlan '1'                                                                              
        list ports 'lan1:u*'                                                                         
        list ports 'lan2:u*'                                                                         
                                                                                                     
config bridge-vlan                                                                                   
        option device 'br-lan'                                                                       
        option vlan '3'                                                                              
        list ports 'lan1:t'                                                                          
        list ports 'lan3:u*'                                                                         
                                                                                                     
config device                                                                                        
        option type 'bridge'                                                                         
        option name 'br1'                                                                            
        list ports 'br-lan.1'                                                                        
        option igmp_snooping '1'                                                                     
                                                                                                     
config device                                                                                        
        option type 'bridge'                                                                         
        option name 'br3'                                                                            
        list ports 'br-lan.3'                                                                        
        option igmp_snooping '1'                                                                     
                                                                                                     
config interface 'lan'                                                                               
        option proto 'static'                                                                        
        option netmask '255.255.255.0'                                                               
        option ip6assign '60'                                                                        
        option ipaddr '192.168.5.111'                                                                
        option gateway '192.168.5.1'                                                                 
        option broadcast '192.168.5.255'                                                             
        list dns '192.168.5.1'                                                                       
        option device 'br1'                                                                          
        option metric '50'

config interface 'guest'                                                                             
        option proto 'static'                                                                        
        option netmask '255.255.255.0'                                                               
        option ip6assign '60'                                                                        
        option ipaddr '192.168.190.2'                                                                
        option gateway '192.168.190.1'                                                               
        option broadcast '192.168.190.255'                                                           
        list dns '192.168.190.1'                                                                     
        option device 'br3'                                                                          
        option metric '150'                                                                          
                                                                                                     
config interface 'wan'                                                                               
        option device 'wan'                                                                          
        option proto 'dhcp'                                                                          
                                                                                                     
config interface 'wan6'                                                                              
        option device 'wan'                                                                          
        option proto 'dhcpv6' 

A quick note of the above file:
The bridges br1 and br3 are designed as a workaround so that wifi devices can reach the tagged subnets. Without this trick, WiFi devices cannot, for example, log into the guest network. The latter applies to both the kernel 5.4.xxx and the kernel 5.10.xxx.

On the forum user @patient0 confirmed this problem with kernel version 5.10 and 5.15 with my setup, please see https://forum.openwrt.org/t/openwrt-support-for-asus-rt-ac88u/78635/135.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing