OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Luiz Angelo Daros de Luca - 16.10.2021

FS#4087 - Cannot use vlan 1 tagged with DSA in WRT1900ACS v2

Hello,

No matter what I change, I cannot create a wan.1 interface. Any other vlan id works:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.4'
        option gateway '192.168.1.1'

config interface 'lan6'
        option proto 'dhcpv6'
        option device 'br-lan'
        option reqaddress 'try'
        option reqprefix 'auto'

config device
        option name 'br-guest'
        option type 'bridge'
        list ports 'wan.3'

config interface 'guest'
        option proto 'none'
        option device 'br-guest'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '3'
        option name 'wan.3'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '2'
        option name 'wan.2'

config interface 'test'
        option proto 'none'
        option device 'wan.1'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '1'
        option name 'wan.1'

I want to add wan.1 to br-lan but the virtual device (wan.1) is never created. I created a test interface just to try to bring it up alone, but nothing made wan.1 appears.

I also tried ip-full and it also failed:

root@ap4:/etc/config# ip link add link wan name wan.1 type vlan id 2
root@ap4:/etc/config# ip link add link wan name wan.1 type vlan id 1
RTNETLINK answers: Not supported

Why vlan 1 is prohibit?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing