OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by howl - 18.01.2017

FS#408 - Archer C7 has incorrect default bssid addresses for wifi networks

Using LEDE Reboot SNAPSHOT r3022-7fb11c8.

This is at least for Archer C7 v2. The default bssids for the networks in my particular device are:

:::::*D for the 2,4 GHz radio and
:::::*C for the 5 GHz radio

In LEDE they result in

:::::*C for the 2,4 GHz radio and
:::::*B for the 5 GHz radio

The problem in LEDE is that the bssid set up for the 2,4 GHz is the one for 5 GHz and then the 5 GHz gets minus one. Don’t know if it could be because the ethernet lan gets also :::::*D and wlan1 can’t have the same mac address as eth1. In the original firmware this seems to be possible, both ethernet lan and 2,4 GHz radio have the same mac/bssid. Also, at least with the 2,4 GHz radio, when you set up another connection with the device as client, the bssid of the master one change *(+2)::::**:*C the second hex digit gets plus 2, the bssid that should get a second connection as ap, but in this case there is one ap one client connections. This one could be right and I have to test with another router to see if it happens because I didn’t notice this before.

howl commented on 19.01.2017 21:55

I have tested with a tp-link tl-wr1043nd and I could see that it also happens that the default bssid of the wlan is used for the client connection and the the ap connection gets another one with the second hex digit incremented by 2, so that it's not a bug.

I also could see that the eth1 (lan) and the bssid of the wlan is the same, so it's possible for lede to have two networks with the same mac address, so indeed in the C7 the default bssid of the wlans are wrong.

The bssid of the 2,4 GHz network should be the same as the eth1 mac address, and the default bssid of the 5 GHz network should be the same one minus 1 to conform the mac and bssids that the default firmware has.

howl commented on 28.01.2017 17:08

Some one else can confirm this one?

Baptiste Jonglez commented on 12.02.2017 14:40

Can you explain whether this causes actual issues? Or is it just a matter of doing the same thing as the stock firmware?

howl commented on 21.02.2017 23:20

The second one, the mac address doesn't correspond to the original ones in the wifi networks. I'm using macaddr in the wireless config to set the original macs.

howl commented on 07.08.2017 21:57

https://git.lede-project.org/?p=source.git;a=commitdiff;h=370aacf53280ca78fb3570558d5e1f29d0ae8d18

Here are a recent example that the rule seems to be to follow the default firmware behavior. Have seen another C7 that I do not own does the same thing for the mac addresses that I have described

howl commented on 20.07.2018 19:17

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=290c54473eadf3ea3ddef81e051b436bcb09224f

This commit is not right:
wlan doesn't need to be decremented, wlan 2 ghz and eth 1 lan has the same mac address in the original firmware.

So correct MAC adress increments for this board are:
wlan0 (5GHz) : -1
wlan1 (2.4GHz) : 0
eth1 (LAN) : 0
eth0 (WAN) : 1

Project Manager
Mathias Kresin commented on 25.07.2018 07:17

Is it fixed with the "ath79: really fix TP-Link Archer C7 v2 MAC address" commit in my staging tree?

howl commented on 05.08.2018 21:22

Actually there is no ath79 builds yet to test https://downloads.openwrt.org/snapshots/targets/

Perhaps they should be enabled in the development tree.

PD: If there is and issue to be enabled I could try to compile myself in the following days.

howl commented on 24.02.2019 13:52

Tested, in ath79 it's solved.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing