OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Bastian Bittorf - 04.10.2021
Last edited by Ted Hess - 19.11.2021

FS#4063 - ath79 / 1043nd v1 hangs in "Decompressing kernel..."

I have a serial console attached:

It is reproduceable with image from
https://downloads.openwrt.org/snapshots/targets/ath79/generic/ openwrt-ath79-generic-tplink_tl-wr1043nd-v1-squashfs-factory.bin
(from Mon Oct 4 02:23:31 2021) and also with selfbuilt r17675.

Closed by  Ted Hess
19.11.2021 15:43
Reason for closing:  Fixed
Bastian Bittorf commented on 04.10.2021 17:37

Here the serial console output

U-Boot 1.1.4 (Nov 17 2009 - 11:56:26)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7114
eth0: 00:03:7f:09:0b:ad     
eth0 up
eth0
Autobooting in 1 seconds## Booting image at bf020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...



OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Looking for OpenWrt image... found at 0xbf022000
Decompressing kernel...

(hangs forever)
Bastian Bittorf commented on 04.10.2021 17:38

a WDR4300 (some arch) works without this issue

Admin
john commented on 04.10.2021 17:43

Hi Bastel Basti

image too big and decompressor overriding itself with the payload ?

  John
Bastian Bittorf commented on 04.10.2021 18:07

Good idea: i will investigate tomorrow.

Bastian Bittorf commented on 05.10.2021 13:05

Bastelbasti reports back:

When building r17677 (head) with GCC10 instead of the default GCC11,
the image boots and works, although the resulting kernel
target-mips_24kc_musl/linux-ath79_generic/linux-5.4.150/vmlinuz
is much bigger: 6.25mb instead of 4.9mb with GCC11.

Other models or also affected, this problem is described e.g. here:
https://forum.openwrt.org/t/gcc11-images-are-not-working-on-cpe510v3

The next step can be a deeper look into the miscompiled
target/linux/ath79/image/lzma-loader/src/loader.c

Bastian Bittorf commented on 05.10.2021 15:33

After looking into the source: the loader.c is fine,
my bet: the problem is in ./target/linux/ath79/image/lzma-loader/src/LzmaDecode.c

UsernameIsAlreadyTakenByMe commented on 11.10.2021 23:54

Hi,
I also had this issue by upgrading with the following image
tplink_tl-wr1043nd-v1-squashfs-sysupgrade.bin 69f36b0ea4631eafc24a5b9b2a71c1559005359677604b92f88bd1bbf522b512
5056.3 KB
Sun Oct 10 16:23:24 2021

I tried to upgrade from 21.02.0-rc3 and 19.07.8

Bastian Bittorf commented on 16.11.2021 19:35

fixed with r18106

commit 0c249ab07645489088c9010bb528b637356aa052 (HEAD -> master, origin/master, origin/HEAD)
Author: Felix Fietkau <nbd@nbd.name>
Date:   Tue Nov 16 10:47:43 2021 +0100

    toolchain/gcc: revert a faulty upstream commit that caused miscompiled code
    
    This broke at least the OKLI loader, but possibly other things as well
    
    Signed-off-by: Felix Fietkau <nbd@nbd.name>

Thanks a lot!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing