OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Viacheslav Dushin - 17.09.2021
Last edited by Jo-Philipp Wich - 25.01.2022

FS#4044 - Failed to change the system password

I can’t change the root password via LuCI on LuCI openwrt-21.02 branch (git-21.231.26241-422c175) / OpenWrt 21.02.0 r16279-5cc0535800
The router is ASUS RT-AC68U.

I can change the root password from the console using passwd but then I can’t login to LuCI using the new password.

The problem is that it used to work. Could it be a conflict with some packages I installed?

See the screenshot and the list of packages attached.

Closed by  Jo-Philipp Wich
25.01.2022 22:07
Reason for closing:  Fixed
Viacheslav Dushin commented on 17.09.2021 22:28

Removing of shadow and shadow-passwd fixed the problem.

Looks like that LuCI used passwd from the package "shadow". Could you fix this issue and let LuCI to use the correct passwd executable?

Frédéric Dumas commented on 17.10.2021 18:50

We can confirm the bug Viacheslav reported.

Our version of LuCI is git-21.252.54297-fc2ff4d
Our router is a Turris Omnia with TurrisOS 5.2.7

Admin
Jo-Philipp Wich commented on 25.01.2022 22:05

LuCI has been patched to explicitly invoke Busybox "passwd" with https://git.openwrt.org/22e2bfb0, see also https://github.com/openwrt/luci/issues/5629.

The "shadow-passwd" <> "musl crypt()" incompatibility needs to be separately addressed in the shadow-tools package though, ideally by honoring CONFIG_MUSL_DISABLE_CRYPT_SIZE_HACK, if the hack is not disabled, shadow-passwd may not use Blowfish or SHA ciphers, but only MD5.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing