OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Grider - 12.09.2021
Last edited by Jo-Philipp Wich - 12.09.2021

FS#4034 - Network interfaces reset on clicking system/startup tab in webui

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

I’m using openwrt x86_64 on a qemu/q35 virtual mahine. Whenever I click system/startup, the network interfaces all reset. Kernel log attatched below.

[   18.401802] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   19.060981] r8169 0000:02:00.0 eth1: Link is Up - 100Mbps/Full - flow control off
[   19.061918] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   20.548964] r8169 0000:01:00.0 eth0: Link is Up - 1Gbps/Full - flow control off
[   20.549879] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   30.628848] pppoe-wan: renamed from ppp0
[   99.023340] r8169 0000:01:00.0 eth0: Link is Down
[   99.042157] r8169 0000:01:00.0 oldeth0: renamed from eth0
[   99.059518] r8169 0000:02:00.0 eth1: Link is Down
[   99.091542] r8169 0000:02:00.0 oldeth1: renamed from eth1
[   99.110024] virtio_net virtio2 oldeth2: renamed from eth2
[   99.123758] br-lan: port 1(eth3) entered disabled state
[   99.125820] virtio_net virtio3 oldeth3: renamed from eth3
[   99.141775] device oldeth3 left promiscuous mode
[   99.142463] br-lan: port 1(oldeth3) entered disabled state
[   99.158988] virtio_net virtio4 oldeth4: renamed from eth4
[   99.203189] virtio_net virtio5 oldeth5: renamed from eth5
[   99.216271] r8169 0000:01:00.0 eth0: renamed from oldeth0
[   99.231386] r8169 0000:02:00.0 eth1: renamed from oldeth1
[   99.251913] virtio_net virtio2 eth2: renamed from oldeth2
[   99.265900] RTL8211E Gigabit Ethernet r8169-0-100:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-100:00, irq=IGNORE)
[   99.450691] 8021q: adding VLAN 0 to HW filter on device eth2
[   99.450781] r8169 0000:01:00.0 eth0: Link is Down
[   99.453798] virtio_net virtio3 eth3: renamed from oldeth3
[   99.474084] RTL8211E Gigabit Ethernet r8169-0-200:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[   99.650523] r8169 0000:02:00.0 eth1: Link is Down
[   99.651028] 8021q: adding VLAN 0 to HW filter on device eth3
[   99.652250] br-lan: port 1(eth3) entered blocking state
[   99.653096] br-lan: port 1(eth3) entered disabled state
[   99.653926] device eth3 entered promiscuous mode
[   99.655583] br-lan: port 1(eth3) entered blocking state
[   99.656403] br-lan: port 1(eth3) entered forwarding state
[   99.657315] virtio_net virtio4 eth4: renamed from oldeth4
[   99.669588] 8021q: adding VLAN 0 to HW filter on device eth4
[   99.671588] virtio_net virtio5 eth5: renamed from oldeth5
[   99.717848] r8169 0000:01:00.0 oldeth0: renamed from eth0
[   99.741815] r8169 0000:02:00.0 oldeth1: renamed from eth1
[   99.755044] virtio_net virtio2 oldeth2: renamed from eth2
[   99.774529] br-lan: port 1(eth3) entered disabled state
[   99.776397] virtio_net virtio3 oldeth3: renamed from eth3
[   99.792808] device oldeth3 left promiscuous mode
[   99.793518] br-lan: port 1(oldeth3) entered disabled state
[   99.813838] virtio_net virtio4 oldeth4: renamed from eth4
[   99.901106] virtio_net virtio5 oldeth5: renamed from eth5
[   99.918951] r8169 0000:01:00.0 eth0: renamed from oldeth0
[   99.930644] r8169 0000:02:00.0 eth1: renamed from oldeth1
[   99.948777] RTL8211E Gigabit Ethernet r8169-0-100:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-100:00, irq=IGNORE)
[  100.145721] RTL8211E Gigabit Ethernet r8169-0-200:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[  100.145745] r8169 0000:01:00.0 eth0: Link is Down
[  100.325354] r8169 0000:02:00.0 eth1: Link is Down
[  100.326914] virtio_net virtio2 eth2: renamed from oldeth2
[  100.345383] virtio_net virtio3 eth3: renamed from oldeth3
[  100.368160] 8021q: adding VLAN 0 to HW filter on device eth3
[  100.369017] br-lan: port 1(eth3) entered blocking state
[  100.369794] br-lan: port 1(eth3) entered disabled state
[  100.370624] device eth3 entered promiscuous mode
[  100.372053] br-lan: port 1(eth3) entered blocking state
[  100.372826] br-lan: port 1(eth3) entered forwarding state
[  100.374170] virtio_net virtio4 eth4: renamed from oldeth4
[  100.389604] virtio_net virtio5 eth5: renamed from oldeth5
[  102.094935] r8169 0000:02:00.0 eth1: Link is Up - 100Mbps/Full - flow control off
[  102.095846] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  102.637803] r8169 0000:01:00.0 eth0: Link is Up - 1Gbps/Full - flow control off
[  102.638654] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  112.724714] pppoe-wan: renamed from ppp0

Notice that, I’m using a staticeth script from External Link to rename my interfaces properly. Already tried to remove the service but still happens even without this service script.

Closed by  Jo-Philipp Wich
12.09.2021 19:26
Reason for closing:  Not a bug
Admin
Jo-Philipp Wich commented on 12.09.2021 19:25

That script you linked does not follow the expected behavior for an init script. In particular it must not execute any code when sourced.

This script must be fixed to only touch interfaces when explicitly invoked with boot or start as action parameter. A mere `source /etc/init.d/staticeth` should not invoke iproute commands.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing