OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Peter Sherman - 11.09.2021
Last edited by Ted Hess - 19.11.2021

FS#4031 - Uplink ethernet ports not connecting at gigabit speeds (Ath79)

- Device problem occurs on
2 devices known at the present time: Ubiquiti RouterStation Pro and Buffalo WZR-HP-AG300H

- Software versions of OpenWrt/LEDE release, packages, etc.
21.02.0 stable release (did not test RC versions).

- Steps to reproduce
Upgrade device to 21.02.0 and observe the uplink ethernet port speeds. Install ethtool and look at the supported link speeds for eth0 (RSPro) (eth1 on the WZR-HP-AG300H).

- More info
This issue presents on 21.02.0, but not on 19.07.x and it affects only eth0 on the RSPro – limiting the uplink speed to 100Mbps. Forcing the link to 1000Mbps causes the link to fail. This does not affect eth1 (3-port switch) which still works at gigabit speeds.

On the RSPro, I have tested with 19.07.8 (ath79) and 21.02.0 (ath79), both completely fresh installations from official stable images with no changes to the default configs or packages except for the installation of ethtool. I used known good cables connected to the device and did not physically change anything between the different images. Upstream is a Ubiquiti Unifi Flex Mini (gigabit) switch, and downstream (on eth1) is a 2009 Mac Pro (gigabit).


The following is the ethtool output from 21.02.0:

root@OpenWrt:~# ethtool eth0
Settings for eth0:

Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 4
Transceiver: external
Auto-negotiation: on
Current message level: 0x000000ff (255)
		       drv probe link timer ifdown ifup rx_err tx_err
Link detected: yes

—-
And this is the ethtool output when running on 19.07.8.

root@OpenWrt:~# ethtool eth0
Settings for eth0:

Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
                                     1000baseT/Full 
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 4
Transceiver: internal
Auto-negotiation: on
Current message level: 0x000000ff (255)
		       drv probe link timer ifdown ifup rx_err tx_err
Link detected: yes

—-

Details can be found in my original post about the RouterStation Pro and in this one for the Buffalo device.

Closed by  Ted Hess
19.11.2021 15:41
Reason for closing:  Fixed
Boris Gjenero commented on 08.10.2021 15:55
Boris Gjenero commented on 10.10.2021 19:02

This problem is already solved in master branch via https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=766e0f584a325b0b80a97bbc86ca515d97c63001

Quoting from the commit message:

  Modifying PHY capabilities in the probe function broke with upstream
  commit 92ed2eb7f4b7 ("net: phy: probe the PHY before determining the
  supported features").
  
  AR8316 switches only support 10/100 Mbit/s link modes because of this
  change.
  
  Provide a get_features method for the PHY driver, so Gigabit link mode
  will be advertised to link partners again.

The fix is not in 21.02.0. You can add it before building from source via:

  git cherry-pick 766e0f584a325b0b80a97bbc86ca515d97c63001

It would be nice if this fix could be included in future releases of version 21.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing