OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Op3n - 10.09.2021

FS#4028 - Extroot cannot mount after boot, block: no usable configuration

I run OpenWRT on my x86 PC(Lenovo tiny series, UEFI+amd64), use the latest 21.02 stable version, squashfs+efi, and burn into USB drive via Rufus, all new flash, no upgrade, no restore backup configuration.
I totally follow this guide to configure extroot, of course enablemodified the partition /dev/sda1 and something like that. But after reboot I found Extroot partition don’t mount automatic as expected.
Try some times still not work I found not checked enable on luci,so I add

option enabled '1'

in /etc/config/fstab, but still don’t work property. I also follow troublshooting on that article increase delay_root, not work, but true, mount it without problems from a shell after boot.

logread | sed -n -e "/- preinit -/,/- init -/p"

Full logs at here , list relative part below

*
user.info kernel: [ 7.764620] block: attempting to load /etc/config/fstab
user.err kernel: [ 7.768095] block: unable to load configuration (fstab: Entry not found)
user.err kernel: [ 7.769569] block: no usable configuration
*

I search and found this report:https://bugs.openwrt.org/index.php?do=details&task_id=2231, looks a patch in it but I don’t know how to compile and hope use pre-compile stable release. It’s old issue, but it still not marked as completed. I don’t know if it’s relevant.

Op3n commented on 10.09.2021 18:35

Looks that patch will let block read fstab from

/tmp/overlay/upper/etc/config/fstab

instead original

/etc/config/fstab

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing