OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by freezeheat - 08.09.2021
Last edited by Ted Hess - 20.10.2021

FS#4014 - Mesh 802.11 doesn't work with encryption and fails to work with batman-adv without encryption

2 Devices with very similar hardware are having the same issue, a Netgear R6220 and a Lenovo newifi D1.
While I had the same problem with both devices, the only one I tried using with the snapshot is the R6220.

I also documented this in the following forum post: https://forum.openwrt.org/t/mesh-network-configuration-mesh-fails-batman/105260

Version used: OpenWrt 19.07.8, r11364-ef56c85848.
Packages: Provided by snapshot + wpad-mesh-openssl(and dependencies), kmod-batman-adv(and dependencies) & batctl-default(and dependencies).

Steps to reproduce the mesh failing with encryption:
1. Install snapshot via sysupgrade (I kept the former settings)
2. Install packages

  • opkg remove wpad-basic
  • opkg update
  • opkg install wpad-mesh-openssl kmod-batman-adv batctl-default

3. /etc/config/wireless add mesh networks for both radios

# adjust network option to your network's name
config wifi-iface 'mesh0'
	option network 'lan'
	option device 'radio0'
	option mode 'mesh'
	option mesh_fwding '1' 
	option mesh_id 'mymesh'
	option encryption 'sae'
	option key 'password'

config wifi-iface 'mesh1'
	option network 'lan'
	option device 'radio1'
	option mode 'mesh'
	option mesh_fwding '1'
	option mesh_id 'mymesh_5g'
	option encryption 'sae'
	option key 'password'

4. Run service network restart or reboot.
5. iw dev wlan0 info Shows no traffic, and ip link shows mesh0 is disabled(isn’t up), on the other hand wlan1(5.0Ghz) has traffic and is shown as up.

NOTE: Network and Wireless configuration files are included.

As for kmod-batman-adv, even when the mesh_fwding option in etc/config/wireless is set to 0, batman’s bat0 is always disabled, with or without mesh encryption.
Steps to reproduce:
1. Same as the above steps.
2. Change mesh_fwding option in etc/config/wireless to ‘0’.
3. Change encryption option in etc/config/wireless to ‘none’.
4. Run: service network restart.
5. Run: batctl n → returns bat0 is disabled.

Closed by  Ted Hess
20.10.2021 11:16
Reason for closing:  Not a bug
freezeheat commented on 08.09.2021 15:28

After updating to version v21.02.0 and installing wpad-mesh-wolfssl, it seems Newifi D1's radio gets disabled when set to channel 11 in mesh_point mode, R6220's radio doesn't get disabled, when both radios are set to channels like 1 or 6, both routers associate with one another.

Also, once that problem was solved, batman worked, with mesh_fwding '0' on both mesh networks and set up bat0 to be part of the bridged network, the routing works and I have internet access from my other node(not the gateway), batctl n doesn't return an error that bat0 is disabled.

Newifi D1 system log:

Wed Sep  8 14:28:44 2021 daemon.err wpa_supplicant[3766]: wlan0-1: Could not join mesh
Wed Sep  8 14:28:44 2021 daemon.notice wpa_supplicant[3766]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Sep  8 14:28:44 2021 kern.info kernel: [ 1519.626597] br-lan: port 5(wlan0) entered disabled state
Wed Sep  8 14:28:44 2021 kern.info kernel: [ 1519.655136] device wlan0 left promiscuous mode
Wed Sep  8 14:28:44 2021 kern.info kernel: [ 1519.659660] br-lan: port 5(wlan0) entered disabled state
Wed Sep  8 14:28:44 2021 daemon.notice wpa_supplicant[3766]: nl80211: deinit ifname=wlan0-1 disabled_11b_rates=0
Wed Sep  8 14:28:44 2021 kern.info kernel: [ 1519.812995] br-lan: port 6(wlan0-1) entered disabled state
Wed Sep  8 14:28:45 2021 kern.info kernel: [ 1520.867562] br-lan: port 6(wlan0-1) entered disabled state
Wed Sep  8 14:28:45 2021 kern.info kernel: [ 1520.903187] device wlan0-1 left promiscuous mode
Wed Sep  8 14:28:45 2021 kern.info kernel: [ 1520.907901] br-lan: port 6(wlan0-1) entered disabled state
Wed Sep  8 14:28:47 2021 daemon.notice netifd: radio0 (8260): command failed: Link has been severed (-67)
Wed Sep  8 14:28:47 2021 daemon.notice netifd: radio0 (8260): command failed: Link has been severed (-67)
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.390393] br-lan: port 5(wlan0) entered blocking state
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.395991] br-lan: port 5(wlan0) entered disabled state
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.402587] device wlan0 entered promiscuous mode
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.413285] br-lan: port 6(wlan0-1) entered blocking state
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.418904] br-lan: port 6(wlan0-1) entered disabled state
Wed Sep  8 14:28:47 2021 kern.info kernel: [ 1522.425376] device wlan0-1 entered promiscuous mode
Wed Sep  8 14:28:48 2021 daemon.notice wpa_supplicant[3766]: wlan0-1: leaving mesh
Wed Sep  8 14:28:48 2021 kern.info kernel: [ 1523.095183] br-lan: port 6(wlan0-1) entered disabled state
Wed Sep  8 14:28:49 2021 daemon.notice wpa_supplicant[3766]: nl80211: Failed to set interface into station mode
Wed Sep  8 14:28:49 2021 daemon.err wpa_supplicant[3766]: wlan0-1: mesh leave error=-134

Kernel log:

[ 1378.973986] device wlan0 left promiscuous mode
[ 1378.978502] br-lan: port 5(wlan0) entered disabled state
[ 1380.402899] br-lan: port 5(wlan0) entered blocking state
[ 1380.408339] br-lan: port 5(wlan0) entered disabled state
[ 1380.414510] device wlan0 entered promiscuous mode
[ 1380.424809] br-lan: port 6(wlan0-1) entered blocking state
[ 1380.430417] br-lan: port 6(wlan0-1) entered disabled state

EDIT:

Made a new task with the above information that's related to the problem: https://bugs.openwrt.org/index.php?do=details&task_id=4036

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing