OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Wade - 06.09.2021

FS#4012 - Can't login to LUCI but can SSH

Linksys WRT3200ACM
OpenWRT 21.02.0 Stable

Steps to reproduce:

  1. Install OpenWRT 21.02.0 Stable as a fresh install.
  2. Visit and sign into Luci (with no password since it is a fresh install), go to System → Administration and assign a password
  3. Close the browser window
  4. Login through SSH and enable HTTPS-redirect for Luci (as mentioned in the release notes:
  5. Open a new browser window in Incognito-mode
  6. Visit (should be redirected to HTTPS and may get browser warning about being unsafe)
  7. Try to sign into Luci (should get message that the user/password is incorrect)

I have tried clearing my browser cookies, tried disabling the HTTPS redirect, restarted the router manually (power switch on device), tried using the “passwd” command to reset the password (and then restarted the router manually).

No matter what, I cannot login into the router ever again after enabling HTTPS redirect for Luci (even if the redirect is turned off and router restarted). I can, strangely, log into the router through SSH with the password I set for root.

I had to login through SSH and run the (cant remember exact) command to reset the router as if I just installed OpenWRT in order to gain access again.

Arek commented on 16.09.2021 18:21

I have the same/similar problem - 21.02 stable, Netgear R6220. Also


doesn't fix it. The weird thing is that

"Thu Sep 16 20:24:05 2021 daemon.err uhttpd[1786]: luci: accepted login on / for root from 192.168.x.x"

is logged so hm, some session management problem maybe.

No cookies are being set.

Oh. I was trying to log in via http:// ! There was no redirection to https://.

All above was with http://.

When I used https:// I logged in just fine.


Available keyboard shortcuts


Task Details

Task Editing