OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by phi-whiterabbit - 05.09.2021
Last edited by Jo-Philipp Wich - 08.09.2021

FS#4006 - kmod-wireguard not available

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

Running openwrt 21.02 on Archer C7 v5.
Trying to install luci-app-wireguard reports missing package kmod-wireguard, claiming that it is not available in any repository.

Closed by  Jo-Philipp Wich
08.09.2021 20:10
Reason for closing:  Fixed
Additional comments about closing:  

Fix for affected package has been merged.

DaGenix commented on 05.09.2021 20:39

I'm seeing the same thing on my Netgear R7800

phi-whiterabbit commented on 06.09.2021 10:47

I just installed via SSH instead of luci web interface using "opkg install luci-app-wireguard", and surprisingly this works well.
So i guess that this is an issue with luci and thus the BUG report should go there. Since everything works when installing from SSH i think this ticket can be closed.

phi-whiterabbit commented on 06.09.2021 10:47

Just for completeness. Here is a screenshot of the error in luci.

Admin
Jo-Philipp Wich commented on 08.09.2021 20:10

The bug was within the `cgi-io` helper which truncated the package lists downloaded by LuCI.

Fixes for master and 21.02 have been merged in https://github.com/openwrt/packages/commit/aff981470fdcea29989bb5eb59e88cee4343f38e and https://github.com/openwrt/packages/commit/8ca8872b3d39406c2ea9e479b16589cc0809f65b respectively.

Once the package has been rebuilt, you can solve the issue using `opkg update; opkg upgrade cgi-io`.

The next maintenance release will contain the fixed version of this package.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing