OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Stephan - 03.09.2021
Last edited by Petr Štetiar - 13.09.2021

FS#4002 - Networking: no bridge for WAN created

Configuration tells to create a bridge for WAN device, but it just ignores it.
Openwrt 19 does create the bridge correctly.

In our project (freifunk dresden) it is essential that LAN and WAN are bridges because a the underlying interface
is changed dynamically (moved between bridges).

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='21.02.0-rc4'
DISTRIB_REVISION='r16256-2d5ee43dc6'
DISTRIB_TARGET='ath79/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 21.02.0-rc4 r16256-2d5ee43dc6'
DISTRIB_TAINTS='no-all no-ipv6'

/etc/config/network:

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.222.1'
        option stp '1'
        option bridge_empty '1'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'
        option stp '1'
        option bridge_empty '1'
        option force_link '1'

 


Closed by  Petr ┼átetiar
13.09.2021 12:56
Reason for closing:  Not a bug
Additional comments about closing:  

Requested.

Stephan commented on 03.09.2021 21:22

I manually change the network configuration to same as automatically generated for lan to:

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth0.2'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'
        option stp '1'
        option bridge_empty '1'
        option force_link '1'

This is configuration created the wan as bridge and assigned the eth0.2 to it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing