OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Aidan R. - 20.08.2021

FS#3983 - TX Power 2.4GHZ Stuck

I’m having a problem with TXPower with my MediaTek 2.4GHz radio on my R6220 Netgear unit flashed with the latest version of OpenWRT, changing the TX power down to 1 dBm all the way down from 20 has no effect on range or RX power seen by devices. The 5GHz radio does not have this problem, and changing the Tx power has a significant effect on both real world range and signal in dBm. I have tried downgrading software with no luck. Any ideas?

- On both 18.06 and 19.07, tried rolling back.
- Tried reflashing to new OS with no luck
- Netgear R6220
- 2.4GHz Radio with TX Power Issues: MediaTek MT7603E 802.11bgn
- 5GHz Radio That Works Fine: MediaTek MT76x2E 802.11acn

Let me know if I can provide more info.

- Aidan

d.souza commented on 18.09.2021 15:36

I can confirm this issue also with the 5Ghz radio on a TP-Link Archer C6 3.2 (MT7621 + MT7603EN 2.4Ghz + MT7613BEN 5Ghz) running a snapshot build (r17525-a46fa5c3a7):

Linux ap2 5.4.145 #0 SMP Thu Sep 16 05:59:50 2021 mips GNU/Linux

The issue seems to be with the M76 driver which is completely ignoring the "TX Power" set via LuCI and UCI. I am saying the issue seems to be the Wi-Fi driver because UCI and iwinfo everything seems to be OK.

See the example below. I've set the TX Power to 0dbm for testing purposes, and UCI and iwinfo correctly show the value I've configured:

root@ap2:~# uci show wireless.radio1
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.path='1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
wireless.radio1.band='5g'
wireless.radio1.htmode='VHT80'
wireless.radio1.country='PA'
wireless.radio1.channel='100'
wireless.radio1.cell_density='0'
wireless.radio1.txpower='0'

root@ap2:~# iwinfo wlan1 info
wlan1     ESSID: "dshome5ghz-tst"
          Access Point: xx:xx:xx:xx:C8:40
          Mode: Master  Channel: 100 (5.500 GHz)
          Center Channel 1: 106 2: unknown
          Tx-Power: 0 dBm  Link Quality: 24/70
          Signal: -86 dBm  Noise: -92 dBm
          Bit Rate: 234.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 14C3:7663 14C3:7663 [MediaTek MT7613BE]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1
root@ap2:~#

However the 0dBm configuration above has no effect on TX Power at all.

With TX Power configured at 0 dBm for the 5Ghz radio in the example above, Wi-Fi signal should be very weak and should work only on the same room and close to the access point.

However as seen below the signal strength measured with a laptop located about 10 meters away from the access point with a brick wall between the laptop and the access point and the wi-if signal strength is still strong. This is the same level as if TX Power is at 22dBm (driver default level), so in fact the TX Power configuration is not working:

ubuntu@ubuntu:~$ iwconfig wlp2s0
wlp2s0    IEEE 802.11  ESSID:"dshome5ghz-tst"  
          Mode:Managed  Frequency:5.5 GHz  Access Point: xx:xx:xx:xx:C8:40   
          Bit Rate=26 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:30   Missed beacon:0

I've experimented other TX Power levels, and none configuration has any effect on OpenWRT TX Power. I am not sure if this is an OpenWRT bug or if it is in fact a MT76 driver issue to be reported upstream by OpenWRT devs.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing