OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by evoserver - 02.08.2021

FS#3961 - Atheros WDS stopped working on TP-Link Archer C60 v2 with OpenWRT 21.02.0 rc4

I tried rc4 of OpenWRT 21.02.0 on my Atheros C60 v2 and WDS stopped working.
WDS is used for forwarding a wired client on the same subnet of the wifi network.
I found the wireless client associated to my Atheros C60 access point

Mon Aug  2 15:46:45 2021 daemon.info hostapd: wlan1-1: STA xxx IEEE 802.11: authenticated
Mon Aug  2 15:46:45 2021 daemon.info hostapd: wlan1-1: STA xxxx IEEE 802.11: associated (aid 1)

but I’m unable even to ping it.
Even if I set up a fixed IP address on both the wireless and the wired clients, they can’t connect to the router.
Other clients are connected to the Atheros C60 access point without problems.
I never had a problem with previous version of OpenWRT, so I went back to rc3 and everything started working again.

The only extra package installed is relayd

/etc/config/network on Archer C60

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth1'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.50.1'
        option gateway '192.168.2.1'
        list dns '192.168.2.5'
        option device 'br-lan'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config interface 'wwan'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '192.168.2.5'
        option ipaddr '192.168.2.50'
        option gateway '192.168.2.1'

config interface 'repeater_bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option gateway '192.168.2.5'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

/etc/config/wireless on Archer C60

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'IT'
        option channel '60'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxx'
        option encryption 'psk2+ccmp'
        option key ''

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option htmode 'HT20'
        option country 'IT'
        option channel 'auto'
        option path 'platform/ahb/18100000.wmac'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'xxx'
        option encryption 'psk2+ccmp'
        option key ''

config wifi-iface 'wifinet2'
        option ssid 'xxx'
        option device 'radio1'
        option mode 'sta'
        option key ''
        option network 'wwan'
        option encryption 'psk2'
        option bssid 'xxx'


Rod Egan commented on 26.08.2021 03:14

I just tried this on my wr842v1 with snapshot and have a similar issue. WDS no longer appears to work. I don't use relayd.
Previous versions worked ok.

Rod Egan commented on 27.08.2021 05:51

Confirming that WDS is broken on client wr842nv1 snapshot r17419-364bd887a1
Can ping when client is simple station but fails when client is station with WDS enabled.
No obvious errors in logs.
Master is c7v5 running SNAPSHOT r17182-f7374bce00

evoserver commented on 06.09.2021 08:37

The problem is still there, even with the stable version.
I'll stay with RC3

Rod Egan commented on 07.09.2021 14:10
Slenderchat commented on 09.09.2021 12:51

Can confirm this bug from 21.02.0-rc4 and up to current stable 21.02.0. My two routers is TP-Link Archer C20 v4 and TP-Link TL-WR841N/ND v9. Downgraded TP-Link Archer C20 v4 to 21.02.0-rc3 and everything rock stable again. In some situations WDS breaking can be lead to severe consequences, as in my situation where i have little fleet of 10 different routers, and 5 WDS links.

shaarkys commented on 09.09.2021 19:50

I did observe similar issues on TP-Link Archer MR200 having bridge with Ubiquiti UniFi AC Pro - going back to RC3 resolved all my WDS issues....

Chad Neufeld commented on 12.09.2021 21:08

I've been trying to figure out which commits have caused this issue for me. I think I have it narrowed down to commit # fe498dd3f1. I had to revert 3 netifd commits before this one (in total 4 netifd commits). 21.02 snapshot installed and running smoothly with the 4 commits removed.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=fe498dd3f108de494594ae8e0eba207fdbf14594

Gili Tzabari commented on 15.09.2021 01:58

Why is the priority of this task very low?

Chad Neufeld commented on 15.09.2021 03:54

I did some more digging. I think the issue is related to this specific commit in NETIFD.

  • f037b082923abc2dad0d14c8401ebe0afd816b5c wireless: handle WDS per-sta devices

I undid just the changes in the above commit related to "wireless_device_hotplug_event", recompiled NETIFD and my WDS links seem to work perfectly fine now.

The end result is OpenWRT 21.02.0 with an up to date NETIFD minus the wireless_device_hotplug_event changes.

Project Manager
Felix Fietkau commented on 20.09.2021 16:14

Please try to apply this patch on top of the affected netifd version to see if it fixes the issue: https://termbin.com/awp7

Chad Neufeld commented on 20.09.2021 17:50

Hi Felix. I applied the patch and updated the netifd package on two access points (one master and one client).

The WDS link seems to be working with the patch. I'll let you know how it works over the day.

Thanks

Daniel Haid commented on 29.09.2021 21:06

Could you try restarting the WDS AP a few times and check if it keeps working every time? I had the same problem, but the patch did not help.

It turns out that the problem was the follwing race condition:

http://lists.openwrt.org/pipermail/openwrt-devel/2021-September/036464.html

Chad Neufeld commented on 01.10.2021 17:33

I haven't seen that issue yet. I'll do some testing next week and let you know how it goes.

Daniel Haid commented on 05.10.2021 07:41

With the latest snapshot, the bug is now also fixed for me, see:

http://lists.openwrt.org/pipermail/openwrt-devel/2021-October/036612.html

Chad Neufeld commented on 08.10.2021 15:57

You are correct. The original patch helped, but it didn't completely solve the issue. My WDS link was down after being away for a week.

I have compiled and applied the new patch. I've restarted my WDS AP a few times with no issue. Will keep you updated.

Chad Neufeld commented on 16.10.2021 01:31

Hi Daniel. I've been running the new NETIFD updates for about a week and the WDS link seems to be nice and stable.

Have you have any issues since the last update?

Do you know if we could port the NETIFD updates to 21.02?

Thanks

Daniel Haid commented on 25.10.2021 21:32

No issues, it works well for me.

Unfortunately, it seems it did not go into 21.02.1.

What can we do to get it into 21.02.2?

evoserver commented on 02.11.2021 16:20

21.02.1 didn't solve the problem for me.
I hope for a 21.02.2 release.

Thank you all

Chad Neufeld commented on 25.11.2021 14:28

It looks like the NETIFD updates have been pushed to the 21.02 branch as of Nov 21, 2021. Hopefully 21.02.2 will have working WDS links again for Atheros.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=be55e7d5dd4b9f26eee98b0e996b752ebe641df8

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing