OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by hamelg - 13.07.2021
Last edited by Ted Hess - 20.10.2021

FS#3931 - [wndr3700v4] unable to upgrade from ar71xx to ath79

I’m trying to upgrade my wndr3700v4 router with the image downloaded at https://downloads.openwrt.org/releases/21.02.0-rc3/targets/ath79/nand/openwrt-21.02.0-rc3-ath79-nand-netgear_wndr3700-v4-squashfs-sysupgrade.bin

The file has the correct sum but sysupgrade doesn’t accept it.

The current and running image has been built with these settings :
CONFIG_TARGET_ar71xx=y
CONFIG_TARGET_ar71xx_nand=y
CONFIG_TARGET_ar71xx_nand_DEVICE_WNDR3700V4=y
any ideas ?

root@OpenWrt:/tmp# cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='19.07-SNAPSHOT'
DISTRIB_REVISION='r11333-cc0b70467d'
DISTRIB_TARGET='ar71xx/nand'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 19.07-SNAPSHOT r11333-cc0b70467d'
DISTRIB_TAINTS='no-all'

root@OpenWrt:/tmp# uname -a
Linux OpenWrt 4.14.229 #0 Fri Apr 9 13:43:38 2021 mips GNU/Linux

root@OpenWrt:/tmp# sha256sum /tmp/openwrt-21.02.0-rc3-ath79-nand-netgear_wndr3700-v4-squashfs-sysupgrade.bin
dacbea4403807a104aac151f1d4973c16477b9095ba698b0f19a4ceaf8e2c38d  /tmp/openwrt-21.02.0-rc3-ath79-nand-netgear_wndr3700-v4-squashfs-sysupgrade.bin

root@OpenWrt:/tmp# sysupgrade -n -v /tmp/openwrt-21.02.0-rc3-ath79-nand-netgear_wndr3700-v4-squashfs-sysupgrade.bin 
Device wndr3700v4 not supported by this image
Supported devices: netgear,wndr3700-v4
Invalid sysupgrade file.
Image check failed.
Closed by  Ted Hess
20.10.2021 11:17
Reason for closing:  Not a bug
Walter Sonius commented on 14.07.2021 10:32

Warning without having access to serial uart bootloader or tested and verified failsafe tftp recovery procedures you are 1 step away from a (semi)BRICKED router!

https://bugs.openwrt.org/index.php?do=details&task_id=3927

hamelg commented on 14.07.2021 20:51

thanks for the warning. Hopefully, sysupgrade has detected the issue and has stopped before flashing.
I don't find any information about the support status of this router. It is just listed here without comments:
https://openwrt.org/docs/techref/targets/ath79?dataflt%5B0%5D=subtarget_%3Dnand

Some users use this ath79 image successfully ?

bob commented on 19.07.2021 17:58

Hi, I have flashed 21.02-rc3 on a netgear wndr3700v4.

sysupgrade did not work and left the router in a dysfunctional state, though the bootloader still worked.

To recover, I flashed the factory image via tftp.

I followed these tftp instructions, especially the subsection titled alternative advice.

nmrpflash appears to be a simpler tftp utility, but I haven't yet tried it.

Good luck!

tones111 commented on 05.09.2021 19:59

I can confirm that flashing the factory image (21.02.0) via tftp after holding the factory reset button during a power cycle works. Once loaded, the firmware update dialog no longer complains about an incompatible sysupgrade image and it appears to make use of the entire flash area (102MB free after install).

Thanks for the tip bob!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing