OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by yoeljacobsen - 25.06.2021

FS#3904 - Adding another SSID to a radio prvents the interface from starting due to duplicate BSSID

Adding a second SSID from Luci results in a configuration error which prevents the radio interface from starting.

resulted configuration:
config wifi-device ‘radio1’

option type 'mac80211'
option hwmode '11g'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option country 'US'
option htmode 'HT40'
option channel 'auto'
option cell_density '0'

config wifi-iface ‘default_radio1’

option device 'radio1'
option network 'lan'
option mode 'ap'
option macaddr '60:38:e0:be:e2:69'
option ssid 'somename'
option encryption 'psk2'
option key 'somepassword'

config wifi-iface ‘another_radio1’

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'anothername'
option encryption 'psk2'
option key 'anotherpassword'

Log:
Fri Jun 25 10:24:07 2021 daemon.notice netifd: Network device ‘wlan1’ link is down
Fri Jun 25 10:24:07 2021 daemon.notice netifd: radio1 (14904): sh: acs_survey: out of range
Fri Jun 25 10:24:07 2021 daemon.notice netifd: radio1 (14904): sh: acs_survey: out of range
Fri Jun 25 10:24:07 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) –> new PHY
Fri Jun 25 10:24:07 2021 daemon.err hostapd: Duplicate BSSID aa:bb:cc:dd:ee:ff on interface ‘wlan1-1’ and ‘wlan1’.
Fri Jun 25 10:24:07 2021 daemon.err hostapd: 1 errors found in configuration file ‘/var/run/hostapd-phy1.conf’ Fri Jun 25 10:24:07 2021 daemon.err hostapd: Failed to set up interface with /var/run/hostapd-phy1.conf
Fri Jun 25 10:24:07 2021 daemon.notice netifd: radio1 (14904): Command failed: Invalid argument
Fri Jun 25 10:24:07 2021 daemon.notice netifd: radio1 (14904): Device setup failed: HOSTAPD_START_FAILED

“workaround”:
If I add a different (fake) macaddr to the 2nd SSID, it works.

yoeljacobsen commented on 25.06.2021 12:27

So it seems the "workaround" isn't. The SSID can be found by clients but can't be actually connected.

yoeljacobsen commented on 27.06.2021 04:12

I changed both BSSIDs and now it works correctly. I changed the U/L bit to L and started from 1 in the last nibble:

config wifi-iface 'default_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option macaddr '62:xx:xx:xx:xx:61'
  option ssid 'somename'
  option encryption 'psk2'
  option key 'somepassword'

config wifi-iface 'another_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option ssid 'anothername'
  option encryption 'psk2'
  option macaddr '62:xx:xx:xx:xx:62'
  option key 'anotherpassword'
aschlager commented on 02.09.2021 14:34

I can confirm this bug on 21.02 with build openwrt-21.02.0-mvebu-cortexa9-linksys_wrt3200acm-squashfs-sysupgrade.bin

Cosworth commented on 21.10.2021 15:50

I just wanted to confirm that this also caused me issues - but that changing the mac address up by 1 as @yoeljacobsen has also solved my problem. Initially I thought it was the name of the config that was causing me the issues.

Although I am not sure exactly what that does since I assume my new 'made up' MAC address doesn't physically exist.

mss555 commented on 27.11.2021 14:39

This issue is still present in version 21.02.1. This appears to be a regression comparing to 19.07 which automatically picked distinct MAC addresses for each wireless interface assigned to a given radio interface.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing