OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by bob - 24.06.2021
Last edited by Ted Hess - 09.07.2021

FS#3902 - Device setup failed: HOSTAPD_START_FAILED

  1. Hardware: netgear, wndr3700-v4 (ath79 ath9k ar9344 ar9582)
  2. Versions of OpenWrt where bug occurs: 21.02.0-rc3, snapshot (ath79)

If /sbin/wifi is used to turn on wifi, an error message appears in syslog.

wifi appears to function normally nevertheless, but,

ubus call network.wireless status

erroneously reports that radio0 is down.

Steps to reproduce

  1. uci set wireless.@wifi-iface[0].disabled=0
  2. uci set wireless.@wifi-device[0].disabled=0
  3. uci commit
  4. wifi

Error message in syslog

Wed Jun 23 11:21:38 2021 daemon.err hostapd: Interface name wlan0 already in use
Wed Jun 23 11:21:38 2021 daemon.notice netifd: radio0 (10450): Command failed: Invalid argument
Wed Jun 23 11:21:38 2021 daemon.notice netifd: radio0 (10450): Device setup failed: HOSTAPD_START_FAILED
Wed Jun 23 11:21:38 2021 daemon.notice netifd: radio0 (10527): WARNING: Variable 'data' does not exist or is not an array/object



Closed by  Ted Hess
09.07.2021 13:38
Reason for closing:  Fixed
bob commented on 24.06.2021 17:52
bob commented on 24.06.2021 19:02
bob commented on 02.07.2021 19:36

These pull-requests have been committed to the master and 21.02 branches, so this bug can be closed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing