Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3898 - Wifi APs are disable when encryption is switched on. #7018

Closed
openwrt-bot opened this issue Jun 23, 2021 · 5 comments
Closed

FS#3898 - Wifi APs are disable when encryption is switched on. #7018

openwrt-bot opened this issue Jun 23, 2021 · 5 comments
Labels
flyspray target/lantiq pull request/issue for lantiq target

Comments

@openwrt-bot
Copy link

DMcDonnell:

Supply the following if possible:

  • Device problem occurs on XRX200 - BT Home Hub 5a
  • Software versions of OpenWrt/LEDE release, packages, etc. Trunk since 10 days or so.
  • Steps to reproduce, Make clean, select BTHH5a as target, make standard build, flash it, wifi APs work without encryption, enable encryption and the APs become disabled (see log below)
    , host
    I tried combinations of WPAD, WPA-supplicant, hostapd, wolfssl, openssl all with the same problem, encrypted APs fail.
    Note using the original Ath10k driver, rather than the CT driver, will bring up the 5GHz AP with encryption enabled.

root@OpenWrt:# uname -a
Linux OpenWrt 5.4.124 #0 SMP Wed Jun 23 06:22:19 2021 mips GNU/Linux
root@OpenWrt:
# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option disabled '0'
option cell_density '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWRT'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:0e.0'
option channel '1'
option band '2g'
option htmode 'HT20'
option disabled '0'
option cell_density '0'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWRT'
option encryption 'none'

root@OpenWrt:# wifi up
root@OpenWrt:
# logread |grep wlan
Wed Jun 23 06:37:03 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.769503] br-lan: port 2(wlan1) entered blocking state
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.773559] br-lan: port 2(wlan1) entered disabled state
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.779392] device wlan1 entered promiscuous mode
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.817116] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.822637] br-lan: port 2(wlan1) entered blocking state
Wed Jun 23 06:37:03 2021 kern.info kernel: [ 897.827390] br-lan: port 2(wlan1) entered forwarding state
Wed Jun 23 06:37:03 2021 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->ENABLED
Wed Jun 23 06:37:03 2021 daemon.notice hostapd: wlan1: AP-ENABLED
Wed Jun 23 06:37:03 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Wed Jun 23 06:37:04 2021 kern.info kernel: [ 898.993296] br-lan: port 3(wlan0) entered blocking state
Wed Jun 23 06:37:04 2021 kern.info kernel: [ 898.997157] br-lan: port 3(wlan0) entered disabled state
Wed Jun 23 06:37:04 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->HT_SCAN
Wed Jun 23 06:37:04 2021 kern.info kernel: [ 899.003263] device wlan0 entered promiscuous mode
Wed Jun 23 06:37:04 2021 daemon.notice netifd: Network device 'wlan1' link is up
Wed Jun 23 06:37:08 2021 kern.info kernel: [ 902.676578] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jun 23 06:37:08 2021 kern.info kernel: [ 902.681875] br-lan: port 3(wlan0) entered blocking state
Wed Jun 23 06:37:08 2021 kern.info kernel: [ 902.686952] br-lan: port 3(wlan0) entered forwarding state
Wed Jun 23 06:37:08 2021 daemon.notice netifd: Network device 'wlan0' link is up
Wed Jun 23 06:37:08 2021 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Wed Jun 23 06:37:08 2021 daemon.notice hostapd: wlan0: AP-ENABLED
root@OpenWrt:# vi /etc/config/wireless
root@OpenWrt:
# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option disabled '0'
option cell_density '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'MyAP-5GHZ'
option encryption 'psk2'
option key 'qwert12345'

config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:0e.0'
option channel '1'
option band '2g'
option htmode 'HT20'
option disabled '0'
option cell_density '0'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'MyAP-2.4GHz'
option encryption 'psk2'
option key 'qwert12345'

root@OpenWrt:# wifi down
root@OpenWrt:
# wifi up
root@OpenWrt:~# logread |grep wlan
.....
Wed Jun 23 06:40:49 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.556186] br-lan: port 2(wlan1) entered blocking state
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.560122] br-lan: port 2(wlan1) entered disabled state
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.566404] device wlan1 entered promiscuous mode
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.772553] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.777787] br-lan: port 2(wlan1) entered blocking state
Wed Jun 23 06:40:49 2021 kern.info kernel: [ 1123.782898] br-lan: port 2(wlan1) entered forwarding state
Wed Jun 23 06:40:49 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Wed Jun 23 06:40:50 2021 kern.info kernel: [ 1124.995987] br-lan: port 3(wlan0) entered blocking state
Wed Jun 23 06:40:50 2021 kern.info kernel: [ 1124.999851] br-lan: port 3(wlan0) entered disabled state
Wed Jun 23 06:40:50 2021 kern.info kernel: [ 1125.005954] device wlan0 entered promiscuous mode
Wed Jun 23 06:40:50 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->HT_SCAN
Wed Jun 23 06:40:50 2021 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->DISABLED
Wed Jun 23 06:40:50 2021 daemon.notice hostapd: wlan1: AP-DISABLED
Wed Jun 23 06:40:50 2021 daemon.err hostapd: wlan1: Unable to setup interface.
Wed Jun 23 06:40:50 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Wed Jun 23 06:40:50 2021 kern.info kernel: [ 1125.021045] device wlan1 left promiscuous mode
Wed Jun 23 06:40:50 2021 kern.info kernel: [ 1125.024384] br-lan: port 2(wlan1) entered disabled state
Wed Jun 23 06:40:50 2021 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Wed Jun 23 06:40:50 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1 wasn't started
Wed Jun 23 06:41:04 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Wed Jun 23 06:41:04 2021 kern.info kernel: [ 1138.536784] br-lan: port 3(wlan0) entered disabled state
Wed Jun 23 06:41:08 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->HT_SCAN
Wed Jun 23 06:41:12 2021 kern.info kernel: [ 1146.527964] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jun 23 06:41:12 2021 kern.info kernel: [ 1146.533315] br-lan: port 3(wlan0) entered blocking state
Wed Jun 23 06:41:12 2021 kern.info kernel: [ 1146.538175] br-lan: port 3(wlan0) entered forwarding state
Wed Jun 23 06:41:12 2021 daemon.notice netifd: Network device 'wlan0' link is up
Wed Jun 23 06:41:12 2021 daemon.notice hostapd: wlan0: interface state HT_SCAN->DISABLED
Wed Jun 23 06:41:12 2021 daemon.notice hostapd: wlan0: AP-DISABLED

@openwrt-bot
Copy link
Author

argonym:

Reverting [[https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=53b6783907f3bd6f0f88f9d6feed20b21e2cd181|53b6783]] fixed my [[https://bugs.openwrt.org/index.php?do=details&task_id=3901|very similar issue]].

@openwrt-bot
Copy link
Author

nbd:

Do you have the DEU driver installed? Does the same issue also happen if you remove that one?

@openwrt-bot
Copy link
Author

DMcDonnell:

@felix Fietkau,

Yes, thank you very much, building without the deu driver resolved the problem. Note I had to build without the due, it was not enough to remove it from /etc/modules.d

Greatly appreciate your efforts!

@openwrt-bot
Copy link
Author

DMcDonnell:

Just to report that I applied Daniel Kestrel's pull request [1] to trunk, selected the Testing Kernel, 5.10.46, and the ltq-deu kmod and did a make. I am happy to report that it runs flawlessly with wifi encryption set to wpa, psk2 etc. Only sae failed to work but I dont use it anyway.

Paul Rowland has a forum thread on testing. [2]

[1]"lantiq: ltq-deu: switch to new kernel api and major rework " #4326
[2] https://forum.openwrt.org/t/testing-the-new-lantiq-deu-driver/100466

@xdarklight
Copy link
Contributor

This has worked for me for a very long time:

  • first ltq-deu was disabled and wifi worked fine again
  • then @kestrel1974's ltq-deu updates were merged and wifi still works

That means this issue has been resolved and can be closed (that said, I am not the original reporter and I don't have permission to do so).

@mkresin mkresin closed this as completed Mar 14, 2022
@ynezz ynezz added the target/lantiq pull request/issue for lantiq target label Mar 15, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
flyspray target/lantiq pull request/issue for lantiq target
Projects
None yet
Development

No branches or pull requests

4 participants