OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Charles JC - 23.06.2021

FS#3897 - odhcp is not assigning lease times as specified in static leases

  • TP-Link Archer C2600
  • OpenWRT 21.02-RC3

From boot, ipv6 leases are mostly assigned with leases of 1 hour. Occasionally leases of 14 days (as specified in Static Leases), and occasionally leases of 30 minutes and occasionally no leases (or leases expire and are not renewed).

What debugging / logging steps can I take to better pin down this issue?

I suspect that this is related to, or causes, occasional long stalls when opening new web pages, reported at the OpenWRT forum

In an initial effort to debug, I stopped odhcp and then started it on the command line with -l 7. The only logging that looked like a possible error are occasional sequences similar to this:

odhcpd[8869]: Received 123 Bytes from fe80::215:5dff:fe01:aa0f%lan@br-lan
odhcpd[8869]: Got a DHCPv6-request on lan
odhcpd[8869]: DHCPV6 REBIND IA_NA from 00020000ab113cca95908581f184 on lan: ok 2401:xxxx:xxxx:7bf7::ffff:253/128 fda6:3ce8:c11::ffff:253/128
odhcpd[8869]: Sending a DHCPv6-reply on lan
odhcpd[8869]: Sent 172 bytes to fe80::215:5dff:fe01:aa0f%lan@br-lan
BusyBox v1.33.1 (2021-06-13 22:02:19 UTC) multi-call binary.

Usage: basename FILE [SUFFIX]

Strip directory path and .SUFFIX from FILE
odhcpd[8869]: Netlink newneigh 2401:xxxx:xxxx:7bf7::aaaa:aaaa on lan
Charles JC commented on 23.06.2021 06:05

Here's the lightly redacted log

   odhcp.log (102.2 KiB)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing