OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Rich - 19.06.2021

FS#3888 - Archer C7 v2: since moving to ath79, intermittent wifi interruption

As the summary says - since I upgraded from 19.07.1 to 19.07.7, and from ar71xx to ath79, I have sometimes (averaging once every few days now) experienced my wifi connection misbehaving (over the 5GHz; I haven’t tried staying on the 2.4 long enough to determine if it affects that too) from my laptop, the main client. When it occurs, sometimes there’s a period of high latency to LAN and WAN first, then either it recovers or my ability to talk to other hosts over the LAN or WAN dies like all my traffic is blackholing, but without my wireless disconnecting - I did not think to attempt pinging/other connection to the router, I will next time.

This state persists until I manually trigger a disconnect and reconnect on my client - I tried leaving it for a minute or two, it doesn’t seem to disconnect on its own or recover. So far, it’s worked normally again every time immediately after reconnecting.

I also didn’t have the only other convenient wifi client I use handy when this happened last (my Android phone); I’ll see if it’s affected at the same time next time this occurs, though since I’ve not noticed any issues with it, either it behaves differently or isn’t affected at all.

The laptop is Win10 x64, the wireless is Intel’s Wireless-AC 8265, driver version 20.70.21.2, and the driver hasn’t been updated since January, so it seems less likely to be at fault.

If you look at Sat Jun 19 06:44:09 in the log attached, you can see where I manually disconnected and reconnected - I’m reasonably confident I only did that once, but memory is inherently unreliable, so who knows.

If there’s any other debugging information I could usefully provide, please let me know.

Walter Sonius commented on 20.06.2021 17:54

You've probably already stumbled upon this forum thread:
Archer C7 2.4 GHz wireless dies in 24~48 hours

Rich commented on 20.06.2021 18:17

I had not, in point of fact, but I'm not sure they're having the same problem, as my wifi was working reliably on 19.07.1, which seems to be after most people in there started reporting issues, I don't ever see the messages in dmesg at least one person reported, and the suggestion seems to be that a router reboot is required for connectivity to return?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing