OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Sven Roederer - 09.06.2021
Last edited by Hauke Mehrtens - 22.06.2021

FS#3866 - no network in failsafe

Adapting my configs to the new-bridge setup I realized that failsafemode is broken.

Device: TPLink WDR-3600 (ath79-generic)
Release: OpenWrt-21.02.0-rc2, snapshot “r16916-7f946a880a”

* just installed the images from download.openwrt.org via “sysupgrade -n” * booted up regularly
* login via SSH * reboot command
* entered failsafe via “button” * sys-led starts to blink fast
* can not ping of ssh to 192.168.1.1
* can not see a reply when ping ff02::1

Closed by  Hauke Mehrtens
22.06.2021 21:59
Reason for closing:  Fixed
Additional comments about closing:  

The problem was fixed here:
https:/ /git.openwrt.org/467cd378db3359814866ec4 121fdb4417783241e and here:
https:/ /git.openwrt.org/c0fdfd15fc8f1ad8c75c60a 8393a6d8b5c2b3b19

There are some other commits fixing also failsafe with DSA:

Sven Roederer commented on 12.06.2021 11:46

I can confirm this also on a Mikrotik RB750GR3 (ramips-mt7621; OpenWrt-21.02.0-rc2).
For some other issue I had to hook up serial-console get some data

Networkconfig seems unconfigured at all:

root@(none):/# ip addr
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4fe:91ff:fe77:e0ea/64 scope link 
       valid_lft forever preferred_lft forever
3: wan@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff
7: lan5@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 06:fe:91:77:e0:ea brd ff:ff:ff:ff:ff:ff

I'm also not sure if the mt7520-switch is setup correctly, as I can't see any port is reporting a link in kernel-log.

Sven Roederer commented on 17.06.2021 20:33

Also present in OpenWrt-21.02.0-rc3 (tested with TPLink WDR3600)

Hannu Nyman commented on 18.06.2021 05:44

Looks like we are still looking for "ifname" in preinit, although the board.json has been changed to contain "device" instead of "ifname".

Preinit:
https://github.com/openwrt/openwrt/blob/ec6293febc244d187e71a6e54f44920be679cde4/package/base-files/files/lib/preinit/10_indicate_preinit#L75

	json_select network
		json_select "lan"
			json_get_vars ifname
		json_select ..
	json_select ..

From board.json

        "network": {
                "lan": {
                        "device": "eth1.1",
                        "protocol": "static"

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing