OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Build Failure
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Steven Johnson - 07.06.2021
Last edited by Baptiste Jonglez - 18.06.2021

FS#3859 - Trying to build ca-certificates using the 21.02-rc2 SDK fails.

My system python is python 3.9.5 used for this build, on linux.

Steps to reproduce:

  1. Download and unpack the sdk. I am using: openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64.tar.xz
  2. Change into sdk directory.
  3. make package/symlinks-install
  4. make defconfig
  5. make package/ca-certificates/compile

Ends with:

rm -f /tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/.built
touch /tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/.built_check
CFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -mips16 -minterlink-mips16 -ffile-prefix-map=/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119=ca-certificates-20210119 -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro  -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/usr/include -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/include/fortify -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/include " CXXFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -mips16 -minterlink-mips16 -ffile-prefix-map=/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119=ca-certificates-20210119 -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro  -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/usr/include -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/include/fortify -I/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/include " LDFLAGS="-L/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/usr/lib -L/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/lib -znow -zrelro " make -j1 -C /tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/work AR="mipsel-openwrt-linux-musl-gcc-ar" AS="mipsel-openwrt-linux-musl-gcc -c -Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -ffile-prefix-map=/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119=ca-certificates-20210119 -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro" LD=mipsel-openwrt-linux-musl-ld NM="mipsel-openwrt-linux-musl-gcc-nm" CC="mipsel-openwrt-linux-musl-gcc" GCC="mipsel-openwrt-linux-musl-gcc" CXX="mipsel-openwrt-linux-musl-g++" RANLIB="mipsel-openwrt-linux-musl-gcc-ranlib" STRIP=mipsel-openwrt-linux-musl-strip OBJCOPY=mipsel-openwrt-linux-musl-objcopy OBJDUMP=mipsel-openwrt-linux-musl-objdump SIZE=mipsel-openwrt-linux-musl-size CROSS="mipsel-openwrt-linux-musl-" ARCH="mipsel" ;
make[3]: Entering directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/work'
for dir in mozilla; do \
  make -C $dir all; \
done
make[4]: Entering directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/work/mozilla'
python3 certdata2pem.py
/home/steven/.pyenv/libexec/pyenv: line 134: /home/steven/.pyenv/libexec/pyenv-exec: Argument list too long
make[4]: *** [Makefile:6: all] Error 126
make[4]: Leaving directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/work/mozilla'
make[3]: *** [Makefile:9: all] Error 2
make[3]: Leaving directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/work'
make[2]: *** [Makefile:73: /tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/build_dir/target-mipsel_24kc_musl/ca-certificates-20210119/.built] Error 2
make[2]: Leaving directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/feeds/base/package/system/ca-certificates'
time: package/feeds/base/ca-certificates/compile#167.52#155.64#316.63
    ERROR: package/feeds/base/ca-certificates failed to build.
make[1]: *** [package/Makefile:114: package/feeds/base/ca-certificates/compile] Error 1
make[1]: Leaving directory '/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64'
make: *** [/tmp/openwrt-sdk-21.02.0-rc2-ramips-mt7621_gcc-8.4.0_musl.Linux-x86_64/include/toplevel.mk:223: package/ca-certificates/compile] Error 2


Closed by  Baptiste Jonglez
18.06.2021 21:14
Reason for closing:  Works for me
Additional comments about closing:  

Related to a local setup (pyenv)

Steven Johnson commented on 07.06.2021 06:22

This is an issue with python 3.9 building with python 3.8.9 succeeded.

Steven Johnson commented on 09.06.2021 05:14

I have tried the upstream source from Debian and it builds with python 3.9.5 correctly, whatever is going on here seems to be related to the OpenWrt build system.

Project Manager
Baptiste Jonglez commented on 18.06.2021 05:19

It looks like an issue with your python installation (you are using pyenv), try removing pyenv from your $PATH and/or report the bug upstream to pyenv.

OpenWrt only checks that python3 is installed on the host, but that does not mean that it's fully functional.

Steven Johnson commented on 18.06.2021 06:50

I have solved the problem locally by building inside a container. The odd thing is i can build OpenWrt itself totally fine, this issue only occurs with the SDK. It was also strange that upstream debian builds completely fine in the same environment.

Uninstalling pyenv is not really an option for me, but building inside a container achieves a similar pyenv-less setup for building, and that does work with python 3.9.

Given i have a work around, and it is more than likely to do with how my PC is set up, i think we can close this one.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing