OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Wade - 06.06.2021

FS#3858 - Wireless devices lose networking

Hardware: Linksys WRT3200ACM connected to AT&T BGW-210 with Passthrough enabled.
Software: OpenWRT 19.07.7, OpenWRT 21.02.0-rc2

WRT3200 configured with 10.1.1.1, BGW-210 configured with 192.168.1.254
BGW-210 has wireless disabled and only has WRT3200 connected

About two weeks ago, wireless devices started to randomly lose networking capability. They would remain connected to WiFi, but had no internet and could also not connect to the Luci interface via IP address in browser. I tried switching to 21.02.0-rc2 hoping that would fix it, but the results are the same. The only two options to fix the problem was to either reboot the WRT3200 or forget the WiFi network/name on the device having issues and then re-connect to WiFi.

My final configurations before I switched back to latest Linksys firmware (because I was going crazy with devices constantly losing internet) was just having Cloudflare DNS setup under Networking → Interfaces → WAN/WAN6 and maybe under LAN. No additional packages beyond the flash were installed. Attempted to give static leases to devices but that did not seem to help.

Wireless was setup as WPA2 AES (NOT WPA3 or WPA2/WPA3-mixed) with a different name for 5Ghz vs 2.4Ghz, Krack protection enabled, auto selection of channel. No other options changed. The 3rd wireless option was configured for Guest with the same settings plus isolate clients, but that config was never turned on.

Each wireless device affected would happen at its own random time. Devices connected via ethernet had no issues.

I keep all packages up-to-date and had been running with this same configuration/setup for over a year with the only change keeping OpenWRT OS version up-to-date. Sometimes I would flash the 19.07.x updates as a fresh config and re-setup everything in the same way.

If I absolutely need to re-flash to provide more information, I can but it will hurt.

Software commented on 18.06.2021 00:47

Do you happen to have 802.11w enabled? It's on the Wireless Security tab of the device settings.

That setting caused huge problems for me when enabled.

Wade commented on 09.08.2021 22:53

I left all of the options to be the default setting except as noted above (ESSID, WPA2 AES, Krack protection enabled). I did not enable 802.11w or 802.11r.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing