OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by rvernica - 04.06.2021
Last edited by Baptiste Jonglez - 18.06.2021

FS#3853 - ath79: NETGEAR WNDR4300v2 Bricked on Power Cycle After Flash

On a NETGEAR WNDR4300v2 with stock firmware I flash OpenWrt. It works fine after flash (not power cycled *yet*). On the first power cycle the device is fails to start. I’m able to restore the factory firmware using nmrpflash.

Device: NETGEAR WNDR4300v2
Factory firmware: V1.0.0.58
OpenWrt firmware: openwrt-21.02.0-rc2-ath79-nand-netgear_wndr4300-v2-squashfs-factory.img

I checked the OpenWrt firmware checksum. I did a factory install. On first boot, OpenWrt works just fine. I’m able to adjust settings and Save & Apply them. If I power-cycle the device it fails to boot. The problem exists even if I don’t change any settings in OpenWrt. The Power led is amber continuously. The led for ports 1-4 flash once then remain off. After about 18 seconds the cycle repeats.

I’m able to restore the factory firmware by connecting to port 1. I set a static IP 192.168.1.100/255.255.255.0 Gateway:192.168.1.1. I ran the nmrpflash tool and power On the unit:

> sudo ./nmrpflash -i enp0s25 -f WNDR4300v2-V1.0.0.58.img
Waiting for physical connection.
Advertising NMRP server on enp0s25 ... |
Received configuration request from xx:yy:...
Sending configuration: 10.164.183.252/24.
Received upload request: filename 'firmware'.
Uploading WNDR4300v2-V1.0.0.58.img ... OK
Waiting for remote to respond.
Remote finished. Closing connection.
Reboot your device now.

Once completed the factory firmware is restored.


xspio commented on 10.06.2021 05:45

exactly the same problem +1

rvernica commented on 26.08.2021 20:00

Tried with the August 25, 2021 snapshot and the behavior is the same.

L.S.S. commented on 11.10.2021 10:27

Just flashed OpenWrt master (built using ImageBuilder with necessary packages included). After power cycle the same issue happens. +1

L.S.S. commented on 12.10.2021 02:53

Does the same issue happen on WNDR4500v3 also? I read that these two devices are similar in terms of hardware and are supported by OpenWrt in a similar fashion.

EDIT: I just read the forum and found someone suggested flashing the image twice: First using the factory image (from stock), then flash the sysupgrade image after booting OpenWrt. The second flash would correctly detect and mark the bad blocks. The same applies to WNDR4500v3 as well (which uses similar hardware).

See this: https://forum.openwrt.org/t/support-for-netgear-wndr4300-v2/26099/42

If this really turns out to be a case where sysupgrade is handling the process correctly, but stock flashing process doesn't, then I don't think it's likely that the issue could be fixed on this side. As such, I seriously think someone who has access to the wiki should put a big red warning about this, as well as the necessary steps to recover/reflash in case a user ended up this way.

L.S.S. commented on 18.10.2021 12:31

An update.

Can confirm that flashing a sysupgrade image (can be the same build) after flashing the factory one is MANDATORY to ensure the router would not brick after a power cycle.

I flashed the factory image and then the sysupgrade image afterwards, after recovering the router using NMRP. The kernel showed some bad blocks being marked when flashing the sysupgrade one, and when I power cycled it today (as I'm moving it to another place), the router works fine.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing