OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by xesarni - 29.05.2021

FS#3835 - [MT7621] Hardware flow offloading doesn't work for PPPoE

Netgear R6220
OpenWrt 21.02-SNAPSHOT r16122-c213

Hardware flow offloading doesn’t work for PPPoE with VLAN (802.1q), so LAN to WAN is slow and CPU heavy. It does work on 19,07, though.

Victor commented on 16.07.2021 09:28

I observe this issue on Xiaomi Mi Router 4A gigabit edition with OpenWrt 21.02-rc3 (r16172-2aba3e9784). The WAN to LAN download speed is about 20 Mbps on the 100 Mbps channel, while the upload speed is OK.

xesarni commented on 16.07.2021 12:25

https://forum.openwrt.org/t/openwrt-21-02-0-second-release-candidate/98026/126

Hardware flow offloading does not work with VLANs because it needs the 5.10 (or newer) kernel. Don't know if the PPPoE is also affected because I'm unable to test it without a VLAN.

Hck commented on 08.10.2021 13:34

I am running 21.02.0 on MT7621 device.
DHCP connection over 802.1q VLAN - 1Gb/s with 0% sirq.
PPPoE connection over DSA wan port - 100Mb/s with 20% sirq.
Looks like HW offloding works for VLAN and doesn't for PPPoE.

LESSLOAD commented on 12.11.2021 10:30

Problem found on all MT7621 that i have.
Seem like Hardware flow offloading not work with PPPoE.
Make me rollback all device to 19.07

luki commented on 12.12.2021 23:12

Is it possible to use kernel 5.10 for MT7621, since it supports Hardware flow offloading for PPPoE?

lamudmr commented on 15.12.2021 01:19

F.Y.I

As of December 14 2021, Snapshot using kernel 5.10 and hardware offloading seems to work on PPPOE (may be on vlans, too). You can get decent download and upload speed.

xesarni commented on 16.12.2021 11:40

Yes, hardware offloading does work (including PPPoE & VLANs) when using kernel 5.10.

luki commented on 02.01.2022 22:14

Since I've been using kernel 5.10 everything it's been fine. 17 days without rebooting and performance close to 1GB/s maximum when using VLAN and PPOE. Thanks for the info.

goldenhunter commented on 03.01.2022 12:51

well, it is a big problem for branch 21.02 , do the ppp support can be porting to kernel 5.4 ?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing