OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Jaap Buurman - 06.05.2021
Last edited by Ted Hess - 06.05.2021

FS#3788 - 21.02 RC1: BUG: Bad page state in process swapper/0

Device used: RT-AC57U (mt7621 based device)
Version used: 21.02 RC1
Steps to reproduce: This ended up in my kernel log after a few days of uptime. I am unsure what exactly caused the issue.

I am currently beta testing the new 21.02 RC1 release on two different devices. Stability seems very good, but I did run into an issue with the aforementioned RT-AC57U. I found this stacktrace in the kernel log. I am unsure if this caused the network to go down, since I am not sure if I was using the network at that time. Does anyone have any idea what is causing this?

[410758.374134] BUG: Bad page state in process swapper/0  pfn:05edc
[410758.386105] page:809236f0 refcount:-1 mapcount:0 mapping:00000000 index:0x0
[410758.400121] flags: 0x0()
[410758.405331] raw: 00000000 00000000 00000122 00000000 00000000 00000000 ffffffff ffffffff
[410758.421588] raw: 00000000
[410758.426956] page dumped because: nonzero _refcount
[410758.436644] Modules linked in: xt_connlimit pppoe ppp_async nf_conncount iptable_nat xt_state xt_nat xt_helper xt_conntrack xt_connmark xt_connbytes xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT wireguard pppox ppp_generic nf_nat_pptp nf_nat nf_flow_table_hw nf_flow_table nf_conntrack_rtcache nf_conntrack_pptp nf_conntrack_netlink nf_conntrack mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 libchacha20poly1305 libblake2s ipt_REJECT cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY ts_kmp ts_fsm ts_bm slhc sch_cake poly1305_mips nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcurve25519_generic libblake2s_generic iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt compat chacha_mips br_netfilter sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit
[410758.436829]  act_mirred ledtrig_usbport xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ifb ip6_udp_tunnel udp_tunnel kpp leds_gpio xhci_plat_hcd xhci_pci xhci_mtk xhci_hcd gpio_button_hotplug usbcore nls_base usb_common
[410758.712580] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.4.111 #0
[410758.724692] Stack : 00000000 80840000 00000003 8007d6e0 00000000 00000000 00000000 00000000
[410758.741481]         00000000 00000000 00000000 00000000 00000000 00000001 87c0db80 5fc2ce17
[410758.758268]         87c0dc18 00000000 00000000 00000000 00000038 805e1804 2e352064 31312e34
[410758.775053]         00000000 00004fd5 00000000 70617773 00000000 87c0db60 00000000 80840000
[410758.791840]         80604b20 806b0000 00000000 806d7f20 00000000 80359e2c 00000000 80810000
[410758.808627]         ...
[410758.813649] Call Trace:
[410758.813663] [<8007d6e0>] 0x8007d6e0
[410758.825779] [<805e1804>] 0x805e1804
[410758.832880] [<80359e2c>] 0x80359e2c
[410758.839978] [<8000b05c>] 0x8000b05c
[410758.847075] [<8000b064>] 0x8000b064
[410758.854173] [<805c6f9c>] 0x805c6f9c
[410758.861271] [<8014dabc>] 0x8014dabc
[410758.868420] [<80150ca4>] 0x80150ca4
[410758.875519] [<804a8b28>] 0x804a8b28
[410758.882662] [<806e0000>] 0x806e0000
[410758.889769] [<80151c80>] 0x80151c80
[410758.896866] [<80063508>] 0x80063508
[410758.903966] [<80150015>] 0x80150015
[410758.911063] [<804326ac>] 0x804326ac
[410758.918163] [<8001e448>] 0x8001e448
[410758.925262] [<80152bc4>] 0x80152bc4
[410758.932359] [<80433040>] 0x80433040
[410758.939456] [<800939cc>] 0x800939cc
[410758.946554] [<803dd720>] 0x803dd720
[410758.953652] [<800104dc>] 0x800104dc
[410758.960754] [<80433858>] 0x80433858
[410758.967852] [<80433acc>] 0x80433acc
[410758.974952] [<805e7d1c>] 0x805e7d1c
[410758.982053] [<80030768>] 0x80030768
[410758.989150] [<802f8404>] 0x802f8404
[410758.996249] [<80006c28>] 0x80006c28
[410759.003344] 
[410759.006466] Disabling lock debugging due to kernel taint
Closed by  Ted Hess
06.05.2021 10:55
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of #3787

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing