OpenWrt/LEDE Project

  • Status Requires testing
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by apcameron - 05.05.2021

FS#3782 - TP-Link CPE510 v2 bootloop with 21.02.0-rc1

Installing the 21.02.0-rc1 Sysupgrade image on the TP-Link CPE510 v2 or TP-Link CPE610 v1 results in the same bootloop as reported in https://bugs.openwrt.org/index.php?do=details&task_id=3750

Here is a log from my device with a line length of 80 chars

TP-LINK SafeLoader (Build time: Jun 14 2017 - 10:08:41)
CPU: 560MHz AHB: 225MHz DDR: 8MB
Performing LED check..  PASS
Press CTRL+B to enter SafeLoader: 1

Allocated memory for elf segment ok: addr: 0x80060000, size 0x16dc
Loading .text @ 0x80060000 (5852 bytes)

Starting kernel


OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Looking for OpenWrt image... found at 0xbf043000
Decompressing kernel... done!
Starting kernel at 80060000...
[    0.000000] Linux version 5.4.111 (builder@buildhost) (gcc version 8.4.0 (Ope
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[    0.000000] MIPS: machine is TP-Link CPE510 v2
[    0.000000] SoC: Atheros AR9344 rev 2
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jf
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, li
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, lin
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 57336K/65536K available (5216K kernel code, 190K rwdata,
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] random: get_random_bytes called from 0x80655984 with crng_init=0
[    0.000000] CPU clock: 560.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_
[    0.000010] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669
[    0.009095] Calibrating delay loop... 278.78 BogoMIPS (lpj=557568)
[    0.052225] pid_max: default: 32768 minimum: 301
[    0.057783] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, line
[    0.066284] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes,
[    0.080827] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, m
[    0.092208] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.100259] pinctrl core: initialized pinctrl subsystem
[    0.109580] NET: Registered protocol family 16
[    0.117299] GPIO line 18 (tp-link:ext:lna0) hogged as output/high
[    0.124466] GPIO line 19 (tp-link:ext:lna1) hogged as output/high
[    0.159972] workqueue: max_active 576 requested for napi_workq is out of ran
[    0.176037] clocksource: Switched to clocksource MIPS
[    0.183518] NET: Registered protocol family 2
[    0.189793] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096
[    0.199606] TCP established hash table entries: 1024 (order: 0, 4096 bytes, 
[    0.208534] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.216742] TCP: Hash tables configured (established 1024 bind 1024)
[    0.224301] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.231970] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.240490] NET: Registered protocol family 1
[    0.245632] PCI: CLS 0 bytes, default 32
[    0.255091] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.271344] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.278179] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORI
[    0.307686] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 
[    0.321044] pinctrl-single 1804002c.pinmux: 544 pins, size 68
[    0.329034] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.339440] printk: console [ttyS0] disabled
[    0.344535] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 25
[    0.354585] printk: console [ttyS0] enabled
[    0.354585] printk: console [ttyS0] enabled
[    0.363495] printk: bootconsole [early0] disabled
[    0.363495] printk: bootconsole [early0] disabled
[    0.388005] spi-nor spi0.0: gd25q64 (8192 Kbytes)
[    0.392920] 6 fixed-partitions partitions found on MTD device spi0.0
[    0.399384] Creating 6 MTD partitions on "spi0.0":
[    0.404285] 0x000000000000-0x000000020000 : "u-boot"
[    0.410563] 0x000000020000-0x000000030000 : "partition-table"
[    0.417611] 0x000000030000-0x000000040000 : "info"
[    0.423688] 0x000000040000-0x0000007c0000 : "firmware"
[    0.430160] 0x0000007c0000-0x0000007f0000 : "config"
[    0.436538] 0x0000007f0000-0x000000800000 : "art"
[    0.445059] libphy: Fixed MDIO Bus: probed
[    0.768479] libphy: ag71xx_mdio: probed
[    0.773748] libphy: ar8xxx-mdio: probed
[    0.785848] switch0: Atheros AR8229 rev. 1 switch registered on mdio.0
[    1.145976] ag71xx 19000000.eth: connected to PHY at mdio.0:1f:04 [uid=004dd
[    1.156116] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    1.162648] i2c /dev entries driver
[    1.169430] NET: Registered protocol family 10
[    1.180091] random: fast init done
[    1.184945] Segment Routing with IPv6
[    1.188879] NET: Registered protocol family 17
[    1.193512] bridge: filtering via arp/ip/ip6tables is no longer available by
[    1.206679] 8021q: 802.1Q VLAN Support v1.8
[    1.212391] hctosys: unable to open rtc device (rtc0)
[    1.218812] /dev/root: Can't open blockdev
[    1.223069] VFS: Cannot open root device "(null)" or unknown-block(0,0): err
[    1.230673] Please append a correct "root=" boot option; here are the availa
[    1.239162] 1f00             128 mtdblock0 
[    1.239166]  (driver?)
[    1.245826] 1f01              64 mtdblock1 
[    1.245829]  (driver?)
[    1.252485] 1f02              64 mtdblock2 
[    1.252488]  (driver?)
[    1.259138] 1f03            7680 mtdblock3 
[    1.259140]  (driver?)
[    1.265792] 1f04             192 mtdblock4 
[    1.265795]  (driver?)
[    1.272452] 1f05              64 mtdblock5 
[    1.272455]  (driver?)
[    1.279103] Kernel panic - not syncing: VFS: Unable to mount root fs on unkn
[    1.287482] Rebooting in 1 seconds..


apcameron commented on 05.05.2021 02:03

When it was working the MTD blocks looked as follows and the firmware MTD partition was correctly split. This is not happening now resulting in the boot failure.
[ 0.356707] m25p80 spi0.0: gd25q64 (8192 Kbytes)
[ 0.361463] 6 fixed-partitions partitions found on MTD device spi0.0
[ 0.367971] Creating 6 MTD partitions on "spi0.0":
[ 0.372843] 0x000000000000-0x000000020000 : "u-boot"
[ 0.378824] 0x000000020000-0x000000030000 : "partition-table"
[ 0.385623] 0x000000030000-0x000000040000 : "info"
[ 0.391320] 0x000000040000-0x0000007c0000 : "firmware"
[ 0.397492] 2 fixed-partitions partitions found on MTD device firmware
[ 0.404182] Creating 2 MTD partitions on "firmware":
[ 0.409228] 0x000000000000-0x0000001c0000 : "kernel"
[ 0.415137] 0x0000001c0000-0x000000780000 : "rootfs"
[ 0.420988] mtd: device 5 (rootfs) set to be root filesystem
[ 0.426845] 1 squashfs-split partitions found on MTD device rootfs
[ 0.433154] 0x000000680000-0x000000780000 : "rootfs_data"
[ 0.439461] 0x0000007c0000-0x0000007f0000 : "config"
[ 0.445457] 0x0000007f0000-0x000000800000 : "art"
[ 0.452421] libphy: Fixed MDIO Bus: probed

GKaURTbV commented on 05.05.2021 06:12

Thanks for the bootlog on the CPE510 v2.

Makes one wonder why the "firmware" partition is not getting split into "kernel" + "rootfs" partitions for the CPE devices with 21.02.0-rc1..

Walter Sonius commented on 05.05.2021 08:35

Thanks apcameron for referencing similar ath79 no root device bug:
https://bugs.openwrt.org/index.php?do=details&task_id=3750

A possible fix from mpratt14 is open for testing:
https://github.com/openwrt/openwrt/pull/4143

apcameron commented on 06.05.2021 01:21

I can confirm that https://github.com/openwrt/openwrt/pull/4143 Resolved the Problem

Project Manager
Baptiste Jonglez commented on 18.06.2021 06:50

Backported as r16181-7a4bd9cc51: https://git.openwrt.org/7a4bd9cc518933d61099f109ce050c03afdc1c83

Please test 21.02-SNAPSHOT in a few days to confirm it works fine.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing