OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-21.02
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by GKaURTbV - 03.05.2021
Last edited by Baptiste Jonglez - 25.06.2021

FS#3778 - TP-Link CPE210 v1 bootloop with 21.02.0-rc1

Supply the following if possible:
- Device problem occurs on:

              TP-Link CPE210 v1

- Software versions of OpenWrt/LEDE release, packages, etc.

              21.02.0-rc1

- Steps to reproduce

I had OpenWrt 19.07.7 installed on a TP-Link CPE210 v1, but with the old ar71xx arch. The device worked just fine - no complaints whatsoever.

From there, I tried sysupgrading to 21.02.0-rc1 with the sysupgrade firmware (https://downloads.openwrt.org/releases/21.02.0-rc1/targets/ath79/generic/openwrt-21.02.0-rc1-ath79-generic-tplink_cpe210-v1-squashfs-sysupgrade.bin), and because of the arch change to ath79, while sysupgrading I choose NOT to keep settings. Judging by the LEDs - the device went into some kind of a bootloop.

I managed to recover the device back to stock, and from there - I tried installing the factory firmware (https://downloads.openwrt.org/releases/21.02.0-rc1/targets/ath79/generic/openwrt-21.02.0-rc1-ath79-generic-tplink_cpe210-v1-squashfs-factory.bin), just to check if it made any difference.

Sadly, no luck the second time either - the same bootloop again.

So then I was back to stock, and the to 19.07.7, and I have a working device again.

Just wanted to report the failure, in contrast with my tries with 21.02.0-rc1 on the TP-LINK Archer C7 v5 and the TP-Link TL-WR1043ND v1, which seem to work just fine.

 


Closed by  Baptiste Jonglez
25.06.2021 08:34
Reason for closing:  Fixed
Additional comments about closing:  

https:/ /git.openwrt.org/7a4bd9cc518933d61099f10 9ce050c03afdc1c83

GKaURTbV commented on 03.05.2021 14:42

Bug report 3750 seems similar:

https://bugs.openwrt.org/index.php?do=details&task_id=3750

Unfortunatelly, I cannot provide such detailed info, because I don't have a serial connection on my CPE210 v1.

If I can try something - please, let me know.

apcameron commented on 03.05.2021 19:19

The TP-Link CPE 610 v1 has the same problem.
I think that the TP-Link CPE devices based on the Same SOC will all bootloop until the root cause is found and addressed.

apcameron commented on 05.05.2021 01:25
GKaURTbV commented on 15.06.2021 10:47

So this change fixed CPE210v1 boot loop for me:
https://github.com/openwrt/openwrt/pull/4143

It got included in the master OpenWrt branch:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=7b9a0c264cb9dc2c5a946a0aa9a290427a5e559c

Can we get this in 21.02 branch as well, please?

It missed both rc2 and rc3 now.

Project Manager
Baptiste Jonglez commented on 18.06.2021 06:49

Backported as r16181-7a4bd9cc51: https://git.openwrt.org/7a4bd9cc518933d61099f109ce050c03afdc1c83

Please test 21.02-SNAPSHOT in a few days to confirm it works fine.

GKaURTbV commented on 19.06.2021 09:37

Thanks, Baptiste,

I can confirm that 21.02.0 branch now works as well. Here is the start of the kernel log:

[    0.000000] Linux version 5.4.124 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16181-7a4bd9cc51)) #0 Fri Jun 18 06:39:14 2021
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[    0.000000] MIPS: machine is TP-Link CPE210 v1
[    0.000000] SoC: Atheros AR9344 rev 2
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000]   Normal zone: 144 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 57272K/65536K available (5247K kernel code, 188K rwdata, 688K rodata, 1228K init, 205K bss, 8264K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] random: get_random_bytes called from 0x8065da28 with crng_init=0
[    0.000000] CPU clock: 560.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6825930166 ns
[    0.000010] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669584382ns
[    0.009085] Calibrating delay loop... 278.78 BogoMIPS (lpj=557568)
[    0.052217] pid_max: default: 32768 minimum: 301
[    0.057764] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.066266] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.080627] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.091994] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.100031] pinctrl core: initialized pinctrl subsystem
[    0.109097] NET: Registered protocol family 16
[    0.116667] GPIO line 18 (tp-link:ext:lna0) hogged as output/high
[    0.123819] GPIO line 19 (tp-link:ext:lna1) hogged as output/high
[    0.156979] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.172726] clocksource: Switched to clocksource MIPS
[    0.179771] thermal_sys: Registered thermal governor 'step_wise'

My only issue left with OpenWrt right now is that if for some reason I need to restart dnsmasq without rebooting my router, it fails to load the hostnames I have set up on the device. The issue and a fix is described in FS#3090:
https://bugs.openwrt.org/index.php?do=details&task_id=3090

Can something be done about that?

Thanks for the great work and for putting up with users like me :)
Stay healthy and strong!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing