OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Nikolay Martynov - 03.05.2021

FS#3776 - Switch bridge VLANs are not configured correctly with DSA

Device: Ubiquiti EdgeRouter X (MT7621)
Version: latest master from github and latest packages.

With this network config (only relevant parts shown:

config interface 'test'
	option proto 'static'
	option ifname 'eth4'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'

config interface 'switch'
	option proto 'static'
	option type 'bridge'
	option ifname 'eth1 eth2 eth3'

config bridge-vlan
	option device 'br-switch'
	list ports 'eth1:t'
	list ports 'eth2:t'
	list ports 'eth3:t'
	option vlan '9'

I get this bridge config after reboot:

# bridge vlan
port              vlan-id  
eth1              1 PVID Egress Untagged
eth2              1 PVID Egress Untagged
eth3              1 PVID Egress Untagged
br-switch         1 PVID Egress Untagged

And if I reload network configuration I get this:

root@erx-router:~# ubus call network reload
root@erx-router:~# bridge vl
port              vlan-id  
eth1              1 PVID Egress Untagged
                  9
eth2              1 PVID Egress Untagged
                  9
eth3              1 PVID Egress Untagged
                  9
br-switch         1 PVID Egress Untagged
                  9

Both result are wrong and do not work.

I did a small debugging session and it looks like `bridge_state.has_vlans` is always false - but I’m not exactly sure this is relevant.

Unfortunately this bugs make impossible to run any VLAN tagged ports on this device with any version of OpenWrt. Given that current releases are using DSA for this platform this is a regression from non-DSA setup.

I’ll be happy to provide any additional information.
I’ve tried to debug it myself by could not really find any obvious problems. So any ideas for this would be welcome too.

Thanks!

anomeome commented on 03.05.2021 02:08

syntax issue?

Nikolay Martynov commented on 24.05.2021 01:43

Yeah... that configuration process seems to be quite easy to mess up.

Thanks for the pointer!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing