OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Craig Miller - 01.05.2021

FS#3771 - odhcpd fails to send Router Advertisements

Supply the following if possible:
- Device problem occurs on
Linksys EA3500

- Software versions of OpenWrt/LEDE release, packages, etc.
21.02.0rc1

- Steps to reproduce
1. Install 21.02.0rc1 on device
2. After successful install, note that your ethernet connected laptop has only a link-local address (no ULA, or GUA).
3. Log into router and run logread command looking for odhcpd errors. Note the following:

logread | grep odhcp
Sun Apr 18 03:07:34 2021 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Sun Apr 18 03:07:38 2021 daemon.err odhcpd[1799]: Failed to send to ff02::1%lan@br-lan (Address not available)
Sun Apr 18 03:07:41 2021 daemon.err odhcpd[1799]: Failed to send to fe80::9ed6:43ff:feae:1915%lan@br-lan (Address not available)
Sun Apr 18 03:07:41 2021 daemon.err odhcp6c[2528]: Failed to send RS (Address not available)
Sun Apr 18 03:07:42 2021 daemon.err odhcpd[1799]: Failed to send to ff02::1%lan@br-lan (Address not available)
Sun Apr 18 03:07:42 2021 daemon.err odhcp6c[2528]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Apr 18 03:07:48 2021 daemon.info dnsmasq[2569]: read /tmp/hosts/odhcpd - 0 addresses

The router does NOT, in fact, have the interface ff02::1%lan@br-lan

After installing ip-full, it is possible to see ‘ip maddr’ and see the correct interfaces on the router:

# ip maddr
1: lo

inet  224.0.0.1
inet6 ff02::1
inet6 ff01::1

...
13: br-lan

link  33:33:00:00:00:01
link  33:33:00:00:00:02
link  01:00:5e:00:00:01
link  33:33:ff:01:70:f1
link  33:33:ff:00:00:01
link  33:33:ff:00:00:00
link  33:33:00:00:00:09
inet  224.0.0.1
inet6 ff02::9
inet6 ff02::1:ff00:0 users 3
inet6 ff02::1:ff00:1 users 2
inet6 ff02::1:ff01:70f1
inet6 ff02::2
inet6 ff02::1
inet6 ff01::1

IMPACT: No attached device can receive an IPv6 address from the router

 


Project Manager
Baptiste Jonglez commented on 01.05.2021 15:25

It looks like br-lan has no link-local address, and there is a mixup between br-lan and lan.

Please provide the full output of "ip addr show" and the content of /etc/config/network

Is it a clean configuration from a 21.02 install, or did you keep settings from a previous install?

Project Manager
Hans Dedecker commented on 01.05.2021 18:50

The trace "lan@br-lan" must not be interpreted as the linux device; it must be interpreted as "logical OpenWrt interface@linux device". So in this case the logical OpenWrt interface is lan while the linux device is br-lan; which is correct.
As mentioned by Baptiste it looks like no operational link local address is present on the br-lan device

Craig Miller commented on 03.05.2021 17:15

Thank you for looking into this. I think it is odhcpd getting confused with the new interface names. But there the full IP addr output:

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 qdisc mq state UP group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::cad7:19ff:fe01:70f1/64 scope link 
       valid_lft forever preferred_lft forever
3: ethernet1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
4: ethernet2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
5: ethernet3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
6: ethernet4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
7: internet@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether c8:d7:19:01:70:f2 brd ff:ff:ff:ff:ff:ff
    inet6 fd60:1373:e6bd:0:cad7:19ff:fe01:70f2/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2607:c000:8011:fd60:cad7:19ff:fe01:70f2/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fd60:1373:e6bd::e7a/128 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2607:c000:8011:fd60::e7a/128 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::cad7:19ff:fe01:70f2/64 scope link 
       valid_lft forever preferred_lft forever
8: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether c8:d7:19:01:70:f3 brd ff:ff:ff:ff:ff:ff
13: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether c8:d7:19:01:70:f1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.241.1/24 brd 192.168.241.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd31:2541:d6a2::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2607:c000:8011:fd68::1/62 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::cad7:19ff:fe01:70f1/64 scope link 
       valid_lft forever preferred_lft forever
17: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP group default qlen 1000
    link/ether c8:d7:19:01:70:f5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::cad7:19ff:fe01:70f5/64 scope link 
       valid_lft forever preferred_lft forever

And the /etc/config/network

# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd31:2541:d6a2::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'ethernet1 ethernet2 ethernet3 ethernet4'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.241.1'

config interface 'wan'
	option ifname 'internet'
	option proto 'dhcp'

config device 'wan_internet_dev'
	option name 'internet'
	option macaddr 'c8:d7:19:01:70:f2'

config interface 'wan6'
	option ifname 'internet'
	option proto 'dhcpv6'

Thanks for looking into this.

Craig Miller commented on 03.05.2021 17:17
Is it a clean configuration from a 21.02 install, or did you keep settings from a previous install?

This is a clean install, as was suggested by LuCI when I did the upgrade from 19.07.

Craig Miller commented on 03.05.2021 18:15

BTW, I also upgraded (clean install) of a GL-iNET USB150 (router on a thumb drive), and I see the same RA problem (none sent out, not even in response to a RS) and error messages in logread as the Linksys EA3500

Craig Miller commented on 05.05.2021 04:24

Loaded the SNAPSHOT onto the Linksys EA3500, and it is sending RAs. Downstream hosts get IPv6 addresses.
OpenWrt SNAPSHOT r16634-5d8ea6d34f / LuCI Master git-21.120.42410-be8d749

I note that I see similar lines in the logread. So I presume the errors in the log are not the problem with 21.02.0rc1

Sun May  2 06:01:10 2021 daemon.err odhcpd[1657]: Failed to send to ff02::1%lan@br-lan (Address not available)
Sun May  2 06:01:13 2021 daemon.err odhcpd[1657]: Failed to send to ff02::1%lan@br-lan (Address not available)
Sun May  2 06:01:14 2021 daemon.err odhcpd[1657]: Failed to send to fe80::9ed6:43ff:feae:1915%lan@br-lan (Address not available)
Craig Miller commented on 18.05.2021 00:59

I just wanted to say that the work-around of installing luci-mod-network to git-21.110.65613 or later, as per the release notes, does work.

I now have a router running 21.02.0-rc1 sending RAs.

Thanks.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing