OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Michael Yartys - 30.04.2021
Last edited by Ted Hess - 11.05.2021

FS#3770 - 802.11r is broken in current master

I’m running a master build (up to and including: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=62a0a8607f2f94f937c17bb7d7f4bff5fbaf15a2) on both of my R7800s. The 2.4 GHz network has 802.11r enabled, and whenever a device tries to roam it fails to connect on the first try. I get the following message in the log of the router which the device tries to roam to:

daemon.err hostapd: nl80211: kernel reports: key addition failed

I’ve tested this with my laptop running Fedora, an iPad running iPadOS 14.5 and my Nokia 8.1 running Android 11. They all produce the behavior described above. I’ve provided the wireless configs of both routers below:

—- Router 1 —-

root@OpenWrt1:~# cat /etc/config/wireless

config wifi-device ‘radio0’

option type 'mac80211'
option hwmode '11a'
option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT20'
option country 'NO'
option channel '44'
option log_level '2'
option cell_density '0'
option txpower '22'

config wifi-iface ‘default_radio0’

option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option key '***'
option encryption 'sae-mixed'
option ieee80211w '1'

config wifi-device ‘radio1’

option type 'mac80211'
option channel '6'
option hwmode '11g'
option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
option htmode 'HT20'
option country 'NO'
option log_level '2'
option txpower '17'
option cell_density '0'

config wifi-iface ‘default_radio1’

option device 'radio1'
option network 'lan'
option mode 'ap'
option ieee80211w '1'
option ssid 'OpenWrt_test'
option encryption 'psk2+ccmp'
option key '***'
option ieee80211r '1'
option ft_over_ds '0'
option ft_psk_generate_local '1'

—- Router 2 —-

root@OpenWrt2:~# cat /etc/config/wireless

config wifi-device ‘radio0’

option type 'mac80211'
option hwmode '11a'
option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT20'
option country 'NO'
option cell_density '0'
option channel '40'
option txpower '21'

config wifi-iface ‘default_radio0’

option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option key '***'
option encryption 'sae-mixed'
option ieee80211w '1'

config wifi-device ‘radio1’

option type 'mac80211'
option hwmode '11g'
option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
option htmode 'HT20'
option channel '1'
option cell_density '0'
option country 'NO'
option txpower '13'

config wifi-iface ‘default_radio1’

option device 'radio1'
option network 'lan'
option mode 'ap'
option ieee80211w '1'
option ssid 'OpenWrt_test'
option encryption 'psk2+ccmp'
option key '***'
option ieee80211r '1'
option ft_over_ds '0'
option ft_psk_generate_local '1'

It appears like 802.11r has been broken since at least February 2021 according to this forum post: https://forum.openwrt.org/t/802-11r-broken-in-recent-master-nl80211-attr-sta-vlan-errors/88888

Closed by  Ted Hess
11.05.2021 10:43
Reason for closing:  Not a bug
tapper82 commented on 30.04.2021 11:56

Same here: Master on r7800 AP is a c7-v2.

Michael Yartys commented on 30.04.2021 21:56

On closer inspection it actually seems like those error messages don't indicate that anything is wrong. I've done a packet capture which showed that my phone successfully roamed while those errors appeared in the log. This just a preliminary observation, and I'll have to perform some more tests to be sure.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing