OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Build Failure
  • Category Toolchain
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by diizzyy - 08.01.2017

FS#375 - Bulidbots should have multilib support installed to prevent unnecessary breakage

I’ve run into this earlier myself and now we are seeing at least one package failing because of it.
https://github.com/openwrt/packages/pull/2823

People seem to have run into this issue before since it’s listed as a requirement for Ubuntu 64-bit as an example.
https://wiki.openwrt.org/doc/howto/buildroot.exigence#examples_of_package_installations

diizzyy commented on 08.01.2017 15:35

"The GNU Makefile-based build system allows cross-compiling on any host for any supported target, as long as both architectures have the same pointer size. If you want to cross-compile to any 32 bit target on an x64 OS, you need to install the multilib development package (e.g. libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part (HOST_CC="gcc -m32")."

http://luajit.org/install.html

Project Manager
Yousong Zhou commented on 14.05.2017 12:58

The issue extends to "prerequisites for buildbot hosts". It also applies to java-related packages: https://github.com/openwrt/packages/pull/3686

dan hamilton commented on 14.06.2019 07:47

prerequisites for buildbot hosts

   Essay.pdf (30.8 KiB)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing